09:01:38 <masahito> #startmeeting blazar
09:01:39 <openstack> Meeting started Tue Feb 7 09:01:38 2017 UTC and is due to finish in 60 minutes. The chair is masahito. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:01:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:01:43 <openstack> The meeting name has been set to 'blazar'
09:01:44 <priteau> Hello
09:01:53 <masahito> #chair priteau hiro-kobayashi
09:01:54 <openstack> Current chairs: hiro-kobayashi masahito priteau
09:02:22 <r-mibu> hi
09:02:24 <masahito> #topic roll call
09:02:30 <priteau> \o
09:02:35 <masahito> o/
09:02:37 <r-mibu> o/
09:02:37 <hiro-kobayashi> o/
09:02:43 <tejaswi> o/
09:02:49 <masahito> tejaswi: hi
09:02:56 <tejaswi> hi masahito
09:03:29 <masahito> today's agenda is
09:03:36 <masahito> 1. Action items from last call
09:03:43 <masahito> 2. Release versioning and date
09:03:49 <masahito> 3. Pike cycle discussion
09:03:56 <masahito> anything else?
09:04:48 <GeraldK> are we ready to migrate the namespace?
09:05:05 <priteau> getting close
09:05:08 <GeraldK> what about check of open reviews?
09:05:33 <masahito> GeraldK: all the patches needed to merge are in review.
09:05:57 <masahito> ok, 4. review status and migrate namespace
09:05:57 <GeraldK> okay. it was meant as input for the agenda
09:06:11 <GeraldK> thanks
09:06:20 <masahito> then move on to first
09:06:33 <masahito> #topic action items from last meeting
09:07:11 <masahito> I see 2 action items.
09:07:29 <masahito> 1. start drafting #2 summit proposal
09:07:49 <masahito> 2. priteau to investigate differences between v1 and v2 API
09:07:55 <masahito> any update?
09:08:42 <priteau> masahito: no time for #2 yet, I focused on the auth patch to unblock tempest and on reviews
09:09:04 <GeraldK> masahito has submitted CfP proposal #2
09:09:10 <masahito> priteau: I know, thanks the nice patch and review
09:09:40 <masahito> yeah
09:09:42 <GeraldK> masahito: thanks for having taken this over.
09:10:09 <masahito> I have submitted #2 summit proposal regarding to Collaboration Promise and Blazar.
09:10:58 <masahito> The action item was done, and I'm believing the proposal is accepted.
09:11:34 <hiro-kobayashi> Yes, we believe that
09:11:49 <masahito> then move on to next.
09:12:00 <masahito> #Release versioning and date
09:12:11 <masahito> #topic Release versioning and date
09:12:43 <masahito> We're getting closer to release latest Blazar release.
09:13:25 <masahito> All of our efforts enables it. thanks a great works all!
09:14:45 <priteau> Thanks for your hard work masahito
09:14:53 <masahito> Then I'm thinking we can release next version once we finish merging patches related to tempest.
09:14:59 <masahito> How do you think?
09:15:16 <masahito> Or we should release after converting blazar namespace?
09:15:24 <priteau> I would prefer after converting
09:15:47 <GeraldK> would also prefer after converting
09:15:51 <masahito> One of both timing looks good timing to me.
09:16:13 <hiro-kobayashi> I think we do not need to wait for converting
09:16:14 <r-mibu> +1 after converting
09:16:19 <priteau> I feel strongly that we don't have to release synchronized with the Ocata date, it's ok if it is a couple of weeks later
09:16:33 <priteau> In this case we still have ~ one month
09:16:47 <masahito> yes.
09:17:28 <masahito> I guess we can convert it by end of Feb then release a new version.
09:17:36 <GeraldK> my understanding was that if we focus on the conversion we could be done within 1 week?
09:17:53 <GeraldK> maybe that is too optimistic
09:18:01 <hiro-kobayashi> masahito: I think so, too
09:18:10 <masahito> ok then,
09:18:18 <priteau> GeraldK: We need to finish oslo migration + tempest test first (hopefully this week), then migrate namespace. There are also other Ocata tasks that we outlined in the Etherpad
09:18:32 <priteau> For example it would be great to have openstackclient support
09:19:25 <GeraldK> sure. yes, i know we also have other tasks. +1 for targeting end of February
09:20:11 <GeraldK> my point was that the conversion of the namespace could be done in 1 week
09:20:27 <masahito> #agree Release new version by end of February
09:20:35 <masahito> GeraldK: yeah. maybe.
09:21:09 <masahito> if we can push patches before PTG, hiro-kobayashi, r-mibu and me can review these there :-)
09:21:30 <masahito> and would be able to merge it
09:21:50 <masahito> Additionally, I
09:22:17 <priteau> masahito: Release new version by end of February *if ready*. We don't want to ship a bad release as first release.
09:23:07 <hiro-kobayashi> priteau: +1, but how to judge it?
09:23:14 <masahito> I'm thinking name of next release version is '0.2.0'. any opinion?
09:23:22 <hiro-kobayashi> +1
09:23:40 <priteau> hiro-kobayashi: I am sure one of us will know if an important patch is still unmerged
09:24:05 <GeraldK> +1
09:24:07 <masahito> priteau: agreed, but we need a milestone that show what should be merged in the release.
09:24:17 <hiro-kobayashi> priteau: thats right
09:24:53 <masahito> I'm not forcing to release anyhow at end of Feb.
09:24:57 <GeraldK> we had agreed on a list of Ocata items in the Blazar status 2016 page from line 140
09:25:23 <GeraldK> should we revisit this to see what is our milestone that we target for the release?
09:26:03 <priteau> +1 GeraldK, we should review this list again
09:26:13 <GeraldK> #link https://etherpad.openstack.org/p/Blazar_status_2016
09:26:40 <masahito> 1. Mainly tasks are caught up with up-to-date OpenStack release (Nova, oslo libraries [Pierre], tempest [Masahito], client and so on)
09:26:42 <GeraldK> we don't have assignees for all action items in this list
09:26:52 <masahito> 2. migrate namespace climate to blazar
09:27:01 <priteau> check documentation is up to date
09:27:03 <masahito> 3. Review state of API versions: v1 vs v2 [Pierre]
09:27:06 <priteau> release notes
09:27:14 <masahito> 4. Clean up Blueprints and bugs in launchpad [
09:27:23 <masahito> 5. Synchronize documentation (both github wiki and blazar/doc/source) with reality
09:27:23 <priteau> deprecate instance reservatio
09:27:33 <masahito> 6. Add releasenotes
09:27:52 <masahito> 7. Make sure we adhere to project conventions
09:28:02 <masahito> 8. VM reservation plugin: raise a warning when people are using it but keep the code for now. Revisit after our next release
09:28:35 <masahito> I can see above 8 items for Ocata release.
09:28:46 <priteau> Good list
09:28:54 <GeraldK> 1. is almost done -> see from line 21
09:29:00 <hiro-kobayashi> about #1, we finish oslo and tempest after merging current in-review patches
09:29:11 <hiro-kobayashi> how about client?
09:29:20 <GeraldK> #2 is planned by end of February
09:29:32 <masahito> yes.
09:30:07 <masahito> #3 is under investigating, but not related to release itself.
09:30:37 <GeraldK> i.e. for the release we will still support both v1 an v2?
09:31:05 <masahito> GeraldK: I think we should only support v1 now. v2 is not stable and not tested.
09:31:12 <priteau> GeraldK: yes because the client only supports v1 now
09:31:18 <GeraldK> masahito: okay
09:32:03 <masahito> For #4, I cleaned up bug report yesterday.
09:32:20 <hiro-kobayashi> masahito: great, thanks!
09:33:04 <masahito> #5 is not done by anyone, I think.
09:33:42 <priteau> #5 would benefit from everyone checking it
09:33:59 <masahito> #6 is in review and know enough notes.
09:34:00 <hiro-kobayashi> +1
09:34:24 <masahito> priteau: right.
09:35:11 <masahito> It looks like #7 is already done.
09:35:23 <GeraldK> masahito: thanks for having cleaned bug report. I closed this issue in the Etherpad
09:36:20 <priteau> #8 can be tricky because extensions were not enabled directly in blazar, but in nova config
09:36:24 <masahito> and #8 is already done b/c instane reservation is not supported in latest Nova release.
09:36:31 <priteau> We need a release notes depreciation item
09:36:38 <masahito> yes
09:36:47 <masahito> GeraldK: thanks
09:37:12 <masahito> So, the rests of things we need to do is
09:37:29 <masahito> 2. migrate namespace climate to blazar
09:38:00 <GeraldK> should we do "actions" on it to have it as a reminder for next agenda?
09:38:16 <masahito> 5. review and update the doc in github wiki and doc/source
09:38:20 <masahito> GeraldK: yes
09:38:45 <hiro-kobayashi> #action migrate namespace climate to blazar by the end of Feb.
09:38:49 <hiro-kobayashi> #action review and update the doc in github wiki and doc/source
09:39:09 <masahito> 8. write a release note that says 'instance reservation is not supported in Ocata'
09:39:36 <hiro-kobayashi> #action write a release note that says 'instance reservation is not supported in Ocata'
09:39:36 <masahito> the three action items?
09:39:42 <priteau> Wait, doc in github wiki?
09:39:47 <priteau> you mean openstack wiki?
09:39:53 <masahito> I just copy from etherpad.
09:40:20 <priteau> I don't see any wiki on github
09:40:36 <masahito> priteau: you're right
09:40:46 <masahito> we don't have wiki page in github.
09:41:32 <masahito> I'll report three bugs of above action items and add its target as 0.2.0 release.
09:41:38 <priteau> Thanks masahito
09:42:15 <masahito> then we can release :-)
09:42:29 <masahito> wow, it's so close.
09:42:50 <priteau> Regarding release items, I would like to mention something I discovered recently
09:43:18 <priteau> Originally, Blazar was using a dedicated admin account to do operations like create host aggregates
09:43:34 <priteau> At some point in 2014, this was migrated to use trusts
09:44:07 <priteau> However, this means that a user needs to be able to create and manage host aggregates if they want to use blazar
09:44:26 <priteau> which is not the default policy for Nova
09:44:47 <priteau> I am not sure if that's by design or accident. I think trusts were added mostly for instance reservation, so it could be by accident
09:45:15 <priteau> What do you want to do about this?
09:45:44 <priteau> I can open a Launchpad bug with more details for discussion if you wnt
09:46:03 <masahito> I think we can fix or discuss the design after release
09:46:07 <masahito> If it breaks Blazar itself, we should fix it before release. or if it doesn't break, we can fix it after release and backport it
09:46:34 <priteau> masahito: It doesn't break it completely, but it means by default only admins can create Blazar leases
09:47:05 <masahito> IMO, it sounds design issue.
09:47:36 <priteau> Yes, which is why I would like to fix it before releasing 0.2.0 if possible
09:47:52 <hiro-kobayashi> How long does it take to fix it?
09:49:03 <r-mibu> i suppose it could depend on how to fix
09:49:09 <masahito> hiro-kobayashi: good point
09:49:14 <priteau> It depends what solution we decide to use
09:49:32 <priteau> I will email previous Blazar developers to ask what they intended to do
09:49:45 <r-mibu> +1
09:49:51 <priteau> One solution would be to restore using the blazar admin account for aggregates
09:50:01 <GeraldK> pls keep us in CC in this thread with previous cores
09:50:11 <priteau> I did that for Chameleon, I can take care of it if we agree that is the good solution
09:50:17 <priteau> GeraldK: of course
09:50:29 <hiro-kobayashi> priteau: thanks
09:51:19 <hiro-kobayashi> I agree with that chameleon solution for now
09:52:03 <r-mibu> priteau, sounds nice
09:52:24 <priteau> r-mibu: it's nothing complex, just restoring older code
09:52:31 <masahito> priteau: I'm ok if it works in your deployment
09:53:07 <priteau> I will email devs first, and start preparing a patch depending on answers or lack of answer
09:53:19 <masahito> then, come back to next meeting with the answer form previous cores. we'll use whether Chameleon solution or not.
09:53:37 <masahito> +1
09:53:41 <hiro-kobayashi> +1
09:54:12 <GeraldK> +1
09:54:53 <masahito> last 5 mins.
09:55:43 <r-mibu> +1
09:55:52 <masahito> GeraldK: do we need to go agenda 4. review status and migrate namespace?
09:56:25 <masahito> GeraldK: it looks already discussed.
09:56:39 <GeraldK> no. we can skip
09:56:47 <masahito> GeraldK: got it.
09:56:58 <masahito> #topic open discussion
09:57:25 <masahito> if you have any update or topic, feel free to say it :->
09:57:35 <GeraldK> I'd like to say thank you for your hard work and the good progess
09:57:55 <priteau> I noticed we had reviews from a new person this week
09:58:00 <priteau> Do you know who it is?
09:58:08 <GeraldK> tejaswi: did you manage to get your environment ready?
09:58:37 <masahito> priteau: no, I guess he/she is new comer.
09:58:57 <tejaswi> GeraldK: yes, devstack came up fine. however, I still have few issues.
09:59:52 <hiro-kobayashi> new commer's name is wanghongtaozz, right?
10:00:15 <priteau> hiro-kobayashi: "wanghongtaozz" is doing +1 reviews in lots of projects
10:00:31 <masahito> tejaswi: what issue happens?
10:01:11 <hiro-kobayashi> priteau: yes he/she is.
10:01:11 <tejaswi> masahito: I've sent email to you regarding the same error. however, I do not see any errors in the logs
10:01:18 <priteau> hiro-kobayashi: he/she doesn't seem to offer any other comment than +1... Not very useful.
10:01:20 <masahito> tejaswi: if you have few mins, I can answer it at #openstack-blazar from now.
10:01:33 <masahito> btw, it's time to end the meeting.
10:01:42 <masahito> thanks, all!
10:01:47 <GeraldK> thanks all
10:02:01 <priteau> bye all, thanks!
10:02:04 <r-mibu> thanks
10:02:09 <masahito> tejaswi: please go to #openstack-blazar
10:02:10 <hiro-kobayashi> bye, thanks!
10:02:17 <masahito> #endmeeting