09:00:37 <hiro-kobayashi> #startmeeting blazar
09:00:37 <openstack> Meeting started Tue Feb 28 09:00:37 2017 UTC and is due to finish in 60 minutes.  The chair is hiro-kobayashi. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:41 <openstack> The meeting name has been set to 'blazar'
09:00:52 <hiro-kobayashi> #chair priteau
09:00:52 <openstack> Current chairs: hiro-kobayashi priteau
09:01:01 <hiro-kobayashi> #topic Rollcall
09:01:07 <hiro-kobayashi> o/
09:01:09 <priteau> o/
09:01:15 <tejaswi> o/
09:01:20 <bertys_> hi all
09:01:28 <hiro-kobayashi> masa will join later, maybe in 15 minutes
09:02:00 <hiro-kobayashi> Is r-mibu?
09:02:41 <hiro-kobayashi> OK lets start a meeting
09:02:53 <hiro-kobayashi> #topic Action items from the last meeting
09:03:10 <hiro-kobayashi> There is not a list of action items, but actions in my mind are:
09:03:19 <hiro-kobayashi> #1 Vote Blueprints
09:03:38 <hiro-kobayashi> #2 Work on bugs for v.0.2.0
09:03:46 <hiro-kobayashi> Anything else?
09:04:34 <hiro-kobayashi> About #1, it looks most of us have voted.
09:04:45 <hiro-kobayashi> Here is the result: https://etherpad.openstack.org/p/Blazar_status_2016
09:05:41 <priteau> Blueprints highlighted in bold font are the ones with the most votes
09:05:51 <priteau> We have 5 of them
09:05:59 <hiro-kobayashi> yes
09:06:40 <hiro-kobayashi> And blueprints with at least 1 vote are [mid]
09:06:53 <hiro-kobayashi> And blueprints with no vote are [low]
09:07:12 <hiro-kobayashi> These results have been reflected to the Launchpad
09:07:23 <hiro-kobayashi> #link https://blueprints.launchpad.net/blazar
09:07:52 <priteau> Thank you hiro-kobayashi for doing this
09:08:48 <hiro-kobayashi> We should detail them, and assign someone after releasing v0.2.0
09:09:39 <hiro-kobayashi> Now we should focus on v.0.2.0
09:09:45 <hiro-kobayashi> hi masahito
09:09:48 <hiro-kobayashi> #chair masahito
09:09:49 <openstack> Current chairs: hiro-kobayashi masahito priteau
09:09:52 <masahito> hi, all. sorry late.
09:10:05 <hiro-kobayashi> masahito: Now we are checking action items
09:10:19 <hiro-kobayashi> #1 Vote Blueprints
09:10:29 <hiro-kobayashi> #2 Work on bugs for v.0.2.0
09:10:48 <hiro-kobayashi> #1 finished
09:10:49 <masahito> hiro-kobayashi: got it. I'll check eavesdrop for past discussion.
09:11:15 <hiro-kobayashi> let's move on #2
09:11:47 <hiro-kobayashi> Here is the status of v0.2.0: https://launchpad.net/blazar/+milestone/0.2.0
09:12:42 <hiro-kobayashi> Do you have anything to discuss here?
09:13:04 <hiro-kobayashi> #topic v0.2.0 status
09:13:16 <priteau> I opened a bug yesterday about ClimateFilter issues
09:13:33 <hiro-kobayashi> priteau: thanks for that
09:13:41 <priteau> is it fixed by https://review.openstack.org/#/c/438796/
09:14:11 <hiro-kobayashi> Yes, I confirmed it works in my environment
09:14:32 <priteau> Great, thanks
09:14:40 <priteau> Should this be fix released? https://bugs.launchpad.net/bugs/1657826
09:14:40 <openstack> Launchpad bug 1657826 in Blazar "blazarclient doesn't work with keystone v3 API" [Medium,Fix committed] - Assigned to Masahito Muroi (muroi-masahito)
09:14:55 <priteau> or do we want until we have python-blazarclient on pypi?
09:15:42 <masahito> priteau: you hit the bug?
09:16:00 <priteau> masahito: 1657826? not since you merged the patch
09:16:02 <masahito> In my local, blazarclient works well with keystone v3
09:16:12 <priteau> I am talking about the launchpad status of the bug
09:16:22 <priteau> it is "Fix committed" rather than "Fix released"
09:16:31 <masahito> oh, I see.
09:16:37 <hiro-kobayashi> Yes, i think we can mark it fix-released
09:17:15 <masahito> right, it should be fix committed.
09:17:33 <hiro-kobayashi> not fix-released?
09:18:01 <hiro-kobayashi> Other completed pathces are "Fix Released"
09:18:04 <masahito> sorry, I was confused.
09:18:39 <priteau> I have changed its status
09:18:51 <hiro-kobayashi> Thanks!
09:18:54 <masahito> IMO, until we have pypi package it's better to use fix released b/c we only have master codes in git.
09:19:01 <priteau> +1
09:19:15 <priteau> master branch is effectively a continuous release
09:19:31 <hiro-kobayashi> +1
09:19:35 <priteau> Thanks masahito for reviewing my patch for https://bugs.launchpad.net/blazar/+bug/1663204. I will reply to your comments
09:19:35 <openstack> Launchpad bug 1663204 in Blazar "Non-admin users cannot create reservations with default policy rules" [High,In progress] - Assigned to Pierre Riteau (priteau)
09:20:00 <masahito> priteau: first of all, thanks the patch.
09:20:34 <masahito> My comments is more focusing on coding itself. Overall it looks good.
09:20:56 <hiro-kobayashi> Thanks priteau and masahito
09:21:43 <hiro-kobayashi> And thanks for https://review.openstack.org/#/c/434775/
09:22:04 <hiro-kobayashi> I want to discuss Documentation
09:22:33 <hiro-kobayashi> Should we publish docs on readthedocs?
09:22:53 <masahito> If it works on readthedocs.
09:23:06 <priteau> I am not sure if we can publish several sets of docs
09:23:13 <priteau> We would need both release notes and documentation
09:23:41 <hiro-kobayashi> I tried and confirmed "docs" works with readthedocs
09:23:55 <hiro-kobayashi> I can push the patch for that
09:24:10 <priteau> What kind of patch is needed?
09:24:19 <hiro-kobayashi> But I don't know how to integrate readthedocs with releasenotes
09:24:24 <hiro-kobayashi> with reno
09:25:06 <hiro-kobayashi> priteau: trivial changes. Adds sphinx requirements into requirements.txt
09:25:12 <masahito> IIRC, readthedocs only works with pure markdown or rst file
09:25:44 <hiro-kobayashi> And add some paths into docs/source/conf.py
09:26:04 <hiro-kobayashi> masahito: Yes I think so
09:26:31 <masahito> ok, then if it works, we can point out it. if not, we can add how to generate the doc on README.md. how do you think?
09:26:33 <hiro-kobayashi> So we should make another version of release notes for readthedocs
09:26:43 <priteau> Another solution is, once we have the final release notes, we copy/paste them to the wiki
09:27:30 <masahito> +1 for priteau. it looks nice.
09:27:46 <hiro-kobayashi> +1 too
09:28:33 <hiro-kobayashi> Then I will push the patch for publish "doc" in readthedocs
09:29:04 <hiro-kobayashi> and After the release, we will copy the release note into "doc" repo
09:29:26 <hiro-kobayashi> Does it make sense?
09:29:46 <priteau> what would be the doc repo?
09:30:07 <hiro-kobayashi> doc directory in the blazar repo
09:30:31 <hiro-kobayashi> #link https://github.com/openstack/blazar/tree/master/doc/source
09:31:02 <hiro-kobayashi> Because readthedocs publishes documents in doc directory
09:31:34 <hiro-kobayashi> Here is a sample: http://test-blazar.readthedocs.io/en/latest/introduction.html
09:31:39 <masahito> I think we don't need to keep copy of releasenotes in docs repo.
09:31:59 <priteau> I agree with masahito
09:32:10 <priteau> Or maybe just an index page, like ironic does: https://github.com/openstack/ironic/blob/master/doc/source/releasenotes/index.rst
09:32:15 <priteau> pointing to the wiki
09:32:17 <masahito> just has a link to wiki in blazar repo in github.
09:32:35 <priteau> otherwise that's a lot of duplicated content
09:33:14 <hiro-kobayashi> OK, then I will add a point to the wiki
09:34:36 <hiro-kobayashi> After we publish docs in readthedocs, I think we should remove duplicated wiki pages. How do you think?
09:35:26 <priteau> or mark them as outdated and link to readthedocs?
09:35:43 <hiro-kobayashi> priteau: its better.
09:35:53 <priteau> keeps the history
09:36:13 <hiro-kobayashi> Make sense! Then I will do that.
09:36:26 <masahito> hiro-kobayashi: thanks the volunteer.
09:36:43 <hiro-kobayashi> That's all for documents, thanks!
09:36:56 <hiro-kobayashi> Oh, not all, sorry
09:37:14 <hiro-kobayashi> tejaswi: How's your patch?
09:37:31 <hiro-kobayashi> https://review.openstack.org/#/c/436557/
09:37:35 <tejaswi> hiro-kobayashi: I've updated v1 API
09:37:53 <tejaswi> I've replaced VM reservation with host reservation
09:38:14 <hiro-kobayashi> Thank you very much!
09:38:42 <tejaswi> should we update v2 API ?
09:38:42 <hiro-kobayashi> the document would be a great help
09:39:12 <hiro-kobayashi> tejaswi No. Because v2 API docs are auto generated as far as I know
09:39:14 <priteau> I believe v2 API is autogenerated
09:39:21 <tejaswi> ok
09:39:31 <priteau> although I still have things I want to verify in it
09:40:19 <tejaswi> In my devstack setup, the API to update host is throwing 500 error. Are you also facing the same issue ?
09:40:39 <priteau> I haven't tried update-host
09:40:51 <priteau> and tempest doesn't check it
09:40:51 <hiro-kobayashi> Me, neither
09:40:55 <tejaswi> ok.
09:41:01 <masahito> me too.
09:41:34 <hiro-kobayashi> Then that should be reported as a bug
09:41:39 <priteau> tejaswi: can you open a bug?
09:41:49 <tejaswi> ok
09:42:01 <hiro-kobayashi> tejaswi Thanks!
09:42:41 <tejaswi> The command to update host "climate host-update --extra abc=1 1" does not throw error, however if we use REST API, it throws 500 error. Ideally, the CLI and REST responses should be the same
09:42:42 <hiro-kobayashi> Anything else about on-reviewing patches?
09:43:19 <priteau> Anyone would have some time to rebase and refresh the patch for checking physical reservation min/max parameters?
09:43:55 <masahito> priteau: which one?
09:43:56 <hiro-kobayashi> priteau: Do you have a link for that?
09:44:56 <hiro-kobayashi> tejaswi: That's should be investigated. Could you describe about it on Launchpad bug?
09:45:09 <tejaswi> ok
09:45:45 <hiro-kobayashi> #action tejaswi to open bug about 'host update'
09:45:47 <priteau> the bug is https://bugs.launchpad.net/blazar/+bug/1404190
09:45:47 <openstack> Launchpad bug 1404190 in Blazar "No validation for --physical-reservation arguments of lease-create command" [High,Confirmed] - Assigned to Pierre Riteau (priteau)
09:46:06 <priteau> client patch https://review.openstack.org/#/c/143044/
09:46:34 <masahito> I've never checked it.
09:46:57 <hiro-kobayashi> OK, I'll do that
09:47:02 <priteau> and server bug: https://bugs.launchpad.net/blazar/+bug/1400642 server patch: https://review.openstack.org/#/c/140306/
09:47:02 <openstack> Launchpad bug 1400642 in Blazar "Internal Server Error while creating lease with physical reservation" [Undecided,In progress] - Assigned to chintha govardhan (chintha-govardhan)
09:47:19 <masahito> But from release side, I don't think it blocks the release
09:47:49 <hiro-kobayashi> masahito: +1
09:48:00 <hiro-kobayashi> Because it's not critical
09:48:09 <hiro-kobayashi> Hi GeraldK
09:48:28 <priteau> It would be good if it was fixed in it though. It throws an exception in the middle of lease creation and leaves it half-created
09:49:13 <masahito> Does it make sense it backport after release 0.2.0.?
09:49:32 <masahito> If we want to make blazar and blazarclient perfect, meaning no bugs, we can't release.
09:49:41 <priteau> :-)
09:49:46 <priteau> Yes we can backport of course
09:50:16 <masahito> I'm planning to cut 0.2.0 release once we merge the five patches.
09:50:22 <GeraldK> hi, sorry, I arrived very late...
09:50:32 <masahito> https://review.openstack.org/436557
09:50:37 <masahito> https://review.openstack.org/#/c/436690/
09:50:41 <masahito> https://review.openstack.org/#/c/438293/
09:50:45 <masahito> https://review.openstack.org/#/c/437004/
09:50:50 <masahito> https://review.openstack.org/#/c/434775/
09:50:57 <masahito> https://review.openstack.org/#/c/434777/
09:51:32 <masahito> does it make sense?
09:52:05 <priteau> 6 patches?
09:52:31 <masahito> oh. '6 patches' is right.
09:52:50 <GeraldK> two of the patches have status "-1"
09:53:00 <hiro-kobayashi> And I want to merge readthedocs related patch which we have discussed. How do you think?
09:53:19 <GeraldK> the others seems to be okay more or less
09:53:31 <masahito> hiro-kobayashi: Could you add it into https://review.openstack.org/#/c/434775/ ?
09:53:58 <hiro-kobayashi> masahito: yes i can
09:54:01 <masahito> GeraldK: Of course, we need to solve the -1 :)
09:54:33 <GeraldK> hiro-kobayashi: OPNFV opnfvdocs project has also started using ReadTheDocs, so if you have any questions on it, we could also reach out to them
09:54:56 <masahito> GeraldK: after resolving the -1s I'll adds the docs.
09:55:03 <hiro-kobayashi> GeraldK: Thanks! That's a great help
09:55:15 <priteau> Should we talk about deprecation policy before the meeting ends?
09:55:31 <GeraldK> masahito: sure, I know. I just wanted to say it seems we have only 2 out of 6 where some more work is needed.
09:55:37 <hiro-kobayashi> priteau: yes we should
09:56:09 <hiro-kobayashi> #topic Deprecation rules
09:56:11 <masahito> GeraldK: i see.
09:56:52 <priteau> My personal preference is to remove code as soon as possible so there is less to maintain, especially while we have very few users
09:57:09 <hiro-kobayashi> priteau: +1
09:57:14 <masahito> +1
09:57:20 <GeraldK> +1
09:57:42 <priteau> masahito: but I thought you proposed to keep climate code until after P release?
09:57:46 <masahito> If it doesn't hit your environment, I think we can do :-)
09:58:04 <masahito> I thought it could hit your environment.
09:58:12 <priteau> nah don't worry at all about it
09:58:18 <masahito> :-)
09:58:37 <priteau> we will continue running our own fork for now since we have some Chameleon-specific patches
09:58:55 <priteau> and rebase them on Ocata when we upgrade
09:59:31 <priteau> If we follow OpenStack rules I think we can remove deprecated code 3 months after release with the deprecation note
09:59:47 <priteau> #link https://governance.openstack.org/tc/reference/tags/assert_follows-standard-deprecation.html
10:00:09 <hiro-kobayashi> priteau: +1. We should follow it
10:00:43 <masahito> ok.
10:01:01 <hiro-kobayashi> Unfortunately we have no more time
10:01:19 <masahito> then mark all climate namespace is deprecated in O. and will remove it in May or somedays.
10:01:32 <hiro-kobayashi> +1
10:01:44 <priteau> Probably in June
10:02:25 <hiro-kobayashi> Let's go to #openstack-blazar if AOB
10:02:30 <priteau> So that the 3 months are March-April-May
10:02:36 <priteau> All right, thanks everyone
10:02:44 <masahito> priteau: all right.
10:02:45 <hiro-kobayashi> Thanks!
10:02:53 <hiro-kobayashi> #endmeeting