09:00:06 <priteau> #startmeeting blazar
09:00:07 <openstack> Meeting started Tue Mar 14 09:00:06 2017 UTC and is due to finish in 60 minutes.  The chair is priteau. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:10 <openstack> The meeting name has been set to 'blazar'
09:00:20 <priteau> #chair hiro-kobayashi
09:00:21 <openstack> Current chairs: hiro-kobayashi priteau
09:00:30 <priteau> #topic Rollcall
09:00:34 <hiro-kobayashi> o/
09:00:41 <hiro-kobayashi> I’m sorry but I can attend just first 30 minutes today.
09:00:46 <priteau> o/
09:01:22 <hiro-kobayashi> masahito cannot attend today because he attends Ops meetup now
09:01:42 <priteau> OK hiro-kobayashi, we'll try to be efficient
09:01:46 <priteau> Hello tejaswi
09:01:53 <bertys_> hi all
09:01:57 <tejaswi> hi priteau
09:01:57 <priteau> Hi bertys_
09:02:04 <priteau> Hi r-mibu
09:02:17 <r-mibu> hi,
09:02:58 <priteau> #topic Agenda
09:03:14 <priteau> The agenda for today is:
09:03:19 <priteau> Action items from last call
09:03:19 <priteau> Ocata (0.2.0) release
09:03:20 <priteau> Pike blueprints
09:03:22 <priteau> Boston Summit
09:03:24 <priteau> AOB
09:03:41 <priteau> #topic Action items from last call
09:04:28 <priteau> I didn't see any explicitly highlighted action item from last week's meeting
09:04:40 <hiro-kobayashi> tejaswi: could you report a bug about host-update?
09:05:11 <hiro-kobayashi> I think that is an item from past meeting
09:05:12 <tejaswi> hiro-kobayashi: host-update is working fine in my setup now
09:05:36 <tejaswi> Did anyone else face issue with host-update ?
09:05:38 <hiro-kobayashi> tejaswi: What was the cause?
09:05:43 <priteau> I see it was an action item from the meeting before last
09:06:21 <hiro-kobayashi> tejaswi: you have reported something wrong with host-update of Blazar CLI
09:06:48 <hiro-kobayashi> Wasn't it a bug?
09:07:09 <r-mibu> priteau, seems so, there is no action items in the last minutes
09:07:11 <r-mibu> http://eavesdrop.openstack.org/meetings/blazar/2017/blazar.2017-03-07-09.00.html
09:07:15 <tejaswi> hiro-kobayashi: yes, the REST API to update a host was throwing error. However, it is working fine now.
09:07:44 <tejaswi> So, I want to check if anyone else is getting an error for host-update /
09:07:45 <tejaswi> ?
09:08:14 <hiro-kobayashi> tejaswi: I haven't tried host-update
09:08:20 <priteau> I don't think I've run it recently, we may want to add a Tempest test for it
09:08:30 <tejaswi> hiro-kobayashi: ok.
09:08:36 <bertys_> priteau: good idea
09:08:52 <priteau> It's not a command that is run frequently so there is a chance that bugs in it will be missed
09:09:01 <priteau> #action Add a Tempest test for host-update
09:09:24 <priteau> Any other action item?
09:09:33 <tejaswi> anyways, I have a question regarding the host-update
09:10:02 <priteau> What is your question tejaswi?
09:10:08 <tejaswi> let's say we run the command climate host-update --extra abc=1 1, where is the value abc stored ?
09:10:17 <tejaswi> climate host-show does not show the value
09:10:32 <priteau> It is stored in the SQL database, computehost_extracapabilities table
09:10:50 <bertys_> tejaswi: have you checked the table?
09:11:31 <tejaswi> bertys_: yes, I checked the tables. Did the DB schema change recently ? Let me check one more time
09:11:51 <priteau> tejaswi: However, the Blazar service refuses to create new extra capabilities
09:12:24 <priteau> https://github.com/openstack/blazar/blob/master/blazar/plugins/oshosts/host_plugin.py#L284-L285
09:12:43 <tejaswi> priteau: ok
09:12:55 <priteau> In Chameleon we have changed that because it is not convenient. I think it can be tackled for 0.3.0
09:13:15 <hiro-kobayashi> +1
09:13:19 <bertys_> +1
09:13:45 <priteau> I think there is some change required in python-blazarclient UI as well, to support removing extra capabilities
09:13:51 <priteau> It is not possible at the moment
09:14:05 <hiro-kobayashi> Could someone open a bug or blueprint about it?
09:14:32 <priteau> #action Create a bug/blueprint about support for changing/removing extra capabilities with host-update
09:14:37 <priteau> Absolutely
09:14:44 <hiro-kobayashi> Thanks!
09:15:01 <priteau> I'll take this one
09:15:31 <priteau> Have we covered all action items?
09:15:52 <priteau> The specs directory that we discussed last week was created by Masahito
09:16:16 <hiro-kobayashi> yes
09:16:31 <priteau> #topic Ocata (0.2.0) release
09:16:51 <priteau> Just a quick announcement if you didn't see yet
09:16:56 <priteau> 0.2.0 has been tagged
09:17:12 <priteau> We'll likely backport some patches, I am still working on one
09:17:45 <hiro-kobayashi> It's a great progress!
09:17:51 <priteau> Yes indeed.
09:18:16 <priteau> I'll ask Masahito if he is planning to update tarballs on launchpad as well
09:18:32 <hiro-kobayashi> thanks
09:18:56 <priteau> I see we have automatically generated tarballs at https://tarballs.openstack.org/blazar/
09:19:25 <priteau> and https://tarballs.openstack.org/blazar-nova and https://tarballs.openstack.org/python-blazarclient/ of course
09:20:11 <r-mibu> if we need some backports, we might need to use 0.2.1 or 0.2.x?
09:20:22 <priteau> I see that there is no stable/ocata branch
09:20:30 <priteau> I'll check with Masahito what he wants to do
09:20:45 <priteau> I think after we have enough backports, we would tag 0.2.1
09:20:56 <r-mibu> ok
09:21:12 <priteau> #action priteau to check with Masahito about Launchpad tarballs, stable/ocata branch, and future 0.2.x tags
09:21:40 <priteau> Let's move on to Pike discussion before hiro-kobayashi has to leave
09:21:49 <priteau> #topic Pike blueprints
09:21:57 <hiro-kobayashi> thanks
09:22:11 <priteau> Work has started on blueprints identified for Pike
09:22:17 <hiro-kobayashi> I've pushed a SPEC for on-end-options which we discussed at the last meeting
09:22:21 <hiro-kobayashi> #link https://review.openstack.org/#/c/445270/
09:22:33 <hiro-kobayashi> I want you guys to review it
09:22:57 <priteau> Thanks, will do
09:23:03 <priteau> And I think you also contributed a patch?
09:23:04 <r-mibu> got it
09:23:18 <hiro-kobayashi> priteau: Yes
09:23:35 <hiro-kobayashi> Sorry for break a right procedure
09:23:49 <hiro-kobayashi> Spec should be approved before implementation
09:24:24 <hiro-kobayashi> So, please focus on the Spec review for the first
09:24:33 <priteau> It can be good to have a WIP patch to see how it might work in practice
09:24:47 <priteau> But maybe mark it as Workflow:-1?
09:25:13 <hiro-kobayashi> OK, I'll update it
09:25:37 <priteau> Thanks
09:25:55 <hiro-kobayashi> I'm sorry but I should quit
09:26:01 <hiro-kobayashi> See you!
09:26:09 <priteau> Good bye hiro-kobayashi, thanks for joining
09:26:38 <priteau> I also created a blueprint from an issue raised during a discussion I had with bauzas
09:26:51 <priteau> It is about how Blazar would work with Nova quotas
09:26:57 <priteau> https://blueprints.launchpad.net/blazar/+spec/nova-quota-cooperation
09:27:07 <priteau> Please contribute if you have ideas about this issue
09:27:55 <priteau> I am not sure if we'll be able to tackle it at all during the Pike cycle, but it's important to keep track issue
09:28:43 <r-mibu> priteau, nice work!
09:29:40 <priteau> Anything else to discuss about Pike blueprints?
09:30:06 <priteau> #action (all) review on-end-options spec: https://review.openstack.org/#/c/445270/
09:31:18 <priteau> Moving on then
09:31:22 <priteau> #topic Boston Summit
09:31:51 <priteau> We've received confirmation that one of our talks was selected for the Boston Summit
09:32:14 <priteau> As part of the Project Updates track
09:32:31 <priteau> #link https://www.openstack.org/summit/boston-2017/summit-schedule/events/18586/project-update-blazar
09:32:51 <r-mibu> congrats!
09:33:17 <bertys_> The second talk has also been accepted!?
09:33:29 <bertys_> #link https://www.openstack.org/summit/boston-2017/summit-schedule/events/17769/collaboration-of-openstack-blazar-and-opnfv-promise-for-meeting-nfv-resource-management-requirements
09:34:06 <bertys_> As part of the Telco/NFV operations
09:34:13 <priteau> bertys_: That's great news! I didn't see it because I am not in speakers
09:34:23 <priteau> And I didn't have time to study the summit schedule yet
09:34:34 <bertys_> priteau: yep, that's great
09:35:22 <priteau> So if you're coming to the summit, mark your calendar:
09:35:38 <priteau> #info Project Update - Blazar: Mon 8, 12:05pm-12:45pm
09:35:52 <priteau> #info Collaboration of OpenStack Blazar and OPNFV Promise for meeting NFV resource management requirements: Wed 10, 11:00am-11:40am
09:36:08 <priteau> Who's going to Boston?
09:36:37 <r-mibu> I suppose all speakers of those sessions
09:36:52 <r-mibu> I will also join
09:37:37 <priteau> Looking forward to see you there r-mibu
09:37:56 <priteau> tejaswi and bertys_ are you planning to go?
09:38:20 <tejaswi> priteau: no, I cannot come to Boston
09:38:21 <bertys_> priteau: Only GeraldK this time
09:39:02 <priteau> OK, hopefully another time
09:39:32 <priteau> #topic AOB
09:39:37 <priteau> Any other business to discuss?
09:40:53 <priteau> If nothing else, we will finish the meeting early
09:41:36 <bertys_> ok for me, have a nice day/week
09:41:49 <priteau> OK, thanks everyone for attending
09:41:57 <r-mibu> thanks, all - bye
09:41:59 <priteau> #endmeeting