09:00:13 <hiro-kobayashi> #startmeeting blazar
09:00:14 <openstack> Meeting started Tue Aug 22 09:00:13 2017 UTC and is due to finish in 60 minutes.  The chair is hiro-kobayashi. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:18 <openstack> The meeting name has been set to 'blazar'
09:00:32 <hiro-kobayashi> #chair priteau
09:00:33 <openstack> Current chairs: hiro-kobayashi priteau
09:00:43 <hiro-kobayashi> #topic RollCall
09:01:11 <masahito> hi
09:01:23 <priteau> o/
09:01:30 <bertys> hi all
09:01:39 <tejaswi> o/
09:01:44 <hrito> o/
09:01:44 <hiro-kobayashi> hi masahito. You can attend only 10 mins today, right?
09:01:48 <masahito> sorry, I need to go in 10 mins
09:01:57 <hiro-kobayashi> Hi all
09:02:03 <GeraldK> hi
09:02:09 <hiro-kobayashi> #topic agenda
09:02:19 <hiro-kobayashi> Todays agenda is
09:02:26 <hiro-kobayashi> 1. Pike release status
09:02:28 <masahito> and I won't join next meeting.
09:02:34 <hiro-kobayashi> 2. Denver PTG
09:02:40 <hiro-kobayashi> 3. AOB
09:02:44 <hiro-kobayashi> Anything else?
09:02:56 <hiro-kobayashi> masahito: np
09:03:14 <masahito> tc interview
09:03:44 <hiro-kobayashi> ok
09:03:53 <hiro-kobayashi> 4 tc interview
09:04:10 <hiro-kobayashi> masahito which one do you want to start?
09:04:57 <masahito> 1 , 4 then 2 if possible
09:05:02 <hiro-kobayashi> Ok
09:05:13 <hiro-kobayashi> #topic Pike release status
09:05:38 <hiro-kobayashi> There are only 2 patch waiting for being merged. Great progress!
09:05:49 <hiro-kobayashi> https://review.openstack.org/#/c/491744/
09:05:54 <priteau> Yes, great job everyone
09:05:56 <hiro-kobayashi> https://review.openstack.org/#/c/482811/
09:06:23 <priteau> I have just rebased 482811 and I am planning to +2
09:06:32 <priteau> I left comments for 491744
09:06:36 <masahito> right, Pike is good release
09:06:53 <hiro-kobayashi> priteau: thanks for your comment for 491744. I'll handle it after this meeting.
09:06:58 <priteau> Thanks hiro-kobayashi
09:07:24 <hiro-kobayashi> Anything to discuss here?
09:07:31 <hiro-kobayashi> > all
09:07:55 <masahito> I'll cut stable/pike branch once both patches are merged
09:08:09 <hiro-kobayashi> masahito: thanks!
09:08:58 <hiro-kobayashi> Deadline will be Aug. 30, right?
09:09:02 <priteau> Great
09:09:16 <masahito> right
09:09:36 <hiro-kobayashi> OK.
09:09:46 <hiro-kobayashi> Anything else?
09:10:03 <hiro-kobayashi> If nothing, let's move on 4
09:10:20 <hiro-kobayashi> #topic TC interview
09:10:53 <hiro-kobayashi> masahito: Can you introduce this topic?
09:11:22 <masahito> TC team offered this team a final interview in next PTG
09:11:49 <masahito> to official project.
09:12:03 <hiro-kobayashi> Great!
09:12:12 <bertys> thanks, date/time fixed yet?
09:12:16 <masahito> the day is Mon. or Tue.
09:12:16 <GeraldK> great
09:12:40 <priteau> Is that a face to face interview?
09:12:55 <masahito> I'll be there from Tue.  so it would be Tue.
09:13:06 <masahito> priteau: yes
09:13:30 <priteau> Is there something to prepare?
09:14:00 <masahito> nothing are required
09:14:03 <GeraldK> can we join or is it you and the TC?
09:14:38 <masahito> if you are in there, it's ok
09:14:51 <masahito> they ask
09:15:31 <masahito> us what we need if we are not official by the time.
09:16:20 <masahito> if we're accepted, they tell us what we need to do next.
09:16:35 <bertys> great, thanks
09:16:53 <hiro-kobayashi> thanks
09:17:33 <hiro-kobayashi> no -1 on gerrit so far :-)
09:18:02 <priteau> #link https://review.openstack.org/#/c/482860/
09:18:29 <masahito> of course, i have to prepare answers of faq for the meeting :-)
09:18:58 <masahito> that's from my side
09:19:17 <hiro-kobayashi> masahito: thanks! Let us know if any help is needed
09:19:34 <hiro-kobayashi> Anything else about this topic? > all
09:19:35 <masahito> got it
09:20:24 <hiro-kobayashi> #topic Denver PTG
09:20:49 <hiro-kobayashi> https://etherpad.openstack.org/p/blazar-ptg-queens
09:21:09 <hiro-kobayashi> masahito has arranged time slots for our meeting. thanks masahito!
09:21:39 <hiro-kobayashi> Please see L4-14
09:22:21 <masahito> 1st meeting is for all of us. 2nd is for attendances or European time zone.
09:22:55 <hiro-kobayashi> OK. maybe I will sleep at that time ;-)
09:22:56 <priteau> I suppose we won't have an IRC meeting at 0900 UTC on the 12th?
09:23:04 <masahito> hiro-kobayashi: sorry, the midnight meetings...
09:23:09 <hiro-kobayashi> masahito: np
09:23:37 <masahito> priteau: yes
09:24:04 <masahito> uh? same time?
09:24:57 <priteau> masahito: Since we have the PTG meeting, the regular IRC meeting is not necessary and will be difficult to attend from Denver anyway?
09:25:17 <masahito> yes. so
09:25:36 <masahito> I planned to cancel it
09:25:48 <priteau> OK
09:26:54 <hiro-kobayashi> Please recheck your attendance at L15-24 > all
09:26:58 <masahito> official teams have a priority for the space.
09:27:38 <masahito> the space could be change.
09:28:15 <hiro-kobayashi> OK
09:28:50 <masahito> but if the time slots are okay to you I share it to ML next week
09:30:47 <priteau> They are good for me
09:31:43 <masahito> thank all! I need to go. I'll read the meeting log later.
09:31:55 <hiro-kobayashi_> masahito: bye!
09:32:04 <hiro-kobayashi_> I'm sorry I was disconnected
09:32:04 <masahito> bye
09:33:57 <hiro-kobayashi_> If you have anything to discuss at PTG, please right it down etherpad
09:34:12 <hiro-kobayashi_> anything else?
09:34:38 <hiro-kobayashi_> #topic AOB
09:35:02 <hiro-kobayashi_> Oh, I'm not a chair now. priteau: could you change the topic?
09:35:09 <priteau> #topic AOB
09:35:11 <priteau> #chair hiro-kobayashi_
09:35:11 <openstack> Current chairs: hiro-kobayashi hiro-kobayashi_ priteau
09:35:21 <hiro-kobayashi_> priteau: thanks!
09:35:31 <priteau> I am requesting comments for this patch: https://review.openstack.org/#/c/494476/
09:35:57 <priteau> It adds state information to leases which is displayed by the CLI and Horizon dashboard
09:36:11 <hiro-kobayashi_> Sorry, I couldn't check it yet
09:36:13 <priteau> It's not 100% complete but I would like to have your opinion before I spend more time on it
09:37:46 <hiro-kobayashi_> The status of lease should be consistent with the status of reservation
09:37:50 <GeraldK> IMHO it is important to keep the status and status reason updated.
09:38:30 <GeraldK> without having looked at the patch in detail yet I feel it is going in a valid direction
09:38:47 <priteau> hiro-kobayashi_: the current DB format is different between leases and reservations
09:39:01 <priteau> For reservation, it's just one "status" field
09:39:32 <hiro-kobayashi_> priteau: yes. Shouldn't them be aligned?
09:39:46 <priteau> For leases, there is an "action" field and a "status" field, which according to the existing code was meant to be used that way
09:40:16 <priteau> I would agree to make them more similar, though that will likely require DB schema changes
09:40:37 <bertys> priteau: have you looked at v2 api? what is your intention here?
09:40:48 <bertys> #link http://blazar.readthedocs.io/en/latest/restapi/rest_api_v2.html
09:41:57 <priteau> bertys: I didn't notice it was documented in v2, but yes my patch pretty much matches that
09:42:46 <hiro-kobayashi_> bertys: thanks for your info!
09:42:55 <bertys> np
09:43:18 <priteau> The main question is, do we want any kind of lease state info in Pike, while we develop an alternative state model for Q?
09:44:25 <hiro-kobayashi_> I think we don't need it in Pike
09:44:49 <hiro-kobayashi_> Gut it's very important task for Q
09:44:59 <hiro-kobayashi_> s/Gut/But
09:45:57 <hiro-kobayashi_> As we discussed at Boston, we should clearly define state machine.
09:46:06 <GeraldK> hiro-kobayashi: +1
09:46:34 <priteau> Yes, it
09:46:46 <priteau> it is important to work on the state machine
09:47:12 <GeraldK> in Pike we could already start working on the mechanisms. if we change state model for Q, for this work do you expect major changes to the code or minor edits only?
09:48:12 <priteau> GeraldK: Pike is going to be branched very soon (maybe later today). We can backport bug fixes, but it's preferable to avoid backporting major changes.
09:49:46 <GeraldK> priteau: agree. so you expect your patch and other work on lease state info NOT to be included for Pike?
09:50:48 <GeraldK> priteau: maybe I misunderstood your above comment where you asked whether to have state info in Pike or not
09:50:52 <priteau> My patch doesn't change any of the schema and intends to use the existing mechanisms, so you can almost consider it a bug fix ;-) But I would include it in Pike only if everyone else was OK with it
09:52:12 <hiro-kobayashi_> I'll check the patch in detail and comment on Gerrit. Basically I agree with your approarch, priteau
09:52:12 <priteau> If the rest of the community prefers to state info for Pike and instead focus on the new mechanism for Queens, we can do that.
09:53:17 <GeraldK> the parts where you update the state based on events seems like something that is independent from the state model and would be kept even if we update the state model, right?
09:54:15 <priteau> GeraldK: There would still be code in the same place, but the code would do something different I guess.
09:54:36 <priteau> e.g. instead of setting action=START and status=COMPLETE, it would set status=started
09:54:50 <priteau> Or status=active
09:55:07 <priteau> I think we need a blueprint for the new mode l:-)
09:56:08 <hiro-kobayashi_> #action review https://review.openstack.org/#/c/494476/ and discuss lease states
09:56:10 <GeraldK> priteau: okay I see. a lot of rework would be needed.
09:56:17 <priteau> yep
09:56:44 <priteau> And there are some edge cases to consider, e.g. if a lease has multiple reservations, some start correctly and one doesn't
09:56:50 <priteau> What's the lease status in that case?
09:57:30 <hiro-kobayashi_> error or something?
09:57:44 <hiro-kobayashi_> A lot of works to do :-)
09:57:55 <hiro-kobayashi_> priteau: Anyway, thanks for starting this work!
09:58:02 <priteau> np
09:58:22 <hiro-kobayashi_> Let's keep discussing on Gerrit
09:58:42 <hiro-kobayashi_> Anything else? a few minutes left ...
09:59:27 <hiro-kobayashi_> OK. Let's end today's meeting.
09:59:30 <hiro-kobayashi_> thanks all!
09:59:33 <priteau> Thanks everyone
09:59:35 <priteau> Good bye.
09:59:43 <hiro-kobayashi_> Good bye!
09:59:46 <bertys> bye
09:59:54 <hiro-kobayashi_> #endmeeting