09:00:10 <priteau> #startmeeting blazar
09:00:11 <openstack> Meeting started Tue Feb 19 09:00:10 2019 UTC and is due to finish in 60 minutes.  The chair is priteau. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:14 <openstack> The meeting name has been set to 'blazar'
09:00:22 <priteau> #topic Roll call
09:01:28 <tetsuro> O/
09:01:37 <priteau> Hi tetsuro
09:02:17 <priteau> Do you know id masahito is planning to join?
09:02:55 <tetsuro> not sure
09:03:16 <tetsuro> I'll ping him on internal slack
09:03:26 <priteau> Thank you
09:03:55 <masahito> o/
09:04:09 <priteau> Hi masahito
09:04:10 <tetsuro> hi
09:04:46 <priteau> Agenda for today
09:04:51 <priteau> 1. Denver Summit Project Updates & Onboarding
09:04:54 <priteau> 2. stein-3 milestone
09:04:57 <priteau> 3. AOB
09:05:01 <masahito> priteau: sorry, I have to leave in 45min today.
09:05:10 <priteau> No problem, we'll try to be quick
09:05:16 <priteau> #topic Denver Summit Project Updates & Onboarding
09:05:40 <priteau> The call for Project Updates & Onboarding is open
09:06:09 <priteau> "This coming Summit for project updates, we have 36 slots that are 20-min long and 6 that are 40-min long. For project onboarding, we have 24 40-min slots."
09:06:38 <priteau> Given that only tetsuro will be in Denver, I assume that we're not going to have an onboarding session this time
09:07:28 <priteau> I think a 20 minute project update slot is good for us
09:07:44 <tetsuro> That decision helps me. Sounds good.
09:07:50 <priteau> tetsuro: Are you still happy to give the project update?
09:08:02 <tetsuro> Yes, pretty much.
09:08:13 <priteau> Great, thanks a lot
09:08:22 <priteau> I will request the 20 minute slot
09:08:23 <masahito> thanks, tetsuro.
09:08:40 <tetsuro> thanks!
09:08:41 <priteau> "You (or one of the other speakers for your onboarding/update), must also confirm that at least one of you are registered to attend* the Summit by emailing knelson@openstack.org by Sunday March 17th at 7:00 UTC."
09:09:03 <priteau> I will remind us about it closer to this date.
09:09:30 <tetsuro> Okay, I remember that.
09:10:41 <priteau> Are you usually able to register quite in advance?
09:11:16 <tetsuro> Yes, as soon as I get discount code.
09:11:43 <priteau> Actually, I just saw that I already received my discount code a month ago
09:11:55 <priteau> All September 2018 Denver PTG attendees receive 80% off a Summit + PTG Combo ticket. To receive the discount, you MUST register with your unique code before early bird pricing ends on February 27 at 11:59pm PST
09:12:09 <priteau> Did you receive it?
09:12:21 <tetsuro> I think so.
09:12:47 <tetsuro> anyway I check it up
09:13:24 <priteau> #action tetsuro register for the OpenStack Summit before early bird pricing ends on February 27
09:13:53 <priteau> #action confirm registration to Kendall Nelson by Sunday March 17th
09:14:25 <priteau> We'll start working on the slides soon.
09:14:54 <priteau> Anything else about Denver?
09:16:31 <priteau> Let's move to the next topic
09:16:40 <priteau> #topic stein-3 milestone
09:17:19 <priteau> ~2 weeks to go to stein-3
09:19:00 <priteau> tetsuro: Is https://bugs.launchpad.net/blazar/+bug/1737676 covered by your affinity patch series?
09:19:02 <openstack> Launchpad bug 1737676 in Blazar "Enable anti-affinity check for instance reservation" [Medium,New] - Assigned to Tetsuro Nakamura (tetsuro0907)
09:19:37 <tetsuro> Ah, that's yes
09:20:58 <priteau> Can you please add a Partial-Bug or Closes-Bug to one of the commit if it is partially/completely resolved?
09:23:01 <tetsuro> okay.
09:23:32 <priteau> I reviewed the full patch series, I mostly had minor comments as you saw, overall it looks good
09:23:46 <priteau> I haven't looked yet at your updated patches from today
09:23:53 <priteau> I expect we will be able to merge soon
09:24:14 <priteau> masahito: Thanks for posting your comment on the floating IP spec: https://review.openstack.org/#/c/609302/10/doc/source/specs/stein/basic-network-plugin.rst@192
09:24:39 <masahito> yup. My comment was in the draft :-)
09:24:43 <tetsuro> looks like I should check it up.
09:25:00 <priteau> The API can get complex with multiple floating IPs
09:25:02 <masahito> Having multi floating ip in one reservation makes sense to me.
09:25:18 <masahito> One thing to discuss is its schema.
09:26:08 <tetsuro> I see the point
09:26:23 <priteau> I am ok with making floating_ip_address a list all the time, even for amount == 1. We should rename it to floatingip_addresses
09:26:48 <priteau> The main question is what to do if len(floatingip_addresses) < amount
09:27:42 <tetsuro> 1. invalid request, 2. complement it  a
09:27:47 <tetsuro> automatilcally
09:27:52 <priteau> I would say, try and allocate from the list. Fail if any in the list is not available. Allocate from other free blazar resources for the rest.
09:28:23 <priteau> I think what I suggest is equivalent to tetsuro's 2.
09:28:50 <masahito> And when len(floatingip_address) > amount, how does the reservation pick up?
09:29:14 <priteau> Maybe this one should be an error
09:29:16 <tetsuro> That should fail.
09:29:19 <tetsuro> yes
09:29:30 <masahito> invalid input?
09:29:36 <priteau> yes
09:29:45 <tetsuro> yes
09:29:50 <masahito> All right. I got it.
09:30:51 <tetsuro> I'm also good with priteau's strategy in len(floatingip_addresses) < amount case.
09:30:56 <priteau> I can see a use case for it: user wants x of y specific floating IP addresses (x<y), but doesn't know which are free and which are used. But it probably not going to be used very often. We should keep things simple if possible.
09:31:36 <priteau> Probably most of the time users will not provide any floating IP address
09:32:27 <masahito> Make sense to me. I'll update it applying the discussion. I guess it's not a big change for the patches.
09:32:42 <priteau> Thanks masahito!
09:32:54 <tetsuro> Thank you.
09:33:59 <priteau> Looks like affinity and floating IP blueprint could be merged by stein-3
09:34:02 <priteau> That's good news
09:34:29 <masahito> Right. We would have big improvements.
09:35:29 <priteau> masahito: Did you see that you have a pep8 failure in https://review.openstack.org/#/c/633462/5 which is fixed in https://review.openstack.org/#/c/633669/
09:36:02 <priteau> The fix should be moved to the first of the two patches above.
09:36:02 <masahito> sorry not yet
09:36:58 <masahito> Ah, right.
09:37:31 <priteau> I have several bug fixes to be reviewed
09:37:34 <priteau> https://review.openstack.org/#/c/636700/
09:37:36 <priteau> https://review.openstack.org/#/c/635005/
09:37:38 <priteau> https://review.openstack.org/#/c/625724/
09:39:11 <priteau> Thanks tetsuro for the review already
09:39:31 <priteau> masahito has to go soon so let's move to AOB
09:39:37 <priteau> #topic AOB
09:39:37 <tetsuro> put those fixes in my list
09:39:44 <masahito> priteau: thanks
09:40:03 <priteau> Anything else to discuss or mention?
09:40:09 <tetsuro> Not from me
09:40:26 <masahito> Nothing from my side.
09:40:49 <priteau> Nothing special from me either.
09:40:55 <priteau> We can finish here for today.
09:41:19 <priteau> Thanks everyone
09:41:21 <priteau> #endmeeting