09:02:02 <priteau> #startmeeting blazar
09:02:03 <openstack> Meeting started Tue Mar 26 09:02:02 2019 UTC and is due to finish in 60 minutes.  The chair is priteau. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:02:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:02:06 <openstack> The meeting name has been set to 'blazar'
09:02:09 <priteau> #topic Roll call
09:02:17 <priteau> Hello everyone
09:02:18 <masahito> o/
09:02:22 <bertys> o/
09:02:51 <tetsuro> o/
09:03:45 <priteau> #topic Denver Summit Project Update
09:04:11 <priteau> Bertrand is now listed in the speaker list
09:04:38 <bertys> right, thanks priteau for your prompt action
09:04:53 <priteau> I see there were edits from masahito and bertys on the slides, great!
09:05:08 <masahito> :-)
09:07:09 <priteau> I think we've got a good base for the slides now
09:07:24 <priteau> Let's fix these TODOs ;-)
09:08:02 <priteau> tetsuro: Have you checked the placement-related info already?
09:08:18 <tetsuro> Yes, that's good as is.
09:08:35 <priteau> Excellent
09:10:04 <priteau> I've quickly checked the schedule, we don't appear to have conflicts with related sessions
09:10:46 <priteau> Let's move to the next topic
09:10:58 <priteau> #topic Stein release
09:11:21 <priteau> RC1 was tagged last Thursday
09:11:45 <priteau> It includes all the floating IP patches except update-lease support
09:11:51 <masahito> Thank you.
09:12:39 <priteau> I see that tetsuro has replied on https://review.openstack.org/#/c/633204/, thanks
09:13:11 <tetsuro> Yup, thanks for caring about this patch
09:13:21 <priteau> I'll review the patch and see if it makes sense to tag an rc2
09:13:53 <priteau> I've also flagged a zuul failure for you to check
09:14:08 <priteau> In https://review.openstack.org/#/c/646070/, the first Zuul check failed
09:14:15 <priteau> #link http://logs.openstack.org/70/646070/1/check/blazar-devstack-dsvm-py35/0d56394/
09:14:44 <priteau> Often it's related to infra issues, but I checked the logs and it looked like it could be placement-related
09:15:25 <tetsuro> Ack. I will look into this
09:15:45 <priteau> Thank you.
09:16:18 <priteau> I encourage you all to do some testing this week to make sure Stein is working well.
09:16:30 <masahito> ok
09:16:45 <masahito> Speaking for Stein, I found the bug report
09:16:51 <masahito> https://bugs.launchpad.net/blazar/+bug/1821576
09:16:52 <openstack> Launchpad bug 1821576 in Blazar "Lease creation should fail if affinity is passed with invalid input" [Undecided,In progress] - Assigned to Asmita Singh (asmita2018)
09:17:58 <priteau> masahito: That's a good point. Do you know if Asmita is actively working on it? (it says in progress)
09:18:08 <priteau> This could be RC2 material
09:19:07 <priteau> It shouldn't be too complex, just check that affinity is true, false, or absent?
09:19:15 <tetsuro> Right
09:19:29 <masahito> I was talked in the IRC channel yesterday, and Asmita will report it.
09:19:50 <masahito> I'm not sure Asmita is working on this RIGHT NOW or not.
09:20:09 <priteau> She's not on IRC right now
09:21:07 <priteau> I can drop her an email. If she's not able to work on it soon, one of us could try to do it quickly.
09:21:56 <priteau> I also noticed that we haven't updated blazar-dashboard to support affinity
09:21:59 <priteau> #link https://bugs.launchpad.net/blazar/+bug/1821168
09:22:00 <openstack> Launchpad bug 1821168 in Blazar "Add affinity support in blazar-dashboard" [High,Confirmed]
09:22:08 <priteau> Is anyone able to change this?
09:23:10 <priteau> We need some UI controls to select affinity, not sure how it should look like since it's not just true/false, it's true/false/none
09:23:23 <priteau> Radio button with three choices?
09:23:40 <masahito> maybe
09:23:42 <tetsuro> I can do the quick bug fix if Asmita is not going to do it, but I'm not familiar with dashboard...
09:23:58 <masahito> I try to dig into this.
09:24:34 <tetsuro> Thank you so much masahito m(_ _)m
09:24:50 <priteau> Thanks masahito, I've assigned the bug to you.
09:25:49 <priteau> I believe the release team will tag blazar-dashboard for release this week, not sure exactly when
09:26:20 <priteau> Anything else to discuss for Stein?
09:27:09 <priteau> If not let's talk about Train
09:27:29 <priteau> #topic Train PTG
09:28:00 <priteau> Blazar doesn't have official presence at the PTG, but of course we have tetsuro and bertys over there
09:28:43 <priteau> We should discuss what we want for the meetings with other teams, in particular placement and nova
09:29:30 <priteau> tetsuro: Will you be talking about requirements for host reservation? (unless it's all merged by then of course)
09:29:55 <priteau> I see there is ongoing work on negative member_of query
09:30:31 <tetsuro> yeah, placement side is pretty ready https://storyboard.openstack.org/#!/story/2005297
09:30:51 <tetsuro> https://review.openstack.org/#/q/status:open+project:openstack/placement+branch:master+topic:bp/negative-aggregate-membership
09:31:06 <tetsuro> so I'd like to talk how we use this in Nova
09:31:34 <tetsuro> https://review.openstack.org/#/c/609960/
09:31:36 <priteau> How to use it from Nova is the unknown bit for me, we haven't really discussed it in Denver last time
09:32:23 <tetsuro> Agreed it is still young
09:34:16 <priteau> If it's based on traits, for host reservation we would do like instance reservation and create a private flavor per reservation?
09:35:21 <tetsuro> No, because it results creating so many private flavors
09:36:11 <tetsuro> It's based on aggregates and Nova should have default aggregate filter
09:37:56 <priteau> I am thinking about how users would select the reservation they want. Can we still use scheduler hints? If they are available in Nova before sending the placement request, we could internally fetch the reservation ID and transform it in in a placement request filter
09:39:29 <priteau> Unless we can leverage something existing, similar to tenant aggregates?
09:40:01 <tetsuro> https://review.openstack.org/#/c/603352/7/specs/stein/approved/negative-aggregate-membership.rst@198
09:40:45 <tetsuro> ^I've put my thoughts in this spec
09:41:16 <tetsuro> regarding to the discussion we had in the last PTG
09:42:18 <priteau> Thanks. I think I saw this spec months ago but don't remember the details
09:42:50 <tetsuro> It's still a draft, it warrants to propose this as a blazar spec in blazar repo and nova repo
09:44:01 <priteau> Let's resume the discussion with the Nova team to see what still needs changes. If we can it in good shape around PTG time, then you may be able to resolve the rest at the PTG.
09:44:26 <priteau> tetsuro: This reminds me I need to prepare the specs repo for Train
09:44:44 <priteau> #action priteau will prepare the specs repo for Train
09:44:58 <priteau> #action priteau will review https://review.openstack.org/#/c/603352/7
09:46:02 <priteau> Heh, I am not quite awake. I didn't see it was approved :D
09:46:36 <priteau> tetsuro: So if it's approved, are there patches for nova that we need to write?
09:46:48 <masahito> I'm also suprised :D
09:48:29 <tetsuro> Yes, this is drafting a use case of this feature in *placement*, we need the nova spec and the spec should also support another usecase described in https://review.openstack.org/#/c/609960/
09:49:19 <priteau> I see, I got confused by the specs because placement specs are in nova-specs :D
09:49:34 <tetsuro> Yes, yes
09:49:46 <priteau> OK so nova side is still under discussion
09:49:52 <tetsuro> Yes, yes
09:50:12 <priteau> Let's resume the discussion then :-) I'll try to read the spec this week and comment.
09:50:32 <priteau> Any other goals for the PTG?
09:52:24 <priteau> We still have some time to discuss it further
09:52:27 <priteau> #topic AOB
09:52:48 <bertys> Sorry slow reply. I remember a thread on openstack discuss on the concept of allocation end time but not sure if this going anywhere
09:53:00 <bertys> e.g. #link http://lists.openstack.org/pipermail/openstack-discuss/2019-February/002712.html
09:53:29 <priteau> I haven't seen this, thanks for the link bertys
09:53:51 <priteau> I have something for AOB: next meetings
09:54:34 <priteau> I may be on travel either April 9 or April 16, I will confirm when I know more.
09:54:56 <priteau> I will definitely be on travel April 23 and April 30
09:55:16 <bertys> On my side I will be on travel next week April 2
09:55:38 <priteau> Is someone happy to chair the meeting on April 23? It could be useful to have one last pre-summit/ptg check
09:55:50 <priteau> April 30 we would cancel anyway, as there is the summit in the US
09:56:02 <priteau> bertys: Thanks for letting us know
09:56:14 <masahito> I'm happy to chair on April 23.
09:57:00 <priteau> Thanks masahito
09:57:30 <priteau> I've updated https://wiki.openstack.org/wiki/Meetings/Blazar#Next_meetings
09:57:37 <priteau> Last few minutes, anything else?
09:57:54 <tetsuro> No, sir
09:58:04 <masahito> Nothing
09:58:29 <priteau> Thanks for joining!
09:58:33 <priteau> #endmeeting