08:59:53 <priteau> #startmeeting blazar
08:59:54 <openstack> Meeting started Tue Aug 27 08:59:53 2019 UTC and is due to finish in 60 minutes.  The chair is priteau. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:59:55 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:59:57 <openstack> The meeting name has been set to 'blazar'
09:00:03 <priteau> #topic Roll call
09:01:02 <masahito> o/
09:01:24 <priteau> Hi masahito
09:03:18 <priteau> tetsuro: Are you here too?
09:03:31 <tetsuro> o/
09:04:00 <priteau> Hi tetsuro
09:04:06 <tetsuro> Hi
09:04:08 <priteau> Agenda for today
09:04:12 <priteau> * Client release
09:04:15 <priteau> * Change of blazar-dashboard release model
09:04:17 <priteau> * Code review priorities
09:04:19 <priteau> * AOB
09:04:33 <priteau> #topic Client release
09:04:44 <priteau> #info python-blazarclient 2.2.0 was released last week
09:04:53 <priteau> #link https://pypi.org/project/python-blazarclient/
09:05:24 <priteau> #action Write floating IP reservation docs
09:06:32 <priteau> There are also some client patches pending review, if we want to include them in Train we need to release the client again before Sep 09 - Sep 13
09:07:58 <priteau> Although none of them are ready: https://review.opendev.org/#/q/project:openstack/python-blazarclient+is:open
09:08:31 <priteau> The switch to stestr is not critical and if we merge it I would like to synchronize it with all the other blazar repos
09:09:06 <priteau> #topic Change of blazar-dashboard release model
09:09:29 <priteau> We got an answer from Thierry about the change of release model: https://review.opendev.org/#/c/675471/
09:09:58 <priteau> He said: "It is possible to move back to cycle-with-intermediary.... However if you are likely to do that, I would rather stay on cycle-with-intermediary and just do one release this cycle. Just remember to do it before the RC1 deadline !"
09:11:08 <priteau> Because we're not sure we will have enough activity on blazar-dashboard to release multiple times per cycle, I propose that we mov to cycle-with-rc for Train and keep using this model until we get enough activity to go back to cycle-with-intermediary
09:11:21 <priteau> Any thoughts / objections?
09:11:39 <masahito> no objections from my side
09:12:19 <tetsuro> no objections
09:13:11 <priteau> So we will need to create an RC1 for blazar-dashboard soon. I would like to see if I can add some floating IP support easily.
09:14:35 <priteau> #topic Code review priorities
09:15:30 <priteau> tetsuro: I see that you submitted a query optimization patch earlier, I will look as soon as possible.
09:15:36 <priteau> Thanks for doing this.
09:15:53 <ttx> priteau: re : RC1 you have a few more weeks for it
09:16:17 <priteau> ttx: About a month, it will come quicly!
09:16:19 <priteau> quickly
09:16:21 <tetsuro> That is after https://review.opendev.org/#/c/672994/3 and less controversial
09:16:32 <ttx> between now and then you could request a beta-1 if you want to exercise the process, after the release model change
09:16:51 <priteau> ttx: Thanks for letting us know
09:17:05 <ttx> One benefit of the cycle-with-rc process is that it lets you have a number of pre-release opportunities (betas)
09:17:25 <priteau> masahito: Could you please take a look at https://review.opendev.org/#/c/671312/ and +2 if it looks good to you?
09:17:33 <ttx> then switch to RCs when you are in "releasable" state
09:18:15 <ttx> we just automatically take the latest RC available to make it as "the release" at the end of the cycle
09:21:37 <priteau> Thanks masahito
09:24:24 <priteau> Other patch series going on:
09:25:02 <priteau> * network reservation: Jake will update his specs patch (I've left comments), we can already comment on the code: https://review.opendev.org/#/c/668749/
09:25:52 <priteau> * floating IP reservation update: https://review.opendev.org/#/c/672763/
09:25:59 <priteau> masahito: what were your thoughts on ^^^
09:28:44 <masahito> I'll check it.
09:29:06 <masahito> Do you plan to release all network reservation feature in T?
09:29:45 <priteau> If possible, yes. But at least completing floating IP reservation is essential since we promised it for T
09:30:13 <masahito> okay. I'll review floating ip patch first
09:31:29 <priteau> Thank you
09:33:11 <priteau> Any other patch to mention particularly?
09:36:10 <tetsuro> The series starting from https://review.opendev.org/#/c/637140/15 is also ready for reviewing
09:37:17 <priteau> Thanks for the reminder
09:38:42 <priteau> #topic AOB
09:39:03 <priteau> PTL election season is coming up again
09:39:12 <priteau> The nomination period officially begins Aug 27, 2019 23:45 UTC.
09:39:17 <priteau> which is later today!
09:40:15 <priteau> Is anyone planning to self-nominate?
09:42:42 <priteau> I will submit my nomination if no one else wants to ;-)
09:43:47 <masahito> +1 to your nomination :-)
09:44:55 <tetsuro> +1. thank you!
09:45:08 <priteau> Thanks for your support :-)
09:45:15 <priteau> Anything else to discuss today?
09:47:59 <priteau> masahito: I noticed that Gerrit still shows your old email address
09:48:42 <masahito> sorry, I haven't changed it yet.
09:49:22 <priteau> Please do so you can receive notifications when we add you as reviewer
09:51:06 <priteau> I think that's all for today, let's end here
09:51:14 <priteau> Thanks both for joining
09:51:18 <priteau> #endmeeting