09:00:53 <priteau> #startmeeting blazar
09:00:54 <openstack> Meeting started Tue Sep  3 09:00:53 2019 UTC and is due to finish in 60 minutes.  The chair is priteau. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:55 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:57 <openstack> The meeting name has been set to 'blazar'
09:01:03 <priteau> #topic Roll call
09:02:08 <priteau> ping masahito asmita_s
09:02:25 <asmita_s> Hi
09:02:37 <masahito> hi
09:03:23 <priteau> I don't see Tetsuro nor Bertrand online
09:03:46 <priteau> #topic Meeting agenda
09:03:51 <priteau> 1. Change of blazar-dashboard release model
09:03:54 <priteau> 2. Train release schedule
09:03:58 <priteau> 3. Code review priorities
09:04:01 <priteau> 4. AOB
09:04:09 <priteau> #topic Change of blazar-dashboard release model
09:04:38 <priteau> Last week we agreed to change the release model of the blazar-dashboard deliverable to cycle-with-rc
09:04:45 <priteau> This change has been approved.
09:05:00 <priteau> https://review.opendev.org/#/c/675471/
09:06:16 <priteau> #topic Train release schedule
09:06:43 <priteau> We're getting closer to end of the release cycle
09:06:44 <priteau> #link https://releases.openstack.org/train/schedule.html
09:07:04 <priteau> This week is final release for non-client libraries
09:07:24 <priteau> which makes me think, we may need to release blazar-nova.
09:07:45 <priteau> #action priteau will check with the release team if we need a new release for blazar-nova
09:08:34 <priteau> Next week is:
09:08:41 <priteau> Train-3 milestone
09:08:50 <priteau> Feature freeze
09:08:53 <priteau> Final release for client libraries
09:09:18 <priteau> Soft StringFreeze
09:09:20 <priteau> Requirements freeze
09:09:22 <priteau> Train Community Goals Completed
09:09:26 <priteau> Cycle highlights marketing deadline
09:09:36 <priteau> So lots of things to do!
09:09:52 <priteau> I'd like to merge all the patches that are ready to land this week
09:10:11 <priteau> asmita_s: I noticed that one of your patches is not passing Zuul checks anymore, could you please fix and resubmit?
09:10:11 <masahito> Thanks.
09:10:37 <asmita_s> Yes , Will resolve the merge conflict of patch https://review.opendev.org/#/c/669079/ and push another Patch set soon.
09:10:57 <priteau> Thank you asmita_s
09:12:18 <asmita_s> Need to resolve merge conflict of https://review.opendev.org/#/c/655837/ and https://review.opendev.org/#/c/655838 as well. Will do that too and upload another PS soon.
09:13:09 <asmita_s> After I resolve these merge conflicts, these patches will be ready to review.
09:13:22 <asmita_s> Thanks , priteau.
09:13:36 <priteau> I will put aside time this week to review
09:13:49 <asmita_s> Thank you very much.
09:14:12 <priteau> masahito: We promised to complete floating IP support for Train. I've submitted documentation, could you please review https://review.opendev.org/#/c/678792/
09:14:45 <masahito> got it
09:16:35 <priteau> I'll look at the two solutions for floating IP reservation update as well.
09:18:26 <priteau> In the client repo we don't have anything ready to merge
09:18:44 <priteau> #link https://review.opendev.org/#/q/project:openstack/python-blazarclient+status:open
09:19:39 <priteau> asmita_s: Do you know if this patch will be reworked? Should we take ownership of it? https://review.opendev.org/#/c/625783/
09:21:29 <asmita_s> This patch can be reworked if after microversion is added in Blazar client.
09:22:06 <asmita_s> I have microversion in blazarclient patch locally.
09:22:17 <asmita_s> Will upload soon.
09:22:25 <priteau> I thought this patch was only relying on existing API features?
09:24:54 <priteau> The commit message says that lease-update supports changing before-end-leaese
09:24:59 <priteau> Sorry, before-end-date
09:25:59 <asmita_s> '--advance-before-end-date', and '--reduce-before-end-date', should be relative from before_end_date and not start_date according to Masahito san. So we can add before_end_date through microversion.
09:26:18 <asmita_s> Forgive me if I am wrong, but this is my understanding.
09:27:24 <priteau> I understand now. Yes, the only alternative would be to fetch the current before-end-date, do the addition/subtraction, and then put the updated data
09:27:39 <asmita_s> Exactly.
09:28:09 <priteau> I agree it's better to use microversion.
09:28:37 <asmita_s> Thank you.
09:29:48 <priteau> #topic Code review priorities
09:30:28 <priteau> We've covered this in the previous agenda item. Priority is to review all the feature patches that are ready to land, before feature freeze.
09:31:16 <priteau> #topic AOB
09:32:10 <priteau> I've submitted my candidacy for PTL for the Ussuri release cycle
09:32:15 <priteau> #link https://opendev.org/openstack/election/raw/branch/master/candidates/u/Blazar/pierre@stackhpc.com
09:32:40 <asmita_s> All the best, Pierre.
09:32:45 <asmita_s> :)
09:33:20 <priteau> If someone else wants to run, last chance to submit your self-nomination until 23:45 UTC today
09:33:31 <masahito> +1 to your candidacy.
09:34:26 <priteau> Thank you :-)
09:34:53 <priteau> Anyone else has something to share?
09:36:07 <masahito> nothing from my side.
09:36:28 <masahito> ah, I changed my email account in UbuntuOne and OpenStack ID
09:36:35 <priteau> I saw this, thank you.
09:36:52 <priteau> Just in time for elections ;-)
09:37:20 <masahito> What I need to change is above two ID, right?
09:37:59 <masahito> I don't remember what I registered when I started to contribute. There're lots of ID relations in OpenStack community...
09:38:10 <priteau> Make sure your new address is displayed on the OpenStack website (Foundation account), Launchpad, and Gerrit.
09:38:51 <priteau> You may want to add your profile to the stackalytics repo as well
09:38:56 <priteau> But that's not mandatory
09:39:26 <masahito> oh I see. Thanks.
09:40:09 <priteau> If nothing else, let's end here for today. Please resubmit all patches that fail to merge / check and let's review before train-3.
09:41:36 <priteau> Thanks a lot for joining
09:41:37 <priteau> #endmeeting