09:00:16 <priteau> #startmeeting blazar
09:00:16 <openstack> Meeting started Tue Sep 17 09:00:16 2019 UTC and is due to finish in 60 minutes.  The chair is priteau. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:19 <openstack> The meeting name has been set to 'blazar'
09:01:59 <priteau> #topic Roll call
09:02:06 <bertys> o/
09:02:20 <priteau> Hi bertys, nice to see you
09:02:28 <bertys> Hi
09:04:06 <priteau> masahito: hi
09:05:13 <masahito> o/
09:06:14 <priteau> I don't see tetsuro online
09:07:31 <priteau> Here is the agenda for today:
09:07:41 <priteau> Enabling Review-Priority flag in Gerrit
09:07:41 <priteau> PTG and virtual PTG
09:07:41 <priteau> Train release
09:07:43 <priteau> Code review priorities
09:07:45 <priteau> AOB
09:07:57 <priteau> Anything else you would like to add?
09:09:03 <priteau> #topic Enabling Review-Priority flag in Gerrit
09:09:19 <priteau> Come on openstack bot
09:09:23 <priteau> #topic Enabling Review-Priority flag in Gerrit
09:10:00 <priteau> I am working on other OpenStack projects which have enabled an additional flag in Gerrit called Review-Priority
09:11:26 <priteau> I think it would be useful for us to identify patches that need attention
09:12:32 <priteau> It needs to be implemented in openstack/project-config
09:12:36 <priteau> Example: https://review.opendev.org/#/c/295253/13/gerrit/acls/openstack/designate-dashboard.config
09:13:46 <priteau> I would like to propose a similar change for Blazar repos, if you are happy to have it?
09:14:55 <masahito> +1 for the change.
09:15:55 <priteau> Thanks, I will prepare a patch then.
09:15:58 <bertys> okay for me as well for all repos
09:16:46 <priteau> Thanks
09:17:00 <priteau> #action priteau will propose Review-Priority patches
09:17:07 <priteau> #topic PTG and virtual PTG
09:18:15 <priteau> Reminder that for the PTG we have a Project Onboarding session, and the possibility of having technical discussions scheduled on the fly in the shared space
09:19:40 <priteau> We need to plan a virtual PTG as well to include everyone in the discussion. I would like to have it before the summit, would you be available during the week of the 28 of October?
09:21:01 <masahito> On Tuesday?
09:22:04 <priteau> Not necessarily, if another day is good for you.
09:22:39 <priteau> There's also the possibility of including Chameleon folks in the discussion, but it may be difficult to schedule due to timezone differences
09:23:02 <masahito> Got it. Mon-Thu works for me.
09:24:48 <priteau> This is the timezones if we wanted to involve Chameleon people in the discussion: https://www.timeanddate.com/worldclock/meetingtime.html?day=28&month=10&year=2019&p1=248&p2=64&p3=195&iv=0
09:25:13 <priteau> This slot is in the middle of the night for them
09:26:57 <priteau> There are some possibilities if some are happy to have a meeting quite early or late during the day. But I think the best approach would be for me to have two meetings, one with Chicago and one with the rest of the community (Japan, maybe NTT data too?)
09:28:21 <priteau> I'll start an Etherpad to collect discussion ideas
09:28:28 <masahito> yup
09:30:08 <priteau> Do you know if NTT Data people will be Shanghai?
09:31:08 <masahito> Sorry, I don't know..
09:31:55 <priteau> I'll ask them directly
09:32:16 <priteau> Asmita has been quite active this cycle, it would be good to keep her involved.
09:33:25 <priteau> #topic Train release
09:34:04 <priteau> python-blazarclient 2.2.1 was released last week: https://pypi.org/project/python-blazarclient/
09:34:50 <priteau> We managed to get floating IP update functionality inside, thanks for your reviews
09:35:26 <masahito> sorry, disconnected.
09:35:30 <priteau> Now focus is on preparing the release of the main Blazar service
09:36:00 <priteau> Yesterday while testing floating IP again I noticed a big regression
09:36:10 <priteau> Thanksfully the fix was easy
09:36:12 <priteau> https://review.opendev.org/#/c/682416/
09:36:30 <priteau> This would be Review-Priority +2 if we had the flag ;-)
09:36:53 <priteau> Also added more floating IP docs, please review https://review.opendev.org/#/c/682411/
09:36:53 <bertys> Got it
09:37:17 <priteau> In general if you are able to do some testing, now is the time
09:38:12 <priteau> I'll try to merge the last patch from Asmita as an exception because it's been up for a long time, but then we'll be in freeze mode
09:38:56 <priteau> RC1 during week of Sep 23 - Sep 27 and final RC (if needed) week of Oct 07 - Oct 11
09:39:54 <priteau> I'll try to add some floating IP tests to tempest, it's really needed as it would have caught the problem caused by the microversion patch
09:41:30 <priteau> #topic Code review priorities
09:41:44 <priteau> The two mentioned above:
09:41:45 <priteau> https://review.opendev.org/#/c/682416/
09:41:49 <priteau> https://review.opendev.org/#/c/682411/
09:42:11 <priteau> And a trivial fix: https://review.opendev.org/#/c/682405/
09:42:40 <priteau> Oh, there's also an IPV6 Train goal, for which a patch was proposed but it doesn't pass Zuul checks
09:42:40 <priteau> https://review.opendev.org/#/c/682361/
09:42:46 <priteau> I haven't looked into it yet.
09:45:39 <priteau> Value for option os_auth_host from LocationInfo(location=<Locations.user: (4, True)>, detail='/etc/blazar/blazar.conf') is not valid: [::1] is not a valid host address
09:46:05 <priteau> From the end of https://storage.bhs1.cloud.ovh.net/v1/AUTH_dcaab5e32b234d56b626f72581e3644c/zuul_opendev_logs_258/682361/1/check/blazar-devstack-dsvm-ipv6-only/258dffd/logs/devstacklog.txt.gz
09:47:51 <priteau> If you are able to work on a fix, please do so
09:49:06 <priteau> I also need to try the PDF docs build (another community goal)
09:50:23 <priteau> #topic AOB
09:50:28 <priteau> Anything else to discuss?
09:51:01 <masahito> Not about Blazar, but I noticed Tetsuro is nominated to Placement PTL
09:51:30 <priteau> Indeed, congratulations to him. I hope he will still have some time for Blazar.
09:53:03 <masahito> http://lists.openstack.org/pipermail/openstack-discuss/2019-September/009274.html
09:54:38 <priteau> It's good news for us that Placement has an active leader, even better that it is someone very familiar with Blazar
09:56:04 <priteau> If that's all for this week, we can end here.
09:56:27 <priteau> Thanks a lot for joining, please remember to look at the high priority patches
09:57:01 <bertys> thanks all
09:57:06 <priteau> #endmeeting