09:00:02 <priteau> #startmeeting blazar
09:00:03 <openstack> Meeting started Tue Oct  8 09:00:02 2019 UTC and is due to finish in 60 minutes.  The chair is priteau. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:07 <openstack> The meeting name has been set to 'blazar'
09:00:50 <priteau> #topic Roll call
09:00:54 <priteau> \o
09:01:14 <masahito> o/
09:01:19 <priteau> Hi masahito
09:02:38 <tetsuro> o/
09:02:40 <bertys> o/
09:02:51 <priteau> Hi tetsuro and bertys
09:03:15 <priteau> Agenda for today:
09:03:19 <priteau> PTG and virtual PTG
09:03:19 <priteau> Train release
09:03:19 <priteau> Code review priorities
09:03:21 <priteau> AOB
09:03:33 <priteau> #topic PTG and virtual PTG
09:04:44 <priteau> You should all have received an invitation for the virtual PTG on October 31
09:04:59 <priteau> Please let me know if that isn't the case
09:06:12 <priteau> I will circulate the meeting information on the list, in case others want to join.
09:06:26 <priteau> #action Share virtual PTG meeting info
09:06:51 <priteau> For the PTG itself, the schedule is now finalized and Blazar is on it :-)
09:06:55 <priteau> #link https://www.openstack.org/PTG
09:07:05 <priteau> All of Friday, November 8
09:08:41 <priteau> So we have one month to prepare material for Project Onboarding
09:09:03 <priteau> Any thoughts about what we should include in this session?
09:11:35 <priteau> Examples of slides from onboarding sessions in Denver:
09:11:41 <priteau> Manila: https://object-storage-ca-ymq-1.vexxhost.net/swift/v1/6e4619c416ff4bd19e1c087f27a43eea/www-assets-prod/summits/26/presentations/23618/slides/ManilaProjectOnboarding.pdf
09:11:59 <priteau> Nova: https://tinyurl.com/DEN-train-nova-onboarding
09:12:19 <priteau> Heat: https://goo.gl/eZ3bbH
09:12:26 <priteau> Kolla: https://object-storage-ca-ymq-1.vexxhost.net/swift/v1/6e4619c416ff4bd19e1c087f27a43eea/www-assets-prod/summits/26/presentations/23651/slides/Kolla-Project-Onboarding-Train.pdf
09:12:54 <tetsuro> I remember hiro-kobayashi has given the onboarding session in Vancouver
09:13:44 <priteau> I didn't remember we did a project onboarding session!
09:13:49 <priteau> Slides: https://docs.google.com/presentation/d/1vOYlFuIK4NX7C73xT-JQkkRdsPzjG1BMq_bXCMKvEe4/edit#slide=id.p
09:14:26 <priteau> I'll copy these slides and update. I think we should also add the following:
09:14:34 <priteau> * view of the various repos
09:14:43 <priteau> (blazar, blazar-nova, python-blazarclient, etc.)
09:14:59 <priteau> * layout of the blazar repo (api code, db code, manager, plugins, etc.)
09:15:09 <priteau> * how to install with devstac, how to run tempest
09:15:28 <priteau> * extend the demo to show floating IP reservation?
09:16:17 <priteau> Anything else?
09:18:02 <priteau> Looks like most onboarding sessions in Denver were 40 minutes long
09:18:20 <priteau> Now that this is part of the PTG, we don't have a fixed timeslot.
09:19:48 <priteau> I'll start with these changes if you're OK with it.
09:20:01 <tetsuro> Sure.
09:20:05 <priteau> #action Create Project Onboarding slides based on Vancouver material
09:20:30 <priteau> Also I was away most of next week so I didn't do my action on project update
09:20:41 <priteau> #action Create Project Update slides based on Denver material
09:22:05 <priteau> I don't remember if I've shared this info: Jacob Colleran (Jake) should be available all of Friday for Blazar technical discussion
09:22:25 <priteau> I mean Friday, November 8. In Shanghai.
09:23:17 <bertys> Good to hear. Looking forward to meeting him in Shanghai
09:23:27 <priteau> Next topic
09:23:31 <priteau> #topic Train release
09:23:52 <priteau> This week is final RC
09:24:18 <priteau> Jake has been testing RC1 on Chameleon. He reported one issue and provided a patch: https://review.opendev.org/#/c/686844/
09:24:46 <priteau> He said he got this error just by running tox. Somehow I cannot reproduce it.
09:26:10 <tetsuro> Yeah, I was curious why some patches have passed the gate without this change.
09:26:48 <priteau> There must be something related to the environment
09:27:02 <priteau> Anyway, I think we should backport and produce RC2?
09:27:37 <bertys> blazar.conf by default now (using devstack) without this plugin?
09:28:00 <bertys> e.g. https://openstack.fortnebula.com:13808/v1/AUTH_e8fd161dc34c421a979a9e6421f823e9/zuul_opendev_logs_24c/686844/3/check/blazar-devstack-dsvm-py35/24cb45a/logs/etc/blazar/blazar.conf.txt.gz
09:28:21 <priteau> this plugin is the default in the code, so if you don't have a blazar.conf, blazar-manager will load it
09:29:18 <priteau> But when I try running blazar-manager in my local env without blazar.conf, it fails on lack of connection URL anyway
09:31:30 <priteau> bertys: I don't think it was in devstack that he saw the issue, but while running unit tests
09:32:16 <priteau> I guess I need to create a release note as well to document what changed between RC1 and RC2
09:34:20 <priteau> I will propose it this week and ping you for reviews ;-)
09:34:51 <priteau> #topic Code review priorities
09:35:40 <priteau> Same as last week:
09:35:49 <priteau> DevStack cleanup: https://review.opendev.org/#/c/683099/
09:36:04 <priteau> Asmita's patch using microversion: https://review.opendev.org/#/c/655838/
09:36:09 <priteau> Thanks tetsuro for the reviews
09:36:19 <priteau> And Jake's spec for network reservation: https://review.opendev.org/#/c/674089/
09:37:36 <priteau> Anything else to highlight?
09:40:28 <priteau> #topic AOB
09:40:32 <priteau> Anything else to share?
09:43:31 <priteau> Nothing from me
09:43:38 <tetsuro> Nothing
09:44:48 <priteau> Thanks for joining, have a good week!
09:45:56 <priteau> #endmeeting