08:59:59 <priteau> #startmeeting blazar
09:00:00 <openstack> Meeting started Tue Nov 19 08:59:59 2019 UTC and is due to finish in 60 minutes. The chair is priteau. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:01 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:03 <openstack> The meeting name has been set to 'blazar'
09:00:06 <priteau> #topic Roll call
09:01:24 <tetsuro> o/
09:02:19 <bertys> o/
09:02:54 <priteau> Hi bertys & tetsuro
09:03:52 <priteau> Let's wait a few minutes in case Masahito joins
09:06:26 <priteau> Agenda for today:
09:06:27 <priteau> * Ussuri planning and priorities
09:06:30 <priteau> * Stable backports
09:06:33 <priteau> * AOB
09:06:43 <priteau> #topic Ussuri planning and priorities
09:07:49 <priteau> We've set priorities in the Etherpad document:
09:07:54 <priteau> Network segment reservation
09:07:54 <priteau> Calendar view
09:07:54 <priteau> Usage enforcement
09:07:56 <priteau> Quota
09:07:58 <priteau> Preemtible
09:08:27 <priteau> It would be good to set some timelines against it so they don't get delayed
09:08:56 <priteau> For network segment reservation, we have reviews requesting changes on the spec.
09:09:14 <priteau> I'll talk with Jake this week and see if he can get an updated spec out for review
09:09:55 <priteau> Goal would be updated spec by end of November, hopefully approved by Christmas?
09:10:18 <priteau> Then in the beginning of the year, or earlier if ready, we can focus on merging the code
09:11:50 <priteau> I am adding some tentative schedule on the Etherpad
09:11:53 <priteau> #link https://etherpad.openstack.org/p/blazar-ptg-ussuri
09:12:13 <priteau> Do we want a spec for calendar view, or code would be enough?
09:13:19 <priteau> For usage enforcement, quota, preemptible, we definitely want a spec.
09:13:25 <tetsuro> Right
09:14:19 <tetsuro> Do we have any controversial point on calendar view?
09:15:39 <tetsuro> As I don't come up with the points, I'm okay that it is a specless blueprint
09:15:52 <priteau> It's currently being used only with host reservation. It's not clear how it could be used to easily visualise instance reservation, since there are 3 resources to consider (vCPUs, memory, disk)
09:16:25 <priteau> We could have an initial version that displays only host reservations.
09:17:47 <tetsuro> Ah, I see. I haven't read any specs that are for GUI, but looks like it is better to have the spec if we have several implementation alternatives?
09:18:18 <priteau> We could have a short spec that explains the limitations
09:19:28 <priteau> I will talk with Jake about it
09:19:55 <priteau> Does the schedule look appropriate to you?
09:21:27 <tetsuro> Since spec can be a good guide line for reviewers of the function, it is worth doing.
09:21:52 <priteau> +1
09:23:15 <priteau> I've set assignes to each task, though I don't have any for the quota spec. Any volunteer?
09:26:20 <tetsuro> ...I'm not sure I can complete it in U release, but I can start it if no one is gonna take it.
09:26:52 <priteau> That's fine tetsuro, no pressure on this one.
09:27:27 <tetsuro> Okay. Thanks.
09:28:53 <priteau> Let's move to the next topic then
09:28:58 <priteau> #topic Stable backports
09:29:56 <priteau> I heard through Stig who was at the summit that staff from Nectar cloud (Australia) is evaluating Blazar and planning to run it in production soon
09:30:10 <priteau> I got in touch with them, they're going to run Rocky
09:30:32 <priteau> So we should consider actively maintaining this release with backports of bug fixes.
09:30:40 <bertys> priteau: Heard this too in Shanghai. Good news.
09:30:53 <tetsuro> great
09:31:12 <priteau> I believe Chameleon is running Stein (and soon Train) so they wouldn't care much about the state of stable/rocky.
09:31:46 <priteau> So if you submit or review a bug fix, please check if it is relevant for train, stein *and* rocky.
09:32:17 <priteau> I know it's extra work but another new deployment would be a good boost for the project
09:34:31 <priteau> I will take a pass at reviewing the state of these branches.
09:34:44 <priteau> #action priteau review stable branches for bug fixes
09:35:53 <priteau> Hopefully the gate still works...
09:37:34 <priteau> #topic AOB
09:37:37 <priteau> Anything else to share today?
09:39:10 <tetsuro> Not from me
09:40:37 <priteau> Nothing from me either
09:41:02 <priteau> Thanks for joining today
09:41:06 <priteau> Have a good week!
09:41:14 <priteau> #endmeeting