09:00:19 <priteau> #startmeeting blazar
09:00:20 <openstack> Meeting started Tue Jul 28 09:00:19 2020 UTC and is due to finish in 60 minutes.  The chair is priteau. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:23 <openstack> The meeting name has been set to 'blazar'
09:00:30 <priteau> #topic Roll call
09:01:14 <tetsuro> o/
09:01:20 <tosky> o/
09:01:31 <priteau> Hi tetsuro and tosky
09:02:16 <priteau> I guess since tosky is here, we should discuss:
09:02:19 <priteau> #topic Victoria OpenStack-wide Goals
09:02:36 <tosky> yep
09:03:03 <tosky> I managed to understand the reason for the failure of https://review.opendev.org/#/c/732694/: I totally missed the statement which reduces the concurrency of the tests to 1
09:03:14 <priteau> Ah, that totally explains it
09:03:27 <tosky> it seems those tests need to be run in serial mode, but anyway the statement was there in the original job and I missed it >.<
09:03:34 <tosky> it seems to work, but please double check
09:03:34 <priteau> The logs looked like multiple tests were running in parallel
09:04:10 <priteau> Yes, our tests are meant to run sequentially because we have only one compute node that we can reserve
09:04:15 <priteau> Hi masahito
09:04:17 <masahito> hello
09:04:19 <tosky> if that works as expected and it's merged, then the next step is https://review.opendev.org/#/c/732697/, whose only error is openstack-tox-py38
09:04:34 <tosky> and I would say that failure is totally unrelated to the zuul patch
09:04:57 <priteau> openstack-tox-py38 was passing when you first submitted the patch
09:05:21 <tosky> I can try to recheck but it may be something else and I don't know that code too much
09:06:06 <tosky> but the error, "Working outside of request context." looks familiar
09:06:14 <tosky> I think I have seen a similar error in another project
09:06:38 <priteau> Maybe our tests are not using Flask as intended
09:06:50 <priteau> There are docs about it: https://flask.palletsprojects.com/en/1.1.x/reqcontext/#manually-push-a-context
09:07:14 <tosky> oh, right, in sahara: https://storyboard.openstack.org/#!/story/2007596
09:07:32 <tosky> we had to rewrite the way the tests were written, maybe this may help: https://review.opendev.org/#/c/724675/
09:07:39 <priteau> https://review.opendev.org/#/c/724675/
09:08:19 <tosky> so something that should be fixed regardless
09:08:26 <priteau> Sounds like the right approach to follow
09:08:50 <tosky> anyway, that's it from my side - the zuul part seems to be working, and if it passes your review, that should be it
09:10:04 <priteau> Thanks a lot for your perseverance tosky
09:11:08 <priteau> The other Victoria priority is migrate-to-focal which is underway, we've already merged a few patches
09:11:22 <priteau> So, please review tosky's patch at https://review.opendev.org/#/c/732694/
09:12:27 <tosky> with the native jobs you won't need any other change on the zuul side to switch to focal - only fix the job failures in case of packaging changes, for example
09:13:50 <priteau> Great
09:14:17 <priteau> Anyone would like to look into the py38 issues we just discussed?
09:16:58 <priteau> Let's record it as an action
09:17:17 <priteau> #action Fix py38 issues in https://review.opendev.org/#/c/732697/ following what was done for Sahara in https://review.opendev.org/#/c/724675/
09:17:35 <priteau> #topic Other Victoria priorities
09:18:10 <priteau> First, specs
09:18:23 <priteau> I had an action item to create a new draft spec for PCI passthrough
09:18:45 <priteau> Sorry, I haven't been able to do this yet, I'll aim for next week
09:19:42 <priteau> Another code review priority is this patch: https://review.opendev.org/#/c/731586/
09:21:54 <priteau> Anything else to highlight?
09:25:26 <priteau> By the way we are at Victoria-2 milestone this week
09:25:42 <priteau> Let's focus on the highest priorities during August
09:25:49 <priteau> #topic AOB
09:25:51 <priteau> Anything else?
09:26:11 <priteau> Holiday schedules, etc?
09:27:08 <priteau> I was off earlier this month but should be working every week for the rest of the summer
09:27:38 <tetsuro> I'm going to be off on Aug. 14
09:28:02 <tetsuro> oh no I meant Aug. 11 Tue
09:28:52 <priteau> Thanks for letting us know tetsuro
09:29:44 <priteau> Let's wrap up
09:29:50 <priteau> Thanks everyone for joining today
09:29:56 <priteau> Talk to you next Tuesday
09:29:58 <priteau> #endmeeting