16:00:38 <priteau> #startmeeting blazar
16:00:39 <openstack> Meeting started Thu Mar 11 16:00:38 2021 UTC and is due to finish in 60 minutes.  The chair is priteau. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:42 <openstack> The meeting name has been set to 'blazar'
16:00:48 <priteau> #topic Roll call
16:06:43 <diurnalist> o7 - hello, sorry for delay priteau
16:07:23 <priteau> howdy
16:07:48 <priteau> So I wanted to discuss a couple of things today
16:07:54 <priteau> 1) Wallaby release
16:07:58 <priteau> 2) Xena PTG
16:08:06 <priteau> and 3) AOB if there is anything else
16:08:19 <priteau> #topic Wallaby release
16:09:21 <priteau> The Wallaby release is coming up. Technically this is feature freeze now, but I would like to merge some of your patches so need one last push.
16:10:01 <diurnalist> OK - which patches do you think we should focus on?
16:10:02 <priteau> I've been working on the usage enforcement patch. I got unit tests fixed on the last version and I am going to test it on a real system.
16:10:45 <priteau> Usage enforcement would be the main one
16:11:08 <priteau> Some of the smaller ones of yours if possible
16:11:14 <priteau> e.g. https://review.opendev.org/c/openstack/blazar/+/762006
16:11:16 <priteau> https://review.opendev.org/c/openstack/blazar/+/766526
16:11:25 <priteau> I've left a comment on that first one
16:12:30 <priteau> If you get the chance of updating the soft delete patch we could look at that as well
16:13:59 <priteau> Network reservation needs more work, difficult to get it merged without someone with time allocated to work on it
16:14:36 <priteau> Do you think you could look at the unit test failures in https://review.opendev.org/c/openstack/blazar/+/766526?
16:15:33 <diurnalist> yeah, re: network reservation, that's not a priority for me. i am thinking that ultimately what we really need to tackle in blazar is some actual plugin architecture. we've got 2 new resource types that i know of, and each one is so annoying to add
16:15:44 <diurnalist> not to mention negotiate upstream patches for
16:15:50 <diurnalist> and i don't even think they're that valuable upstream
16:16:15 <diurnalist> i will fix up tests for CH-823002
16:16:18 <diurnalist> grr
16:16:22 <diurnalist> https://review.opendev.org/c/openstack/blazar/+/766526 even
16:16:51 <priteau> Thanks. I've rebased the change so in one hour there should be updated results.
16:17:13 <priteau> Of course you can run `tox -e py3` locally
16:19:05 <priteau> I'll request a review from you when I upload the updated usage enforcement patch
16:19:10 <diurnalist> ok
16:20:30 <priteau> Now looking further ahead
16:20:34 <priteau> #topic Xena PTG
16:21:11 <priteau> In case you're not aware, the Project Teams Gathering for the Xena cycle will be held in April, 19-23
16:21:58 <priteau> I think it would be good to discuss using the video conference tools offered by the PTG
16:22:10 <priteau> It so happens that April 22 at 1600 we normally have an IRC meeting
16:22:44 <diurnalist> that sounds like a good idea
16:23:34 <priteau> There are well defined meeting slots, the best one for us is within the 13-17 UTC range
16:23:57 <priteau> We could do just 16-17, but maybe booking 15-17 gives us more options?
16:24:30 <diurnalist> agreed, 15-17, we can decide on how much of that we will use later
16:25:28 <priteau> That would be 10 AM - 12 PM in Chicago if I can trust this online timezone planner
16:25:36 <priteau> We will be in DST by then
16:25:41 <diurnalist> very do-able
16:26:18 <priteau> OK so I booked the Bexar (virtual Zoom) room for 15-17 UTC on April 22
16:26:35 <diurnalist> great :)
16:26:41 <priteau> I will start a document to list agenda topics
16:27:17 <priteau> #action priteau Create etherpad to list Xena PTG topics
16:27:39 <priteau> And I'll share the link next time
16:28:02 <priteau> Feel free to invite your coworkers if they want to learn more about Blazar :)
16:28:11 <diurnalist> :+1:
16:28:43 <priteau> #topic AOB
16:29:01 <priteau> Before I forget: you need to register for the PTG
16:29:11 <priteau> #link https://april2021-ptg.eventbrite.com/
16:29:16 <priteau> It's free
16:29:18 <diurnalist> i will do that today, thank you
16:29:35 <diurnalist> will also pass this on to the rest of the team
16:29:41 <priteau> It takes just a couple of minutes
16:30:19 <priteau> I also had something else to share
16:31:06 <priteau> I've mentioned recently, maybe just privately to you, that I saw issues with Blazar requests hanging in DevStack after the service had been up for a while.
16:31:10 <priteau> A restart would fix it.
16:31:34 <priteau> I thought it was due to https://review.opendev.org/c/openstack/blazar/+/771110 which changed some RPC stuff
16:31:41 <priteau> But a revert didn't fix it
16:32:16 <priteau> It turns out it was originating from oslo.messaging
16:32:19 <priteau> https://review.opendev.org/q/Id5cddbefbe24ef100f1cc522f44430df77d217cb
16:33:05 <priteau> There is a fix in a released package for master, but last time I looked it wasn't released for stable branches
16:33:28 <priteau> Not sure if this is something that would affect your deployment.
16:33:50 <diurnalist> i don't think i've seen it. is it only a thing if "direct_mandatory_flag" is set to True?
16:34:17 <priteau> That's what I understand, but direct_mandatory_flag = True is the default
16:34:32 <priteau> And it's not set to False by kolla-ansible
16:34:47 <diurnalist> aha
16:34:56 <priteau> So not sure why it wasn't seen on Chameleon. Maybe only affects new versions
16:35:20 <priteau> Anyway, the oslo.messaging commit message hints that we're using their interface wrongly, so I will need to look into this.
16:35:26 <diurnalist> interesting. could be. I don't think we've changed anything else in the RPC layer
16:36:00 <priteau> But if you see MessageUndeliverable exceptions in logs, it could be the issue
16:36:21 <priteau> I don't think I had anything else to discuss today.
16:37:25 <diurnalist> interesting, good find
16:37:58 <diurnalist> I don't have any other business either. maybe in the future we can talk more about the preemptible feature. it's currently being evaluated
16:38:24 <priteau> I am working on this as well, but not yet ready to go upstream
16:38:54 <priteau> I could share some early patches and design ideas if that's of interest to you
16:40:21 <diurnalist> that would be good, we're actively pulling in your existing patch so any future ones would be good to know about
16:40:46 <priteau> Cool. I'll make sure to share then.
16:41:52 <diurnalist> thanks priteau!
16:41:54 <priteau> Anything else?
16:42:48 <diurnalist> nope, i think that's it
16:43:04 <priteau> Thanks
16:43:15 <priteau> Back to code review then :)
16:43:18 <priteau> Bye
16:43:22 <priteau> #endmeeting