16:01:12 <nijaba> #startmeeting Ceilometer
16:01:12 <nijaba> #meetingtopic Ceilometer
16:01:12 <nijaba> #chair nijaba
16:01:12 <nijaba> #link http://wiki.openstack.org/Meetings/MeteringAgenda
16:01:13 <openstack> Meeting started Thu Aug 30 16:01:12 2012 UTC.  The chair is nijaba. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:15 <openstack> The meeting name has been set to 'ceilometer'
16:01:17 <openstack> Current chairs: nijaba
16:01:29 <nijaba> Hello everyone! Show of hands, who is around for the ceilometer meeting?
16:01:29 <nijaba> o/
16:01:31 <gmb> o/
16:01:41 <DanD> o/
16:02:09 <dhellmann> o/
16:02:11 <nijaba> #topic actions from previous meeting
16:02:26 <nijaba> #topic jaypipes to create ceilometer cookbook
16:02:26 <jd___> o/
16:02:38 <nijaba> not sure if jaypipes is back from vacations
16:02:48 <nijaba> does not look like it
16:03:08 <nijaba> should we just open a bug and follow up on this later?
16:03:13 <jd___> probably
16:03:20 <dhellmann> sounds like a good plan
16:03:33 <spn> o/
16:03:42 <nijaba> #action nijaba to open a bug for cookbook and assign to jaypipes
16:03:53 <nijaba> #topic nijaba to link schema in the doc
16:04:04 <nijaba> This was done, as well a updating the component description a bit in
16:04:04 <nijaba> #link https://review.openstack.org/#/c/12171
16:04:04 <nijaba> which should show up soon in
16:04:04 <nijaba> #link http://ceilometer.readthedocs.org/en/latest/architecture.html#high-level-description
16:04:20 <nijaba> anything missing in there?  more suggestions?
16:04:45 <dhellmann> the image is there now (I have to push doc changes to my repo before they show up on RTD, still)
16:05:12 <spn> can see the image
16:05:21 <nijaba> should I add the image to the project, rather than link to it from google?
16:05:29 <dhellmann> that's a good idea
16:06:04 <nijaba> #action nijaba to add architecture image to project /doc rather than link from google
16:06:12 <dhellmann> you could include a comment in the rst file linking to the google document where you build the image, so we can remember where it is later
16:06:17 <spn> can the name of the image be ceilometer architecure.. which will come up in images.google.com much easily
16:06:25 <dhellmann> good idea spn
16:06:34 <spn> :)
16:06:46 <nijaba> #action nijaba to include a comment in the rst file linking to the google document where you build the image, so we can remember where it is later
16:07:02 <jaypipes> nijaba: back today. :)
16:07:21 <jaypipes> nijaba: I have the ceilo cookbook on my list of issues in github (private branches) to address. will get to it next week.
16:07:32 <nijaba> spn: sure. it's just not a feature of google doc to be able to name the image, but I will do so when adding it ot the project
16:07:52 <nijaba> jaypipes: should I create a bug to track your progress?
16:07:56 <spn> great..
16:08:16 <jaypipes> nijaba: yes, please do create a bug and assign to me.
16:08:28 <nijaba> jaypipes: welcome back, btw, and hope you had a great time off.  same applies to jd___
16:08:37 <nijaba> I will :)
16:08:39 <jd___> :)
16:08:59 <nijaba> anything else on the architecture doc?
16:09:29 <nijaba> I guess not :)
16:09:41 <nijaba> #topic nijaba to start a thread on meeting time
16:09:41 <nijaba> The thread was started yesterday, Angus and Jd have started to reply. We'll get back to this in a few minutes.
16:09:54 <nijaba> That's it for last week's action, should we move on?
16:10:12 <nijaba> #topic Discuss sessions proposal for Grizzly summit
16:10:14 <spn> central agent on collector is a one way components like glance, cinder?
16:10:15 <jaypipes> nijaba: thx :)
16:10:37 <nijaba> dhellmann and I are colaborating on 3 session descriptions:
16:10:37 <nijaba> 1- state of metering
16:10:37 <nijaba> 2- Customizing ceilometer to measure your cloud
16:10:37 <nijaba> 3- Beyond Metering - Extending Ceilometer
16:10:37 <nijaba> I do not have the rights to give view access to our shared google doc collection, maybe dhellmann can do it and send us a link?
16:10:38 <nijaba> Does anyone else see other sessions we should be hosting at the dev summit?
16:10:40 <nijaba> (as a reminder, I already proposed a conference session on Ceilometer, voting should start soon on conference topics, hope that we'll get lots of support on that one)
16:11:11 <nijaba> spn: not sure I get your question.  Can we get back to it in the Open Discussion?
16:11:18 <spn> sure..
16:12:19 <nijaba> dhellmann: can you try to make the document collection public with comment rights, so other can comment on our proposals?
16:12:24 <dhellmann> try this link: https://docs.google.com/a/dreamhost.com/folder/d/0B57LxbbiEQtbb291eVg0RHIyNUE/edit
16:12:33 <dhellmann> sorry, was trying to figure out how...
16:12:49 <spn> requesting access...
16:12:50 <dhellmann> if that doesn't work, I will move them to the wiki this evening
16:13:11 <dhellmann> I'm using our DreamHost app account, so I might not be able to give public access in a blanket way
16:13:17 <nijaba> does not seem to work from my personal account
16:13:28 <dhellmann> ok
16:13:31 <nijaba> I guess wiki might be a good idea then
16:13:47 <nijaba> plus that will be easier to link from blueprints
16:13:56 <dhellmann> #action dhellmann to move summit proposal outlines to the wiki and email links to the dev mailing list
16:14:04 <nijaba> coolio
16:14:18 <nijaba> any other ideas for summit sessions?
16:15:47 <nijaba> I guess not.  Well, it's not too late if ideas come to mind in the next week...
16:15:50 * dhellmann used up all of his ideas
16:16:08 <nijaba> #topic Discuss changing the meeting time
16:16:19 <nijaba> So, based on the mailing list discussion that started, we should to find a way to accommodate people from down under. jd__ had a couple suggestion:
16:16:19 <nijaba> UTC 21:00:
16:16:19 <nijaba> - 23:00 for me (and Nick most of the time I guess) in France
16:16:19 <nijaba> - 14:00 for Doug
16:16:19 <nijaba> - 7:00 for Angus
16:16:21 <nijaba> or UTC 06:00:
16:16:23 <nijaba> - 08:00 for me (and Nick most of the time I guess) in France
16:16:26 <nijaba> - 23:00 for Doug
16:16:28 <nijaba> - 16:00 for Angus
16:17:03 <spn> 21.30 for spn
16:17:11 <dhellmann> what is 1 hour earlier than the time we're using now?
16:17:20 <nijaba> 3PM UTC
16:17:58 <nijaba> which I guess would not work for angus, but should work for me and jd___
16:18:10 <dhellmann> yeah, that's what it looks like
16:20:38 <nijaba> So I propose to open a simple doodle poll to have a vote between 06000, 1500 and 2100 UTC
16:20:56 <jd___> ack
16:21:00 <dhellmann> that seems good
16:21:09 <spn> nice
16:21:16 <nijaba> keeping it on the same day, right?
16:21:19 <dhellmann> it feels like there might be another option in there somewhere
16:21:27 <dhellmann> yes, Thursday works well for me
16:22:17 <nijaba> dhellmann: I can wait till tomorrow to open the poll, in case another option comes to your mind
16:22:32 <dhellmann> I'm trying to work out the values of noon GMT
16:22:40 <dhellmann> might be faster to just ask, if you guys are used to doing this :-)
16:22:45 <nijaba> timeanddate.com helps
16:23:15 <nijaba> #action nijaba to open a doodle poll to pick between viable options
16:24:28 <nijaba> We did not seem to have any other topic on the agenda.
16:24:30 <dhellmann> yeah, nijaba, would you add 12:00 UTC to the list? that doesn't look too bad for any of us and I'm more of a morning person than evening
16:24:46 <nijaba> dhellmann: ok. I'll add 1200
16:24:52 <dhellmann> thanks
16:25:23 <nijaba> #topic Open Discussion
16:25:39 <nijaba> spn: so can you please reformulate your question?
16:25:52 <spn> sorry for the earlier mess up
16:25:57 <nijaba> np
16:26:09 <spn> In the diagram..
16:26:34 <spn> I was wondering whether the central agent to glance/nova communication is a 2-way arrow..
16:27:06 <nijaba> IIUC, the central agent polls, so it's one way
16:27:07 <dhellmann> interesting
16:27:10 <jd___> dhellmann: noon gonna be early for you, no? :)
16:27:28 <nijaba> dhellmann noted that he is an early bird
16:27:39 <dhellmann> jd___: noon UTC is 8:00 AM here, so I could talk to you guys while I eat breakfast :-)
16:28:08 <dhellmann> spn: we haven't had any call to pass data from ceilometer into the other services, yet. were you thinking of something specific?
16:28:19 <jd___> dhellmann: sounds good :)
16:28:38 <jd___> forgot you were on -4
16:29:06 <dhellmann> jd___: I keep asking DH to move me to Paris, but so far no luck.
16:29:16 <jd___> dhellmann: :-D
16:29:27 <dhellmann> but if you know of any nice apartments for rent...
16:29:28 <nijaba> dhellmann: I'll ping oubiwann about it ;)
16:29:51 <spn> dhellmann:no no..  I am still going thru that part of code..
16:29:54 <dhellmann> nijaba: please do! we have another dev in italy right now, but I don't speak any italian
16:30:02 <nijaba> hehe
16:30:07 <dhellmann> spn: ah, ok.
16:30:23 <oubiwann> hehe
16:30:36 * dhellmann forgot oubiwann lurks in here
16:30:59 <nijaba> oubiwann can feel the force from anywhere
16:31:03 * oubiwann lives on IRC
16:31:10 <oubiwann> nijaba I can
16:31:27 <dhellmann> spn: If you do think of a use case for passing data out of ceilometer into the other services, let me know.
16:31:29 <oubiwann> especially if planets are getting destroyed
16:31:35 <oubiwann> or spun very rapidly
16:31:44 <spn> dhellmann: sure...  I will
16:32:47 * nijaba notes to add a force meter, code named oubiwann, to ceilometer
16:33:18 <oubiwann> hahaha
16:33:38 <dhellmann> nijaba: we should use that as an example in the "extending ceilometer" talk
16:33:51 <dhellmann> or the customizing one, I guess I mean
16:33:53 <nijaba> any other topic before I let everyone run to their jedi duties?
16:34:01 <nijaba> dhellmann: great idea!
16:34:06 <dhellmann> nijaba: noted
16:35:14 <nijaba> ok...  I guess that's it for today.  Thanks a a great and fun meeting everyone!
16:35:18 <dhellmann> thanks!
16:35:25 <nijaba> #endmeeting