15:00:36 <nijaba> #startmeeting Ceilometer
15:00:36 <nijaba> #meetingtopic Ceilometer
15:00:36 <nijaba> #chair nijaba
15:00:36 <nijaba> #link http://wiki.openstack.org/Meetings/MeteringAgenda
15:00:37 <openstack> Meeting started Thu Sep  6 15:00:36 2012 UTC.  The chair is nijaba. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:39 <openstack> The meeting name has been set to 'ceilometer'
15:00:41 <openstack> Current chairs: nijaba
15:00:48 <nijaba> Hello everyone! Show of hands, who is around for the ceilometer meeting?
15:00:48 <nijaba> o/
15:00:50 <gmb> o/
15:00:54 <spn> o/
15:00:55 <dhellmann> o/
15:01:14 <dachary> o/
15:01:25 <nijaba> great, looks like almost a full house!
15:01:28 <nijaba> #topic actions from previous meeting
15:01:49 <nijaba> #topic dhellmann to move summit proposal outlines to the wiki and email links to the dev mailing list
15:01:53 <nijaba> This was done and is now available at http://wiki.openstack.org/EfficientMetering/GrizzlySummit
15:01:53 <nijaba> More to come on the subject in a few minutes
15:02:08 <nijaba> #topic nijaba to open a bug for cookbook and assign to jaypipes
15:02:17 <nijaba> Done as well. Bug #1046404
15:02:17 <nijaba> Jaypipes started working on it yesterday. Do you want to comment about it Jay?
15:02:18 <uvirtbot> Launchpad bug 1046404 in ceilometer "Ceilometer would welcome a chef cookbook" [Low,In progress] https://launchpad.net/bugs/1046404
15:02:59 <nijaba> Well, jay may come back to it later...
15:03:04 <nijaba> #topic nijaba to add architecture image to project /doc rather than link from google & to include a comment in the rst file linking to the google document where you build the image, so we can remember where it is later
15:03:12 <nijaba> This was merged: https://review.openstack.org/#/c/12269/
15:03:23 <nijaba> That's it for last week's action, should we move on?
15:03:27 <dhellmann> and the image is at http://ceilometer.readthedocs.org/en/latest/architecture.html
15:03:48 <jd___> (hi)
15:03:57 <nijaba> hello jd___!
15:04:04 <nijaba> #topic Discussion on session proposal for the summit
15:04:16 <nijaba> #link http://wiki.openstack.org/EfficientMetering/GrizzlySummit
15:04:16 <nijaba> Any comments about these proposals?
15:04:16 <nijaba> Does anyone else see other sessions we should be hosting at the dev summit?
15:05:02 <dhellmann> nijaba: based on ttx's email about the sessions, I wonder if the "State Of" session should really be done the way it's described. It seems more presentation-like than discussion.
15:05:19 <dhellmann> I didn't realize they wanted to make that distinction this time
15:05:39 <dhellmann> or maybe it has always been that way and I just didn't pick up on it during the folsom summit
15:05:39 <nijaba> dhellmann: I think it should be a workshop, but preparing content to level set everyone is always a good idea
15:05:47 <dhellmann> ok, that works
15:06:08 <dhellmann> leave plenty of time for discussion of future work?
15:06:14 <nijaba> yup
15:06:24 <dhellmann> I'll make a note of that on the wiki page
15:06:30 <nijaba> thanks
15:06:52 <nijaba> anything else?
15:07:08 <nijaba> Who is planning being at the summit?
15:07:13 <dachary> o/
15:07:14 <dhellmann> o/
15:07:16 <nijaba> o/
15:07:23 <spn> :-(
15:07:45 <dhellmann> angus' latest message on the mailing list implies he is coming, too
15:07:53 <nijaba> I assumed he would
15:08:09 <dhellmann> nijaba: we should set up an openspace session to work through the metering vs. monitoring discussion
15:08:26 <spn> yes
15:08:26 <dhellmann> or is that part of beyond metering...
15:08:27 <nijaba> that was the goal of the beyong metering session
15:08:35 <dhellmann> oops, right, forgot
15:09:01 <nijaba> and this is were angus will be very welcome :)
15:09:15 <nijaba> not that he would not be in other sessions too
15:09:22 <ttx> nijaba: fwiw, we have 3 extra rooms at the design summit. At least one of them should be organized with round tables... so there should be room for you to meet
15:09:39 <ttx> even if no official "topic" is set
15:09:44 <spn> interface for ceilometer is also a part of beyond metering?
15:09:44 <spn> i meant in horizon
15:09:53 <nijaba> ttx: do you think it is ok for us to ask fro 3 sessions?
15:10:37 <nijaba> spn: no, would consider that fit in normal future work
15:10:37 <ttx> nijaba: it's ok for you to occupy one of the round tables in the free room... and probably ok to book space in the other two for 3 sessions
15:10:40 <dhellmann> spn: that's on the list for the "state of" session under "grizzly work to be done"
15:10:49 <ttx> nijaba: especially early in the summit
15:10:57 <ttx> when nobody rushes to get them
15:11:07 <nijaba> ttx: but can we be mentioned in the official program?
15:11:16 <spn> dhellman: yes.. sorry missed that
15:11:47 <ttx> nijaba: that's a more tricky question. I don't think anyone will take up the hassle of syncing the unconference whiteboard with "the official program"
15:12:15 <ttx> nijaba: but there should be opportunities to publicize it
15:12:42 <nijaba> ttx: let's take this offline.
15:13:17 <nijaba> shall we move to the next topic?
15:14:04 <nijaba> #action nijaba to see with ttx how our sessions can be shown on official program
15:14:16 <nijaba> #topic Discussion on alternating meeting time to allow presence from down under
15:14:30 <nijaba> The result of the meeting time poll left out Angus.  The new meeting time that was selected makes it a 1AM meeting for him.
15:14:30 <nijaba> I have seen other projects have meeting time alternate to allow for a larger representation from around the globe.  For example, we could hold meeting at 3PM UTC on even weeks and at 9PM UTC on odd weeks.  What would you think of this?
15:14:45 <gmb> Works for me.
15:15:31 <nijaba> This could also help us recruit more from asia
15:15:31 <dhellmann> the idea is fine, I need to convert those times to see if they actually work for me
15:15:33 <spn> 9PM -> 2.30AM
15:15:43 <spn> Asia
15:15:55 <nijaba> ah, then not so muc
15:15:59 <nijaba> h
15:16:12 <zigo> The current meeting is like 11pm.
15:16:16 <zigo> That's fine for me.
15:16:19 <zigo> Later it wouldn't.
15:16:35 <dhellmann> nijaba: both of those times work for me
15:16:39 <zigo> (shanghai time)
15:16:54 <spn> India current 8.30 PM is good.. :-)
15:17:22 <dachary> works for me too
15:17:28 <nijaba> so I guess 9PM UTC would be fine from western europe (11pm) to Autralia (inlcuding us)
15:18:19 <spn> zigo: what is 9PM UTC for you?
15:18:23 <zigo> That's 5am, Shanghai time, that's like crazy !
15:18:29 <zigo> I wouldn't *not* attend.
15:18:49 <zigo> Sorry. I wouldn't be there.
15:19:01 <nijaba> yup, but you could still attend on even weeks... which is the goal of alternating times
15:19:11 <zigo> Fine then.
15:19:12 <dhellmann> is there some way we could move more discussion to the mailing list, too?
15:19:30 <jd___> dhellmann: +1
15:19:41 <nijaba> dhellmann: feel free to continue on the thread I started there
15:19:51 <nijaba> or create a new one even
15:19:57 <dachary> zigo: you have a baby, you don't sleep at 5am ;-)
15:20:04 <dhellmann> nijaba: I meant the sorts of things that we would discuss on IRC could also be discussed on the mailing list in some cases.
15:20:17 <spn> on ML is anytime good
15:20:18 <zigo> dachary: He actually wakes up at 6am, and *my wife* gets up! :)
15:20:25 <nijaba> and I think we are, most of the time
15:20:54 <dhellmann> nijaba: true
15:21:15 <nijaba> #startvote should we hold our meetings at alternating times on even and odd weeks? Yes, No
15:21:16 <openstack> Begin voting on: should we hold our meetings at alternating times on even and odd weeks? Valid vote options are Yes, No.
15:21:17 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
15:21:23 <dhellmann> #vote yes
15:21:27 <jd___> #vote yes
15:21:29 <nijaba> #vote Yes
15:21:30 <zigo> #vote yes
15:21:38 <gmb> #vote yes
15:21:48 <zigo> Is this case sensitive? :)
15:21:50 <nijaba> please use Yes, not yes
15:21:55 <nijaba> zigo, it is
15:21:57 <dachary> #vote yes
15:21:58 <zigo> #vote Yes
15:21:58 <gmb> #vote Yes
15:21:59 <dhellmann> #vote Yes
15:22:16 <dachary> #vote yes
15:22:20 <dachary> #vote Yes
15:22:22 <dachary> damit
15:22:26 <nijaba> hehe
15:22:28 <zigo> :P
15:22:32 <dachary> ahahah
15:22:38 <zigo> Anyway, we all agree.
15:22:45 <nijaba> yup
15:22:48 <nijaba> #endvote
15:22:49 <openstack> Voted on "should we hold our meetings at alternating times on even and odd weeks?" Results are
15:22:50 <openstack> Yes (6): dachary, nijaba, dhellmann, gmb, zigo, jd___
15:23:31 <nijaba> ok, so next week's meeting will be at 9PM UTC
15:23:58 <nijaba> #action nijaba to update meeting page to note new alternating meeting time
15:24:14 <nijaba> #topic Release management
15:24:26 <nijaba> as we are nearing the release of folsom, I think it would be great to try to release a first cut of Ceilometer in parallel to it. In order to do so, I think that we would need to have a "release manager" to keep us all on track for this delivery.  What do you think? Any volunteer?
15:24:32 <eglynn__> FYI weekly nova meeting also on Thurs at 2100 UTC
15:24:45 <gmb> I'm happy to take on the responsibility for that
15:24:47 <nijaba> eglynn__: ouch...
15:25:01 <jd___> arf
15:25:03 <nijaba> should have checked that
15:25:27 <eglynn__> here are the taken slots ... http://wiki.openstack.org/Meetings
15:25:48 <nijaba> eglynn__: I know where to check, jus tforgot to do t
15:25:56 <eglynn__> cool
15:26:30 <nijaba> anyone which to challenge gmb's offer to act as release manager for this release?
15:26:58 <nijaba> s/which/wish
15:27:14 <dhellmann> thanks for volunteering, gmb!
15:27:21 <gmb> np.
15:27:29 <gmb> It fits in well with the recruiting of my team.
15:27:32 <nijaba> #action gmb to act as release manage!
15:27:53 <nijaba> so now, let's discuss what is there to be done...
15:28:04 <nijaba> In term of actions the list doug and I came up with is as follow:
15:28:04 <nijaba> 1/ to review which feature we really need to have before calling it a first release
15:28:04 <nijaba> 2/ to define a feature cut off date
15:28:04 <nijaba> 3/ to have some qa/bug fixes done
15:28:04 <nijaba> 4/ to ensure that documentation is aligned with the code, as well as
15:28:05 <nijaba> deployment instructions that have been tested
15:28:07 <nijaba> 5/ to decide on a versioning scheme and release channels
15:28:09 <nijaba> Anything else that we forgot?
15:28:41 <zigo> Has anyone started doing some .deb packaging?
15:28:54 <nijaba> zigo: I think zul has
15:29:29 <zul> nijaba: i looked at, i havent had a chance to start it yet
15:29:44 <dachary> there is a ppa somewhere, not sure it's up to date though
15:29:48 <zigo> So it should be set in the agenda, IMO.
15:29:49 <zul> nijaba: lets talk after the meeting
15:29:52 <nijaba> zul: k
15:29:54 <dhellmann> zul: would the packaging instructions need to go in the ceilometer repo, or do those live somewhere else?
15:30:04 <dhellmann> either is fine, I'm just curious about how that works
15:30:15 <dachary> https://launchpad.net/~heut2008/+archive/ppa
15:30:17 <zul> dhellmann: they live somewhere else
15:30:19 <nijaba> dhellmann: the practice is to have no pkg in the upstream repo
15:30:24 <dhellmann> ok
15:30:48 <jaypipes> nijaba: I'm going to make ceilometer recipes in the main nova cookbook for now, then once the nova db stuff is separated from ceilometer, I will push a separate ceilometer cookbook.
15:31:18 <nijaba> packaging is "a distro thing", not an upstream thing.  So I think we should concentrate on producing a tarball
15:31:22 <dhellmann> jaypipes: it's looking like that change won't happen until grizzly
15:31:38 <dhellmann> nijaba: "python setup.py sdist"?
15:31:55 <nijaba> why not
15:32:01 <zul> nijaba:  yes please :)
15:32:15 <dhellmann> works for me, I just wasn't sure it was "enough" for anyone else
15:32:17 <nijaba> gmb: ?
15:32:27 <jaypipes> dhellmann: no? ok, no worries, I will hurry up on the recipes int he nova cookbook then.
15:32:40 <gmb> nijaba, I'm happy with a tarball and setup.py
15:32:42 <dhellmann> jaypipes: yeah, time is running out
15:32:45 <nijaba> dhellmann: looks like we would also need some example conf...
15:32:57 <zigo> I was to propose myself to help on that... :)
15:33:07 <dhellmann> nijaba: that should be easy to add to the sdist using a manifest
15:33:11 <nijaba> zigo: which that?
15:33:16 <zigo> Packaging.
15:33:30 <nijaba> zigo: then please sync with zul
15:33:55 <zigo> k
15:34:07 <dhellmann> and please cc the openstack-dev mailing list so the rest of us can eavesdrop on the conversation!
15:34:15 <nijaba> Regarding 1/ what do you think is really missing at the moment? Doug mentioned the API being a bit thin and Angus the auth on the API being a big need.  What else?
15:34:15 <nijaba> We had quite a few expectation for folsom-3 as described on http://wiki.openstack.org/EfficientMetering/RoadMap but only one has been completed AFAICS. Noticeably, we currently have no coverage for anything outside of Nova.
15:35:11 <nijaba> I think metering for swift and cinder would be really helpful...
15:35:29 <dhellmann> adding auth to the api is actually bigger than wrapping the app with the middleware. all of the endpoints assume an admin user right now, which would have to change to include more complicated logic about users asking for data about other accounts.
15:35:54 <dhellmann> yes, we're going to need cinder at DreamHost
15:36:27 <jd___> dhellmann: we may use the policy system used by keystone/nova probably?
15:36:32 <nijaba> dhellmann: yup, I talked with jonathan last week, and that seemed a biggie.  not swift though ;)
15:36:44 <dhellmann> right, not swift :-)
15:37:34 <nijaba> anyone caring about swift?
15:37:35 <dhellmann> jd___: I don't know enough about the policy system to comment. Does it let you check if users have admin rights on specific projects? the project id would be in the URL
15:38:31 <jd___> dhellmann: yes, you map user/tenant/role to whatever you need in your app
15:38:53 <dhellmann> jd___: that sounds like it should be usable then
15:40:32 <nijaba> do you guys really want to see me coding?  I could try to add a few bugs for the swift implementation...
15:40:34 <eglynn__> no metering coverage for glance either as yet, presumably?
15:41:10 <nijaba> eglynn__: nope, not yet
15:41:17 <eglynn__> (I *may* have some time available to look into that next week ...)
15:41:38 <nijaba> eglynn__: bug #1004462
15:41:38 <uvirtbot> Launchpad bug 1004462 in ceilometer "Listen for Glance notifications" [Wishlist,Confirmed] https://launchpad.net/bugs/1004462
15:41:44 <eglynn__> cool
15:42:14 <dhellmann> eglynn__: please let us know if the docs for pollsters are not clear or detailed enough. I would like to have good enough developer docs that we can have pollsters contributed from outside of this small group!
15:42:35 <eglynn__> dhellmann: will do
15:42:57 <nijaba> eglynn__: and if you start on it, please assign yourself to the bug, so that their is no duplication of effort
15:43:06 <dhellmann> +1
15:43:15 <eglynn__> nijaba: understood!
15:44:10 <dhellmann> how about the feature cut-off? do we want to try to have a release before the summit?
15:44:32 <nijaba> Regarding 2/ what milestones should we use?
15:45:13 <nijaba> I think it would be nice to release before the summit, if not at the same time as folsom
15:45:20 <jd___> +1
15:45:23 <dhellmann> if we're going to have a qa period we should be cutting things off pretty soon
15:45:43 <nijaba> dhellmann: 2 weeks for QA enough?
15:45:58 <nijaba> it's a small project still
15:45:58 <dhellmann> maybe a feature freeze at the end of september and -- yeah, nijaba that's what I'm thinking
15:46:23 <dhellmann> announce the release on the first day of the summit for maximum attention for our openspace sessions?
15:46:40 <nijaba> gmb: can you take the action of proposing a plan on the ml withfixed dates?
15:46:51 <nijaba> dhellmann: uhuh, marketing!
15:47:08 <dhellmann> I propose a pre-1.0 version number, though, to reflect the incompleteness #antimarketing
15:47:37 <nijaba> pre-1.0 as 0.9 ?
15:47:56 <dhellmann> well, we haven't had any other releases. should it just be 0.1?
15:48:04 <gmb> nijaba, Happy to.
15:48:06 <nijaba> sure
15:48:09 <dhellmann> maybe that's something to discuss on the ml, too
15:48:21 <dhellmann> I don't have strong feelings, except that it should be < 1.0
15:48:24 <zigo> pre-1.0 isn't package friendly.
15:48:39 <nijaba> #action gmb to a plan on the ml with fixed dates
15:48:53 <dhellmann> zigo: I meant not 1.0, not exactly "pre-1.0" :-)
15:49:04 <nijaba> #vote use 0.1 as our first release? yes, no
15:49:05 <asalkeld> hi
15:49:21 <nijaba> #startvote use 0.1 as our first release? yes, no
15:49:22 <openstack> Begin voting on: use 0.1 as our first release? Valid vote options are yes, no.
15:49:23 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
15:49:28 <nijaba> #vote yes
15:49:31 <dhellmann> #vote yes
15:49:31 <gmb> #vote yes
15:49:36 <spn> #vote Yes
15:49:52 <jd___> #vote yes
15:49:53 * gmb notes that nijaba has switched the cases for yes and no this time, to keep everyone on their toes...
15:50:10 <spn> #vote yes
15:50:15 * nijaba tried to make things simpler... but yes, that too! ;)
15:50:33 <nijaba> #endvote
15:50:33 <openstack> Voted on "use 0.1 as our first release?" Results are
15:50:34 <openstack> yes (5): nijaba, dhellmann, jd___, spn, gmb
15:50:38 * dhellmann wonders if we're sure voting is actually case sensitive
15:50:54 <jd___> it's not case sensitive according to the previous vote (I used lowercase)
15:51:06 <nijaba> #startvote let's see if voting is case sensitive? YeS, nO
15:51:07 <openstack> Begin voting on: let's see if voting is case sensitive? Valid vote options are YeS, nO.
15:51:08 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
15:51:14 <dhellmann> #vote invalid
15:51:15 <openstack> dhellmann: invalid is not a valid option. Valid options are YeS, nO.
15:51:16 <nijaba> #vote NO
15:51:19 <jd___> #vote No
15:51:19 <dhellmann> #vote no
15:51:25 <spn> #vote n0
15:51:26 <openstack> spn: n0 is not a valid option. Valid options are YeS, nO.
15:51:28 <jd___> spn: :D
15:51:37 <gmb> #vote YEs
15:51:38 <jd___> #vote 
15:51:39 <openstack> jd___: ∅ is not a valid option. Valid options are YeS, nO.
15:51:40 <spn> #vote No
15:51:43 <nijaba> #endvote
15:51:44 <dachary> #vote NO
15:51:45 <openstack> Voted on "let's see if voting is case sensitive?" Results are
15:51:46 <openstack> YeS (1): gmb
15:51:47 <dhellmann> so it looks like it's not case sensitive and you get an error if you use a value that isn't an option
15:51:47 <openstack> nO (4): nijaba, dhellmann, spn, jd___
15:52:00 <jd___> mystery solved
15:52:06 <nijaba> :)
15:52:07 <gmb> I call that a win
15:52:12 <dachary> +1
15:52:26 <jd___> this meeting is totally worth it
15:52:30 <gmb> :)
15:52:34 <zigo> :)
15:52:34 <dhellmann> we're about out of time, is there anything else we need to decide before wrapping up? :-)
15:52:34 <spn> hehe..
15:52:35 <nijaba> ok, enough fun! :P
15:52:44 <nijaba> #topic Open Discusssion
15:53:02 <nijaba> any other brillant subjects for today?
15:53:05 <zigo> I've been searching what I should look into.
15:53:14 <asalkeld> hi are you guys open to flask to wsgi?
15:53:21 <zigo> Appart from Glance metering, is there anything I should work on?
15:53:21 <spn> shud we be using the ceilometerclient to see the output?
15:53:28 <jd___> well, see you next week for "is #action <nickname> case sensitive" !
15:53:31 <zigo> (something easy...)
15:53:49 <asalkeld> so move to move to more glance style api?
15:53:51 <nijaba> zigo: swift should be decently easy, I think
15:53:55 <jd___> what about Quantum?
15:54:05 <zigo> nijaba: Nobody did that yet?
15:54:09 <dhellmann> zigo: there are a bunch of tickets marked "effort-s" in the tracker
15:54:23 <dhellmann> asalkeld: not sure what you mean. our api is written in flask right now.
15:54:30 <asalkeld> I know
15:54:42 <asalkeld> are you open to me changing that
15:54:48 <spn> dhellmann: and devstack does not mark flask as requires...
15:54:55 <nijaba> zigo: https://bugs.launchpad.net/ceilometer/+bugs?field.tag=effort-s
15:54:56 <dhellmann> spn: the ceilometer client is experimental right now. we don't have an official client project
15:55:05 <asalkeld> to be more consistent with other openstack api
15:55:12 <spn> dhellman: ok..
15:55:15 <dhellmann> spn: does devstack set up the api?
15:55:48 <eglynn__> I don't think devstack runs the API service
15:55:50 <dhellmann> asalkeld: let's discuss changes of that scope on the mailing list, we won't have time to go into the details here (5 min)
15:55:55 <spn> dhellman: not yet.. but I see that flask is missing
15:56:00 <asalkeld> ok dhellmann
15:56:02 <nijaba> zigo: nope, see bug #1004450
15:56:03 <uvirtbot> Launchpad bug 1004450 in ceilometer "Pollster for Swift" [Wishlist,Confirmed] https://launchpad.net/bugs/1004450
15:56:12 <zigo> Cheers.
15:56:15 <zigo> Will try.
15:56:26 <dhellmann> #action dhellmann make sure flask is listed as a dependency of ceilometer
15:56:37 <zigo> Could anyone do a bit of mentoring with ne?
15:56:42 <zigo> jd___: Do you have time for that?
15:56:53 <zigo> s/ne/me
15:57:13 <jd___> zigo: eventually
15:57:17 <zigo> Cheers.
15:57:27 <jd___> :)
15:57:43 <spn> dhellman: flask from ubuntu is older version. need to mark it in files/pips/ceilometer  *may-be*
15:57:59 <dhellmann> spn: thanks!
15:58:37 <nijaba> ok, looks like we have a wrap
15:58:50 <nijaba> thanks everyone! was another fun meeting!
15:58:58 <dhellmann> thanks!
15:59:07 <nijaba> #endmeeting