15:00:09 <nijaba> #startmeeting Ceilometer
15:00:09 <nijaba> #meetingtopic Ceilometer
15:00:09 <nijaba> #chair nijaba
15:00:09 <nijaba> #link http://wiki.openstack.org/Meetings/MeteringAgenda
15:00:09 <openstack> Meeting started Thu Sep 20 15:00:09 2012 UTC.  The chair is nijaba. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:11 <openstack> The meeting name has been set to 'ceilometer'
15:00:14 <openstack> Current chairs: nijaba
15:00:14 <jd__> hi
15:00:18 <nijaba> Hello everyone! Show of hands, who is around for the ceilometer meeting?
15:00:18 <nijaba> o/
15:00:26 <jd__> o/
15:00:43 <nijaba> only us 2?
15:00:52 <jd__> looks like a party to me
15:01:05 <nijaba> we should have done the meeting f2f last night ;)
15:01:13 <jd__> yeah :)
15:01:21 <nijaba> #topic actions from previous meeting
15:01:35 <nijaba> #topic dhellmann write up details of blueprint https://blueprints.launchpad.net/ceilometer/+spec/config-driven-notification-monitoring
15:01:42 <jd__> i think Doug will show up
15:01:43 <spn> o/
15:01:46 <spn> I am there..
15:01:52 <nijaba> hey spn!
15:01:52 <jd__> hi spn
15:02:03 <spn> sorry I was pinging on other channel
15:02:19 <spn> jd__:  spn
15:02:31 <spn> jd__: says hi
15:02:51 <nijaba> so I am not sure dhellman was able to work on this item last week
15:02:58 <spn> meeting at this time is awesome
15:03:13 <DanD> o/
15:03:21 <spn> nijaba: Hi Nick
15:04:05 <gmb> o/
15:04:13 <gmb> Half here; also OTP.
15:04:14 <nijaba> hello gmb :)
15:04:26 <gmb> Hi Nick, fancy seeing you here :)
15:04:59 <nijaba> so, dhellmann is not around and the last mod to the wikie page is 2012-08-27 20:58:25
15:05:17 <nijaba> so I guess we'll have to forward this item to next week
15:05:27 <jd__> ack
15:05:33 <nijaba> #action dhellmann write up details of blueprint https://blueprints.launchpad.net/ceilometer/+spec/config-driven-notification-monitoring
15:05:51 <nijaba> and thats all the topics we had for this week
15:06:04 <nijaba> #topic open discussion
15:06:21 <nijaba> anything, anyone?
15:06:24 <spn> yes
15:06:50 <spn> I submitted a micro sized patch last week to add Flask to files/pips
15:07:11 <spn> doug thinks it is not required since he defined it in ceilometer/pip-requires..
15:07:23 <spn> I dont see it working that way..
15:07:37 <jd__> could you elaborate?
15:07:46 <spn> ok..
15:07:50 <jd__> patch url maybe?
15:07:55 <spn> ceilometer-api requires Flask 0.9
15:08:24 <spn> I submitted a patch to enable ceilometer-api through devstack
15:08:44 <spn> but it does not run.. since Flask 0.9 which is a dependecy does not get installed
15:08:57 <spn> throug pip-requires defined in ceilometer branch..
15:09:22 <spn> but if I add it in devstack/files/pips/ceilometer-api , it forces itself to be installed and ceilometer-api works
15:10:08 <spn> https://review.openstack.org/13188
15:10:12 <jd__> I didn't encountered this when installing devstack
15:10:31 <spn> There is a mail from doug.. saying..
15:10:36 <spn> "Patch Set 1:
15:10:36 <spn> Flask is listed as a dependency, with a version number, in the tools/pip-requires file in the ceilometer source code. Doesn't that cause Flask to be installed when devstack runs "sudo python setup.py develop" for ceilometer?
15:10:36 <spn> "
15:11:01 * dhellmann sorry I'm late
15:11:08 <spn> jd__: I tried multiple times.. and I dont see Flask getting installed..
15:11:17 <spn> dhellmann: hello
15:11:44 <jd__> spn: you're right, I didn't tried ceilometer-api, it's not installed
15:11:59 <jd__> spn: I can't say if your patch is the good solution, but there's a problem indeed
15:12:13 <jd__> hi dhellmann
15:12:26 <nijaba> Hey doug!
15:12:31 <spn> the new devstack version will get the ceilometer-api also .. but it will not run
15:12:36 <dhellmann> I don't understand why flask is a problem but the other depdencies work correctly
15:12:45 <dhellmann> is flask the only piece missing
15:12:52 <jd__> dhellmann: dunno either but I confirm it's a problem :)
15:12:57 <spn> as far as I know it is..
15:13:21 <spn> I am kind of jittery to create a pips folder just for our Flask in devstack
15:13:59 <jd__> dhellmann: I think pip-requires is not used at all by setup.py actually, only by tox; I miss stevedore too
15:14:34 <dhellmann> ah, jd__ might be right
15:14:45 <dhellmann> I thought there was some magic going on to load the pip-requires file into setup.py
15:15:03 <dhellmann> but install_requires isn't being set at all
15:15:08 <jd__> me too, I like to think about magic when talking about setuptools
15:15:34 <jd__> yes we miss that probably
15:15:34 <dhellmann> spn: check the use of openstack.common.setup in the nova setup.py file
15:15:38 <dhellmann> that's what we need to do
15:15:45 <spn> ok..
15:16:06 <jd__> def parse_requirements(requirements_files=['requirements.txt',
15:16:07 <jd__> 'tools/pip-requires']):
15:16:07 <jd__> 
15:16:09 <jd__> exactly :-)
15:16:11 <dhellmann> yep, that's it
15:16:23 <dhellmann> so the correct fix is to do that in our setup.py file, not to change devstack
15:16:31 <spn> ok..
15:16:34 <jd__> exactly
15:16:35 <spn> I will look into it..
15:16:51 <jd__> spn: if you prefer I can come up with a change myself
15:16:55 <spn> I will ping you (dhellmann) and jd__ if I have questions..
15:17:02 <spn> jd__: I will do it..
15:17:09 <jd__> spn: ok great!
15:17:16 <spn> jd__: please bear with me. .I am bit new here.. :)
15:17:28 <jd__> spn: no problem :)
15:17:34 <spn> jd_: thanks..
15:17:47 <dhellmann> thanks, spn
15:18:26 <spn> One more q? Is someone already looking into the glance metering part?
15:18:55 <dhellmann> I think jd__ submitted a patch for that earlier today
15:19:15 <jd__> yes, the pollster is on a good way
15:19:24 <nijaba> \o/
15:19:30 <spn> jd__: cool..
15:19:34 <jd__> I've started to work on notifier, but stoped for now because somebody is already working on it
15:19:44 <jd__> eglynn_ actually
15:19:46 <nijaba> notifier?
15:19:47 <spn> elgyn
15:19:54 <spn> yup
15:19:55 <eglynn_> yep, working on it
15:20:01 <jd__> nijaba: glance notification listener
15:20:06 <nijaba> k, thanks
15:20:11 <eglynn_> should have something by tmrw
15:20:17 <jd__> eglynn_: great
15:20:19 <nijaba> 2x\o/
15:20:22 <dhellmann> nijaba: my action item from last week was to write up details about a blueprint. the results are at http://wiki.openstack.org/EfficientMetering/ConfigDrivenNotificationMonitoring
15:20:39 <jd__> eglynn_: I've sent a patch to Glance to clean the notification, because it would send error on the info bus :)
15:20:58 <eglynn_> jd__: cool, looking ...
15:21:01 <nijaba> dhellmann: so this is complete from your perspective, I was not sure
15:21:08 <nijaba> ?
15:21:12 <jd__> eglynn_: https://review.openstack.org/#/c/13190/ FYI
15:21:24 <dhellmann> nijaba: I believe so, but if someone else ends up trying to implement it they may think otherwise ;-)
15:21:47 <nijaba> ok, thanks
15:22:01 <nijaba> I remove the earlier added action for next week then
15:22:15 <nijaba> I *will* remove...
15:22:33 <dhellmann> ok, thanks
15:23:03 <spn> should there be an action on me for pip-requires issue.. ?
15:23:04 <nijaba> #agreed dhellmann action for this week was completed.
15:23:24 <nijaba> spn: feel free to add one for yourself
15:23:36 <nijaba> use: #action spn ...
15:24:02 <jd__> or better, open a bug report and assign it to yourself: )
15:24:23 <spn> #action spn  fix Flask pickup when setup.py is used
15:24:28 <nijaba> it depends if you want us to talk about it next week or not...
15:24:42 <spn> jd__: okies.. I will do that tooo
15:24:59 <spn> nijaba: surely we want to fix that problem..
15:25:00 <nijaba> jd__: #action spn to open a bug about ... and assign it to himself ;)
15:25:43 <spn> nijaba: I will do it..
15:26:11 <jd__> :))
15:26:25 <nijaba> spn: was more a joke than a real action for you ;)
15:26:31 <dhellmann> I want to make a quick disclosure, if jd__ hasn't already said something, that DreamHost has contracted with jd__ to work on some ceilometer features we consider high priority for our launch.
15:26:32 <nijaba> but thanks
15:26:54 <dhellmann> we will be doing all of the work through the normal code review and bug reporting processes (in the open)
15:26:57 <nijaba> dhellmann: that's excellent news I think!  Congrats jd__!
15:27:13 <nijaba> well done dreamhost
15:27:15 <spn> superb.. what are those features btw
15:27:16 <dhellmann> a couple of the changes he has submitted recently were on our list, and I think others' lists, too
15:27:34 <jd__> thanks! :)
15:27:46 <jd__> glad to work with dhellmann on that
15:27:51 <dhellmann> nova notification on delete, integration with glance and cinder so far
15:27:57 <dhellmann> we're still working on our full list of priorities
15:28:20 <dhellmann> I have to say it's going really well so far, so I'm glad we were able to get some of his time!
15:28:42 <spn> dhellmann: is this list of priorities open?
15:29:01 <dhellmann> spn: It's not really a secret, I guess, but the list isn't in a public place right now
15:29:21 <jd__> FWIW I've started to work on cinder notification/pollster
15:29:45 <nijaba> I am sure we'll be able to deduce it from the list of patch jd__does in the next few weeks :)
15:29:55 <jd__> hehe :->
15:29:57 <spn> haha..
15:30:40 <dhellmann> spn: we also have on our list removing the direct db access where possible and adding authentication to the api
15:31:08 <nijaba> spn: and don't expect anything related to object storage...
15:31:53 <spn> Are you referring to the collector/manager.py where we have a FIXME flag?
15:32:02 <nijaba> anything else to cover?
15:32:52 <spn> nijaba: is there any reason not to expect object storage.. sorry I am not aware of history
15:33:15 <nijaba> spn: from dreamhost?  they are rolling their own using ceph and not swif
15:33:16 <dhellmann> spn: nijaba likes to rib me about our use of ceph for object storage instead of swift
15:33:18 <nijaba> spn: from dreamhost? they are rolling their own using ceph and not swift
15:33:30 <zykes-> when will there be some integration for horizon ?
15:33:41 <spn> nijaba: ;) got it..
15:33:48 <jd__> dhellmann: you don't want pollster for ceph into ceilometer?
15:33:54 <nijaba> dhellmann: not sure it is ribbing, more a distintive feature from my pov
15:34:15 <jd__> I though ceph was backed by Canonical anyway, nijaba? :p
15:34:17 <dhellmann> jd__: the folks who did the DreamObjects project set up their own metering solution as a one-off, so it is handled for now. we may change that later.
15:34:25 <jd__> dhellmann: ok!
15:34:29 <dhellmann> nijaba: all good natured, in any case! :-)
15:34:30 <nijaba> jd__: so far, as a backend for cinder :)
15:35:07 <jd__> heh
15:35:16 <spn> :):)
15:35:27 <nijaba> but RADOS_GW just made it in main for 12.10...
15:35:54 <spn> great..
15:36:33 <nijaba> ok, we are getting slighly off topic.  anything else on topic?
15:36:42 <spn> last q
15:37:01 <spn> some one is already working on the chef thing for ceilometer?
15:37:14 <zykes-> anyone got a answer for my question ?
15:37:14 <nijaba> spn: jaypipes should be
15:37:40 <nijaba> zykes-: what integration would you expect?
15:37:42 <dhellmann> zykes-: what sort of integration? showing details?
15:37:56 <nijaba> zykes-: I was thinking about a plugin to show some basic info
15:38:14 <nijaba> zykes-: but you may have something else in mind?
15:38:15 <spn> dhellmann: I had this question sometime back about showing stuff in horizon
15:38:35 <nijaba> spn: zykes-: it's on the roadmap
15:38:39 <jd__> there will probably be a point where the API will have to be opened for users to access their data
15:38:41 <dhellmann> horizon integration isn't on our list of priorities for DreamHost, but I definitely agree we need it for ceilometer at some point
15:38:45 <jd__> that could lead to horizon integration I imagine
15:38:51 <dhellmann> the API is not fully baked yet, so it may be premature
15:39:14 <dhellmann> however, I would be interested in seeing some blueprints and other design documents describing desired views, so we could start thinking about requirements and implementation
15:39:22 <spn> so it is like the billing front end or just showing some ceilometer data?
15:39:41 <dhellmann> spn: I think we should limit ourselves to showing ceilometer data
15:39:49 <nijaba> spn: I don;t thing we'll ever have a full billng front end...
15:40:01 <nijaba> dhellmann: agreed :)
15:40:19 <spn> nijaba: it is more of template/policy driven thing specific to organizations
15:40:27 <dhellmann> although it might make sense to think about a way to let a plugin add rate info
15:40:46 <zykes-> ok.
15:41:03 <nijaba> dhellmann: it all depends on the billing model
15:41:22 <spn> some time backk. I tried this.. added a billing tab and defined a template policy which can be edited by admin tenet
15:41:42 <dhellmann> nijaba: agreed. The DreamHost rate plans are a little complex to calculate
15:41:51 <spn> ok..
15:42:10 <nijaba> spn: It would be nice to have stuff like this as examples, but could never be made universal, I think
15:42:55 <dhellmann> nijaba: exactly
15:43:00 <spn> had a kind of very generic template.. but there is a limit to making it generic
15:43:24 <jd__> dhellmann: that's nice if it's complicated, at least it will force us to make a good API :)
15:43:26 <nijaba> spn: contrib/examples are welcome.  feel free to submit
15:43:39 <spn> nijaba: ok..
15:43:46 <dhellmann> jd__: when we're all done with the project, I'll see if I can write it up
15:43:56 <jd__> sounds great
15:44:07 * nijaba crosses dhellmann's fingers ;)
15:44:24 <dhellmann> :-)
15:44:47 <nijaba> anything else?
15:45:13 <nijaba> going once...
15:45:27 <nijaba> going twice...
15:45:40 <jd__> sold!
15:45:43 <nijaba> ok.... we are done for tdoay!  Thanks a lot everyone!
15:45:45 <spn> thanks for answering my questions
15:45:49 <dhellmann> thanks!
15:45:49 <jd__> thanks guys
15:45:53 <nijaba> #endmeeting