15:00:19 <nijaba> #startmeeting Ceilometer
15:00:19 <nijaba> #meetingtopic Ceilometer
15:00:19 <nijaba> #chair nijaba
15:00:19 <nijaba> #link http://wiki.openstack.org/Meetings/MeteringAgenda
15:00:19 <openstack> Meeting started Thu Nov  1 15:00:19 2012 UTC.  The chair is nijaba. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:21 <openstack> The meeting name has been set to 'ceilometer'
15:00:23 <openstack> Current chairs: nijaba
15:00:29 <nijaba> Hello everyone! Show of hands, who is around for the ceilometer meeting?
15:00:29 <nijaba> o/
15:00:34 <dhellmann> o/
15:00:40 * dhellmann made it on time!
15:00:43 <anniec> o/
15:01:09 <nijaba> #topic actions from previous meeting
15:01:16 <eglynn_> o/
15:01:26 <krtaylor> krtaylor, o/
15:01:44 <nijaba> #topic scrubbing actions from meeting notes
15:02:07 <nijaba> dhellmann: I think you were done with that right?
15:02:16 <dhellmann> yes
15:02:22 <dhellmann> I'm hunting for the right etherpad link...
15:02:24 <nijaba> same for you eglynn?
15:02:35 <nijaba> #link https://etherpad.openstack.org/grizzly-ceilometer-actions
15:02:54 <dhellmann> thanks
15:02:55 <eglynn> nijaba yep, I put a first cut on grizzly-ceilometer-actions
15:02:57 <nijaba> what about you jd?
15:03:04 <nijaba> jd__: ^^
15:03:20 <eglynn> (I'll polish some more later on today ...)
15:03:29 <jd__> o/
15:03:29 <nijaba> and I think I am done done (my part was easy)...
15:03:52 <jd__> done!
15:04:04 <nijaba> thanks, so this is complete !
15:04:22 <nijaba> #topic jd to propose an implementation for source and wait for our comments
15:04:38 <nijaba> jd__: comments?
15:04:50 <jd__> this has been implemented
15:05:01 <nijaba> and approved, right?
15:05:10 <jd__> yes
15:05:16 <jd__> I can find the commit id, a minute
15:05:31 <jd__> https://github.com/stackforge/ceilometer/commit/f6868e5e4827e96754f832a0eae4c4210ea41df7
15:05:37 <jd__> and https://github.com/stackforge/ceilometer/commit/acf8fb88d56b776cf0b83041f5e87e1b6ee88fd2
15:05:43 <jd__> for the record :)
15:05:45 <nijaba> perfect. thanks a lot
15:05:54 <nijaba> #topic nijaba to update project objective on relevant pages
15:06:10 <nijaba> I think this was done wherever I could think of.
15:06:13 * jd__ is sorry to not have prepared the link before :)
15:06:24 <nijaba> let me know if you find some missing pages...
15:06:36 <jd__> nijaba: great :)
15:07:06 <nijaba> #topic Review actions from https://etherpad.openstack.org/grizzly-ceilometer-actions and agree on priorities
15:07:57 <nijaba> so, what do you think we should be prioritizing out of this work?
15:08:14 <dhellmann> I've marked a few of the items as done :-)
15:08:41 <jd__> just see this indeed
15:09:21 <eglynn> assessing commonality with other OS measurement-related initiatives is a high-priority work item IMO
15:09:28 <nijaba> should we all have 5 minutes on the etherpad to write our names next to the actions we consider most important?
15:09:37 <eglynn> cool
15:09:39 <jd__> remove all nova imports is almost complete done I think we should do it for G anyway
15:09:47 <jd__> not sure it's listed, but the multi-publisher blueprint I scrubed from the etherpad page beyond-metering should be included
15:12:59 * nijaba is done
15:13:44 <eglynn> jd__ does https://blueprints.launchpad.net/ceilometer/+spec/multi-publisher subsume https://bugs.launchpad.net/ceilometer/+bug/1073988 ?
15:13:45 <uvirtbot> Launchpad bug 1073988 in ceilometer "Adapt ceilometer for multiple publication conduits" [Undecided,New]
15:13:46 <eglynn> (I raised the bug to capture work from http://lists.openstack.org/pipermail/openstack-dev/2012-October/001840.html)
15:13:59 <eglynn> seems like a dupe ...
15:15:02 <dhellmann> eglynn: yes, those seem like the same thing
15:15:53 <sandywalsh> (hey! side note ... I'm nearly done the bp wiki page for architectural commonality)
15:18:00 <nijaba> ok, that looks good.  So I proposed to sum this back in the wiki page as follow: 3+ votes=high, 1or2 vote=medium, low for rest in terms of priorities?  makes sense?
15:18:31 <jd__> nijaba: +1
15:18:39 <dhellmann> +1
15:18:54 * jd__ have been disconnected, I hope I didn't miss anything
15:18:54 <dhellmann> are there any interested parties whose input we want but who are not present?
15:19:04 <nijaba> if you know of a bug# for each item, please add it to the list.  otherwise we'll have to open one
15:19:15 <dhellmann> jd__: nope
15:19:20 <nijaba> dhellmann: angus?
15:19:22 <eglynn> asalkeld would be interested
15:19:24 <jd__> dhellmann: thanks :)
15:19:51 <nijaba> not seeing input from jtran either
15:20:18 <dhellmann> eglynn, nijaba : yes to both
15:20:27 <nijaba> I am a bit worried of asking other to complete the etherpad on the ml though
15:20:34 <nijaba> we may get a lot of rogue input
15:20:42 <dhellmann> nijaba: private email?
15:20:42 <eglynn> so perhaps we shuld leave the "vote" open for 24 hours?
15:20:50 <nijaba> dhellmann: yes, that sounds better
15:20:51 <eglynn> (to hit al TZs)
15:20:55 <jd__> +1 for private mail
15:20:57 <nijaba> eglynn: +1
15:21:17 <dhellmann> nijaba: it would be interesting to run a surveymonkey survey to the mailing list, too, as long as it's clear we aren't committing to follow the results
15:21:25 <dhellmann> eglynn: +1
15:21:49 <nijaba> dhellmann: I can try to prepare that for next week
15:22:28 <dhellmann> nijaba: ok
15:22:35 <nijaba> #action nijaba to send private email to all comitter to come vote on the etherpad in the next 24h
15:23:22 <eglynn> so I guess there's an implication that a vote for some high priority item comes with some (loose?) commitment to contribute time to it?
15:23:24 <nijaba> #action nijaba to then update wiki page as follow: 3+ votes=high, 1or2 vote=medium, low for rest in terms of priorities
15:23:38 <jd__> eglynn: not sure
15:23:40 <nijaba> eglynn: agreed
15:23:48 <dhellmann> eglynn: that's a good way to phrase it :-)
15:23:53 <eglynn> cool
15:24:09 <nijaba> eglynn: but I won't send the collector squad to enforce... ;)
15:24:24 <eglynn> nijaba: LOL
15:24:28 <dhellmann> I would like to have some input from "users" too, but only to help rebalance my own priorities
15:24:39 <eglynn> that's sensible
15:24:47 * nijaba cares about your kneecaps :P
15:25:44 <nijaba> I guess I should action the survey too...
15:25:46 * jd__ wonders if that does mean mean nijaba will have to code ;)
15:26:08 <dhellmann> jd__: "contribute" != "code", right? :-)
15:26:08 <nijaba> #action nijaba to prepare survey for ml next week
15:26:24 <jd__> dhellmann: ;)
15:26:31 <nijaba> jd__: it's halloween for reviewers, I would guess
15:26:38 <jd__> nijaba: lol
15:27:16 <nijaba> next topic?
15:27:20 <dhellmann> +1
15:27:31 <nijaba> #topic Changing the versioning to adhere to OpenStack standards
15:27:38 <nijaba> So I had a discussion with ttx
15:27:57 <nijaba> he would like us to adhere to openstack standard for versioning
15:28:21 <jd__> I don't see any problem with that
15:28:29 <nijaba> something like ceilometer -2013.1~g1~20121025.16635.tar.gz
15:28:46 <eglynn> seems reasonable
15:28:49 <nijaba> instead of current 0.2, that looks like a release but is not
15:29:07 <nijaba> example job: https://jenkins.openstack.org/view/Nova/job/nova-tarball/
15:29:43 <nijaba> anybody with strong feelings about versioning?
15:30:10 <dhellmann> no, that seems fine
15:30:15 <anniec> following the standard is good
15:30:20 <dhellmann> is there a guide for decoding that format? some of it makes sense, but some is odd
15:30:35 <nijaba> anyone caring about it enough to take the action?
15:31:12 <dhellmann> I guess I'll take it
15:31:35 <dhellmann> #action dhellmann update versioning in ceilometer repo to match openstack standards
15:31:43 <nijaba> thanks dhellmann
15:31:46 <anniec> thanks dhellmann
15:32:16 <nijaba> that's it on the topics for today
15:32:27 <dhellmann> I have a couple of items to raise
15:32:27 <eglynn> so how much leeway do we have during the incubation period?
15:32:28 <nijaba> #topic open discussion
15:32:30 <eglynn> is the idea that we start adopting all standard openstack project practices ASAP or gradually?
15:32:45 <nijaba> eglynn: ASAP
15:32:49 <dhellmann> eglynn: we tried to follow most of them from the start
15:33:02 <dhellmann> is there something else we need to do besides the version numbering and milestones?
15:33:04 <eglynn> nijaba, dhellmann: cool, makes sense
15:33:08 <sandywalsh> versioning should really be following quickly
15:33:16 <nijaba> eglynn: apparently, the renaming of git will require a gerrit reboot, so that will have to be planned
15:33:20 <sandywalsh> we ran into that with novaclient ... made a big difference once we switched
15:33:39 <sandywalsh> the CI guys were very grateful.
15:33:42 <nijaba> I had a meeting with ttxt, mordred and jeblair on the subject  this week (they are at UDS)
15:34:07 <dhellmann> I'll look into it between now and our next meeting
15:34:20 <nijaba> dhellmann: versioning and project name are the last bits, it seems
15:34:20 <eglynn> so I was wondering about the milestone releases, IIRC last week someone mentioned the idea was to get in train for G-3 ... did I understand that right?
15:34:30 <nijaba> eglynn: you did
15:34:36 <dhellmann> "in train"?
15:34:39 <nijaba> eglynn: but we can join eralier
15:34:49 <nijaba> earlier, even
15:34:53 <eglynn> in train = line up with with the other projects
15:35:02 <dhellmann> aha
15:35:03 <eglynn> so maybe earlier would be better
15:35:12 <jd__> nijaba: so there's a timeline for the switch or what?
15:35:24 <jd__> s/what//
15:35:35 <dhellmann> do we need to appoint an official release manager?
15:35:41 <nijaba> jd__: wait for an email on the ml announcing a downtine for gerrit
15:35:48 <jd__> I think the release team handle all project, no?
15:35:50 <nijaba> dhellmann: ttx is the release manager
15:35:54 <jd__> nijaba: ok!
15:35:56 <eglynn> yep ttx
15:35:57 <dhellmann> nijaba: ah, ok
15:36:10 <dhellmann> I didn't know if we needed someone to coordinate with him, but I guess that's nijaba
15:36:29 <eglynn> usually he coordinates with the PTLs AFAIK
15:36:38 <dhellmann> that would make sense
15:36:48 <nijaba> yup.  I may ask for some help to go to the release meeting every other week, as I have a personal conflict with it
15:37:08 <nijaba> in fact, is there a volunteer to cover for me for next tue?
15:37:14 <jd__> what's the time?
15:37:33 <eglynn> 21:00 UTC
15:37:36 <nijaba> http://wiki.openstack.org/Meetings/ProjectMeeting
15:38:21 <eglynn> nijaba: I can cover it
15:38:30 <nijaba> eglynn: thanks a lot!
15:38:30 <jd__> can do that
15:38:35 <jd__> ok :)
15:38:46 <nijaba> jd__: feel free to join too
15:38:55 <jd__> yeah, I'll add it to my agenda :)
15:38:56 <dhellmann> I'll try to eavesdrop
15:39:01 <eglynn> cool
15:39:09 <jd__> btw what about eglynn proposal to core?
15:39:21 <jd__> are we good on that?
15:39:27 <dhellmann> that was one of the 3 things I wanted to bring up
15:39:39 <dhellmann> we voted on the list, do we need anything more formal than that?
15:39:46 <jd__> sorry, didn't mean to steal your points :o)
15:39:48 <dhellmann> or just an action item for nijaba to flip the bit
15:40:00 <dhellmann> heh
15:40:01 <jd__> I think the delay is 5 days without -1
15:40:04 <nijaba> dhellmann: I think the later
15:40:13 <jd__> so we should be almost good anyway
15:40:14 <nijaba> jd__: ah...
15:40:28 <jd__> I don't think anybody will dare -1 ! :)
15:40:51 <eglynn> hope not anyway ;)
15:40:58 <jd__> process is at http://wiki.openstack.org/Governance/Approved/CoreDevProcess
15:40:59 <nijaba> #action nijaba to add eglynn to ceilometer drivers on satureday if all goes well
15:41:19 <nijaba> saturday, too...
15:41:19 <dhellmann> I would also like to propose asalkeld for core
15:41:33 <nijaba> dhellmann: same process?  via ml?
15:41:39 <dhellmann> ah, right, ok
15:41:54 <jd__> dhellmann: copy/paste the mail I sent for eglynn
15:42:03 <nijaba> "When a developer feels he has met the criteria and would like to apply for Core Developer status, He/She should send an email to the main OpenStack mailing list requesting to become a Core Developer for a specific sub-project. "
15:42:03 <dhellmann> jd__: reading my mind
15:42:06 <jd__> I meant to do it, but prefered to wait for eglynn to be done first :)
15:42:13 <nijaba> "We will use lazy consensus for the approval vote from the current sub-project core developers. The lazy consensus process shall last five days after the email is sent to the mailing list. During the lazy consensus period the applicant must get approval responses from either 5 active Core Developers or a simple majority of the active Core Developers, whichever is smaller, with no rejection votes. "
15:42:54 <dhellmann> ok, I'll send a proposal email
15:43:01 <nijaba> dhellmann: thanks
15:43:02 <jeblair> o/  (sorry, got dragged into another discussion; any CI questions i can answer?)
15:43:24 <dhellmann> jeblair: we were talking about version numbering before, and your name came up related to that
15:43:25 <nijaba> jeblair: nope, I was just relating the discussion we had about having to restart gerrit
15:43:38 <dhellmann> sorry, that
15:43:41 <nijaba> jeblair: not for versioning, but for naming
15:43:51 <nijaba> dhellmann: :)
15:44:12 <jeblair> i think there is another project that wants a name change
15:44:19 <dhellmann> ok, the other thing I wanted to ask for was a review of the api auth fix in https://review.openstack.org/#/c/15133/
15:44:46 <dhellmann> that needs one more +2
15:44:51 <jeblair> openstack-common -> oslo-incubation or something, so i think we want to batch that.  let's check on the timing for that, and hopefully execute in a couple of weeks.
15:45:21 <nijaba> jeblair: thanks!
15:46:08 <nijaba> dhellmann: will do asap.  Sorry, a bit busy with 3 week on the road.  coming back to normal next week
15:46:58 <nijaba> anything else?
15:47:05 <sandywalsh> yes
15:47:07 <dhellmann> nijaba: I understand, and thanks
15:47:21 <eglynn> one other thing, how do we regenerate http://ceilometer.readthedocs.org/en/latest/install.html in the light of https://review.openstack.org/14831 ?
15:47:27 <eglynn> (zykes- and davidkranz both tripped over the notification_driver mis-direct in the last while ...)
15:47:49 <sandywalsh> as I mentioned, I'm nearly done the bp on common code for StackTach/Ceilometer/etc ... hope to wrap it up today. Really looking forward to feedback on it.
15:47:51 <dhellmann> eglynn: I need to push those changes to my github repo, which is tied to readthedocs
15:47:52 <nijaba> eglynn: it is not generated, is just an rst in the source
15:48:09 <eglynn> dhellmann: a-ha, cool
15:48:13 <nijaba> dhellmann: isn't this automatic?
15:48:14 <dhellmann> #action dhellmann update readthedocs copy of our docs
15:48:30 <dhellmann> nijaba: it's automatic when I push to my private repo, because I don't have permission to turn on the hook on the shared repo
15:48:32 <eglynn> sandywalsh looking forward to reading that!
15:48:53 <dhellmann> sandywalsh: me, too
15:49:10 <nijaba> dhellmann: infra team would certainly have that rigght...
15:49:25 <dhellmann> nijaba: and now that we're incubated, I can ask them to do things like this :-)
15:49:31 <anniec> sandywalsh: will make sure y! open stackers too
15:49:38 <dhellmann> nijaba: maybe we can coordinate with/after the name migration
15:49:38 <sandywalsh> cool ... hope you guys had a chance to look at the stacktack video?
15:49:48 <nijaba> dhellmann: sounds good
15:49:56 <dhellmann> sandywalsh: not yet, have a link for the logs?
15:50:00 <sandywalsh> http://www.youtube.com/watch?v=pZgwDHZ3wm0
15:50:16 <sandywalsh> latest code is up on github
15:51:17 <eglynn> step-thru' videos are great for driving adoption, we should consider one for ceilo also
15:51:28 <eglynn> (one the grizzly features satrt shaping up ...)
15:51:37 <eglynn> s/satrt/start/
15:51:59 <nijaba> eglynn: great idea.  I guess jd__ and I could work on that together
15:52:05 <nijaba> jd__: up to it?
15:52:21 <jd__> sure
15:52:23 <eglynn> cool!
15:52:26 <davidkranz> Is the API stable enough to start adding some simple tempest integration tests?
15:52:28 <dhellmann> nice
15:52:43 <dhellmann> davidkranz: probably not
15:52:53 <nijaba> eglynn: hope you don't mind if the video comes with a frnech accent ;)
15:53:03 <dhellmann> davidkranz: soon, though, I hope
15:53:15 <davidkranz> dhellmann: Ok. I think that is an important part of openstack process so just let me know when.
15:53:15 <dhellmann> nijaba: subtitles?
15:53:16 <eglynn> all the better, add some Euro-focus ;)
15:53:17 * dhellmann ducks
15:53:26 <nijaba> dhellmann: accessibility rules!
15:53:32 <dhellmann> davidkranz: agreed!
15:54:20 <nijaba> #action jd__ and nijaba to start preparing a video demo of ceilometer
15:54:55 * jd__ laughed at "subtitles?"
15:55:18 * nijaba laughed first, then thought about hearing impaired
15:55:41 <nijaba> anything else?
15:55:52 * nijaba starts the 30s count down?
15:55:58 * nijaba starts the 30s count down!!
15:55:59 * dhellmann has a room full of hungry coworkers who want to go to lunch
15:56:08 <m4dcoder> i have a question about data backend...
15:56:20 * nijaba throws virtual peanuts
15:56:33 <nijaba> m4dcoder: sure.  shoot
15:56:34 <m4dcoder> for ceilometer, any direction to push data to NoSQL backend?
15:56:52 <nijaba> m4dcoder: we have one backend implemented: mongo
15:56:52 <eglynn> other than MongoDB?
15:57:15 <nijaba> m4dcoder: but the abstraction would allow you to do anything else you want...
15:57:23 <jd__> anyone can come with a new storage engine
15:57:52 <nijaba> jtran is finishing the SQLAlchemy one
15:58:30 * nijaba resets the 30s count down
15:58:31 <m4dcoder> that answers my question.  thx.  i just started catching up on this project.  so still figuring this out.
15:59:19 <nijaba> m4dcoder: feel free to join #openstack-metering for other questions you may have
15:59:23 <nijaba> #endmeeting