#openstack-meeting: Ceilometer

Meeting started by nijaba at 15:00:02 UTC (full logs).

Meeting summary

    1. http://wiki.openstack.org/Meetings/MeteringAgenda (nijaba, 15:00:02)

  1. actions from previous meeting (nijaba, 15:01:04)
  2. eglynn drive fleshing out of nova-virt API to completion (nijaba, 15:01:04)
  3. yjiang5 to start a thread on transformer (nijaba, 15:17:04)
    1. ACTION: yjiang5_away to send patches for transformer (nijaba, 15:21:51)

  4. eglynn to report on synaps' decision (nijaba, 15:21:55)
    1. ACTION: eglynn kick off Synaps discussion on upstream ML (eglynn, 15:24:34)

  5. nijaba to get rid of roadmap page content to point to lp (nijaba, 15:24:44)
    1. http://wiki.openstack.org/EfficientMetering/RoadMap (nijaba, 15:24:44)

  6. dhellmann test more lenient anyjson support for folsom and grizzly compatibility (nijaba, 15:25:06)
  7. dhellmann update user-api blueprint (nijaba, 15:25:52)
    1. http://wiki.openstack.org/spec-ceilometer-user-api (nijaba, 15:26:57)

  8. dhellmann update pecan port blueprint (nijaba, 15:27:56)
    1. http://wiki.openstack.org/spec-ceilometer-api-server-pecan-wsme (nijaba, 15:28:41)

  9. zykes to report status on Bufunfa / BillingStack port (nijaba, 15:29:50)
  10. Bug squashing day (nijaba, 15:30:57)
    1. VOTE: Voted on "when to do bugday?" Results are, jan4: 4, jan7: 2 (nijaba, 15:39:09)
    2. AGREED: bugday on jan 4th (nijaba, 15:39:30)

  11. Review blueprints and progress (nijaba, 15:40:50)
    1. VOTE: Voted on "agree on dec 15th for bluprint "freeze"?" Results are, yes: 6 (nijaba, 15:44:55)
    2. AGREED: blueprint freeze on dec 15th (nijaba, 15:45:09)

  12. Discuss suggested re-narrowing of project scope for grizzly versus user-oriented monitoring (nijaba, 15:45:24)
  13. multi-publisher blueprint (nijaba, 15:49:20)
  14. multi-dimensions bp (nijaba, 15:50:30)
    1. http://wiki.openstack.org/Ceilometer/blueprints/multi-dimensions (dhellmann, 15:51:08)
    2. https://blueprints.launchpad.net/ceilometer/+spec/multi-dimensions (nijaba, 15:51:10)
    3. ACTION: nijaba to update the bp to specify complex request in a future version (nijaba, 15:53:12)
    4. ACTION: dhellmann to prepare example of dimension query syntax that will work with WSME (dhellmann, 15:56:13)

  15. Discuss adopting asalkeld's client implementation officially (nijaba, 15:56:55)
    1. https://github.com/asalkeld/python-ceilometerclient (dhellmann, 15:57:49)
    2. AGREED: adopt asalkeld's client officially (nijaba, 15:59:52)
    3. ACTION: move asalkeld's client into openstack incubation/core (jd__, 16:00:15)
    4. ACTION: jd__ move asalkeld's client into openstack incubation/core (jd__, 16:00:31)

  16. open discussion (jd__, 16:02:10)
    1. http://www.meetup.com/OpenStack-Ireland/events/92413652/ (eglynn, 16:02:14)
    2. https://docs.google.com/presentation/d/1i30roVZp00Wvo46F4k5CT98sw2uMgaf5Lh3bSfiQ-Cg/edit#slide=id.p (jd__, 16:02:49)
    3. http://docs.openstack.org/developer/ceilometer/ (dhellmann, 16:05:54)
    4. ACTION: talk with doc team to link to ceilometer docs (yjiang5_away, 16:10:09)
    5. ACTION: yjiang5 talk with doc team to link to ceilometer docs (yjiang5_away, 16:10:38)


Meeting ended at 16:11:49 UTC (full logs).

Action items

  1. yjiang5_away to send patches for transformer
  2. eglynn kick off Synaps discussion on upstream ML
  3. nijaba to update the bp to specify complex request in a future version
  4. dhellmann to prepare example of dimension query syntax that will work with WSME
  5. move asalkeld's client into openstack incubation/core
  6. jd__ move asalkeld's client into openstack incubation/core
  7. talk with doc team to link to ceilometer docs
  8. yjiang5 talk with doc team to link to ceilometer docs


Action items, by person

  1. dhellmann
    1. dhellmann to prepare example of dimension query syntax that will work with WSME
  2. eglynn
    1. eglynn kick off Synaps discussion on upstream ML
  3. jd__
    1. jd__ move asalkeld's client into openstack incubation/core
  4. nijaba
    1. nijaba to update the bp to specify complex request in a future version
  5. openstack
    1. move asalkeld's client into openstack incubation/core
    2. jd__ move asalkeld's client into openstack incubation/core
  6. yjiang5_away
    1. yjiang5_away to send patches for transformer
  7. UNASSIGNED
    1. talk with doc team to link to ceilometer docs
    2. yjiang5 talk with doc team to link to ceilometer docs


People present (lines said)

  1. nijaba (119)
  2. eglynn (106)
  3. dhellmann (89)
  4. jd__ (45)
  5. yjiang5_away (31)
  6. openstack (14)
  7. n0ano (12)
  8. shardy (1)
  9. Pete_ (1)


Generated by MeetBot 0.1.4.