20:59:58 <dhellmann> #startmeeting Ceilometer
20:59:59 <openstack> Meeting started Wed Dec  5 20:59:58 2012 UTC.  The chair is dhellmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:00 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:02 <openstack> The meeting name has been set to 'ceilometer'
21:00:12 <dhellmann> #chair dhellmann
21:00:13 <openstack> Current chairs: dhellmann
21:00:25 <dhellmann> #link http://lists.openstack.org/pipermail/openstack-dev/2012-December/003685.html
21:00:34 <dhellmann> #link http://wiki.openstack.org/Meetings/MeteringAgenda
21:00:35 <dhellmann> if you are here for the ceilometer meeting, please raise your hand
21:00:35 <dhellmann> o/
21:00:39 <n0ano> o/
21:00:39 <eglynn__> o/
21:00:43 <yjiang5> o/
21:01:04 <jd__> o/
21:01:23 <dhellmann> nijaba is traveling, so may be in and out depending on connectivity
21:01:26 <dhellmann> first up, actions from previous meetings
21:01:27 <dhellmann> #topic yjiang5 to send patches for transformer
21:01:28 <dhellmann> #link https://review.openstack.org/#/c/17440/
21:01:41 <yjiang5> dhellmann: yes, sent out
21:01:43 <dhellmann> this is under review, with good discussion
21:02:00 <nijaba> o/ (from flaky 3G in the high speed train)
21:02:03 <dhellmann> do we need to do anything else with it, aside from continue discussing, for next week?
21:02:17 <dhellmann> you live in the future, nijaba
21:02:26 <yjiang5> dhellmann: I will rebase according to feedback.
21:02:33 <dhellmann> yjiang5: but no action for the meeting?
21:02:40 <yjiang5> dhellmann: no
21:02:47 <dhellmann> #info patch under review, task complete
21:02:55 <dhellmann> #topic eglynn kick off Synaps discussion on upstream ML
21:02:56 <dhellmann> #link http://lists.openstack.org/pipermail/openstack-dev/2012-December/003731.html
21:03:25 <dhellmann> eglynn: we have an agenda item about this for later in the meeting
21:03:26 <dhellmann> d
21:03:26 <eglynn> yep ... so the discussion is underway
21:03:26 <dhellmann> o you
21:03:27 <dhellmann> have
21:03:36 <dhellmann> do you have anything else to add now?
21:03:48 <eglynn> I'll prod the Synaps guys to try to get them more vocal on the list
21:04:09 <dhellmann> yeah, I'd like to know that we'll hear from them more than once a week or so if we're going to bring them into the team
21:04:10 <dhellmann> I
21:04:11 <dhellmann> a
21:04:22 <eglynn> yes, agreed
21:04:26 <dhellmann> ok, we can discuss more in a bit
21:04:32 <dhellmann> #topic nijaba to update the bp to specify complex request in a future version
21:04:33 <dhellmann> #link http://wiki.openstack.org/Ceilometer/blueprints/multi-dimensions
21:04:33 <yjiang5> eglynn: so can they access IRC?
21:04:46 <eglynn> yjiang5: I need to confirm that
21:05:09 <dhellmann> this appears to be done, right nijaba ?
21:05:18 <nijaba> right
21:05:36 <dhellmann> #info done, see second example under number 2 in the "Design" section
21:05:53 <dhellmann> #topic dhellmann to prepare example of dimension query syntax that will work with WSME
21:05:54 <dhellmann> #link http://wiki.openstack.org/Ceilometer/blueprints/multi-dimensions
21:06:12 <dhellmann> #info done, see the WSME example under number 2 in the "Design" section
21:06:13 <dhellmann> questions?
21:06:40 <dhellmann> ok
21:06:42 <dhellmann> #topic jd move asalkeld's client into openstack incubation/core
21:06:51 <dhellmann> jd__: any updates?
21:07:05 <jd__> yes, started this afternoon with https://review.openstack.org/#/c/17537/
21:07:19 <dhellmann> #link https://review.openstack.org/#/c/17537/
21:07:23 <jd__> wait'n see :)
21:07:41 <dhellmann> cool, is that a new repo, then?
21:07:51 <jd__> obviously!
21:08:01 * dhellmann didn't click through
21:08:05 <jd__> hehe
21:08:07 <dhellmann> any actions on this for next week?
21:08:07 <asalkeld> hi, sorry bit late
21:08:14 <jd__> like every other python-<osprojecc>client
21:08:23 <dhellmann> jd__: ok, good
21:08:26 <jd__> dhellmann: I don't think so, I'll follow my review request
21:08:32 <dhellmann> ok
21:08:47 <dhellmann> #topic yjiang5 talk with doc team to link to ceilometer docs
21:08:48 <dhellmann> #link https://review.openstack.org/#/c/17444/
21:08:48 <dhellmann> that's merged, so is this work done?
21:08:53 <yjiang5> yes
21:08:57 <dhellmann> #info done
21:09:06 <dhellmann> on a related note, the references on launchpad have been updated to point to the new location
21:09:07 <dhellmann> should I delete ceilometer.readthedocs.org? replace it with a page pointing to the new location?
21:09:26 <jd__> dhellmann: yeah, replace it and then delete
21:09:52 <dhellmann> #action dhellmann replace ceilometer.readthedocs.org with a page directing readers to the new site
21:09:53 <nijaba> +1
21:10:06 <jd__> here's the nijaba
21:10:10 <yjiang5> dhellmann: so we will update the new doc site
21:10:25 <yjiang5> dhellmann: to improve it , right?
21:10:28 <dhellmann> yjiang5: yes, the jenkins job updates the new site automatically after every merge
21:10:53 <dhellmann> so we can expand the documentation through our normal review process, without waiting for me to remember to push to my repo to get rtd.org updated :-)
21:11:00 <yjiang5> dhellmann:  great.
21:11:09 <nijaba> dhellmann: we may want to keep readthedoc for0.1 doc?
21:11:18 <dhellmann> nijaba: ah, good point
21:11:35 <dhellmann> I will see if I can figure out a way to do that
21:11:46 <yjiang5> nijaba: why do we want to keep 0.1 doc, if we have v1 api back compatibility?
21:12:04 <nijaba> yjiang5: because we have people deloying it
21:12:12 <dhellmann> yjiang5: there are some developer details in the docs that have changed, too
21:12:31 <yjiang5> nijaba: dhellmann: got it.
21:12:59 <dhellmann> I think I can make that work by using a branch in my private github repo
21:13:11 <dhellmann> I think that's it for past actions, on to new business
21:13:11 <dhellmann> #topic Discuss v2 API proposal
21:13:47 <dhellmann> I think this is a combination of the pecan/wsme stuff and asalkeld's desire to tighten up the api urls
21:13:50 <dhellmann> (and mine)
21:13:54 <jd__> yeah, I've added this to the agenda because I didn't see much trace of what v2 API should look like
21:14:19 <jd__> I assume you mimic-ed the v1 URL scheme, but I didn't have the chance to review your work :p
21:14:31 <jd__> anyway I had the feeling we could improve and change a lot of thing in v2
21:14:33 * nijaba concurs to the need of a bp
21:14:42 <dhellmann> I've been working on documentation for the v2 api, and I do have to say it's a bit odd to have a bunch of urls that return the same thing with different filters
21:14:55 <asalkeld> jd__, I was hoping we could flatten the api
21:14:56 <dhellmann> does anyone think we should *not* make any api changes?
21:15:03 <dhellmann> assuming we get a blueprint together quickly
21:15:04 <jd__> asalkeld: I was thinking the same actually
21:15:23 <jd__> dhellmann: it's v2, we can do anything! :)
21:15:24 <asalkeld> so like: /meters /resources /samples
21:15:31 <dhellmann> although I would be inclined to give this blueprint an extension on our approval deadline if we needed to. I think it's important enought.
21:15:34 <asalkeld> something like that
21:16:01 <nijaba> dhellmann: +1 for an extension, as long as we start it sooner than later
21:16:02 <jd__> dhellmann: makes sense, especially now that the code is merged :)
21:16:28 <dhellmann> asalkeld: do you have enough info to put together a concrete proposal?
21:16:41 <dhellmann> or do you need more details about how wsme parses queries
21:16:43 <dhellmann> oo
21:16:43 <dhellmann> ps
21:17:07 <asalkeld> sorry
21:17:09 <asalkeld> disconnect
21:17:10 * dhellmann hopes it wasn't something he said
21:17:11 <asalkeld> grr
21:17:13 <asalkeld> yes
21:17:19 <nijaba> asalkeld: trying to avoid embarrassing questions? ;)
21:17:29 <asalkeld> I can put something together
21:17:42 <asalkeld> ctrl-r
21:17:48 <asalkeld> == disconnect
21:17:54 <nijaba> hehe
21:18:07 <dhellmann> asalkeld: action?
21:18:11 <asalkeld> yip
21:18:27 <dhellmann> #action asalkeld prepare a blueprint for v2 api "tightening" changes
21:18:40 <asalkeld> faster typer
21:18:48 <dhellmann> let me know if I can help with wsme questions
21:18:57 <dhellmann> his docs are a little thin, I need to help him expand on those
21:18:58 <asalkeld> sure, probably the query
21:19:15 <asalkeld> and your usecases
21:19:16 <nijaba> dhellmann: yeah, can we get rif of the [] in the query ?
21:19:34 <dhellmann> nijaba: I'll have to see. I think that's how wsme makes arrays of objects
21:19:46 <dhellmann> I haven't had a chance to experiment, yet
21:19:52 <nijaba> dhellmann: k
21:20:02 <dhellmann> #action dhellmann experiment with passing arrays of parameters to wsme for queries
21:20:16 <dhellmann> ok, anything else on this topic?
21:20:24 <jd__> good for me
21:20:31 <jd__> i'll wait for asalkeld bp :)
21:20:42 <asalkeld> I'll do it today
21:20:56 <dhellmann> sounds good
21:20:59 <dhellmann> ok, next up
21:21:00 <dhellmann> #topic Mechanics of getting synaps on-board
21:21:05 <eglynn> so the approach I suggested on the ML ...
21:21:12 <eglynn> (big-bang import of the code prior to clean-up tasks, manual migration of launchpad issues)
21:21:18 <eglynn> too simplistic, or?
21:21:23 <eglynn> ... or just simplistic enough ;)
21:21:32 <eglynn> I don't know enough about git submodules/subtrees
21:21:34 <jd__> hm at first glance I'm not in favor of importing a lot of code that way
21:21:39 <eglynn> but I'm hoping it can be done in a straight-forward history preserving way
21:21:45 <dhellmann> eglynn: I haven't checked for a reply to my question about doing cleanup before vs. after importing
21:21:47 <jd__> I'd rather have a cherry-picking-surgeon approach
21:22:13 <eglynn> jd__: OK, I'll assess the code to see if that's feasible
21:22:18 <yjiang5> eglynn: I rememner they have even java code?
21:22:22 * eglynn was just eager to get it in there ...
21:22:30 <nijaba> it would be nice to have a meeting with them present to discuss this, no?
21:22:37 <jd__> eglynn: would be great to pick code we'd need and put it into our various ceilometer components (or create new ones)
21:22:43 <eglynn> yjiang5: yep, there's a small amount of Java code to define the strom topology
21:22:48 <asalkeld> else it is just a code dump
21:22:57 <eglynn> yjiang5: (as opposed to functional code)
21:23:14 <yjiang5> eglynn: ok, just curios how to import that code :)
21:23:19 <asalkeld> how about:
21:23:27 <eglynn> nijaba: I'll prod them to get on the ML to discuss at least
21:23:32 <asalkeld> we commit the post/get
21:23:36 <asalkeld> then the alarm
21:23:58 <asalkeld> so we get _some_ seperation
21:24:07 <dhellmann> post/get?
21:24:16 <eglynn> asalkeld: what's the post/get? their impl of PutMetricData/GetMetricStats
21:24:18 <eglynn> ?
21:24:21 <asalkeld> post_meter_data
21:24:34 <asalkeld> basically the monitoring
21:24:39 <asalkeld> then the alarms
21:25:00 <asalkeld> I am keen to have an option to have a different alarm system
21:25:06 <eglynn> asalkeld: by the alarms, do you mean the alarm evaluation logic in Synaps?
21:25:07 <jd__> commiting inside ceilometer itself or as a side-project inside ceilometer repo? because that sounds 2 different options to me
21:25:14 <asalkeld> eglynn, ya
21:25:19 <jd__> and not sure what we're talking about here
21:25:25 <dhellmann> asalkeld: that order and separation makes sense to me
21:25:29 <asalkeld> O, haven't read ml
21:25:37 <dhellmann> but yeah, where is it going in our repo?
21:25:41 <asalkeld> assume in code base
21:26:05 <eglynn> under ceilo/monitoring or something of that ilk
21:26:05 <asalkeld> so where else we putting it
21:26:15 <eglynn> or ceilo/synaps even ...
21:26:15 <yjiang5> jd__: as a side-project possibly tricky to manage?
21:26:29 <jd__> ok, that sounds fine to me, I'd dislike having a side project I think
21:26:30 * eglynn is not sure what a side project is ...
21:26:35 <asalkeld> so put the api under api/
21:26:42 <jd__> eglynn: another project in another subdirectory… :)
21:26:57 <asalkeld> and the alarming under alarm
21:27:04 <asalkeld> seems simple to me
21:27:09 <dhellmann> that makes sense
21:27:23 <dhellmann> this seems like something we need a blueprint for, to map out all of these details in an easy to review form
21:27:27 <eglynn> jd__: like a git submodule/subtree? or just a seperate dir?
21:27:32 <asalkeld> dir?
21:27:38 <dhellmann> yeah, no submodules
21:27:44 <eglynn> k
21:27:48 <asalkeld> more complexity
21:28:10 <asalkeld> ceilometer/api/{v1,v2,cw}
21:28:14 <eglynn> asalkeld: dir, just in the sense of a plain ol' directory
21:28:16 <yjiang5> eglynn: what's the target schedule for this merge? In G? H?
21:28:26 <asalkeld> I recon
21:28:39 <dhellmann> asalkeld: the cw api should be part of v2, no?
21:28:44 <dhellmann> we'll have to version it as it changes
21:28:49 <asalkeld> no it's aws
21:28:53 <dhellmann> ah
21:28:54 <eglynn> yjiang5: late G
21:29:01 <asalkeld> it has it's own versioning
21:29:10 <eglynn> date based
21:29:12 <dhellmann> what tool did they use to build it?
21:29:18 <eglynn> but we'll have a native API eventually too right
21:29:37 <asalkeld> v2?
21:29:38 <dhellmann> the native api will go under our versioned tree?
21:29:46 <jd__> why not?
21:29:52 <eglynn> dhellmann: yes I'd expect so
21:29:56 <dhellmann> ok
21:30:06 <yjiang5> dhellmann: but user will assume aws version still, so a map from our version to aws version?
21:30:12 <dhellmann> so, who is going to pull all of this together into a blueprint?
21:30:19 <eglynn> we don't want to get in the nova API extensions versioning fragmentation
21:30:26 <eglynn> I can do that
21:30:35 <eglynn> but would appreciate input on the ML thread
21:30:39 <dhellmann> #action eglynn prepare a blueprint for synaps integration
21:30:41 <dhellmann> agreed
21:30:51 <asalkeld> cool
21:30:59 <dhellmann> I presume part of this will be giving some of the synaps team +2 rights for reviewing our changes to their code?
21:31:27 <eglynn> yes I think so
21:31:32 <yjiang5> dhellmann: agree.
21:31:48 <dhellmann> if that is the case, we need a commitment of responsiveness, I think?
21:31:51 <eglynn> (but not structured as a veto on everything)
21:32:08 <asalkeld> yes: " commitment of responsiveness"
21:32:08 <eglynn> yes, I'm going to prod them again to get some clarity on that
21:32:15 <dhellmann> ok
21:32:32 <jd__> ok
21:32:38 <asalkeld> well other approach
21:32:39 <dhellmann> I think we should hold off on any code work until we have the team aspects of the integration worked out
21:32:46 <eglynn> makes sense
21:33:01 <asalkeld> is to let them get involved as they want to
21:33:02 <dhellmann> although design discussions should proceed, to avoid holding us up later?
21:33:26 <asalkeld> and we make changes as we see fit
21:33:26 <eglynn> yes
21:33:33 <dhellmann> asalkeld: if they say they don't want +2, that's ok, but I don't think we should take the code without offering
21:33:47 <dhellmann> seems, I don't know, rude
21:33:59 <eglynn> rudeness is not our style ;)
21:34:07 <jd__> yet
21:34:11 <eglynn> LOL
21:34:13 <asalkeld> well maybe a suggestion of expections
21:34:19 <dhellmann> so the commitment is just if they say yes to wanting +2, just like for any other team -- you have to contribute to keep it
21:34:31 <dhellmann> asalkeld: right
21:34:56 <asalkeld> like come to irc meetings?
21:35:07 <dhellmann> that would be good, if we can work out the timing
21:35:13 <dhellmann> they're in asia somewhere, right?
21:35:13 <jd__> would make sense
21:35:20 <jd__> Korea I imagine
21:35:33 <nijaba> yep
21:35:41 <dhellmann> ok
21:35:42 <eglynn> yep, this slot is better than the alternate Euro-friendly one
21:35:58 <eglynn> so maye every other week would be acceptable
21:36:14 <dhellmann> sure, and not necessarily all of them if they want to appoint a representative or something
21:36:15 * jd__ is sleeping on his keyboard and don't get what eglynn is talking about
21:36:39 <asalkeld> haha
21:36:40 <eglynn> just meant that they may not be able to make the Thurdsday afternoon GMT slot
21:36:43 <dhellmann> I'm not trying to stress the participation, but it feels like stealing to bring their code in without involving them.
21:36:58 <eglynn> agreed
21:37:01 <dhellmann> ok
21:37:04 <jd__> eglynn: I was kidding :)
21:37:13 <asalkeld> it's opensource, no such thing as stealing
21:37:16 <asalkeld> ;)
21:37:20 <dhellmann> so, mordred also brought up healthnmon moving to stackforge on the mailing list
21:37:25 * eglynn is slow on the up-take at this hour ;)
21:37:25 <yjiang5> dhellmann: why can't firstly work with two project, and comunicate with RPC?
21:37:50 <mordred> ola
21:37:54 <dhellmann> yjiang5: that would be another approach, but I think we felt there would be a lot of benefits to sharing actual code
21:38:07 <dhellmann> hi, mordred
21:38:07 <eglynn> yjiang5: RPC or REST API?
21:38:29 <eglynn> yjiang5: REST makes more sense to me, as opposed to AMQP ...
21:38:37 <yjiang5> eglynn: either way is ok, synaps support AMQP IIRC.
21:38:51 <dhellmann> either, but let's finish exploring the code merge path before we give up and go back to two projects
21:38:59 <eglynn> yep
21:39:02 <yjiang5> dhellmann: sure
21:39:17 <dhellmann> ok, so healthnmon -- we looked at this a couple of weeks ago, didn't we?
21:39:23 <asalkeld> yea
21:39:30 <asalkeld> but they are super quite
21:39:46 <asalkeld> maybe we can email them directly
21:39:52 <dhellmann> apparently they are working with mordred to get stackforge access
21:39:59 <asalkeld> yea
21:40:05 <mordred> yeah - I believe they want to work on this in the open and stuff
21:40:06 <eglynn> they were vocal at the summit, but haven't heard anything much since
21:40:20 <mordred> just gotta get them bootstrapped I think
21:40:48 <eglynn> cool enough
21:40:56 <dhellmann> I can't find my notes from that meeting.
21:40:57 <dhellmann> di
21:40:57 <dhellmann> d
21:41:21 <dhellmann> did we agree that monitoring at that level was going to wait for another release?
21:41:38 <asalkeld> dhellmann, they are at a bunch of levels
21:41:51 <asalkeld> trace + inventory
21:42:03 <asalkeld> and some alarms
21:42:31 <asalkeld> so seems like somewhat of an overlap
21:43:07 <asalkeld> I have go and take kids to school
21:43:14 <asalkeld> later ...
21:43:23 <dhellmann> later
21:43:48 <eglynn> so one think that wasn't fully clear to me at the summit was how much they'd actually built-out
21:43:49 <dhellmann> ok, so I'm trying to remember why we approached synaps instead of healthnmon. was it just activity on the mailing list?
21:44:07 <eglynn> heathnmon wasn't opensourced at the time
21:44:14 <dhellmann> aha
21:44:17 <eglynn> (they just released RPMs initially)
21:44:22 <dhellmann> ok
21:44:39 <eglynn> then later pushed the code up tot github (whithout any fan-fare)
21:44:57 <dhellmann> so, is it worth approaching them now?
21:45:10 <eglynn> sure
21:45:20 * nijaba has to get off the train before it goes back to london...
21:45:27 <dhellmann> eglynn: is that an action for you again?
21:45:34 <dhellmann> you have the most practice… ;-)
21:45:38 <eglynn> sure ;)
21:45:38 <yjiang5> dhellmann: I can also have a look on it
21:45:55 <eglynn> #action eglynn reach out to healthnmon project
21:46:02 <yjiang5> dhellmann: our team is quite intrersting in host monitor, which is a bit overlap with healmon
21:46:12 <eglynn> yjiang5: cool
21:46:29 <eglynn> about the build-out completeness, IIRC their architecture included all manner of integration points with other monitoring frameworks
21:46:35 <eglynn> nagios, ganglia etc
21:46:37 <dhellmann> yjiang5: good, you and eglynn can take that together
21:46:43 <yjiang5> dhellmann: sure.
21:46:48 <dhellmann> eglynn: yeah, I remember a very complex diagram
21:46:55 <eglynn> wasn't clear though wether that was aspirational as yet ...
21:47:04 <dhellmann> #link http://wiki.openstack.org/CloudInventoryManager
21:47:54 <dhellmann> anything else on this?
21:48:13 <dhellmann> #topic Open discussion
21:48:40 <eglynn> yep, that's a big ol' diagram all right ;)
21:49:01 <dhellmann> I will update the wiki, but I wanted to mention that I'll be out for the next 2 meetings due to travel
21:49:19 <jd__> I heard about that
21:49:23 <dhellmann> and I'll be offline entirely from 12/8-12/19
21:49:28 <dhellmann> well, almost entirely
21:49:48 <eglynn> I may have a conflict next week as well
21:49:50 <jd__> Jenkins has submitted this change and it was merged.
21:49:51 <jd__> 
21:49:51 <jd__> Change subject: Add python-ceilometerclient
21:49:52 <jd__> FYI
21:50:07 <dhellmann> nice!
21:50:19 <jd__> https://github.com/openstack/python-ceilometerclient
21:51:13 <dhellmann> oh, I've been given permission to open source the DUDE, so after my break I'll start working on adding that to the client library as an example app
21:51:38 <jd__> great
21:52:01 <eglynn> cool
21:52:13 <dhellmann> ok, we're close to the end of our time slot. any other announcements or topics?
21:52:18 <eglynn> so the DUDE is the dreamhost billing engine, right?
21:52:32 <dhellmann> DUDE is the tool that exports data from ceilometer into our billing system
21:52:37 <dhellmann> Dreamhost Usage Data Exporter
21:52:55 <eglynn> a-ha, nice acronym ;)
21:53:10 * dhellmann was feeling inspired that day
21:53:50 <dhellmann> if there's nothing else, we can close up a couple of minutes early...
21:54:31 <dhellmann> ok, thanks everyone!
21:54:31 <eglynn> sounds good, 'night folks ...
21:54:57 <dhellmann> #endmeeting