15:00:02 <nijaba> #startmeeting Ceilometer
15:00:03 <openstack> Meeting started Thu Dec 27 15:00:02 2012 UTC.  The chair is nijaba. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:03 <nijaba> #meetingtopic Ceilometer
15:00:03 <nijaba> #chair nijaba
15:00:03 <nijaba> #link http://wiki.openstack.org/Meetings/MeteringAgenda
15:00:03 <nijaba> ATTENTION: please keep discussion focused on topic until we reach the open discussion topic
15:00:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:06 <openstack> The meeting name has been set to 'ceilometer'
15:00:08 <openstack> Current chairs: nijaba
15:00:12 <nijaba> Hello everyone! Show of hands, who is around for the ceilometer meeting?
15:00:12 <nijaba> o/
15:00:13 <dhellmann> o/
15:00:16 <llu-laptop> o/
15:00:17 <zehndton> 0/
15:00:33 <graflu0> o/
15:01:01 <nijaba> nice.  I see a few new nicks.  welcome
15:01:09 <nijaba> #topic actions from previous meeting
15:01:19 <nijaba> #topic nijaba to schedule v2 review for next meeting
15:01:19 <nijaba> #info Done, see meeting agenda
15:01:30 <nijaba> #topic nijaba to link API v2 proposal to appropriate bp
15:01:30 <nijaba> #info done, I added the link to the whiteboard of https://blueprints.launchpad.net/ceilometer/+spec/api-server-pecan-wsme
15:01:43 <nijaba> #topic jd__ write a wiki page on how to participate to the bug squashing day
15:01:43 <nijaba> #info done, see http://wiki.openstack.org/Ceilometer/Contributing and http://wiki.openstack.org/Ceilometer/BugSquashingDay/20130104
15:01:50 <nijaba> jd__: around?
15:02:31 <yjiang5> o/
15:02:38 <nijaba> I guess he'll come by later...
15:02:48 <nijaba> #topic nijaba to organize new vote next week for meeting on Jan 2nd
15:02:48 <nijaba> #info Done, see meeting agenda topic
15:02:58 <nijaba> #topic nijaba to approve synaps's bp
15:02:58 <nijaba> #info done see https://blueprints.launchpad.net/ceilometer/+spec/synaps-integration which is the overarching bp
15:03:23 <nijaba> #topic nijaba to organixe next thu as bp cleanup day
15:03:23 <nijaba> #info lots of cleanup done, but see subsequent topic about remainder
15:03:35 <nijaba> #topic nijaba to reschedule topic about healthmon for next week when lianhao is around
15:03:35 <nijaba> #info Done, see meeting agenda topic
15:03:46 <nijaba> #topic dhellmann experiment with passing arrays of parameters to wsme for queries
15:03:46 <nijaba> dhellmann, have you made it back yet?
15:04:03 <dhellmann> I've finally caught up with email, and have this task on my list for this week
15:04:25 <nijaba> should you reassign the task to yourself for next meeting?
15:04:52 <dhellmann> I did talk to Christophe about it, and he agrees that if it doesn't work the way I think, without the [], then it would be a good enhancement
15:05:06 <dhellmann> #action dhellmann experiment with passing arrays of parameters to WSME for queries
15:05:10 <nijaba> great
15:05:33 <nijaba> the few remaining actions are for jd__ whom does not seem to be around :(
15:05:56 <nijaba> #topic  jd__ announce the bug squashing day on the ml
15:06:09 <nijaba> I have not seen the announce, have you?
15:06:16 <llu-laptop> I've seen it
15:06:16 <nijaba> at least not on the ml
15:06:18 <dhellmann> I think I saw a blog post
15:06:31 <llu-laptop> I've seen it on the ml
15:06:40 <nijaba> ok, thanks #info done
15:06:46 <nijaba> #info done
15:06:49 <dhellmann> oh, yeah, it was on Dec 24
15:06:58 <nijaba> #topic jd__ megatweet about the bug squashing day every hour
15:06:58 <nijaba> #info Done, please RT :)
15:07:25 <nijaba> I believe this was done, right?
15:07:34 <nijaba> err
15:07:35 <dhellmann> #link https://lists.launchpad.net/openstack/msg19657.html
15:07:45 <nijaba> #topic jd__ rename api to api-v2 and api-v1 to api
15:07:45 <nijaba> I believe this was done, right?
15:07:49 <dhellmann> yes
15:08:00 <dhellmann> it's either done, or waiting for review, but I did see a changeset
15:08:07 <nijaba> #info done
15:08:10 <jd__> done
15:08:21 <nijaba> yeah, jd__ is here!!
15:08:32 <jd__> always :-)
15:08:41 <jd__> but not my IRC client :)
15:08:48 <nijaba> That's it for last week action, I think
15:09:08 <nijaba> topic Meeting on Jan 2nd?
15:09:08 <nijaba> So, the question remaining is will there be enough people to have a meeting on Jan 2nd.
15:09:21 <nijaba> asalkeld has already indicated that he should be available, what about others
15:09:28 <nijaba> #startvote on january 2nd at 21UTC, I plan to be? present, absent
15:09:29 <openstack> Begin voting on: on january 2nd at 21UTC, I plan to be? Valid vote options are present, absent.
15:09:30 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
15:09:36 <nijaba> #vote absent
15:09:40 <yjiang5> #vote absent
15:09:45 <llu-laptop> #vote absent
15:09:56 <dhellmann> #vote present
15:10:00 <zehndton> #vote absent
15:10:10 <graflu0> #vote absent
15:10:24 <nijaba> jd__: ?
15:11:20 <jd__> #vote present
15:11:31 <nijaba> #endvote
15:11:32 <openstack> Voted on "on january 2nd at 21UTC, I plan to be?" Results are
15:11:33 <openstack> absent (5): yjiang5, nijaba, llu-laptop, graflu0, zehndton
15:11:34 <openstack> present (2): jd__, dhellmann
15:12:00 <nijaba> so we'll have at least 3 core devs present I think it is enough to hold a meeting
15:12:04 <nijaba> who wants to chair?
15:12:15 <jd__> I can do that
15:12:36 <nijaba> #agree meeting on jan 2nd will be chaired by jd__
15:12:44 <nijaba> thanks jd__
15:12:53 <dhellmann> thanks, jd__
15:12:57 <nijaba> #topic Discuss heathmon/ceilometer duplication and differences http://wiki.openstack.org/Ceilometer/CeilometerAndHealthnmon
15:13:13 <nijaba> llu-laptop: the floor is yours
15:14:01 <nijaba> reading your wiki page, it seemed to me that it is a good candidate to integration via multi-publisher
15:14:05 <llu-laptop> the question is how we want to integrate the effort of healthnmon/ceilometer, depends on the data models are quite different
15:14:12 <nijaba> as theire data model is very different
15:14:46 <jd__> from what I understood, as nijaba said, this is a use case for multi-publisher
15:14:54 <nijaba> llu-laptop: consumer through multi-publisher would seem more appropriate indeed
15:15:25 <dhellmann> is the data being used in a way that we could eventually reproduce using our API?
15:15:26 <yjiang5> nijaba:  agree, but possible for pyhsical device, we will need implement in ceilometer side, right?
15:15:43 <llu-laptop> so this means we should put healthnmon's agent work(getting raw data) into ceilometer agent?
15:15:53 <dhellmann> yjiang5: for physical device, do you mean bare-metal servers or hypervisors?
15:15:58 <nijaba> llu-laptop: thatś what I would propose
15:16:08 <yjiang5> dhellmann: hypervisor side.
15:16:16 <dhellmann> yjiang5: ok
15:16:37 <llu-laptop> I think we should also consider the bare-metal servers
15:16:54 <dhellmann> integrating by moving data collection into the ceilometer agent and then having healthnmon receive the data through our publisher seems like a good first step
15:17:17 <nijaba> so the proposal would be: a) implemented missing meters in ceilometer, b) integrate healthmon through multi-publisher ?
15:17:24 <dhellmann> after that, I would like to explore options for eliminating the need for separate storage, too (it isn't clear whether that is realistic)
15:17:26 <yjiang5> I'm glad the multiple publisher patch will have 3rd  consumer :)
15:17:29 <jd__> nijaba: likely
15:17:39 <jd__> dhellmann: +1
15:17:42 <dhellmann> nijaba: agreed
15:17:48 <nijaba> does anyone disagree?
15:18:25 <nijaba> #agree healthmon integration: a) implemented missing meters in ceilometer, b) integrate healthmon through multi-publisher
15:18:25 <dhellmann> the alerting features seem to have some overlap with the requirements for Heat, so there may be room to combine efforts there, too, as a third phase
15:18:47 <nijaba> dhellmann: right
15:19:07 <nijaba> llu-laptop: do you mind reporting the result on your wiki page?
15:19:25 <llu-laptop> ok. I'll do it
15:19:37 <dhellmann> llu-laptop: would we need to add any information to what we currently publish to make the integration easier (or possible)?
15:19:57 <nijaba> #action llu-laptop to report agreement result to wiki page http://wiki.openstack.org/Ceilometer/CeilometerAndHealthnmon
15:20:09 <dhellmann> I mean metadata, not the meters we are not yet collecting
15:20:38 <nijaba> thanks llu-laptop, very nice analysis
15:20:44 <llu-laptop> dhellmann, sorry I didn't understand your questions. what kind of metadata are you talking about?
15:21:17 <dhellmann> llu-laptop: well, I'm not really sure :-) Something like a property of an instance or event that we ignore or just don't publish now.
15:21:49 <dhellmann> say we have an event that you're interested in, does it have all of the information about that event that you would need to populate your data model completely?
15:22:17 <dhellmann> I guess that level of analysis may take more time, though, and be part of doing (b)
15:22:19 <llu-laptop> Well, I think there is many libvirt information missing in ceilometer, compared to healthnmon,
15:23:19 <dhellmann> ok. we'll need to get a list of those items, eventually. maybe in the wiki page associated with the blueprint?
15:24:10 <yjiang5> nijaba: I think llu-laptop himself is not healthnmon developer, so should we discuss the conclusion with healthnmon team?
15:24:24 <nijaba> yjiang5: yes, we now need some bp created and to identify someone to implent the plan
15:24:38 <llu-laptop> ok, I'll do a full detailed analysis of what needs to be got from underlying hypervisor to feed the 'greedy' healthnmon data sink. Of course, the healthnmon team's help would be greate
15:24:46 <nijaba> yjiang5: possibly someone from healthmon
15:25:09 <nijaba> I would say that there is no point of doing this work without them...
15:25:31 <dhellmann> ah, I thought llu-laptop was on the healthnmon team. we definitely need them for full integration, but we could start on (a) without them, I think
15:26:03 <nijaba> I can take the action of reaching to them with the result...
15:26:13 <nijaba> and report what their plans are
15:26:23 <nijaba> unless someone else wants to do it
15:27:11 <nijaba> #action nijaba to get in touch with the healthmon team to see what their reaction is to our plan for integration
15:27:25 <nijaba> shall we move to the next topic?
15:27:31 <dhellmann> ep
15:27:32 <llu-laptop> one more thing, about the physical monitoring
15:27:37 <dhellmann> er, yep
15:27:52 <nijaba> llu-laptop: sure, go ahead
15:28:08 <llu-laptop> the healthnmon can only monitor the physical device where hypervisor runs, how about ohter physical device,
15:28:17 <llu-laptop> https://blueprints.launchpad.net/ceilometer/+spec/monitoring-physical-devices
15:28:38 <nijaba> I don see any reason why we could not monotor other nodes
15:29:11 <llu-laptop> Do we plan to have a unified way for the ceilometer agent to reporting such kind of data? or are we ok if we have duplications here
15:29:12 <dhellmann> I'm not sure.
15:29:48 <nijaba> the issue is how can it be linked to something that can be of use.
15:29:58 <dhellmann> monitoring that part of the infrastructure is already possible with so many other tools
15:30:06 <llu-laptop> physical server's data in healthnmon is got from underlying libvirt
15:30:13 <dhellmann> I think we should stay focused on monitoring the cloud itself
15:30:49 <dhellmann> we care about the hypervisor servers for that, because the data can be used by the scheduler eventually
15:30:50 <nijaba> dhellmann: agreed, but we could have nodes which are bare metal instances
15:31:01 <dhellmann> nijaba: bare-metal instances are a different story
15:31:13 <dhellmann> they are instances, and we should monitor them
15:31:16 <jd__> I'm aware of work on power comsuption for cloud based on monitoring power usage of bare-metal hosting servers FWIW
15:31:37 <dhellmann> but nova api nodes, or glance servers, seem like they are covered elsewhere
15:31:44 <jd__> I mean work based on Ceilometer infrastructure
15:31:44 <nijaba> jd__: outside of ceilometer, right?
15:32:00 <yjiang5> jd__: I think host power comsumption is helpful even in hypervisor situation.
15:32:09 <nijaba> jd__: ah, I have not seen any bp on the subject
15:32:12 <jd__> nijaba: providing Ceilometer pollster
15:32:34 <dhellmann> interesting
15:33:08 <jd__> it's still at an early stage (prototype) but it's something that's planned to be done since Ceilometer is has a good infra for that
15:33:33 <nijaba> neat.  we should invite those prototypers to join our meetings
15:33:34 <dhellmann> that's a good use case for making it easy to push data into ceilometer.
15:33:41 <dhellmann> +1
15:33:56 <jd__> nijaba: yes, I'm trying hard to bring them into OpenStack :)
15:34:07 <nijaba> hehe, good!
15:34:10 <jd__> it's working but it takes time :)
15:34:31 <nijaba> it does...
15:34:45 <nijaba> shall we move on
15:34:46 <nijaba> ?
15:34:52 <jd__> I think so
15:35:00 <nijaba> #topic API bv2 proposal review http://wiki.openstack.org/Ceilometer/blueprints/APIv2
15:35:14 <nijaba> dhellmann: have you had time to review this?
15:35:26 <dhellmann> I don't think I've looked at the most recent incarnation
15:35:32 <dhellmann> I did look at an early draft
15:35:32 <nijaba> I have linked it to your pecan-wsme bp
15:35:49 <dhellmann> I think the only concerns I had were with the variability of some of the output
15:36:29 <dhellmann> WSME really wants types to be statically defined for consistency, so making fields optional may make the returned data structure a bit ugly
15:36:50 <dhellmann> I like the general direction, though, and agree that we should move some of the path components to query parameters
15:37:17 <nijaba> dhellmann: should you work on improving the current proposal for next meeting
15:37:17 <jd__> yeah last time discussing with asalkeld the conclusion was we just need /meters, and query parameters
15:37:19 <nijaba> ?
15:37:19 <dhellmann> it will make using and documenting the API a good bit simpler
15:37:49 <dhellmann> nijaba: I think the action I had about experimenting with query parameters was related to this, too
15:37:58 <nijaba> sounds good
15:38:57 <nijaba> I'll reschedule the topic for jan 2nd meeting then
15:39:05 <jd__> sounds like a plan
15:39:10 <dhellmann> agreed
15:39:22 <nijaba> #action API v2 topic to be continued on jan 2nd
15:39:28 <nijaba> #action nijaba API v2 topic to be continued on jan 2nd
15:39:53 <nijaba> #topic blueprints cleanup
15:40:01 <nijaba> #info So I have spent most of the morning cleanup our bps.  You should have received notification if I changed a bp you are registered on.
15:40:01 <nijaba> Any questions about the changes I made?
15:40:46 <jd__> Not from what I received :)
15:41:00 <dhellmann> nope
15:41:08 <yjiang5> no
15:41:22 <nijaba> #info The following bp are still needing more definition and an assignee or will otherwise be retargeted for H.
15:41:22 <nijaba> #link https://blueprints.launchpad.net/ceilometer/+spec/move-listener-framework-oslo
15:41:22 <nijaba> #link https://blueprints.launchpad.net/ceilometer/+spec/meter-post-api
15:41:22 <nijaba> #link https://blueprints.launchpad.net/ceilometer/+spec/non-libvirt-hw
15:41:22 <nijaba> #link https://blueprints.launchpad.net/ceilometer/+spec/rpc-zeromq
15:41:23 <nijaba> #link https://blueprints.launchpad.net/ceilometer/+spec/api-aggregate-average
15:41:24 <nijaba> #link https://blueprints.launchpad.net/ceilometer/+spec/remove-disabled-pollsters-option
15:41:27 <nijaba> Any takers?  Feel free to email me, dhellmann or jd__ if you wish to be assigned to any of those
15:42:00 <jd__> I'll take the last one
15:42:21 <jd__> done.
15:42:37 <nijaba> jd__: thanks!
15:42:52 <dhellmann> I took the first one
15:42:55 <dhellmann> I thought I was already assigned there
15:43:04 <jd__> great
15:43:26 <yjiang5> Just notice that https://blueprints.launchpad.net/ceilometer/+spec/meter-post-api , will it be similar to CW's publish_metric_data?
15:43:59 <nijaba> yjiang5: good question.  I was hoping to get some light on this from asalkeld
15:44:02 <yjiang5> s/publish_metric_data/put_metric_data/
15:44:11 <nijaba> but I xould not reach him this morning
15:44:37 <yjiang5> nijaba: this is created by jd__,
15:44:51 <jd__> yjiang5: yes that's the idea
15:45:09 <llu-laptop> The new v2 api would have the aggregate-average? right?
15:45:27 <dhellmann> llu-laptop: if someone signs up to implement it :-)
15:45:32 <nijaba> llu-laptop: if someone implements it
15:45:38 <nijaba> dhellmann: hehe
15:45:40 <jd__> :)
15:45:56 <dhellmann> that was a bit scary
15:46:25 <llu-laptop> how does the synaps do that?
15:46:32 <nijaba> I think I may have someone at enovance that could eb interested in that one.  I'll chase him
15:47:07 <nijaba> #action nijaba to find out if EmilienM wishes to commit on https://blueprints.launchpad.net/ceilometer/+spec/api-aggregate-average
15:49:13 <nijaba> Should I send an email to the ml about the 3 remaining bp to see if we catch any commiters?
15:49:27 <jd__> it can't hurt
15:49:54 <nijaba> #action nijaba to send an email to openstack-dev listing the orphan bps
15:49:56 <dhellmann> I'll bet eglynn is interested in non-libvirt-hw.
15:50:10 <nijaba> maybe...
15:50:31 <nijaba> #info Here is the list of bp that are going to be in Grizzly 2, only 2 are not yet completed.  I hope they will be before the end of next week
15:50:31 <nijaba> #link https://launchpad.net/ceilometer/+milestone/grizzly-2
15:50:31 <nijaba> Any issues about those?
15:51:19 <nijaba> remember g2 milestone is Jan 10
15:51:44 <dhellmann> I'm not sure we'll have an official release of wsme by then to fix the bug on that list
15:52:14 <dhellmann> is that issue mitigated by the change to make the v1 api the default again?
15:52:24 <nijaba> dhellmann: yes, but I don think that would block the release.  we could reassign the bug to g3
15:52:34 <dhellmann> ok
15:53:02 <nijaba> reassigned to g3
15:53:23 <nijaba> jd__: I think the 2 remaining bp are in your hands, right?
15:53:40 <nijaba> jd__: confortable about them?
15:53:49 <jd__> nijaba: yep
15:53:56 <nijaba> cool
15:54:19 <nijaba> I think we are done with that topic then
15:54:20 <jd__> don't know if gpernot will fix meters' unit implementation by then, so I may jump in and take over if needed
15:54:33 <nijaba> jd__: please do
15:54:50 <nijaba> #topic Open discussion
15:54:53 <dhellmann> didn't I see something about that already? was it just the bug/blueprint, or wasn't there a changeset?
15:55:09 <nijaba> dhellmann: a partial changeset
15:55:15 <dhellmann> ah, ok
15:55:20 <dhellmann> I have 2 items to bring up
15:55:38 <dhellmann> first, it seems like we're seeing more interest in the sqlalchemy storage driver
15:55:49 <nijaba> dhellmann: https://review.openstack.org/18413
15:56:07 <dhellmann> how comfortable are we that it's feature-complete? some people seem to want to make mysql the default...
15:56:25 <dhellmann> IIRC, we've got some NotImplemented exceptions in a few places
15:56:34 <dhellmann> do we need to prioritize working on those?
15:56:38 <jd__> dhellmann: I think we're not comfortable because we don't have tests on the abstraction layer above IIRC
15:56:52 <nijaba> dhellmann: should we look for those and open bugs if they are not there already?
15:57:06 <dhellmann> nijaba: yes, I think so
15:57:20 <dhellmann> jd__: have you had any time to think about how to implement those?
15:57:21 <nijaba> jd__: good point.  We should have tests for that
15:57:39 <jd__> dhellmann: not at all, but I think it's something we should put on our priority list
15:57:47 <dhellmann> jd__: I agree
15:57:52 <nijaba> for g3 I would think, right?
15:57:59 <dhellmann> yes, I was just going to suggest g3
15:58:04 <jd__> makes sense to me
15:58:36 <nijaba> #action nijaba to add bp skeleton to remind ourselves to implement higher level tests for db backends
15:58:59 <dhellmann> there may already be a bug open, too
15:59:12 <dhellmann> ok, second item: we have a couple of "questions" open on launchpad
15:59:15 <nijaba> Iĺl look for it and reference it in the bp then
15:59:20 <dhellmann> #link https://answers.launchpad.net/ceilometer/+questions?field.sort=recently+updated+first&field.actions.search=Search&field.status=Open&field.search_text=
15:59:33 <dhellmann> is everyone else subscribed to see those when they come in?
15:59:48 <dhellmann> subscription isn't automatic, IIRC
16:00:04 <nijaba> dhellmann: hmmm,  I need to set a contact for this.  I guess it should point to the team, right?
16:00:15 <dhellmann> if you can do that, that's a good idea
16:00:28 <dhellmann> I subscribed myself individually
16:00:31 <nijaba> ceilometer-drivers?
16:00:48 <nijaba> and core-devs
16:01:03 <dhellmann> yeah, I think those make sense
16:01:09 <nijaba> done
16:01:18 <dhellmann> at least to ensure the questions get some attention
16:01:25 <nijaba> right!!!
16:01:33 <dhellmann> I'm not sure there are answers to the ones we have open now about installation dependencies
16:02:21 <nijaba> which should then be turned into bugs?
16:02:53 <dhellmann> well, the one about keystone client may be a bug somewhere, but it's hard to say
16:02:54 <dhellmann> I'll ask for more details about what versions of things they are running on one server
16:03:08 <dhellmann> the other one about how to install just the agent depends on the OS packagers, doesn't it?
16:03:25 <nijaba> it does
16:03:25 <dhellmann> we're not currently packaging the agent separately, but we have instructions for starting it separately
16:03:33 <nijaba> yep
16:03:34 <dhellmann> ok, I can answer that way then
16:03:39 <nijaba> thanks
16:03:58 <jd__> dhellmann: yeah the keystonclient version problem is typically some old version of glanceclient or the like that requires old keystoneclient version…
16:04:44 <dhellmann> jd__: ugh, yeah
16:04:54 * nijaba notes that we are now 4 min past meeting end time
16:05:40 <dhellmann> that's all I had
16:06:02 <nijaba> ok, great
16:06:15 <nijaba> thank you all for another great meeting!
16:06:32 <nijaba> #endmeeting