21:00:01 <nijaba> #startmeeting Ceilometer
21:00:02 <openstack> Meeting started Wed Jan 16 21:00:01 2013 UTC.  The chair is nijaba. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:02 <nijaba> #meetingtopic Ceilometer
21:00:02 <nijaba> #chair nijaba
21:00:02 <nijaba> #link http://wiki.openstack.org/Meetings/MeteringAgenda
21:00:02 <nijaba> ATTENTION: please keep discussion focused on topic until we reach the open discussion topic
21:00:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:05 <openstack> The meeting name has been set to 'ceilometer'
21:00:07 <openstack> Current chairs: nijaba
21:00:14 <nijaba> Hello everyone! Show of hands, who is around for the ceilometer meeting?
21:00:14 <nijaba> o/
21:00:20 <dhellmann> o/
21:00:22 <n0ano> o/
21:00:28 <egallen> o/
21:00:31 <eglynn_> o/
21:00:53 <nijaba> #topic actions from previous meeting
21:00:53 <danspraggins> o/
21:00:59 <danflorea> o/
21:01:04 <nijaba> #topic llu to get in touch with the healthmon team to see what their reaction is to our plan for integration, putting the ml in cc
21:01:14 <nijaba> That was done, we saw a few exchanges on the ml.  I don't think llu can join us at this time.
21:01:25 <nijaba> #topic nijaba to make the api-aggregate-average bp a dep for v2 api
21:01:29 <jd__> o/
21:01:33 <fnaval> o/
21:01:39 <nijaba> That was done as well.
21:01:53 <nijaba> #topic nijaba to prepare a blogpost announcing the release
21:02:04 <nijaba> That was published on monday
21:02:04 <nijaba> #link https://launchpad.net/ceilometer/+announcement/11069
21:02:16 <eglynn> yay!
21:02:42 <nijaba> We'll be talking a bit about the release shortly
21:02:51 <nijaba> #topic nijaba to start a thread on ml about unit policy
21:03:01 <nijaba> Thread was started yesterday. We'll talk about it a bit more in a minute.
21:03:14 <nijaba> That's it for last week action
21:03:22 <nijaba> #topic Units discussion
21:03:43 <nijaba> so, any progress on this?
21:04:15 <jd__> I think we all more or less agree on the same things
21:04:21 <eglynn> didn't we agree to go with specific units for counts at last week's meeting?
21:04:33 <jd__> we did
21:04:38 <dhellmann> I believe that's right
21:04:57 <nijaba> we did, but we still had not closed on the discussion
21:05:21 <nijaba> and I think we should write up the policy for future ref
21:05:41 <nijaba> any volumteer to start a wiki page?
21:06:37 <nijaba> I guess not.  So I'll take the action
21:06:45 <jd__> oh too many candidates, shall we vote?
21:06:50 <jd__> :-D
21:06:50 * eglynn confused on the all units should be integers|floats point
21:06:54 <Shengjie_home> wiki for all the meters' units ?
21:06:57 * dhellmann was distracted by the sound of crickets
21:07:12 <jd__> dhellmann: lamest excuse *ever*
21:07:14 <nijaba> #action nijaba to specify draft policy on wiki for units
21:07:25 <jd__> eglynn: what confuses you?
21:07:34 <eglynn> surely units are just labels without a intrinsic numeric value?
21:07:51 <jd__> I think nijaba meant volume
21:08:01 <eglynn> a-ha, I see
21:08:05 <eglynn> got it ...
21:08:10 <dhellmann> so we agree to count things using numbers? :-)
21:08:13 <nijaba> jd__: right
21:08:25 <nijaba> yeah!!!
21:08:25 <jd__> i.e. you can't have 'foobar' 'meters'
21:08:39 <dhellmann> sure
21:08:40 <eglynn> s/Units should always be [integer|floats]/the values associated with units should always be [integer|floats]/
21:08:42 <jd__> dhellmann: that's how far we went :)
21:09:04 <jd__> next week debate, should we use base 10 ?
21:09:10 <nijaba> lol
21:09:38 <nijaba> ok, let's move on then
21:09:48 <danflorea> Hi. I'm a new guy here. I can help with docs as I learn, so I'm happy to help. Just don't want to take a lead on things I know nothing about. But I can assist if guided..
21:09:51 <nijaba> #topic G3 blueprint review
21:09:59 <dhellmann> jd__: please wait until april 1 to propose the move to base 2
21:10:05 <dhellmann> hi, DanFlorea, welcome!
21:10:13 <nijaba> so we have 28 unimplemented bp with grizzly as a target
21:10:15 <eglynn> welcome+1
21:10:20 <danflorea> thanks!
21:10:20 <eglynn> slow progress on the synaps blueprints
21:10:34 <eglynn> I've been dragged off doing some glance work for the last week or so
21:10:35 <jd__> hi danflorea, welcome
21:10:48 <eglynn> but will be back on it from about Friday of this week
21:11:04 <nijaba> we should start cleaning this up as feb 21 sounds like a month away
21:11:35 <eglynn> nijaba: any response to your call for volunteers?
21:11:38 <nijaba> if you know of stuff you won't be able to complete in the next month, please let me know
21:11:43 <nijaba> eglynn: none
21:11:48 <dhellmann> nijaba: is there an easy way to get that list of blueprints out of launchpad?
21:11:59 <eglynn> danflorea: http://lists.openstack.org/pipermail/openstack-dev/2013-January/004398.html
21:12:16 <jd__> nijaba: I think https://blueprints.launchpad.net/ceilometer/+spec/provide-meter-units is done now?
21:12:16 <nijaba> dhellmann: #link https://blueprints.launchpad.net/ceilometer/grizzly
21:12:34 <eglynn> danflorea: something may catch your eye in the the above list of unassigned work
21:12:52 <danflorea> ok, great
21:13:33 <nijaba> jd__: updated
21:14:06 <nijaba> anything else that I should update?  any bp that I should push to H?
21:14:14 <dhellmann> https://blueprints.launchpad.net/ceilometer/+spec/config-driven-notification-monitoring can be closed entirely
21:14:20 <dhellmann> it is obsoleted by the multipublisher work
21:14:26 <dhellmann> which is covered better elsewhere
21:14:30 <dhellmann> I will close it
21:14:52 <dhellmann> oh, actually, I can't change its status
21:15:12 <nijaba> dhellmann: done
21:15:45 <nealph> nijaba: will you be updating that list as people sign up?
21:15:56 <nijaba> nealph: yes
21:16:14 <dhellmann> nijaba: I suspect we should remove rpc-zeromq as well
21:16:22 <dhellmann> is anyone actively working on non-libvirt-hw?
21:16:23 <Shengjie_home> jd__: if I am targeting G3, can I change the milestone for the bp myself
21:16:26 <nijaba> dhellmann: push to H?
21:16:37 <eglynn> +1 on remove zmq
21:16:39 <jd__> Shengjie_home: not sure, ask for someone to do it
21:16:41 <dhellmann> nijaba: let's leave it unassigned
21:16:54 <dhellmann> nijaba: I would rather have someone interested in zeromq step up to help
21:16:56 <nijaba> Shengjie_home: not if your are not a driver I am afraid.  ping me, or one of the core devs
21:17:19 <Shengjie_home> nijaba: k, i will take it offline
21:17:27 <jtran> dhellmann:  i might be interested in that one
21:17:27 <nijaba> dhellmann: done
21:17:38 <dhellmann> jtran: for grizzly or later?
21:17:44 <jtran> sure, why not :)
21:17:46 <jtran> grizzly
21:18:08 <nijaba> jtran: let me know
21:18:15 <jtran> i'll give you a more concrete answer in a couple days
21:18:20 <jtran> nijaba: will do!
21:18:20 <nijaba> np
21:18:33 <eglynn> non-libvirt-hw is more do-able now with with the inspector abstraction, but it should be split into per-hypervisor BPs I think
21:18:52 <nijaba> eglynn: it is already
21:19:12 <dhellmann> nijaba: rpc-qpid is much like rpc-zeromq
21:19:36 <nijaba> eglynn: I'll let you decide on that one
21:19:45 <nijaba> (qpid)
21:20:13 <eglynn> nijaba: I'll see if I hand it off to another red hatter
21:20:28 <nijaba> eglynn: I'll keep it as is for now then
21:20:37 <eglynn> k
21:20:46 <nijaba> anything else?
21:21:27 <nijaba> I geuss not.  let's move on
21:21:42 <nijaba> #topic Discuss downstream packaging efforts underway, identify potential problematic dependencies
21:21:52 <nijaba> eglynn: the floor is yours
21:22:21 <eglynn> k, so we cranking up to attack the fedora/epel/rhel aspects of packaging ceilometer
21:22:36 <nijaba> \o/
21:22:39 <eglynn> but I noticed that some prior work had been done on deb/ubuntu packaging
21:22:49 <nijaba> it has
21:22:56 <nijaba> zul and zigo
21:23:16 <eglynn> so I want at least to establish a conduit for sharing experience etc.
21:23:37 <dhellmann> +1
21:23:40 <eglynn> one big question is whether the deb work pre-dated the flask->pecan switch
21:23:52 <nijaba> both are pretty active on openstack in general, so they read the ml
21:23:56 <jd__> eglynn: yes and it has been updated since too
21:24:11 <eglynn> cool
21:24:20 <eglynn> the other thing two things I had in mind
21:24:32 <eglynn> 1. the ceilo client will need to be packaged also
21:24:50 <nijaba> I beleive we have a deb for it
21:24:52 <eglynn> 2. we have some 'bleeding edge' dependencies, e.g. WSME
21:25:10 <jd__> we have a .deb for python-ceilometerclient too
21:25:12 <eglynn> by bleeding edge I mean that we rely on some unrelease fixes on trunk
21:25:25 <eglynn> jd__: great
21:25:28 <nijaba> dhellmann: what's the status on this?
21:25:29 <jd__> yeah, that's a problem even for Debian, we don't have that yet
21:25:30 <dhellmann> eglynn: I'm on the hook to talk to Christophe about that already for our internal packaging at DH
21:25:54 <eglynn> dhellmann: so waht would be a good cut-off point for that release?
21:25:59 <dhellmann> I believe I owe him one doc patch, and then he and I need to figure out what to do about the auto-generated docs for the ceilometer api
21:26:10 <eglynn> I thing asalkeld has some recently proposed patches also
21:26:16 <eglynn> s/thing/think/
21:26:20 <dhellmann> eglynn: for wsme? I wasn't aware of that
21:26:42 <eglynn> dhellmann: at least I thought that's what he said
21:26:47 * eglynn may have misheard ...
21:26:51 <dhellmann> you might be thinking of pecan, which is in a similar situation
21:26:53 * nijaba surprised asakeld is not around
21:27:05 <dhellmann> although the pecan maintainer is my manager, so I can get a release done on fairly short order
21:27:07 <eglynn> dhellmann: a-ha, yes, you could be right
21:27:43 <dhellmann> we work with the current version of pecan, but we wanted an config option to completely turn off content-type guessing based on url extension
21:27:56 <eglynn> ok
21:27:56 <dhellmann> I have that on my todo list, too, but got a little wrapped up in internal stuff this week
21:28:06 <eglynn> so apart from pecan and WSME, are there any other lurking banana skins in the current set of dependencies?
21:28:36 <eglynn> (obviously a bunch of other wrinkles in the synaps stuff, but lets limit to trunk for now)
21:29:09 <nijaba> zul: around? anything worth noting?
21:29:14 <jd__> eglynn: I don't think so
21:29:19 <eglynn> was the webob 1.2.x thing the major transitive dependency version mismatch for example?
21:29:26 <eglynn> k
21:29:32 <jd__> eglynn: maybe stevedore if you don't have this as RPM yet
21:29:35 <dhellmann> yeah, that was the only cross-project dependency with an issue afaik
21:29:54 <eglynn> jd__: k, I'll check out the stevedore aspect
21:30:16 <eglynn> great, sounds like we're in (slightly) better shape than I thought :)
21:30:16 <jd__> eglynn: but it's a really trivial standard Python package so not a blocker
21:30:31 * eglynn ever the optimist ;)
21:30:34 <jd__> :-)
21:30:40 <dhellmann> oh, yeah, stevedore is unlikely to be an rpm yet
21:30:50 <dhellmann> let me know if you have any issues packaging that, eglynn
21:31:05 <eglynn> cool, will do
21:31:22 <eglynn> I'll reach out to zul & zigo too to pick their brains
21:32:07 <nijaba> anything else on packaging?
21:32:29 <eglynn> MING is just for testing, right?
21:32:39 <dhellmann> eglynn: yes
21:32:39 <eglynn> i.e. not a runtime dependency in any form?
21:32:41 <eglynn> cool
21:33:07 <nijaba> shall we move on to open discussion?
21:33:21 <eglynn> yep, thanks all for the info above ...
21:33:28 <nijaba> #topic Open discussion
21:33:41 <nijaba> topics, anyone?
21:34:23 <nijaba> huh, looks like we are going to finish this meeting early
21:34:33 <nijaba> that's unusual!
21:34:42 <jd__> but that's how we are
21:34:43 <Shengjie_home> nijaba: can u send us the link for units once you are done with that wiki
21:34:50 <Shengjie_home> thanks
21:34:50 <eglynn> quick, run before anyone thinks of anything ;)
21:34:53 <dhellmann> oh, here's one: we need folks to look over the v2 flattening changeset
21:34:57 <nijaba> Shengjie_home: sure
21:35:19 <dhellmann> #link https://review.openstack.org/#/c/19615/
21:35:41 <nijaba> that's a large one
21:35:58 <dhellmann> most of the changes are updating the tests to reflect the new urls
21:36:10 <dhellmann> but we did rearrange and squash a good bit of code in the v2.py file as well
21:36:15 <jd__> dhellmann: I'll re-look again tomorrow
21:36:22 <dhellmann> jd__: thanks
21:36:39 <dhellmann> I hesitate to +2 it myself because I worked with asalkeld on it
21:36:40 <eglynn> I'll try to fit in a review tmrw too
21:38:13 <nijaba> anything else?
21:38:19 * dhellmann shakes head
21:38:28 <eglynn> nowt from me
21:38:49 <nijaba> ok, nice and short!  Thanks everyone
21:38:58 <nijaba> #endmeeting