21:03:20 <nijaba> #startmeeting Ceilometer
21:03:20 <nijaba> #meetingtopic Ceilometer
21:03:20 <nijaba> #chair nijaba
21:03:20 <nijaba> #link http://wiki.openstack.org/Meetings/MeteringAgenda
21:03:20 <nijaba> ATTENTION: please keep discussion focused on topic until we reach the open discussion topic
21:03:21 <openstack> Meeting started Wed Mar 13 21:03:20 2013 UTC.  The chair is nijaba. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:03:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:03:24 <openstack> The meeting name has been set to 'ceilometer'
21:03:26 <openstack> Current chairs: nijaba
21:03:29 <nijaba> Hello everyone! Show of hands, who is around for the ceilometer meeting?
21:03:29 <nijaba> o/
21:03:32 <eglynn> o/
21:03:34 <llu-laptop> o/
21:03:36 <asalkeld> o/
21:03:45 <danspraggins> o/
21:03:48 <shanewang> o/
21:03:50 <Shengjie_home> o/
21:04:06 <nealph> o/
21:04:07 <nijaba> good to see everyone
21:04:10 <sew> o/
21:04:21 <nijaba> #topic actions from previous meeting
21:04:34 <nijaba> #topic nijaba to check room allocation for ceilometer during summit
21:04:43 <nijaba> I talked to ttx
21:05:06 <epende> o/
21:05:12 <nijaba> says there shoud be no worry but will be something for the next ptl to worry about, as they shoudl do it in a couple weeks
21:05:36 <asalkeld> ok
21:05:44 <eglynn> cool
21:05:49 <nijaba> #topic dhellmann investigate the process for releasing a client library
21:06:20 <nijaba> dhellmann is not around and apologized...
21:06:28 <nijaba> #action dhellmann investigate the process for releasing a client library
21:06:41 <nijaba> #topic dhellmann propose an ODS session for tempest integration
21:06:44 <eglynn> #link http://summit.openstack.org/cfp/details/87
21:06:54 <nijaba> eglynn: thanks
21:07:14 <nijaba> #topic dhellmann approach documentation team about a joint session at ODS
21:07:18 <eglynn> #link http://summit.openstack.org/cfp/details/104
21:07:26 <nijaba> #topic eglynn invite heat team to participate in doc and qa sessions at ODS
21:07:35 <eglynn> done, they're happy to
21:07:43 <nijaba> great!
21:07:59 <nijaba> #topic Organize a user doc sprint?
21:08:37 <nijaba> I am not sure who proposed this
21:08:38 <eglynn> when were we planning that for?
21:08:40 <nijaba> anyone?
21:08:47 <eglynn> pre-grizzly?
21:08:58 <asalkeld> better be quick
21:09:04 <eglynn> prolly make more sense after we've spoken to the docs team
21:09:05 <nijaba> yep
21:09:21 <eglynn> (i.e. after the joint session at summit)
21:09:30 <nijaba> +1
21:09:56 <llu-laptop> +1, though we should continue to improve our doc in the meantime
21:10:00 <nijaba> ok, moving on
21:10:06 <nijaba> #topic Check status on RC1
21:10:16 <nijaba> #link https://launchpad.net/ceilometer/+milestone/grizzly-rc1
21:10:44 <nijaba> all bp implemeted
21:10:47 <nijaba> great!
21:10:51 <Shengjie_home> bravo!
21:11:02 <asalkeld> is jd back from holiday?
21:11:06 <nijaba> there are some open bugs
21:11:10 <zehndton> good!
21:11:17 <asalkeld> do we need to take his bugs?
21:11:19 <nijaba> asalkeld: not yet, the 16th
21:11:40 <nijaba> asalkeld: or retarget if it is not blocking
21:12:12 <eglynn> yolanda opened a new bug earlier https://bugs.launchpad.net/ceilometer/+bug/1154596 ... might be a candidate for RC1
21:12:13 <uvirtbot> Launchpad bug 1154596 in ceilometer "Cpu meters stop after stopping/resuming an instance" [Undecided,New]
21:12:25 <eglynn> I'll triage it in the morning and target it appropriate
21:12:30 <nijaba> eglynn: looks like one, yes...
21:12:47 <llu-laptop> we're still waiting for new version of python-keystoneclient on pypi, https://bugs.launchpad.net/python-keystoneclient/+bug/1151665
21:12:51 <nijaba> any other bugs that should be retargeted?
21:12:57 <uvirtbot> Launchpad bug 1151665 in python-keystoneclient "Pypi python-keystoneclient(v0.2.2) not compatible with the latest oslo.config-1.1" [Critical,Confirmed]
21:13:30 <llu-laptop> current this is wordround to depend on python-keystoneclient master
21:14:17 <llu-laptop> though one of the keystone guys just said in the email that they would plan to release 0.3.0 in RC1 time window
21:14:17 <nijaba> llu-laptop: ok, can someone attend keystone meeting, or go talk on their chan?
21:15:21 <gordc> i don't think there is a keystone channel. a few keystone cores are in #openstack-dev  right now
21:15:42 <nijaba> gordc: thanks
21:16:06 <llu-laptop> what's the time of their meeting?
21:16:11 <nijaba> anything else gerading the next milestone?
21:16:20 <gordc> nijaba: i can ask about client release
21:16:50 <gordc> llu-laptop: keystone meetings are on tuesday
21:16:55 <nijaba> #link http://wiki.openstack.org/Meetings
21:17:09 <dolphm> following the discussions, i think it might be worthwhile to do a release of keystoneclient just for oslo, 0.2.3 or something
21:18:05 <llu-laptop> #link http://lists.openstack.org/pipermail/openstack-dev/2013-March/006616.html
21:18:19 <llu-laptop> i'm not sure if it's their commitment
21:19:18 <llu-laptop> 1800UTC, bad time for me :-(
21:19:50 <nijaba> dolphm: can you keep us informed of your final choice?
21:19:59 <dolphm> nijaba: sure
21:20:06 <nijaba> dolphm: thanks a lot
21:20:26 <shanewang> its better to have someone in the same time zone to follow up that.
21:21:05 <nijaba> what about bug #1060985?
21:21:07 <uvirtbot> Launchpad bug 1060985 in ceilometer "Notifications are lacking for the L3 API (router-interface add and remove)" [High,Confirmed] https://launchpad.net/bugs/1060985
21:21:32 <nijaba> High, confirmed, unasigned...
21:21:38 <asalkeld> is a quantum patch needed?
21:22:13 <nijaba> asalkeld: marked released
21:22:23 <asalkeld> ok
21:22:23 <eglynn> quantum already patched https://review.openstack.org/#/c/18961/
21:22:27 <eglynn> yep
21:22:57 <eglynn> so we need the corresponding fix on the ceilo side, right?
21:23:00 <llu-laptop> Should we add a new metric for this?
21:23:09 <eglynn> yeah sounds like it
21:23:10 <nijaba> eglynn: it seems
21:23:38 <eglynn> I can have a look at that tmrw also
21:23:52 <nijaba> eglynn: nice :)
21:24:15 <nijaba> anything else?  anyone?
21:24:26 <nijaba> or shall we move on?
21:24:45 <asalkeld> all good
21:24:46 <llu-laptop> ok to move on for me
21:24:47 <eglynn> yep, lets move on
21:24:58 <nijaba> #topic open discussion
21:25:48 <nijaba> topics, anyone?
21:26:30 <Shengjie_home> summit dinner? what day is that?
21:26:46 <eglynn> we just agreed not Sundat night
21:26:57 <eglynn> other than that it's still open IIRC
21:27:07 <eglynn> depends on the party schedule :)
21:27:18 <asalkeld> ha
21:27:31 <nijaba> board diner on sunday night, I'll try to bail out early ;)
21:27:44 <asalkeld> bored diner?
21:27:46 <Shengjie_home> 14th April
21:27:48 <asalkeld> ;)
21:28:02 <eglynn> any particular day suits folks? ... might be good the evening of the ceilometer track day
21:28:10 <nijaba> asalkeld: not so, but always more fun with you guys :)
21:28:24 <asalkeld> good idea eglynn
21:28:24 <Shengjie_home> shoot, goona miss it, arrive at sunday nite
21:28:32 <asalkeld> or before
21:28:59 <eglynn> Shengjie_home: me too, and dhellmann also, so we agreed not to do it on the Sunday night if poss
21:29:15 <Shengjie_home> eglynn: that'd be great
21:29:15 <nijaba> eglynn: so that's great for me too!
21:29:34 <eglynn> asalkeld: yeah, the night before could work too
21:30:11 <asalkeld> lets wait for  the schedule first?
21:30:19 <nijaba> asalkeld: +1
21:30:21 <eglynn> senisble
21:30:22 <Shengjie_home> agree.
21:31:24 <nijaba> anything else?
21:31:36 <eglynn> not hustling for votes but ... the PTL election closes midnight PST tmrw, so don't forget to vote if you haven't already
21:31:43 <eglynn> a good vote turn-out => a healthy project
21:32:00 <maksimov_> who gets to vote? core?
21:32:11 * maksimov_ says hi
21:32:11 <eglynn> all contributors
21:32:17 <nealph> eglynn:thanks for the reminder...will pop out there.
21:32:23 <nijaba> maksimov_: active contributors in the past year
21:33:00 <maksimov_> does a person with one commit count as active contributor? :)
21:33:06 <eglynn> yep
21:33:06 <Shengjie_home> eglynn: do you have the link off your hand
21:33:22 <nijaba> maksimov_: yes, but you may be short on delay, I do not know the cuttoff date
21:33:26 <eglynn> Shengjie_home: you would have been mail a personalized link
21:33:54 <maksimov_> nijaba: i'll have to check so
21:34:11 <eglynn> subject line ... Poll: Spring 2013 Ceilometer PTL Election
21:34:12 <Shengjie_home> eglynn: i think I got that now
21:34:45 <ttx> nijaba: will start discussion on summit track allocation Friday fwiw
21:35:07 <nijaba> ttx: ok, so right after the election result.  thanks
21:35:30 <nealph> nijaba: if we've not consolidated summit topics by then will we consider rolling multiple into one session?
21:35:33 <ttx> nijaba: but you will have less slots than you already have proposed sessions
21:35:40 <maksimov_> eglynn: so if there's no email it means i missed the cutoff?
21:35:49 <ttx> so merging a bit will be necessary methinks
21:35:50 <eglynn> maksimov_: sadly, yes
21:35:59 <maksimov_> eglynn: ok, so i guess i missed it :)
21:36:05 * ttx checks proposed plan
21:36:31 <nealph> nijaba:ttx: sort of a forced merge?
21:36:47 <nijaba> nealph: yep, based on discussions
21:36:48 <ttx> My plan is to give ceilo 11 slots
21:36:53 <eglynn> maksimov_: are you a foundation member?
21:36:57 <nijaba> ttx: not bad
21:37:06 <maksimov_> eglynn: i think i am
21:37:08 <ttx> nijaba: that's if all the others agree to give you room
21:37:19 <eglynn> maksimov_: membership was required to vote this time as well as a code contrib
21:37:28 <eglynn> maksimov_: details here in any case ... http://lists.openstack.org/pipermail/openstack-dev/2013-March/006165.html
21:37:34 <maksimov_> eglynn: i think i only merged last week, if memory serves
21:37:36 <nijaba> ttx: ah...
21:37:39 <ttx> nijaba: we'll see how that flies
21:37:50 <nijaba> ttx: ok, thanks
21:38:20 <eglynn> how many sessions do we have currently, 15/16 or so?
21:38:35 <llu-laptop> i just counted to 17
21:38:40 <asalkeld> yiks
21:38:50 <nijaba> eglynn: and expect more before cuttoff
21:38:53 <eglynn> indeed
21:39:01 <asalkeld> cm devs are chatty;)
21:39:15 <nijaba> cm is popuplar :)
21:39:36 <eglynn> dhellmann cunningly assigned the tempest and docco sessions to the QA and Docs tracks ;)
21:40:02 <shanewang> when can we know the sessions submitted are selected for summit?
21:40:05 <nijaba> dhellmann was smart!
21:40:15 <nijaba> shanewang: the week before
21:41:00 <nijaba> for summit, not conference, right?
21:42:03 <nijaba> anything else?
21:42:18 <asalkeld> all good
21:42:30 <eglynn> nowt from me
21:42:31 <llu-laptop> nothing more
21:42:49 <shanewang> nothing
21:43:19 <nijaba> llu-laptop: can you go to openstack-dev  about the client?
21:43:29 <llu-laptop> now?
21:43:32 <nijaba> thanks everyone
21:43:45 <Shengjie_home> cheers
21:43:49 <nijaba> llu-laptop: yup, dolphm asking a few q
21:44:06 <nijaba> #endmeeting