15:00:52 <jd__> #startmeeting ceilometer
15:00:53 <openstack> Meeting started Thu Jul 11 15:00:52 2013 UTC. The chair is jd__. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:54 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:56 <openstack> The meeting name has been set to 'ceilometer'
15:01:18 <dragondm> o/
15:01:19 <terriyu> o/
15:01:21 <apmelton> o/
15:01:25 <jd__> hi there
15:01:25 <eglynn> o/
15:01:29 <llu-laptop> o/
15:01:32 <danspraggins> o/
15:01:55 <dhellmann_> o/
15:02:08 <gordc> o/
15:02:12 <xingzhou> o/
15:02:29 <thomasem> o/
15:03:03 <nealph> o/
15:03:09 <DanD> o/
15:03:10 <jd__> #topic action from previous meeting: jd__ Write a terminology page in the documentation
15:03:29 <jd__> I discovered we had a glossary already, so I've updated it
15:03:35 <jd__> new version is online at http://docs.openstack.org/developer/ceilometer/glossary.html
15:04:06 <thomasem> awesome
15:04:09 <nealph> that's a good lesson to all...don't underestimate the power of the search. :)
15:04:16 <jd__> hehe
15:04:27 <jd__> that's all for this
15:04:32 <jd__> #topic Deprecate the "counter" term?
15:04:47 <jd__> IIRC I'm the one who wrote that while working on the glossary
15:05:03 <jd__> we use the counter term in a few place, especially in the source code, but it doesn't match anything really
15:05:16 <jd__> we build Counter and store them as Samples… in a Meter table
15:05:30 <jd__> so my idea would be step #1 let's drop this term from our source
15:05:41 <dhellmann> replace with sample?
15:05:45 <jd__> dhellmann: yes
15:05:49 <eglynn> yeah counter and sample are just too close in meaning
15:05:52 <dhellmann> wfm
15:05:53 <eglynn> (currently)
15:05:57 <eglynn> so +1 on that
15:05:59 <gordc> "we build Counter and store them as Samples… in a Meter table" seems easy enough to understand :)
15:06:23 <dhellmann> we'll have to figure out how to rename a collection in mongo, but that shouldn't be too much trouble
15:06:26 * jd__ gags gordc
15:06:57 <xingzhou> emm, can keep consistent with code if use sample
15:06:58 <jd__> dhellmann: eventually, I think we should start by targetting ceilometer.counter.* as a good first step
15:07:00 <eglynn> dhellmann: mongo equivalent of a sqlalchemy-migrate migration script
15:07:01 <eglynn> ?
15:07:03 <jd__> the API has some problem wrt this too
15:07:36 <dhellmann> eglynn: yes, I just meant we need to work out how to actually make the change in mongo, but that can come after we have our code changed as jd__ points out
15:07:50 <dhellmann> I thought asalkeld got rid of counter in the v2 api?
15:08:19 <llu-laptop> I only saw get_samples in v2 api
15:08:40 <nicolae_> quit
15:08:41 <eglynn> dhellmann: k, if it's considered likely to be a tractable problem to manage the migration
15:08:51 <gordc> dhellmann, i think when you query, it's still 'counter_name'...
15:08:56 <jd__> dhellmann: you hoped so, but the fields are still named counter_name in the samples returned by /meters
15:09:02 * jd__ puked
15:09:04 <jd__> :->
15:09:16 <nealph> gordc: concur.
15:09:29 <jd__> but well we can't break the API (for now) so let's go step by step on this
15:09:55 <dhellmann> ah, because we deliver data right from the schema
15:09:58 <dhellmann> oh well
15:10:16 <dhellmann> yeah, let's clean up the code now and the schema and api during icehouse
15:10:44 <eglynn> sensible
15:10:54 <gordc> dhellmann, +1
15:10:56 <jd__> +1
15:10:58 <llu-laptop> dhellmann, +1\
15:11:20 <jd__> #agreed let's clean the code now removing counter when we can and clean the API during icehouse
15:11:30 <jd__> #topic Review Havana-2 milestone
15:11:38 <jd__> #link https://launchpad.net/ceilometer/+milestone/havana-2
15:11:39 <eglynn> I was hoping to get patches proposed for alarm-service-partitioner tomorrow
15:11:47 <eglynn> but burned far too much time sheparding unit-transformer patches
15:11:54 <eglynn> a likely h2 miss at this stage :(
15:11:58 <eglynn> apologies!
15:12:02 <eglynn> but should land soon after ...
15:12:03 <dhellmann> we lost a lot of time this week to the oslo.config installation issue
15:12:33 <jd__> that and we really miss reviews I think
15:12:47 <jd__> but life is life.
15:13:00 <eglynn> declare tomorrow a review day?
15:13:06 <dhellmann> yes, I'm going to spend as much time today as I can on reviews, too
15:13:14 <dhellmann> I need to rebase my changes, apparently :-)
15:13:24 <jd__> eglynn: as you wish. every day is a review day for me for a few months now…
15:14:02 <jd__> I'm pretty sure we can fit most of the bp in h2 but we have to just focus on this these next days
15:14:39 <gordc> are we setting a cutoff date for h2 items?
15:14:44 <jd__> dhellmann: maybe https://bugs.launchpad.net/ceilometer/+bug/1178845 should be moved to h3 OTOH?
15:14:47 <uvirtbot> Launchpad bug 1178845 in ceilometer "API server should not create a new database handle on each request" [Medium,Confirmed]
15:15:38 * dhellmann looks
15:16:00 <jd__> dhellmann: also, remove yourself from assignee maybe if you don't think you'll handle it soon
15:16:45 <dhellmann> yes, let's move that
15:16:52 <dhellmann> moved
15:16:55 <dhellmann> and unassigned
15:17:28 <jd__> ack
15:18:07 <jd__> I'll move https://blueprints.launchpad.net/ceilometer/+spec/monitoring-physical-devices to h3 too
15:18:44 <jd__> and probably others low priority items soon
15:19:02 <gordc> jd__, +1 that is going to be beast to review by h2.
15:19:25 <jd__> #topic Tempest tests
15:19:39 <jd__> #vote yes
15:19:45 <jd__> :-)
15:19:45 <sileht> #vote yes
15:19:49 <dhellmann> heh
15:19:59 <dhellmann> so, tempest tests came up in the -infra room the other day
15:20:00 <eglynn> +1
15:20:11 <dhellmann> I forget who was asking, but they wanted to know if we were going to add them :-)
15:20:25 <llu-laptop> +1
15:20:25 <dhellmann> sdague suggested wrapping the other existing tests
15:20:38 <dhellmann> and mordred suggested using a specific feature of testtools to do that
15:20:40 * dhellmann looks for link
15:20:55 <mordred> matchers
15:21:16 <jd__> I think what we really need is a volunteer to do the job at this point
15:21:17 <mordred> https://testtools.readthedocs.org/en/latest/for-test-authors.html#matchers
15:21:28 <dhellmann> #link https://testtools.readthedocs.org/en/latest/for-test-authors.html?highlight=Matchers#matchers
15:21:37 <dhellmann> bah, mordred beat me to it :-)
15:21:39 <mordred> :)
15:21:48 <jd__> and to at least start so followers can program by imitation
15:22:09 * dhellmann is already overcommitted for this release
15:23:06 <nealph> is there a bug/feature submitted for this yet?
15:23:56 <jd__> nealph: only good intentions and https://blueprints.launchpad.net/ceilometer/+spec/more-qa-test
15:24:17 * nealph should take his own advice about searching
15:24:28 <jd__> which is partially done since we're in the devstack-gate now
15:24:45 <dhellmann> jd__: sorry to backtrack, but I'd like to move the low priority bp pipeline-configuration-cleanup to h3, if that's ok
15:24:56 <jd__> dhellmann: sure
15:25:10 <jd__> ultimately we should open a bp on https://blueprints.launchpad.net/tempest I guess
15:25:11 <dhellmann> moved
15:25:45 <jd__> dhellmann: if you don't have time to tackle your stuff, ping me at some point I'll try to jump in
15:26:02 <dhellmann> jd__: I expect to get some more time between h2 and h3, but thanks
15:26:17 <jd__> dhellmann: we all hope so ;)
15:26:41 <jd__> any volunteer to lead the Tempest effort?
15:26:54 <nealph> jd_: I'll look at that a little closer and see what I can do. No promises at this point. :-)
15:27:53 <jd__> nealph: do you want to store an #action or something so we can track this during the next meetings?
15:28:33 <nealph> that'll keep me honest...sure.
15:29:09 <nealph> #action nealph to follow up on tempest qa efforts
15:29:42 <jd__> good! thanks nealph!
15:29:59 <jd__> hashtag-way-to-go
15:30:17 <jd__> #topic Release python-ceilometerclient?
15:30:31 <jd__> do we need that?
15:30:38 <eglynn> is there anything we need?
15:30:47 <jd__> not from my PoV
15:30:57 <eglynn> lets wait for https://review.openstack.org/#/c/35728/ to land so
15:31:14 <jd__> fair enough
15:31:40 <jd__> #topic Open discussion
15:32:10 <litong> @jd__, since this open discussion. I would like to bring the File Publisher comments here.
15:32:43 <litong> I used RotatingFileHandler to make sure that the file won't grow so big and out of control.
15:33:02 <litong> that was the reason to have it using rotatingFile vs, plain log file.
15:33:23 <jd__> litong: there's bigger problem in your code AFAIU at this point
15:33:35 <litong> like what?
15:33:57 <jd__> litong: like the inability to have different files for different pipelines (if I understood correctly)
15:34:14 <jd__> litong: about rotating, I'm happy to have a rotating file, but I want the possibility to not have one too
15:34:45 <litong> hmmm. making even that configurable?
15:35:01 <litong> the different pipeline use, for that one, need to get different logger.
15:35:09 <jd__> litong: yeah, my point, with it used by default with max_size and backup set to None
15:35:22 <jd__> litong: indeed
15:35:52 <litong> @jd__, oh, ok, so if no setting for these two, then use plain log.
15:35:52 <jd__> I wrote all that in the review a few minutes earlier if you didn't see :)
15:35:58 <jd__> litong: yes :)
15:35:58 <litong> ok. that will be fine.
15:36:12 <boris-42> Hi guys=)
15:36:30 <eglynn> hey boris-42
15:36:35 <litong> any other stuff want to be in this one?
15:37:28 <litong> @jd__, the IIUC comment, I do not think I follow what you were saying.
15:37:55 <litong> file:///tmp/foobar that should be the string in the pipeline .
15:38:11 <boris-42> oh it is opendisucssion
15:38:12 <boris-42> =)
15:38:14 <jd__> litong: if you use multiple pipeline with different file:/// your code will only use one file:///
15:38:31 <jd__> boris-42: do you want to flood us? :)
15:38:48 <boris-42> ahaha=)
15:38:54 <litong> so that was the comment for multiple pipeline uses?
15:38:55 <boris-42> I could give some feedbac
15:38:59 <jd__> litong: yes
15:39:05 <litong> the solution is to get a logger for each pipeline.
15:39:29 <boris-42> jd__ are you interested?)
15:39:31 <litong> well each instances of the publisher I assume.
15:39:50 <jd__> litong: yeah, but I think you can instanciate logger and keep them locally in the class, you are not forced to use the system loggers globally registered
15:40:02 <jd__> boris-42: always, feedback on what?
15:40:26 <litong> @jd__, right. ok. thanks for clarifing it.
15:40:29 <boris-42> jd__ we have started work around test scenarios and doing first step around migration to sqlalchemy alembic
15:40:40 <litong> thanks for reviewing it.
15:41:15 <boris-42> jd_ here is one patch about test scenarios https://review.openstack.org/#/c/36237/
15:41:51 <boris-42> jd__ and we started to sync db Models to schema that is created by Migrations
15:42:11 <boris-42> jd__ then we will fix some bugs in current schema
15:42:36 <jd__> sounds like a good plan :)
15:42:45 <jd__> I'll try to review this today
15:42:47 <boris-42> jd__ And I think that best solution for switching to alembic will be replace part by part of migrations
15:42:56 <boris-42> old migrations
15:43:01 <boris-42> so replace in place
15:43:11 <boris-42> instead of creating some new and then switching
15:43:18 <boris-42> new queue
15:43:29 <boris-42> jd__ what do you think about it ^
15:44:20 <jd__> if we can do this step by step that works for me I guess
15:45:17 <boris-42> jd__ we are investigating this question
15:45:24 <jd__> ok cool
15:45:28 <boris-42> jd__ so we are searching for the best solution to do it step by step
15:45:49 <boris-42> jd__ because it will be impossible in one step to replace all migrations for example in nova=)
15:45:58 <jd__> indeed
15:46:06 <boris-42> jd__ so we have to find the right way to do it step by step=)
15:46:39 <boris-42> jd__ also we would like to implement some new features
15:46:58 <boris-42> jd__ to use Agent not only on compute_node but also inside the VMs
15:47:19 <boris-42> jd__ but I couldn't give you a some drafts of plan because we are still investigating this thing
15:47:39 <boris-42> jd__ are you interested in such things, just theoretically?)
15:48:29 <jd__> boris-42: probably
15:48:55 <jd__> we have a mechanism so user can publish their own samples via the API
15:48:56 <boris-42> jd__ ok then we will work around paper to have something for discussion
15:49:08 <jd__> boris-42: ack, feel free to build a blueprint or enhance an existing one
15:49:16 <boris-42> jd__ thanks
15:49:20 <gordc> quick note: we got multiple patches for updating keystoneclient version requirements, can we agree on one? https://review.openstack.org/#/c/36396/ and https://review.openstack.org/#/c/36561/
15:49:22 <jd__> then you can bring such things on the meeting's agenda
15:49:58 <jd__> gordc: too late I think https://review.openstack.org/#/c/36396/ won
15:50:23 <gordc> jd__, darn, saved that msg too long.lol
15:50:32 <gordc> nm, carry on.
15:50:38 <jd__> dhellmann: also https://review.openstack.org/#/c/36465/ should be approved quickly I guess if you've a minute
15:50:43 <jd__> gordc: haha
15:51:21 <gordc> +1, 36465 patch works for me.
15:51:30 <dhellmann> approved
15:51:34 <jd__> thanks dhellmann
15:51:41 <gordc> yay
15:51:49 <jd__> wrapping up in a minute now if there's nothing left
15:52:06 <terriyu> oh, I'm the intern that's hanging around, in case anyone is wondering
15:52:16 <terriyu> let me know if I screw anything up
15:52:17 <eglynn> terriyu: hi!
15:52:24 <jd__> terriyu: :)
15:52:47 <terriyu> jd__ is my mentor. I think my official internship runs through September 23
15:52:49 <dhellmann> hi, terriyu
15:53:17 <terriyu> It's been fun so far and I look forward to working with all of you
15:53:19 <nealph> welcome, terriyu!
15:54:26 <terriyu> I studied physics for a long time, so part of my interest in OpenStack is how it can be used for science
15:54:57 <terriyu> ping me if you'd like to talk about that :)
15:55:06 <terriyu> or anything else :)
15:55:27 <llu-laptop> terriyu: welcome
15:55:42 <eglynn> terriyu: if you can see any specific opportunities to apply your analytical background to ceilo, that would be welcome!
15:59:26 <jd__> time to wrap up guys
15:59:31 <jd__> see you on -metering!
15:59:32 <jd__> #endmeeting