15:00:21 <jd__> #startmeeting ceilometer
15:00:22 <openstack> Meeting started Thu Nov 28 15:00:21 2013 UTC and is due to finish in 60 minutes. The chair is jd__. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:25 <openstack> The meeting name has been set to 'ceilometer'
15:00:29 <eglynn> o/
15:00:36 <ildikov> o/
15:00:40 <gordc> o/
15:00:45 <jd__> happy turkey day
15:00:49 <llu-laptop> o/
15:01:02 * eglynn prefers goose ;)
15:01:13 <dhellmann> o/
15:01:15 <ildikov> :)
15:01:18 <nprivalova> o/
15:01:41 <ildikov> duck for me ;)
15:02:14 <jd__> #topic icehouse-1 status
15:02:25 <jd__> #link https://launchpad.net/ceilometer/+milestone/icehouse-1
15:02:41 <jd__> so we're still rather right on track
15:02:56 <jd__> except for one low prio blueprint that I am not sure I know what it is about
15:03:15 <jd__> just need to review llu work
15:03:38 <jd__> for people not aware, Icehouse-1 release is in one week
15:03:42 <llu-laptop> good to hear that :)
15:03:45 <eglynn> so perhaps bump https://blueprints.launchpad.net/ceilometer/+spec/zabbix-agent-adoption to i-2?
15:04:22 <jd__> eglynn: yes, just did :)
15:04:35 <eglynn> cool :)
15:04:43 <jd__> I'll try to send patches on counter renaming, if any, soon
15:04:52 <jd__> but it's not a big deal if it slips to i2
15:05:08 <jd__> #topic progress on writing up blueprints for icehouse
15:05:44 <jd__> has everybody written everything?
15:05:49 <eglynn> #link https://blueprints.launchpad.net/ceilometer/icehouse
15:06:03 <jd__> #link https://blueprints.launchpad.net/ceilometer/icehouse
15:06:06 <jd__> arf :-)
15:06:35 <eglynn> nadya_: this one should be targeted also? https://blueprints.launchpad.net/ceilometer/+spec/aggregation-and-rolling-up
15:06:55 <eglynn> (or too premature as yet?)
15:06:59 <jd__> eglynn: I'll set the status to "Not started", is that ok for you?
15:07:12 <nadya_> eglynn, I think yes. We may try to start it at least
15:07:15 <llu-laptop> jd__: can you target https://blueprints.launchpad.net/ceilometer/+spec/monitoring-physical-devices to icehouse-2 ?
15:07:19 <eglynn> jd__: yep
15:07:30 <jd__> llu-laptop: sure, done
15:07:45 <llu-laptop> jd__: thx
15:08:30 <jd__> I'll set priorities on the ones without after the meeting
15:08:36 <jd__> anything else gentlemen?
15:09:24 <jd__> #topic Telemetry: rename?
15:09:38 <jd__> so the Ceilometer project has now an official name, being "OpenStack Telemetry"
15:10:00 <eglynn> cool, that governance patch landed?
15:10:05 <jd__> (thanks to our Official Namer of Things)
15:10:08 <jd__> eglynn: it did
15:10:10 <eglynn> :)
15:10:13 <dhellmann> #link https://git.openstack.org/cgit/openstack/governance/commit/?id=d66f47d89616d2832af3ead686d1469fcdcd3236
15:10:29 <nadya_> I saw official email about it :)
15:10:34 <jd__> I've updated the Launchpad page
15:10:46 <ildikov> I saw the mail too today :)
15:10:47 <jd__> the question is: should we rename everything, including this channel?
15:11:03 <llu-laptop> do we have some official answer template when being asked why naming Telemetry? :)
15:11:10 <jd__> not this channel, but Ceilometer's one, sorry :)
15:11:27 <jd__> llu-laptop: "because why not?"
15:11:41 <ildikov> jd__ probably for longer term it would worth it to rename
15:11:48 <jd__> llu-laptop: "ask the Irish guy"?
15:12:02 <dhellmann> I think we should probably rename wiki pages and the irc channel
15:12:03 <gordc> jd__: so we keep metering channel active with topic saying to go to openstack-telemetry?
15:12:05 <jd__> I tend to agree for a rename of things too
15:12:14 <jd__> gordc: something like that
15:12:16 <eglynn> llu-laptop: because it was the only name we could think of that didn't seem to exclude a big chunk of our expanded project mandate
15:12:20 <gordc> works for me
15:12:28 <dhellmann> the other teams use their code name for their irc channel, so maybe instead of openstack-telemetry that should be openstack-ceilometer?
15:12:35 <jd__> llu-laptop: you see, "ask the Irish guy" was the right one :)
15:12:41 <eglynn> LOL :)
15:12:53 <llu-laptop> jd__, eglynn: :)
15:12:58 <gordc> dhellmann: i'm good with that too.
15:13:05 <llu-laptop> dhellmann: agreed
15:13:08 <jd__> dhellmann: agreed
15:13:28 <ildikov> dhellmann: agreed
15:13:42 <llu-laptop> should we rename https://wiki.openstack.org/wiki/Meetings/MeteringAgenda?
15:13:48 <jd__> #action jd__ rename #openstack-metering to #openstack-ceilometer
15:13:55 <dhellmann> llu-laptop: yes
15:14:09 <dhellmann> s/MeteringAgenda/Telemetry/
15:14:10 <eglynn> +1 for the IRC rename, better to follow the general patterm
15:15:00 <jd__> cool, cool
15:15:12 <jd__> a lot of grunt work :-)
15:15:50 <jd__> feel free to change or notify me if you encounter any occurence that needs to be changed
15:15:56 <jd__> #topic Release python-ceilometerclient?
15:16:09 <eglynn> already did earlier today
15:16:17 <eglynn> here's the tag desc: http://fpaste.org/57485/38564721/raw/
15:16:18 <jd__> yay thanks
15:16:27 <jd__> #topic Open discussion
15:16:39 <eglynn> WRT to i-1 targeted bugs
15:16:47 <eglynn> just to re-iterate the old mantra about backporting to stable
15:16:53 * eglynn is like a broken record ...
15:16:59 <eglynn> you know the blast radius of your own bug fix the best
15:17:14 <eglynn> so please take a moment after it lands on master to consider whether a suitable backport candidate
15:17:28 <eglynn> #link https://wiki.openstack.org/wiki/StableBranch#Appropriate_Fixes
15:17:34 <eglynn> critera there ^^^
15:17:49 <eglynn> and if so, tag the bug with 'havana-backport-potential' in LP
15:18:01 <eglynn> or even better, cherry-pick and propose the backport yourself ;)
15:18:15 <eglynn> BTW experience suggests the density of backport-suitable patches is highest *early* in the dev cycle
15:18:18 <eglynn> i.e. now-ish
15:18:25 <eglynn> (for obvious reasons ...)
15:18:45 <eglynn> BTW here's what we've got so far for 1st stable/havana cut ... https://launchpad.net/ceilometer/+milestone/2013.2.1
15:19:03 * eglynn puts away his soap-box ;)
15:19:45 <gordc> i'd recommend this as well: https://review.openstack.org/#/c/52638/
15:19:53 <gordc> kind of just sitting there.
15:19:56 <jd__> :)
15:20:02 <nadya_> guys, let's discuss https://review.openstack.org/#/c/57883
15:20:13 <eglynn> gordc: that's testing only, right?
15:20:26 <eglynn> gordc: (so not directly user-visible ...)
15:20:40 <gordc> eglynn: yeah... is that not an appropriate fix? (i didn't read the wiki link.lol)
15:21:02 <nadya_> jd__, we investigated api-clients today and see that apiclient from oslo is used only in cinder
15:21:02 <eglynn> gordc: well, usually user visibility is a requirement
15:21:18 <eglynn> gordc: ... but if it helps other patches gate on stable
15:21:30 <eglynn> gordc: ... then would be still OK IMO
15:21:48 <dhellmann> nadya_: the api client in oslo is a work in progress
15:21:53 <nadya_> jd__, other clients use 'requests' lib for proxy support
15:22:09 <jd__> nadya_: that's another plan, what shall we do dhellmann?
15:22:17 <gordc> eglynn: i think it was to allow tests to be run outside +000
15:22:32 <gordc> i don't think we can run stable/havana tests in north america.
15:23:05 <eglynn> gordc: that's a good enough motivation methinks
15:23:14 <eglynn> gordc: I'll review it after meeting
15:23:17 <dhellmann> jd__: I'm not certain of the best path forward here
15:23:30 <gordc> eglynn: cool cool. thanks.
15:23:31 <dhellmann> there is some other work going on to try to create a common client library
15:23:38 <dhellmann> it's not clear which version is going to win :-)
15:23:54 <dhellmann> so we should probably do the most expedient thing to fix the client for now, and then keep an eye on that other work
15:23:59 <jd__> "sit tight and buy popcorn"
15:24:13 <jd__> dhellmann: fair enough
15:24:23 <llu-laptop> what's our conclusion about the pagination support in ceilometer? Should we continue with our current patches in gerrit or what?
15:24:25 <dhellmann> eglynn, gordc : I just posted the question on the changeset
15:24:40 <nadya_> jd__, dhellmann maybe we may have proxy support as we suggested :)? and remove it after client in oslo is done?
15:25:14 <gordc> dhellmann: ok. i'll answer there.
15:25:47 <dhellmann> nadya_: that seems reasonable to me
15:26:01 <yfujioka> hello
15:26:08 <yfujioka> I want to create plugin for metering statistics of physical switches via OpenDayLight.
15:26:15 <jd__> nadya_: yep
15:26:27 <dhellmann> nadya_, jd__ : this looks interesting: https://pypi.python.org/pypi/slumber/0.6.0
15:26:43 <eglynn> yfujioka: how are those metric exposed?
15:26:43 <jd__> dhellmann: indeed
15:26:45 <yfujioka> Should plugin works in ceilometer-agent-central?
15:26:58 <eglynn> yfujioka: as AMQP notifications or via an API?
15:27:22 <eglynn> yfujioka: the central agent is for polling APIs
15:27:42 <eglynn> yfujioka: we've a new notifications-agent for consuming AMQP notifications
15:27:48 <yfujioka> eglynn:I will via OpenDayLight collector API
15:28:06 <jd__> btw I don't think I'll be available for the meeting next week as I will likely be eating frogs and snails with dhellmann, if anyone wants to chair we can keep it, otherwise I'll cancel it
15:28:09 <eglynn> yfujioka: is that a public REST API?
15:28:14 <yfujioka> yes
15:28:45 <eglynn> jd__: we can decide next week if we need it depending on agenda items, I can chair it if we do ...
15:28:56 <eglynn> yfujioka: the central agent is the place so
15:29:06 <yfujioka> eglynn: https://jenkins.opendaylight.org/controller/job/controller-merge/lastSuccessfulBuild/artifact/opendaylight/northbound/statistics/target/site/wsdocs/resource_StatisticsNorthbound.html
15:29:07 <llu-laptop> yfujioka: that seems to fit in central agent to me
15:29:13 <jd__> eglynn: works for me! I'll leave it up to you then, thanks! :)
15:29:17 <eglynn> np!
15:31:12 <nadya_> sandywalsh, I saw your email about performance. I'm interested in this too. Now I'm getting familiar with multi-node deployment. will come to your etherpads soon
15:31:39 <llu-laptop> jd__: what's our conclusion about the pagination support in ceilometer?
15:31:41 <yfujioka> thanks, I see > eglynn, llu-laptop
15:32:31 <nadya_> by the way, I'm almost installed ceilometer to the big lab. Will start to load it tomorrow. Hope I will get interesting results
15:32:38 <yfujioka> I think I must create BP for the plugin.
15:33:12 <jd__> llu-laptop: not sure, I think we should go for whatever makes sense
15:33:23 <yfujioka> I have found template of BP. https://wiki.openstack.org/wiki/Ceilometer/BlueprintTemplate
15:33:30 <yfujioka> Is this in available?
15:34:25 <jd__> also PA: I stopped sending meeting agendas on openstack-dev@l.os.o as it seems unnecessary and the list is already really busy
15:35:05 <eglynn> sensible move methinks, that ML is like a firehose already ...
15:35:20 <llu-laptop> jd__: how about we go on with the current pagination patch? I don't see any harm.
15:35:32 <jd__> llu-laptop: I didn't review them
15:35:57 <llu-laptop> I think Fengqian needs to rebase it
15:36:35 <llu-laptop> I mean we should continue to review the pagination patch.
15:36:42 <jd__> agreed
15:37:09 <eglynn> yeap, since there's a bunch of storage driver code landed already
15:37:15 <eglynn> (related to pagination)
15:37:24 <eglynn> IIUC
15:37:43 <llu-laptop> eglynn: you're right. part of them are already there
15:39:50 <jd__> I think we're done
15:39:57 <jd__> thanks guys!
15:40:03 <jd__> and join #openstack-ceilometer
15:40:04 <eglynn> yep, thanks all!
15:40:05 <gordc> laters
15:40:10 <jd__> #endmeeting