15:00:52 <eglynn> #startmeeting ceilometer
15:00:54 <openstack> Meeting started Thu Apr 17 15:00:52 2014 UTC and is due to finish in 60 minutes.  The chair is eglynn. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:55 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:58 <openstack> The meeting name has been set to 'ceilometer'
15:01:02 <eglynn> welcome all :)
15:01:09 <ildikov> o/
15:01:11 <nealph> o/
15:01:13 <nprivalova> o/
15:01:57 <nealph> thin crowd today. :)
15:02:05 <jd__> o/
15:02:06 <eglynn> nealph: yeah, just thinking
15:02:19 <eglynn> k, we got quorem methinks
15:02:26 <eglynn> #topic icehouse released!
15:02:29 <eglynn> #link https://launchpad.net/ceilometer/icehouse/2014.1
15:02:42 <eglynn> high-fives & bear-hugs all round, spark up those cigars :)
15:03:06 <eglynn> we needed a last-minute RC3 for that bug with the SNMP load averages
15:03:07 <nprivalova> congrats!!
15:03:16 <dhellmann> o/
15:03:17 <eglynn> ... luckily ttx was in an adventrous mood! ;)
15:03:31 <dhellmann> good work, everyone!
15:03:32 <sileht> o/
15:03:41 <llu-laptop> o/
15:04:03 <eglynn> yeap, let the mutual back-slapping begin! ;)
15:04:08 <jd__> :-)
15:04:12 <jd__> thanks everyone
15:04:19 <jd__> it was a great cycle :)
15:04:22 <llu-laptop> sorry for that SNMP bug, I didn't catch that when rebasing Toni's snmp work
15:04:37 <eglynn> and thank you jd__ for all the cat-wrangling :)
15:04:53 <eglynn> llu-laptop: np, I figured that ... also I +1'd the patch
15:05:36 <eglynn> ... or is the phrase cat-herding?
15:05:54 <nealph> either is applicable in this case, methinks.
15:06:08 <eglynn> cool
15:06:14 <eglynn> #topic recap on ongoing TC gap analysis for ceilometer
15:06:38 <eglynn> we had the gap analysis action plan review on Tuesday evening
15:06:47 <eglynn> #link http://eavesdrop.openstack.org/meetings/tc/2014/tc.2014-04-15-20.03.log.html
15:07:16 <eglynn> here's the action plan etherpad, with actions & designated owners etc
15:07:27 <eglynn> #link https://etherpad.openstack.org/p/ceilometer-integration-gap-analysis-coverage-plan
15:07:57 <eglynn> TL;DR: the TC approved of the plan, but expect to see definite progress on closing gaps in Juno
15:08:10 <eglynn> ... esp. re the Tempest-related gaps
15:08:19 <eglynn> ... we need to frontload progress onto j1 or latest j2
15:08:36 <eglynn> ... not to pile on the pressure or anything ;)
15:08:56 <nealph> eglynn:how can non-owners pitch in?
15:09:09 <jd__> non-owners?
15:09:24 <nealph> i.e. those not assigned to the etherpad items
15:09:32 <eglynn> nealph: contirbuting to the summit sessions, picking up BPs, landing patches ... the usual way
15:09:32 <nealph> but willing to help...
15:09:44 <ildikov> nealph: these are just the areas
15:09:51 <eglynn> nealph: ... the term "owner" wasn't meant to be exclusive
15:10:00 <nprivalova> nealph: I think "owners" is just a person to punish :)
15:10:09 <nealph> sure, okay. was really asking if there was a separate process for these gaps...answer is "no".
15:10:11 <ildikov> nealph: there will corresponding BPs, tasks, that you can assign to yourself, so the names are the responsibles for the whole area
15:10:15 <nprivalova> nealph: and they need help anyway :)
15:11:05 <eglynn> nealph: ... the idea was more to reassure the TC that the items wouldn't fall thru the cracks
15:11:42 <eglynn> nealph: ... not to ringfence off tasks only for certain contributors
15:12:13 <eglynn> nprivalova: ... bad choice of words on my part, not very open-source-y
15:12:27 <eglynn> nealph: ^^^
15:12:45 <nealph> eglynn:cool..."a single neck to wring". :)
15:12:53 <nprivalova> :-D
15:13:03 <eglynn> LOL :)
15:13:07 <dhellmann> s/owner/driver
15:13:07 <ildikov> BTW, if anyone has ideas/questions/topics to talk about for the Mike Bayer SQLA session on the summit, pleasee add a note to this etherpad: #link https://etherpad.openstack.org/p/juno-oslo-bayer
15:13:26 <eglynn> dhellmann: yep, that's better ... will change it
15:14:51 <eglynn> overriding message: lets commit to closing off these gaps during Juno
15:16:05 <eglynn> k, moving on?
15:16:27 <eglynn> #topic f20-based gating for ceilo/py27, also possibly a tempest-mongodb variant
15:16:51 <eglynn> so basically the mongo scenario tests only run in the py26 job on centos :(
15:17:17 <eglynn> since py27 is our "primary" check job, we need the mongo tests running under 27 also
15:17:39 <eglynn> initial idea is to rebase this on Fedora 20
15:17:53 <nprivalova> AFAIK, Ubuntu 14 is comming and will have Mongo
15:18:28 <eglynn> nprivalova: true, but we don't have a tight time constraint on the Trusty switchover for the gate
15:18:28 <nprivalova> today
15:18:47 <eglynn> nprivalova: switch over is happening today?
15:19:16 <eglynn> nprivalova: ... I thought it was more "sometime during the Juno cycle"
15:19:18 <nprivalova> eglynn: no, it's released today. switching will take 2-8 weeks
15:19:41 <nprivalova> we may ask infra
15:19:51 <eglynn> nprivalova: AFAIK there are new f20 nodes coming on stream very soon in the gate nodepool for tripleO testing
15:20:04 <eglynn> #link https://review.openstack.org/#/c/86842/
15:20:39 <eglynn> so we could be up and motoring with an f20-based py27 job for ceilo within days potentially
15:20:54 <nprivalova> sounds great
15:21:10 <eglynn> cool!
15:21:15 <nprivalova> and for tempest?
15:21:51 <eglynn> nprivalova: for tempest, we could do similar assuming the py27 job proves itself
15:22:17 <eglynn> nprivalova: ... i.e. an f20 or event centos7-based mongodb variant of the tempest job
15:22:22 <jd__> that's cool but that does not bridge any gap
15:22:29 * jd__ party killer
15:22:35 <gordc> eglynn: how do gates work with f20 and ubuntu14? they just gate randomly on either OS?
15:23:07 <eglynn> gordc: jobs will be target'd to one or the other is my understanding
15:23:25 <gordc> eglynn: i see.
15:23:44 <eglynn> jd__:  potentially the blocked tempest tests could then land, if decorated as "slow running tests" or whatever so not run agains sqla
15:23:50 <nprivalova> I think we need to determine plan for tempest. Are we going to make sql driver work faster :)? Or we will test only Mongo (assuming it's fast enough)?
15:24:24 <eglynn> jd__: so gaps bridged initially = [py27 scenarios on mongo, wider tempest coverage for mongo only]
15:24:43 <eglynn> nprivalova: yes we need to fix sqla as well
15:25:02 <jd__> ok
15:25:43 <nprivalova> eglynn: running tempest for Mongo only will fill the gap?
15:26:00 <gordc> nprivalova: i think a data model rework will allow sql to function with tempest... postgres works right now no?
15:26:20 <eglynn> nprivalova: well the idea was to have "main tempest job" still run against sqla with the slow tests excluded
15:26:45 <eglynn> nprivalova: ... and also a "variant tempest job" run against mongo will all tests enabled
15:26:46 <nprivalova> gordc: will check that. cannot say right now
15:27:06 <eglynn> nprivalova: ... same as we have a variant tempest run against postgres currently, right?
15:28:10 <nprivalova> eglynn: it's running against postgres, right. And once it was successful. I will check that ASAP
15:29:08 <eglynn> nprivalova: ... yeah so I meant the principal of having variants of the tempest jobs targeted to different DBs (mysql versus postgres) is already established practice
15:29:47 <eglynn> nprivalova: ... /me is hoping that'll allow us to argue the case with infra for an extra tempest job based on mongo
15:29:59 <nprivalova> eglynn: right, I see
15:30:29 <eglynn> but I think first step is just get py27 running on f20 with mongo scenarios actually tested
15:30:56 <eglynn> maybe even make that new py27 job non-voting for a short transition period?
15:31:18 <eglynn> then disable the old py27 job after a couple of days
15:31:52 <eglynn> ... /me is not familiar with negotiating with infra folks, nprivalova prolly has a better sense of what they might agree to?
15:32:21 <gordc> eglynn: i had some people from Percona (a MySQL company) ask me where they can contribute to Ceilometer in regards to MySQL. maybe they can look at sql backend for us (so we don't need to abandon it)
15:32:24 <nprivalova> eglynn: ok, will try to talk to them
15:32:30 <eglynn> nprivalova: thanks!
15:32:43 <nprivalova> eglynn: you may create #action on me
15:33:12 <eglynn> gordc: yeah jd__ forwarded me a note from Matt Griffin also, sounds promising!
15:33:42 <gordc> eglynn: cool cool. same email probably.
15:34:06 <eglynn> #action nprivalova reach out to infra to discuss rebasing ceilo/py27 check job on f20
15:34:15 <eglynn> gordc: cool
15:34:30 <eglynn> prolly should move on
15:34:41 <nealph> nprivalova:eglynn:I thought there was some thought around schema re-architecting...is the percona discussion related, or a new approach?
15:35:25 <gordc> nealph: i told them to join the schema re-architecting session.
15:35:34 <eglynn> nealph: my understanding is that we hope they'll have some good domain knowledge for rationalizing our SQL schema
15:35:51 <eglynn> yep wot gordc said
15:36:17 <eglynn> #topic Tempest integration
15:36:53 <eglynn> nprivalova: anything extra to add to the f20/sqla/mongo discussion above?
15:37:17 <nprivalova> we've already discussed several thing above. I can add that we've started to implement alarm-scenario test
15:37:30 <eglynn> nprivalova: cool, thanks!
15:37:38 <eglynn> #topic Release python-ceilometerclient?
15:37:40 <eglynn> no need
15:37:58 <eglynn> AFAIK anyway
15:38:11 <eglynn> #topic New alternate meeting time slot, replacing the Wed 2100UTC
15:38:20 <eglynn> so this was mooted at last week's meeting
15:38:32 <eglynn> but deferred since we didn't really have quorem then
15:38:44 <nprivalova> 2100UTC is now :)?
15:38:55 <eglynn> yep with DST esp, the Wed meeting is getting pretty late for Europe
15:39:04 <eglynn> ... 10pm Dublin, 11pm continental Europe, 1am Moscow
15:39:29 <eglynn> I've a vague notion that the alternating slot was to facilitate our then active core from Australia?
15:39:37 <llu-laptop> nprivalova: I think now is 15:39UTC
15:39:53 <nprivalova> llu-laptop: thanks, true
15:39:53 <jd__> eglynn: it was
15:40:12 <jd__> tsss nprivalova :)
15:40:25 <eglynn> yeah so Melbourne is UTC+10 now (UTC+11 in their summer) hence the need
15:40:28 <jd__> we can drop the alternative time if nobody objects
15:40:51 <sileht> +1
15:40:51 <jd__> and I won't.
15:40:54 <nprivalova> so I would be happy to change time a little
15:40:55 <eglynn> jd__: yeah good timeslot to reflect current contributor timezones
15:41:05 <gordc> this time works for me.
15:41:10 <eglynn> gordc: Toronto is EST/EDT (UTC-5/4) right?
15:41:12 <llu-laptop> jd__: that means UTC15 all? That's fine to me
15:41:28 <eglynn> llu-laptop: China is UTC+8 all year round?
15:41:30 <gordc> its 10/11am for me in toronto
15:41:34 <llu-laptop> eglynn: yep
15:41:44 * nealph trying to do the math to US mountain time
15:42:09 <jd__> that's now basically, nealph , if you're there :)
15:42:10 <eglynn> llu-laptop: so 15UTC == 2300 CST, not too late for you?
15:42:39 <nprivalova> eglynn: do you suggest a new time? I'm lost
15:42:59 <eglynn> nprivalova: suggestion is to just go with a single slot same every week
15:43:05 <jd__> what about Sunday? No I'm not trying to scramble your minds
15:43:13 <gordc> nprivalova: this time slot
15:43:35 * nealph feels better that someone else wasn't tracking...
15:43:39 <nprivalova> gordc: 15UTC?
15:43:48 <gordc> jd__: i'd love to work on sunday.
15:43:48 <llu-laptop> eglynn: i can live with that. at least it's much better than 21UTC
15:44:00 <gordc> nprivalova: yep
15:44:02 <jd__> gordc: I'm sure nobody will object if you do
15:44:07 <ildikov> jd__: Sunday is my favourite workday too ;)
15:44:07 <eglynn> ... do we have any West Coast US contributors?
15:44:18 <llu-laptop> eglynn: but if someone try to move it early, happy to do that :)
15:44:37 <nealph> eglynn:will likely have some joining in the near future
15:44:43 <gordc> jd__: it's agreed that everyone will be hungover for sunday's meeting right?lol
15:44:45 <eglynn> llu-laptop: great thanks!
15:44:54 <jd__> gordc: I nod
15:44:58 <eglynn> nealph: so 1500UTC == 0700PST, outrageously early?
15:45:49 <nealph> eglynn: I don't think so....can't be ideal for everyone.
15:45:57 <nealph> :)
15:46:04 <eglynn> nealph: k, thaaks!
15:46:11 <eglynn> *thanks
15:46:21 <eglynn> so I think we've converged on a rough consensus
15:46:45 <eglynn> #agreed move to a single weekly meeting timeslot at 1500UTC
15:47:21 <eglynn> since we've already got this channel every second week, we shouldn't need to move to the -alt meeting channel either
15:48:15 <eglynn> #topic summit sessions
15:48:32 <eglynn> quick reminder folks, we're coming up fast against the deadline for proposals
15:48:49 <eglynn> ... weirdly that's Easter Sunday this year (april 20th)
15:48:56 <eglynn> (... speaking of working on Sundays)
15:49:15 <eglynn> so if you've something in mind, please knock out a proposal
15:49:26 <eglynn> #link http://summit.openstack.org/
15:49:34 * jd__ did
15:49:54 * eglynn thanks jd__ :)
15:50:15 <eglynn> while we already have more proposals than slots, there'll be some trimming of that current list
15:50:18 <eglynn> (for dupes, merges etc.)
15:50:20 <jd__> dunnow if you read my long rant, but maybe that may pop a new session, don't know
15:50:37 <eglynn> jd__: I did and I was gonna suggest just that
15:51:11 <eglynn> jd__: ... on the unadorned metric time series data etc.
15:51:43 <jd__> now I'm going to have pressure to work on that until th summit
15:51:44 <eglynn> jd__: ... sounds great and defo needs to be discussed, but obviously cross-over with the data model session too?
15:51:54 <jd__> yep
15:52:04 <jd__> maybe having one session is enough
15:52:11 <jd__> I think it depends on how many slot you can use for that
15:52:32 <eglynn> jd__: or give ourselves the option to slip over into another half-slot possibly
15:52:47 <jd__> yep
15:53:11 <eglynn> k, let's see how the final proposal list looks on the 20th, then we can do the horse-trading as necessary
15:53:53 * jd__ nods
15:54:09 <eglynn> #topic open discussion
15:54:47 <nealph> eglynn: data model session = http://summit.openstack.org/cfp/details/163?
15:55:06 <eglynn> nealph: exactomundo!
15:55:25 <mattgriffin> nealph, eglynn: just wrapped up another meeting and catching up in the discussion
15:55:40 <mattgriffin> would like to see where percona can help on this
15:57:04 <eglynn> mattgriffin: your input during that session in ATL would be great!
15:57:34 <gordc> mattgriffin: i'm tied to this work... i'm more than happy to secretly defer work to you guys :)
15:57:39 <mattgriffin> eglynn, cool. is there any more context or issues reported that would be good to prep for ATL?
15:57:42 <mattgriffin> gordc, :)
15:58:28 <gordc> mattgriffin: there were a few mailing list items regarding ceilometer and tempest in march i believe... that might give some background.
15:59:02 <mattgriffin> gordc, cool
15:59:26 <eglynn> gordc: could you and Alexei put together a quick etherpad in advance of the session, with links to relevant ML threads etc.?
15:59:40 <eglynn> (so that mattgriffin has a single source for background?)
15:59:50 <gordc> sure.
15:59:56 <eglynn> gordc: thank you sir!
16:00:15 <eglynn> k, we're up against the shot clock here folks
16:00:46 <eglynn> I'll wrap up as it's the top of hour, assuming no one has anything else pressing?
16:01:08 <eglynn> thanks folks for a productive meeting! :)
16:01:20 <eglynn> #endmeeting ceilometer