15:01:00 <eglynn> #startmeeting ceilometer
15:01:03 <openstack> Meeting started Thu Jul 17 15:01:00 2014 UTC and is due to finish in 60 minutes.  The chair is eglynn. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:06 <openstack> The meeting name has been set to 'ceilometer'
15:01:08 <eglynn> hey y'all!
15:01:10 <DinaBelova> o/
15:01:11 <idegtiarov> o/
15:01:15 <nealph> o/
15:01:17 <ildikov> o/
15:01:30 <eglynn> #topic Juno-2 status
15:01:33 <nsaje> o/
15:01:33 <llu-laptop> o/
15:01:41 <eglynn> #link https://launchpad.net/ceilometer/+milestone/juno-2
15:02:03 <eglynn> let's go thru' the BPs and get a feel for what's gonna land
15:02:46 <eglynn> eeek!
15:02:49 <DinaBelova> eglynn, https://blueprints.launchpad.net/ceilometer/+spec/mongodb-events-feature has been merged already :)
15:02:51 <eglynn> netsplit :(
15:02:53 <DinaBelova> :d
15:02:56 <cdent> wheeeeeeeeeeeee
15:03:05 <llu-laptop> what's going on?
15:03:12 <eglynn> DinaBelova: updated
15:03:15 <DinaBelova> cool
15:03:18 <eglynn> llu-laptop: netslpit
15:03:26 <nsaje> tsk, net split again
15:03:38 <eglynn> nsaje: arithmetic transformers looking good?
15:03:57 <eglynn> cdent: ironic notifications looking good?
15:04:28 <cdent> yup, just want a verify from you and potentially a poke from lucas (or his peers) to make sure the metadata is payload is happy
15:04:36 <cdent> (I added some more tests)
15:04:51 <eglynn> cdent: great :)
15:04:58 <eglynn> nsaje: around?
15:05:17 <nsaje> eglynn: looking good
15:05:37 <eglynn> nsaje: cool, thanks :)
15:05:43 <eglynn> sileht: around?
15:06:15 <eglynn> cdent: grenade/javelin, what's the thought on that?
15:06:48 <cdent> jogo is not excited: until javelin is operating in grenade he doesn't see much point adding features on it (he reiterated that on review today)
15:07:08 <eglynn> cdent: so, prolly bump to juno-3 would be sensible?
15:07:25 <cdent> however Sean is more excited: he's pretty ready to get javelin running and is waiting for I'm not sure what for a patchset that does the intergration to be passed
15:07:32 <jogo> cdent: working on getting it in grenade as we speak. hoping to get it working this week
15:07:44 <eglynn> cdent, jogo: OK, I'll hold off bumping in that case
15:07:46 <cdent> speak of the devil!
15:07:49 <eglynn> :)
15:08:00 <eglynn> pradk: around?
15:08:03 <jogo> I am excited for new javelin features once the basics are working
15:08:19 <pradk> eglynn, hello
15:08:21 <eglynn> jogo: cool, and EoW is realistic?
15:08:34 <cdent> jogo have you seen the discussion eglynn and I are having around how to manage semantics in the javelin tests?
15:08:45 <jogo> eglynn: thats the goal, will know more in a few hours
15:08:53 <eglynn> jogo: cool
15:08:59 <eglynn> pradk: confident on FWaaS/VPNaaS for juno-2?
15:09:03 <jogo> cdent: right now I just want it to work, so no
15:09:42 <cdent> it's kind of germane to that actually: our disagreement is because 'create' doesn't fully work (depending on your definition of "work")
15:10:08 <pradk> eglynn, so far yes.. i should at least be able to get it in partially.. there are a couple of deps from neutron side which we might have to wait on for other metrics. Other than that, so far on track
15:10:52 <eglynn> cdent, jogo: so the key question is whether we chould run javelin/create+check on the old version, or just javelin/create and keep check to post-upgrade?
15:11:25 <cdent> I think it's agreed that is should be just create upgrade check
15:11:25 <eglynn> pradk: cool, sounds like it'll be enough to declare vistory for the milestone
15:11:32 <cdent> but until create is "correct" that's not reliable
15:11:33 <eglynn> cdent: cool
15:12:26 <pradk> yea hopefully, i can get the resource discovery tests working soon.. getting close
15:12:39 <DinaBelova> eglynn, as for the tempest testing (for j2) - lots of tests are ready to be merged, but due to the QA sprint folks are busy this week....
15:12:50 <eglynn> llu-laptop: SNMP-improvement isn't on the list because the spec hasn't landed
15:13:05 <eglynn> https://review.openstack.org/104113
15:13:13 <DinaBelova> eglynn, vrovachev and I will ping all QA folks asap..
15:13:24 <eglynn> DinaBelova: great, thanks!
15:13:36 <DinaBelova> eglynn - I still hope to see and least all notifications tests merged in j2
15:13:47 <DinaBelova> at least*
15:14:10 <eglynn> DinaBelova: did Vadim make any headway with the intermittent nova notification test timeout, do you know?
15:14:12 <llu-laptop> llu-laptop: yes i'm still doing the coding, but it's risky for j2. My hope is to get the code ready before j2, and get it merged early j3
15:15:01 <DinaBelova> eglynn, that's no reproducible for him :(
15:15:02 <llu-laptop> sorry, last msg should be directed to eglynn :(
15:15:19 <eglynn> llu-laptop: having patches up up by j2 would be great, thanks for the update
15:15:47 <DinaBelova> eglynn`- that's really strange thing - he tried several times to catch it - no results yet :(
15:15:54 <ildikov> eglynn: as for the polling testing in tempest, some mails already landed on the dev list trying to solve the issues there
15:16:13 <eglynn> DinaBelova: yeah, it's happening pretty regularly in the gate according to logstash
15:16:20 <ildikov> eglynn: hopefully we will get some response after the qa sprint
15:16:30 <eglynn> ildikov: what's the $subject?
15:16:39 <DinaBelova> ildikov, eglynn - yep, as QA folks have meetup - no way they will answer quicker...
15:17:01 <DinaBelova> eglynn - [openstack-dev] [qa] Test Ceilometer polling in tempest
15:17:15 <eglynn> #link http://lists.openstack.org/pipermail/openstack-dev/2014-July/040434.html
15:17:44 <ildikov> eglynn: yeap, that's it :)
15:17:47 <DinaBelova> eglynn, although polling tests were not supposed to be part of j2 (too much work even with basic ones)
15:17:59 <eglynn> ildikov, DinaBelova: did you discuss with on IRC also with the qa folks?
15:18:12 <DinaBelova> eglynn, they went to the sprint :)
15:18:12 <ildikov> eglynn: we couldn't reach them
15:18:17 <eglynn> a-ha, got it
15:18:28 <DinaBelova> they are lost for this week :)
15:18:33 <ildikov> eglynn: that is why we started with the mail as async version
15:18:38 <DinaBelova> Sean travelled to Germany on Friday
15:18:52 <eglynn> ildikov, DinaBelova: fair enough
15:18:55 <DinaBelova> so even previous week was a little bit lost
15:19:09 <eglynn> so other stuff for juno-2 ...
15:19:22 <eglynn> this bug would be great to see fixed https://bugs.launchpad.net/bugs/1336193
15:19:25 <uvirtbot> Launchpad bug 1336193 in pecan "Timeout test_coordination_assign gate error" [Undecided,Confirmed]
15:19:37 <eglynn> nsaje: has a potential fix in the olso-messaging fake driver
15:20:03 <eglynn> we were waiting on a oslo-messaging 1.3.1 release to get our hands on that
15:20:12 <tnurlygayanov> hi there, probably someone can help me - I can't upload image to Glance and see the following error in Glance logs: http://paste.openstack.org/show/86954/  - how to fix it?
15:20:20 <eglynn> however that's now looking like it may not happen
15:20:51 <eglynn> tnurlygayanov: redirect to #openstack-glance
15:21:19 <DinaBelova> tnurlygayanov, wrong chat :)
15:21:45 <eglynn> instead we may have to just straight to the 1.4 series ... i.e. >=1.4.0.0a3
15:22:19 <eglynn> possible as part of an overall dependency upgrade a la https://review.openstack.org/103029
15:22:32 <eglynn> anyone see anything problematic in that?
15:23:13 <DinaBelova> eglynn, no from my side
15:23:32 <DinaBelova> eglynn - just silent nice update :)
15:24:21 <eglynn> ok anything else relevant to juno-2?
15:24:45 <eglynn> ildikov: how is the admin guide looking?
15:25:05 <ildikov> eglynn: kind of on track :)
15:25:21 <ildikov> eglynn: but I do not think that the whole story will fit in j-2
15:25:40 <eglynn> ildikov: ok, shout if you need extra eyes and/or content contributions
15:26:03 <ildikov> eglynn: sure, will do
15:26:24 <nsaje> there's some bugfixes for python-ceilometerclient in gerrit that need core reviews (seems only llu-laptop looks at that repo these days :-) )
15:26:35 <nsaje> I guess it'd be good if they landed for juno-2?
15:26:57 <eglynn> nsaje: yeah we'd need to cut a new python-ceiloclient release
15:27:24 <eglynn> nsaje: the client releases are decoupled from the main release cycle
15:27:38 <nsaje> eglynn: oh right, I remember that now
15:28:39 <eglynn> just on juno-2 admin in general ...
15:28:48 <eglynn> I need to take half-days off next week for family reasons
15:28:52 <eglynn> but will be contactable
15:28:59 <eglynn> (so just shout on email re. anything relevant to the milestone)
15:29:16 <eglynn> ... also ttx will not be doing the release this time
15:29:24 <eglynn> (it'll be russellb instead pushing the buttons)
15:29:47 <eglynn> ok shall we move on?
15:29:59 <russellb> o/
15:30:09 <ttx> some praying is also involved
15:30:25 <eglynn> ttx: LOL :)
15:30:30 <russellb> ttx has scripted and documented the process well :)
15:30:43 <nsaje> haha :)
15:30:52 <eglynn> #topic gnocchi update
15:31:00 * eglynn channels jd__
15:31:09 <DinaBelova> hehe :)
15:31:22 <eglynn> so work is progressing on the aggregation/truncation fixes discussed at midcycle
15:31:46 <DinaBelova> fyi, /me still working on opentsdb driver draft - hope to post it tomorrow (at least, its parts) :)
15:31:53 <eglynn> this patch is up for review https://review.openstack.org/105185
15:32:22 <eglynn> DinaBelova: cool! ... by draft, do you mean a WIP/strawman patch?
15:32:45 <DinaBelova> eglynn, no, I mean normal change - but I think I'll need to add smth there
15:32:53 <DinaBelova> I'm not sure
15:33:12 <eglynn> DinaBelova: cool enough
15:33:14 <DinaBelova> some of my efforts there might require some opensdb patching :)
15:33:34 <eglynn> a-ha, you're finding opentsdb issues? ... nice
15:33:50 <DinaBelova> eglynn, like retention thing - it's not fully implemented there via rest api - just through hbase directly
15:34:13 <DinaBelova> but as we use happybase+thrift agent to work with it from python we can't set ttl there :)
15:34:23 <DinaBelova> as opentsbd is java one - I may fix it there :)
15:34:35 <DinaBelova> and it'll work without any issues :)
15:34:51 <eglynn> a-ha, k
15:34:59 <eglynn> in other gnocchi news ...
15:35:07 <eglynn> ildikov's ceilo/gnocchi dispatcher spec landed
15:35:10 <eglynn> https://github.com/openstack/ceilometer-specs/blob/master/specs/juno/dispatcher-for-gnocchi-integration.rst
15:35:23 <ildikov> \o/ :)
15:35:47 <DinaBelova> just a link to the gnocchi+opentsdb ML: https://groups.google.com/forum/#!topic/opentsdb/9O57MfpRXI0
15:36:01 <ildikov> trying to start working on it now, j-2 is not a realistical target, aiming for early j-3
15:36:42 <DinaBelova> ildikov, hehe :)
15:36:47 <eglynn> ildikov: cool
15:36:55 <eglynn> k, move on from gnocchi?
15:37:00 <DinaBelova> eglynn, +1
15:37:03 <eglynn> #topic trusty switchover in the gate
15:37:31 <eglynn> so as you've probably noticed, clarkb has enabled trusty nodes in the gate
15:37:54 <eglynn> so finally the ceilo py27 is actually running the mongodb scenario tests! :)
15:37:58 <eglynn> \o/
15:38:06 <ildikov> \o/
15:38:21 <eglynn> against mongodb version 2.4.9 IIRC
15:38:26 <llu-laptop> yeah~
15:38:32 <DinaBelova> eglynn, :)
15:38:49 <eglynn> so the question is, are we ready to enable a tempest variant running against mongo?
15:38:53 <nsaje> great!
15:39:21 <eglynn> seeing as running against sql-a was always just a workaround for mongodb of the correct version not being available on precise
15:39:28 <DinaBelova> eglynn, actually we need to try - because I see no serious issues here to be met
15:39:36 <eglynn> DinaBelova: cool
15:39:49 <DinaBelova> eglynn, only if it'll be found in the process of trying :)
15:39:57 <eglynn> does anyone feel like proposing such a change to infra?
15:40:13 <DinaBelova> eglynn, me or Vadim may do that :)
15:40:23 <cdent> Is the idea to run both sql-a and mongo, or just one?
15:40:24 <eglynn> DinaBelova: excellent! :)
15:40:33 <eglynn> cdent: both probably
15:40:35 <cdent> good
15:40:37 <DinaBelova> cdent, I guess for the first time both
15:40:50 <DinaBelova> eglynn, oh
15:40:51 <DinaBelova> https://review.openstack.org/#/c/96316/
15:41:26 <DinaBelova> eglynn - it was a while ago, I need to remember that change
15:41:27 <DinaBelova> ;d
15:41:34 <eglynn> DinaBelova: yeah f20 was run into issues with skew in the nodepool allocation algorithm
15:41:40 <DinaBelova> a-ha
15:41:45 <DinaBelova> yes, exactly
15:41:49 <DinaBelova> ok, good
15:41:54 <eglynn> DinaBelova: (effectively discriminates against less-used distros)
15:42:01 <DinaBelova> :D
15:42:41 <eglynn> though ianw had a priority-aging patch up that addressed that
15:42:58 <eglynn> not sure if it actually landed in the end or was abandoned
15:43:12 <eglynn> landed :)
15:43:14 <eglynn> https://review.openstack.org/#/c/101110/
15:44:01 <DinaBelova> eglynn, a-ha, /me looking
15:44:29 <eglynn> even so, resistence might be reduced for a tempest-mongodb variant running on trusty as opposed to f20
15:44:41 <DinaBelova> eglynn, yes, for sure
15:44:51 <eglynn> because of the duration of support question with fedora
15:44:53 <DinaBelova> I just found that old change in my reviews
15:45:06 <DinaBelova> and tried to get what it was about :D
15:45:16 <eglynn> the qa folks want >=18 months support for any distros they gate on
15:45:31 <DinaBelova> eglynn, yep, I remember your ML thread about that
15:45:51 <eglynn> DinaBelova: yeap, so I think the path would be smoother if the new tempest variant was proposed for trusty
15:46:07 <eglynn> k, move on?
15:46:11 <DinaBelova> eglynn, agreed, ok, /action for me
15:46:24 <DinaBelova> +!
15:46:26 <DinaBelova> +1
15:46:43 <eglynn> #action DinaBelova propose tempest-mongodb variant on trusty
15:46:48 <DinaBelova> :)
15:46:52 <eglynn> #topic opens discussion
15:46:59 <llu-laptop> guys, SAD is 20th, right? It seems that we still have quite specs to review.
15:47:06 <llu-laptop> #link https://review.openstack.org/#/q/status:open+project:openstack/ceilometer-specs,n,z
15:47:12 <eglynn> llu-laptop: good point
15:47:33 <eglynn> llu-laptop: I think we'll have to treat that freeze as more a "slush"
15:48:06 <eglynn> but yes, please do review and let's get any specs that are close over the line if possible
15:48:23 <eglynn> e.g. the llu-laptop's SNMP spec just needs a +1
15:50:03 <cdent> some small number of those specs are hung up on proposers on holiday
15:50:29 <eglynn> cdent: good point
15:50:41 <eglynn> fabiog flagged that at mid-cycle
15:50:53 <eglynn> he'll be back next week IIRC
15:51:05 <nealph> indeed
15:52:09 <eglynn> so I indicated to fabiog that we'll be somewhat flexible with the spec acceptance deadline because of that
15:53:12 <eglynn> who else lost money on kilo? ;)
15:53:25 <cdent> was that the decision?
15:53:33 <cdent> where did it happen?
15:53:34 <eglynn> yeap
15:53:41 * eglynn bet the farm on kepler
15:53:52 <cdent> kilo is booooooooooooring
15:53:54 <eglynn> cdent: on the openstack (non dev) ML
15:54:08 <cdent> ah, i'm less frequent on that one
15:54:30 <nealph> cdent:understandable given the sheer volume. :)
15:54:43 <eglynn> cdent: http://lists.openstack.org/pipermail/openstack/2014-July/008447.html
15:55:28 <cdent> meh
15:55:29 <DinaBelova> eglynn, I was voting for Kyoto :)
15:55:40 <eglynn> that came in second
15:55:52 <eglynn> ... there were worse options I guess
15:55:53 <llu-laptop> looks like no more follow the  city/steet name convention
15:56:13 <nealph> llu-laptop:+1 :(
15:56:20 <llu-laptop> is kyoto a japan city?
15:56:21 <eglynn> llu-laptop: yeah, it all went to hell when we allowed grizzly ;)
15:56:32 <DinaBelova> eglynn, :D
15:56:43 <eglynn> llu-laptop: yeah, but there was a tenuous connection to Paris also I think
15:57:18 <eglynn> ... {Rue|Place|Avenue|Metro} de Kyoto ;)
15:57:54 <eglynn> ok, we're up against the shot clock as usual
15:58:07 <eglynn> anyone got anything else they want to raise up before we close?
15:58:30 <DinaBelova> no, not from me
15:58:42 <eglynn> k, let's call it a wrap
15:58:55 <eglynn> thanks for the productive meeting!
15:59:00 <DinaBelova> thanks!
15:59:07 <eglynn> #endmeeting