15:00:26 <gordc> #startmeeting ceilometer
15:00:27 <openstack> Meeting started Thu Apr  9 15:00:26 2015 UTC and is due to finish in 60 minutes.  The chair is gordc. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:31 <openstack> The meeting name has been set to 'ceilometer'
15:00:37 <cdent> o/
15:00:38 <ityaptin> Hi!
15:00:41 <sileht> o/
15:00:47 <eglynn> o/
15:00:57 <fabiog> hi
15:01:02 <prad> o/
15:01:15 <idegtiarov> o/
15:01:20 <llu-laptop> o/
15:01:27 <eglynn> I, for one, welcome our new Canadian overlord :)
15:01:54 <gordc> eglynn: lol we're 'peacekeepers'
15:02:06 <eglynn> LOL :)
15:02:42 <gordc> eglynn: want to take over controls or you have to drop for meeting still?
15:02:42 <eliqiao> o/
15:02:56 <_nadya_> o/
15:03:04 <eglynn> gordc: no, no ... all your's :)
15:03:10 <gordc> cool cool.
15:03:19 <gordc> i think we have enough people. lets begin!
15:03:25 <gordc> #topic kilo-rc1 status
15:03:55 <gordc> so kilo-rc1 is in process of being tagged
15:03:56 <gordc> https://review.openstack.org/#/c/171152/
15:04:13 <gordc> err just noticed it failed... regardless.
15:04:34 <cdent> omen
15:04:37 <gordc> lol
15:04:54 <gordc> um. so yeah, test as much as possible against the proposed rc1 branch
15:05:27 <_nadya_> stop working, let's go home :)
15:05:27 <gordc> if you see bugs, file them. criteria for rc bugs here: https://wiki.openstack.org/wiki/Release_Cycle#Other_release_candidates
15:06:07 <gordc> _nadya_: it's 11am. for me...i'll call it a day at 12pm. :)
15:06:19 <eglynn> also we'll need the kilo release notes to be filled in shortly
15:06:22 <eglynn> https://wiki.openstack.org/wiki/ReleaseNotes/Kilo#OpenStack_Telemetry_.28Ceilometer.29
15:06:51 <eglynn> "Key New Features" in particular, I guess we can crowd-source that aspect?
15:07:36 <gordc> eglynn: good point. i'll work on setting a list of features we've added this cycle but yeah, if anyone has a comment on important stuff we've added this cycle, don't hesitate to add it
15:07:44 <eglynn> coolness :)
15:08:28 <gordc> anyone have stuff to add regarding rc1? or stuff they know they want for potential rc2?
15:08:40 <jd__> o/
15:08:59 <gentux> o/
15:09:27 <gordc> i'll take that as a no... carrying on.
15:09:39 <gordc> #topic liberty blueprints
15:10:12 <gordc> liberty specs are open
15:10:23 <gordc> just need to merge this: https://review.openstack.org/#/c/168321/
15:10:48 <cdent> are we going to have a theme? it seems like a theme would be useful to focus effort.
15:11:05 <gordc> i don't have any idea regarding number of sessions we'll have at the summit this year but we'll do the same thing as last cycle by voting via docs
15:11:29 <eglynn> gordc: 2 fishbowl sessions, 8 working sessions, half day contrbutor meetup
15:11:32 <gordc> cdent: hmmm.. i don't know if we have a general theme... i guess it'll come out based on specs proposed and what people vote on.
15:11:46 <eglynn> gordc: compared to 6 sessions and a full day meetup in Paris
15:12:06 <fabiog> gordc: is the doc already available, please?
15:12:10 <eglynn> (of which the afternoon was mainly zombiefied)
15:12:14 <gordc> eglynn: cool cool... more time
15:12:31 <gordc> fabiog: i will do this after the meeting.
15:12:39 <fabiog> gordc: thanks
15:12:54 <gordc> #action make summit session doc
15:13:05 <gordc> cdent: did you have a theme in mind?
15:13:10 <jd__> we'll do a bit of Gnocchi I hope :)
15:13:33 <cdent> No New Features
15:13:38 <gordc> jd__: yep :)
15:13:38 <cdent>15:13:52 <eglynn> cdent: ... except in gnocchi :)
15:14:04 <gordc> cdent: do you have a list of unicode stuff memorised?
15:14:32 <ityaptin> Folks, a little spec for liberty here -> https://review.openstack.org/#/c/168349/.
15:14:33 <eglynn> it's an actual key on the Mac keyboard ;)
15:15:38 <gordc> interesting... so i guess from my pov, just don't add bloat would be my general theme. but yeah we can discuss plans via specs and session proposals.
15:15:58 <eglynn> gordc: re. summit scheduling ... one thing to watch out for would be clashes between conference sessions presented by ceilo contributors, and the ceilo design summit track
15:16:09 <eglynn> do we know who's presenting when?
15:16:40 <eglynn> cdent: did you get a timeslot for api-matters?
15:16:40 * gordc is happy eglynn's around to ask important questions.
15:17:40 <gordc> i have two sessions which i need to check up on in regards to time. but yeah, if anyone has talks, let me or someone know so we can schedule accordingly.
15:18:34 <prad> gordc, i think one of ours is Monday so we should be ok on that one
15:18:49 <gordc> prad: cool cool.
15:19:09 <gordc> anyone have anything else summit related?
15:19:23 <jd__> gordc: also spliting alarm/polling would be on my table
15:20:06 <cdent> weird, I became a zombie
15:20:21 <cdent> my timeslot for api-matters, last I checked, was 11 on tuesday
15:20:22 <gordc> jd__: ack, cdent mentioned it, i think there's a few questions on what exactly is splitting so we should probably get a spec up to explain that.
15:20:25 <cdent> or something like that
15:20:50 <jd__> you know how much I love specs
15:20:55 <gordc> ildikov asked for fancy diagrams on a whiteboard
15:21:19 <gordc> jd__: i want it to be at least 5000 words too... in times new roman.
15:21:38 <jd__> yeah I'll do that for you guys 😬 💕
15:21:49 <cdent> we probably need to have a pre-spec discussion to spec what we are speccing
15:22:03 <cdent> specifically
15:22:13 <jd__> with spectators
15:22:46 <cdent> \o/
15:22:55 <gordc> yeah, i think we should probably set up time for splitting work and the database config spec again.
15:23:44 <eglynn> cdent: that's safe from clashes with ceilo track IIUC, as Tuesday is cross-project day
15:23:58 * gordc will create doodle once we have a rough idea formulated.
15:25:22 <gordc> i should also mention there's an ops session proposed regarding ceilometer (and gnocchi). so if you've played with deployment, it might be good for you to join.
15:25:50 <gordc> i think jasonmyers was suppose to give us a time once that's all planned on ops side.
15:26:31 <gordc> anything else?
15:27:08 <cdent> what's the emoji for a headshake?
15:27:23 <gordc> summary: if you have a large/controversial idea. might want to have an open discussion to hash out ideas.
15:27:50 * gordc does not know any special characters business
15:28:03 <gordc> #topic Gnocchi status update
15:28:14 <gordc> jd__: floor is yours.
15:28:17 <jd__> 👌
15:28:38 * gordc sees a box with hexadecimal
15:28:56 <jd__> we didn't merge much exciting stuff but we have things under review pretty interesting
15:29:08 <jd__> sileht wrote a branch that allow to track resources history
15:29:17 <cdent> etags! woot!
15:29:20 <jd__> i.e. if you resize an instance you'll have its historic of flavor
15:29:26 <jd__> yeah we'll have etags for resources and all
15:29:35 <jd__> it's pretty impressive
15:29:49 <gordc> cool stuff.
15:30:01 <jd__> fingers crossed it'll merge by next week and we'll do a rc1
15:30:24 <jd__> we also struggle with MySQL a lot, it's painful to support
15:30:48 <jd__> and I wait for a new version of oslo.db with a lot of fixes too to improve the driver
15:30:52 <jd__> that's pretty much all
15:30:58 <jd__> questions?
15:31:07 <gordc> jd__: coolio. sounds like good progress.
15:31:49 <gordc> jd__: was just making a note to discuss use cases on how events and gnocchi will interact
15:32:14 <gordc> jd__: we can discuss later.
15:33:05 <jd__> sure
15:33:39 <gordc> #topic adding ZhiQiang Fan as core
15:34:18 <gordc> since we had overwhelming consensus, i'll be adding ZhiQiang Fan as the latest ceilometer core.
15:34:34 <llu-laptop> remember we have a patch with lots of +1/+2s for that :)
15:34:45 <gordc> i don't think he's here but i'll announce it on list.
15:35:26 <gordc> llu-laptop: :) i just remembered we had an actual MAINTAINERS file that i could've edited.
15:35:57 <gordc> but yeah, we're all aware of it. just announcing that formally now.
15:36:05 <eglynn> coolness, congrats ZhiQiang Fan! :)
15:36:15 <jd__> cool
15:36:33 <Zhongjun> lol
15:36:48 <gordc> #topic Open discussion
15:37:11 <llu-laptop> can anyone give me some clue about a specific ceilometerclient patch failure on gate?
15:37:17 <llu-laptop> https://review.openstack.org/#/c/169442/
15:37:24 <llu-laptop> http://logs.openstack.org/42/169442/3/check/gate-tempest-dsvm-neutron-src-python-ceilometerclient-juno/e29169a/logs/devstacklog.txt.gz#_2015-04-08_18_23_53_045
15:37:44 <llu-laptop> it's the only patch met that problem, others seems fine
15:38:11 <jd__> sounds like requirement failure
15:38:33 <gordc> llu-laptop: we had a discussion in #celiometer/infra yesterday
15:38:57 <gordc> dhellmann: mentioned it relates to require stable branch for libraries now.
15:39:08 <llu-laptop> my question is why others patches are fine, but this one got stuck constantly
15:39:25 <jd__> ➔ grep ceilometer requirements.txt
15:39:25 <jd__> python-ceilometerclient>=1.0.6,<=1.0.12
15:39:33 <jd__> that's in ceilometer juno branch
15:39:37 <gordc> llu-laptop: yeah, i wasn't aware it was just this patch. i would think they'd all collapse
15:39:49 <jd__> they should all collapse, did you recheck?
15:40:21 <_nadya_> gordc:  regarding hbase testing. ityaptin will run tests on real env to be sure that it works fine
15:40:45 <eglynn> llu-laptop: I looked into creating a stable/juno in python-ceiloclient earlier
15:40:52 <llu-laptop> jd__: https://review.openstack.org/#/c/170760/ passed the gate this morning
15:41:09 <_nadya_> gordc: on next week I guess. ityaptin, please confirm
15:41:25 <eglynn> ... apparently I have powerz to push tags in python-ceiloclient, but not create branches
15:41:32 <gordc> _nadya_: awesome, thanks for update.
15:41:49 <ityaptin> _nadya_, gordc: Yes, I think we'll make it at next week.
15:42:29 <gordc> ityaptin: cool cool. would either one of you want to be the 'maintainer' of HBase in MAINAINTER file?
15:42:52 <gordc> llu-laptop: i think that was because the gate doesn't run the same jobs as check
15:42:59 <eglynn> gordc: are we agreed that we need a stable/juno branch in python-ceiloclient to resolve the build failure in the gate?
15:43:16 <gordc> llu-laptop: rechecking another patch right now
15:43:28 <llu-laptop> gordc: ah, didn't noticed that
15:43:43 <gordc> eglynn: i think we do but if the recheck i just triggered doesn't fail it might be something else
15:43:59 <_nadya_> gordc: I think that ityaptin is a good candidate:)
15:44:02 <gordc> eglynn: that said, i think i saw all the client gates broken yesterday so we probably do.
15:44:26 <eglynn> gordc: kk, I'll await the outcome of that recheck before forcing the issue with stable/juno
15:44:26 <llu-laptop> eglynn: yes, I think we really need that
15:44:53 <gordc> _nadya_: cool cool, ityaptin: this is the file i'm talking about: https://github.com/openstack/ceilometer/blob/master/MAINTAINERS
15:44:55 <llu-laptop> we have some other oslo namespace patch got stuck by the icehouse/juno check jobs
15:46:48 * eglynn was sorry to hear that sad news about Chris Yeoh
15:47:40 <llu-laptop> really sad news
15:47:41 <gordc> same. former ibm colleague.
15:48:45 <_nadya_> folks, we have a patch about tests restructure https://review.openstack.org/#/c/160827/ . But it becomes expired in 10-30 minutes. Please review it even it has -1 from jenkins
15:49:10 <gordc> there's a place to contribute if you are inclined. http://lists.openstack.org/pipermail/openstack-dev/2015-April/060886.html
15:49:39 * eliqiao Chris Yeoh is eli's leader in ibm. I am sorry to hear about that and so sad.
15:50:01 <gordc> _nadya_: ok. will do.
15:51:07 <gordc> will close this off in next few minutes...
15:51:27 <vrovachev> _nadya_: thank you :-) Jenkins  add -1 to patch with merge conflict, because patch for all unit tests.
15:52:01 <ityaptin> gordc: Yes, I'm understand. I think I may handle it. Also,  I have an interest in MongoDb storage and am going to research it better. Who will be maintainer of MongoDb?
15:53:06 <gordc> ityaptin: i don't think we have an expert in that yet... maybe it's something we should hash out the coming cycle
15:53:54 <gordc> anything else pressing?
15:54:32 <eglynn> nowt from me :)
15:54:53 <gordc> happy hacking
15:54:59 <gordc> #endmeeting