15:02:49 <gordc> #startmeeting ceilometer
15:02:49 <openstack> Meeting started Thu Jul  2 15:02:49 2015 UTC and is due to finish in 60 minutes.  The chair is gordc. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:52 <openstack> The meeting name has been set to 'ceilometer'
15:02:55 <jasonamyers> o/
15:02:57 <cdent> o/
15:02:59 <fabiog> hi
15:03:05 <idegtiarov> hi
15:03:07 <ildikov> o/
15:03:14 <prad> o/
15:03:25 <gordc> #topic virtual Midcycle Meetup (https://etherpad.openstack.org/p/ceilometer-liberty-midcycle-agenda)
15:03:33 <cdent> so
15:03:44 <cdent> we did some vote gathering to figure out what topics people care about
15:03:52 <cdent> that information is at
15:04:00 <cdent> #link https://docs.google.com/spreadsheets/d/1mKLlRtTUWEq62ZrIi4Xr7EoV7SwGUNPORa7yauXYCbk/edit#gid=0
15:04:43 <cdent> we didn't get a ton of voters, so there's been some discussion if we should allow people who haven't voted to register some input on that list (there on the spreadsheet)
15:05:23 <cdent> but we're not sure if that kills the process we wanted to have which was to register _committed_ interest as opposed to drive by interest
15:05:29 <gordc> cdent: seems like the 'open' way... i'ver heard this open word used a ot
15:05:32 <gordc> alot*
15:05:58 <jasonamyers> I missed all this this past week :(
15:06:02 <llu-laptop> o/
15:06:11 <jasonamyers> but that's the stuff I wanna see
15:06:22 <cdent> the other main question on that list is where do we cut it off. is 2 votes enough to be in the schedule or should it be 3, or even 4
15:06:36 <cdent> I think we should have a smaller number of quality sessions, rather than many sessions
15:06:47 <cdent> but I'd prefer it we make that decision here
15:07:04 <_nadya_> o/
15:07:08 <gordc> cdent: agreed
15:07:11 <prad> to me 3+ is reasonable.. 2 == 1:1 discussion and can be done outside of meetup?
15:07:11 <jasonamyers> I like 4+ but it cuts off the API one
15:07:19 <jasonamyers> prad: ++
15:07:19 <cdent> for reference the topic definitions are here: 
15:07:24 <cdent> #link: https://etherpad.openstack.org/p/ceilometer-liberty-midcycle-agenda
15:07:27 <gordc> i don't think we realistically could tackle even the 3 votes
15:07:30 <ildikov> cdent: it can be even 4, regarding to the number of topics IMHO
15:07:44 <gordc> jasonamyers: i just voted for api
15:07:46 <cdent> cool, that soulds like something resembling a consensus
15:08:00 <cdent> the next thing that we need is for people to review their votes on their time availability
15:08:13 <cdent> this the "what days" doodle poll:
15:08:17 <cdent> #link http://doodle.com/6vfksdu38wcwqqd3
15:08:22 <cdent> this is the "what hours":
15:08:28 <cdent> #link http://doodle.com/gzhumwaakrqds38h
15:08:43 <gordc> cdent: we configured it to align with viewers timezone right?
15:08:55 <cdent> no, it is in UTC and it says so
15:09:04 <cdent> "Pick hours of the day (in UTC) that you are willing and able to be available for the virtual midcycle."
15:09:15 <gordc> does not read above
15:09:26 * cdent does not give gordc a cookie
15:09:29 <ildikov> is this one day we are aiming for?
15:09:32 <cdent> two
15:09:35 <ildikov> ok
15:10:05 <cdent> when I was reviewing the data it seemed to make sense for a few of the topics to be split across the two days: get brains filled with ideas on day one, decide things on day two
15:10:15 <cdent> we don't have to do it that way but it seems like it could work well
15:10:41 <ildikov> if we can stick with fewer topics we can have room for that, I think
15:10:47 <ildikov> it sounds like a good idea to me
15:11:14 <ildikov> maybe not specify the topic right now, just leave room for that
15:11:51 <cdent> next question: if we find that we can make the time fit, is the beginning of next week okay or is that too soon, and we should set something like wednesday as the earliest possible start?
15:11:57 <cdent> (or even later than that?)
15:12:25 <prad> if we can schedule the agenda based on interest(and TZs) it would be better .. vs open agenda
15:12:39 <cdent> yes, there is _not_ going to be an open agenda
15:12:50 <prad> good
15:12:51 <gordc> cdent: i'm assuming holiday weekend will make people sluggish start of week
15:12:53 <cdent> the entire purpose of doing this planning was to be able to have an in advance agenda
15:13:01 <cdent> roger that gordc
15:13:06 <gordc> cdent: that said, we don't have many americans...
15:13:29 * cdent looks at prad and jasonamyers
15:13:32 <gordc> tuesday?
15:13:51 <jasonamyers> I'm willing to do odd hours
15:13:57 <prad> yea early next week is too soon i think.. i'm not planning on working this weekend, want to watch fireworks like gordc did in canada :)
15:14:06 <cdent> if we start on tuesday that kills off jd__ unless he's will to change his schedule
15:14:21 <prad> wed+ works i think
15:14:23 <jd__> which Tuesday?
15:14:23 <cdent> and since jd seems a requirement on two of the more popular topics he's holding power
15:14:27 <prad> gives us a day or two to prep
15:14:30 <cdent> 7th and 8th
15:14:46 <cdent> gordc claims to unavailable the 9th and 10th
15:14:49 <cdent> (thursday and friday)
15:14:52 <jd__> really can't be there, I'll be on vacation
15:15:22 <cdent> gordc you have thursay friday flexibility?
15:15:34 <prad> 16th, 17th ?
15:15:37 <cdent> or jd__ you have flexibility 13, 14, 15?
15:15:41 <ildikov> the hours doodle for me is not the same for all days, but I will do my best with parallel meetings
15:15:46 <gordc> cdent: i'll be here for most part... probably not later in day but that doesn't affect euro people
15:15:54 <jd__> cdent: neither, vacation again :(
15:16:02 <ildikov> or 8-9
15:16:07 <jd__> cdent: I really didn't lie in the poll :D
15:16:11 <cdent> k so either 9/10 or 16/17 seem the best choices
15:16:15 <ildikov> so we can have one day with each :)
15:16:19 <prad> yep
15:16:19 <cdent> jd__: everyone lies, all the time ;)
15:16:31 <jd__> cdent: hmmm that would make a good show
15:16:33 <gordc> cdent: true story
15:16:36 <cdent> ha!
15:17:04 <cdent> okay, let's put it this way: if anyone lied on the doodle, fix it
15:17:13 <jasonamyers> haha
15:17:14 <gordc> cdent:  you have original doodle for availability days?
15:17:17 <cdent> and then prad and I will figure it out, using wednesday as the earliest possible date
15:17:21 <prad> hehe
15:17:48 <cdent> gordc I have no idea what you mean?
15:18:08 <gordc> the doodle where everyone put what days they were availabile
15:18:13 <prad> http://doodle.com/6vfksdu38wcwqqd3#table
15:18:15 <cdent> that's what we're talking about
15:18:33 <ildikov> cdent: updated
15:18:37 <cdent> thanks
15:19:02 <_nadya_> I have two entities of myself
15:19:02 <ildikov> cdent: it does not mean I lied, when I first filled it :)
15:19:45 <jd__> I lied I'm actually not there the 16th :> just fixed
15:19:49 <ildikov> _nadya_: it shows an option to delete, if I saw correctly
15:20:05 <_nadya_> ildikov: yep, fixed :)
15:20:10 <jd__> cdent: then maybe let's not try to have consecutive days?
15:20:22 <prad> cdent, 9/10 looks promising to me.. most people are available
15:20:25 <cdent> that would be fine jd__ if everyone is cool with that
15:20:30 <ildikov> _nadya_: now we know that option works too :)
15:20:35 <jd__> I'm cool with that
15:20:37 <cdent> I was just worried that people might lose momentum or forget stuff or something
15:20:47 <cdent> I think I would probably prefer that
15:20:51 <cdent> time to reflect
15:20:58 <gordc> cdent: 9/10 seems best.
15:21:11 <cdent> even though you claim to be gone
15:21:23 <gordc> my available didn't really reflect euro timezone
15:21:31 <prad> i vote 9/10 unless jd__  cant make it
15:21:33 <gordc> availibility
15:21:37 <ildikov> cdent: maybe that's the reason :)
15:21:57 <jd__> 9/10 works for me
15:22:13 <cdent> right let's run with it
15:22:20 <cdent> because otherwise we'll be here all day
15:22:28 <ildikov> cdent: +1
15:22:28 <jasonamyers> +1 9/10
15:22:31 <gordc> cdent: yep
15:22:32 <jd__> #agreed 9/10 virt sprint yeah mojitos
15:22:49 <cdent> please update the other doodle poll as well, we don't need to discuss that part, we'll just use it for schedule: http://doodle.com/gzhumwaakrqds38h
15:22:59 <cdent> and with that I think we can move on because we also:
15:23:06 <cdent> #agreed 4 is the cuttoff
15:23:15 <cdent> thanks everyone
15:23:41 <ildikov> cdent: prad: thanks for all the prep
15:23:42 <cdent> since prad will be bbq and beers tomorrow I'll either make some mail tomorrow or wait for him until monday and we'll send some mail
15:24:12 <gordc> cdent: cool cool. thanks to both of you for organising.
15:24:44 <llu-laptop> one question, which tool will us use?
15:24:56 <prad> good point
15:25:08 <prad> does hangout work for everyone?
15:25:08 <cdent> hangouts got the most votes
15:25:19 <gordc> it does not
15:25:19 <prad> or should we setup blue jeans?
15:25:27 <prad> last i heard its blocked in china
15:25:30 <cdent> webex got a "please no"
15:25:35 <jasonamyers> haha
15:25:42 <jasonamyers> haters gonna hate
15:25:47 <ildikov> hmm, it usually does not work for me from the office, but I will see whether I can do some hacks
15:25:47 <prad> hehe
15:25:47 <gordc> google is a pain in China.
15:25:48 <cdent> from the redhat side of the house we can set up public bluejeans thingie
15:26:06 <_nadya_> folks, are you sure about cutting func tests off? maybe one more vote :)?
15:26:29 <cdent> (I'd like to see it in)
15:26:32 <prad> yea we can setup bluejeans.. might not be the most open thing but it works i think
15:26:48 <gordc> _nadya_: we can put '3' topics as 'if we have time'
15:26:54 <llu-laptop> I can try hangout with VPN
15:27:08 <llu-laptop> looks like bluejeans needs service fee?
15:27:13 <cdent> we can schedule an initial "does any of this tech actually work session"
15:27:17 <gordc> bluejeans is free
15:27:31 <prad> llu-laptop, we can setup a publich session.. no fee
15:27:31 <gordc> prad/cdent can one of you try it out with llu?
15:27:37 <prad> sure
15:27:47 <gordc> cool cool.
15:28:09 <_nadya_> gordc: ok, maybe it's interesting only to our team indeed...
15:28:52 <cdent> oh one more thing: if you feel like you would be a suitable facilitator/leader for topic, put yourself in the spreadsheet
15:28:53 <cdent> thanks
15:29:00 <gordc> _nadya_: i think it's more that we're all in agreement of it. :) if there's things to discuss than we can bump it up
15:29:03 <ildikov> _nadya_: does it need more discussion or more hands to actually do it?
15:29:10 <cdent> if we close up this topic in the next minute we'll be the winners of the internet
15:29:24 <prad> :)
15:30:33 <_nadya_> let it be the first in queue 'if we have time', ok?
15:30:43 <cdent> (somebody already pushed it over the 4 vote limit)
15:30:49 <cdent> so it's in there
15:31:27 <gordc> cdent: your open google sheet is flawed.lol... lock it down.
15:31:41 <_nadya_> ok, so I have to prepare a show for it :)
15:31:53 <cdent> dood, man, you said you wanted some open man, I was all like "Lemme be a fascist" and you were all "cool your jets goose"
15:32:01 <gordc> _nadya_: ppt, cdent requests it.
15:32:10 <idegtiarov> cdent, it was me i missed to vote for it earlier
15:32:17 <cdent> idegtiarov++
15:32:23 <gordc> cdent: yeah, true. i give you permission to take absolute control... that ends well always.
15:32:23 <llu-laptop> just tried, hangout works on my VPN. but no objection to bluejeans either
15:32:45 <gordc> llu-laptop: it works... for now.lol
15:33:30 <ildikov> hangouts always disconnects on my laptop periodically
15:33:36 <gordc> let's try hangouts i guess and fall back on bluejeans if needed and then fall back on no visual/audio of llu...
15:33:43 <ildikov> although we can start with one and have the other as fall-back
15:33:49 * cdent nods
15:33:52 <ildikov> gordc: snap :)
15:33:59 <gordc> great minds...
15:34:02 <gordc> or slow minds...
15:34:28 <ildikov> gordc: my vote is on the first one :)
15:34:35 <llu-laptop> gordc: good plan :)
15:35:13 <gordc> any other questions regarding midcycle?
15:35:25 <cdent> WHO IS BRINGING THE SNACKS
15:35:44 <jasonamyers> I'll ship cookies to everyone who gives me a mailing address
15:35:44 <ildikov> is there a chance to decide on the M one regarding dates before Aug 17?
15:35:51 <gordc> allergies?
15:36:03 <prad> jasonamyers, beers?
15:36:04 <jasonamyers> ildikov: I'd love to do that
15:36:15 <jasonamyers> prad: I don't drink
15:36:23 <ildikov> jasonamyers: cool :)
15:36:27 <gordc> jasonamyers: we have a doodle up?
15:36:31 <jasonamyers> yes
15:36:50 <ildikov> shouldn't we have a Doodle as a Service?
15:36:53 * gordc will give headsup. i'm not sure i'm available all of early dec
15:36:57 <jasonamyers> https://wiki.openstack.org/wiki/Meetings/Ceilometer/M*_Mid-Cycle
15:37:22 <jasonamyers> I'm game for late november it's just hard to miss turkey time
15:37:35 <jasonamyers> which might only be a US thing
15:37:38 <ildikov> gordc: not all of or none of?
15:37:41 <janonymous> o/
15:38:12 <gordc> ildikov: none of? i tend to take holiday around early dec.
15:38:41 <ildikov> gordc: usually me too
15:38:48 <cdent> I'm unclear on the constraints: Is January too late? Also, is Msummit coming early this year?
15:39:02 <ildikov> gordc: but understood
15:39:30 <prad> this is Dublin or Paris?
15:39:42 <ildikov> cdent: I guess we are trying hard to avoid the it's too late in the cycle issue
15:39:44 <jasonamyers> eglynn said we should do before jan
15:39:50 <jasonamyers> prad dublin
15:40:04 <gordc> cdent: i don't think it's too late but i guess it links back to reason why we scrapped this midcycle.
15:40:07 <cdent> ildikov: yeah that's what I assumed just wanted to be clear
15:40:26 <cdent> let's all skip summit, and just go to a midcyle in early november :)
15:40:50 <jasonamyers> okay
15:41:09 * jasonamyers isn't gonna make tokyo
15:42:24 <gordc> let's see how the doodle plays out for decemeber. if we have nothing we might as well try for january... and then we can always do virtual one again
15:42:37 <ildikov> I think early Jan can work too
15:43:04 <jasonamyers> I can do a hosted on in Jan
15:43:13 <jasonamyers> I wanna make sure we get together once a year
15:43:27 <gordc> jasonamyers: yeah, that'd be good.
15:43:30 <ildikov> jasonamyers: +1
15:43:48 <gordc> #action vote on december doodle for now (http://doodle.com/hmukqwzvq7b54cef)
15:44:07 <ildikov> check back on the Doodle next week and decide whether it's Dec or Jan?
15:44:32 <gordc> ildikov: 2 weeks? we won't have meeting next week because of midcycle
15:45:12 <ildikov> gordc: yeap, two weeks is fine too, forgot about 9th is Thursday
15:45:43 <gordc> ildikov: cool cool. we'll see then
15:45:55 <gordc> other midcycle comments?
15:46:57 <jasonamyers> there will be COOKIES!
15:47:06 <gordc> #topic gnocchi status
15:47:14 * cdent cookiecoptrs
15:47:19 <gordc> jasonamyers: no raisins
15:47:29 <gordc> jd__: cdent: anything?
15:47:55 <cdent> not really; jd__ has been on aodh and I've been on devstack plugin stuff and the previous topic
15:48:04 <cdent> there have been some fixes and such but nothing revolutionary
15:48:06 <gordc> cdent: cool. next!
15:48:13 <_nadya_> we continue active work on InfluxDB driver
15:48:15 <cdent> there's some progress on influxdb, but not ready yet
15:48:32 <gordc> _nadya_: awesome. any blockers we need to raise to pauldix?
15:48:39 <jd__> what cdent said
15:49:28 <ityaptin> gordc: release 0.9.0 have some critical failing from the rest requests, but first versions of 0.9.1 looks better
15:49:43 <_nadya_> gordc: IlyaT is managing with blockers using different hacks :)
15:50:14 <_nadya_> cdent: are you working on influx driver too?
15:50:27 <gordc> ityaptin: cool cool. let me know if you need anything prioritised. pauldix seemed receptive to prioritising the issues we run into
15:50:38 <cdent> _nadya_: no, I was trying to give an overview of everything I was aware of including what ityaptin is up to
15:50:51 <_nadya_> cdent: ok!
15:51:33 <gordc> #topic open discussion
15:51:33 <ityaptin> gordc: ok, cool! I have some suggestions for InfluxDb team)
15:51:45 <_nadya_> btw, I've started alarming on Influx. looks optimistic
15:52:15 <gordc> ityaptin: kk. maybe we can forward him a list of suggestions.
15:52:57 <gordc> i jumped the gun on topic change. but i guess this falls into open discussion as well
15:53:22 <ityaptin> gordc: Good! I prepare they to the start of next week)
15:53:58 <gordc> ityaptin: awesome.
15:54:13 <gordc> any other topics? or we can end this 5-6 min early.
15:54:25 <rjaiswal> Would appreciate more eyes on reloadable pipeline review - https://review.openstack.org/#/c/190842/
15:54:58 <ityaptin> Folks, how do you think, will we ends work on API V3 to end of a liberty cycle?
15:55:12 <gordc> rjaiswal: will take a second look today.
15:55:18 <ityaptin> I looked into our UI in Horizon and was scared
15:55:29 <gordc> ityaptin: we won't implement it... but we can start to plan it.
15:55:41 <gordc> ityaptin: because they are using it incorrectly?
15:56:20 <ityaptin> Yep) but in some place our api do not provide requirement functionality
15:56:23 <ildikov> ityaptin: it's impossible to get it implemented for Liberty, but we surely need to start design it for M
15:56:39 <ityaptin> ildikov, I'm agree with it
15:57:16 <ildikov> ityaptin: there were some queries and statistics they wanted to do but there wasn't a good way with our API IIRC, are youreferring to smth similar?
15:57:20 <gordc> ityaptin: i'm not sure there's any logic/use case to what horizon does with ceilometer. it's just hitting available apis blindly it seems
15:57:57 <rjaiswal> Thanks gordc, wishing for more participation:)
15:57:59 <ityaptin> gordc, for example, I think Horzion UI need a Api endpoint for querying stats filtered by some same fields (n resource ids in query for example)
15:58:03 <gordc> maybe we need a liason for ceilometer/horizon
15:58:32 <ildikov> gordc: probably
15:58:47 <gordc> ityaptin: this is a gap in our current api or something horizon doesn't do?
15:58:58 <ildikov> gordc: we could start with the question whether anyone complained about the Ceilo UI
15:59:02 <ityaptin> gordc: our api
15:59:19 <gordc> ityaptin: ok. maybe open a bug for it.
15:59:24 <ildikov> gordc: just to see how much it is used at the moment
15:59:40 <gordc> ildikov: i don't think anyone uses horizon ceilometer interface... it was pretty non-sensical last time i looked at it.
15:59:41 <_nadya_> ildikov: it's just not used I guess
16:00:02 <gordc> carry on in main channel... times up
16:00:09 <gordc> thanks folks
16:00:12 <gordc> #endmeeting