15:00:46 <gordc> #startmeeting ceilometer
15:00:47 <openstack> Meeting started Thu Aug 20 15:00:46 2015 UTC and is due to finish in 60 minutes.  The chair is gordc. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:49 <jasonamyers> o/
15:00:51 <ityaptin> hi!
15:00:51 <openstack> The meeting name has been set to 'ceilometer'
15:01:00 <sileht> o/
15:01:01 <idegtiarov_> o/
15:01:02 <gordc> whatup
15:01:02 <cdent> o/
15:01:16 <pradk> o/
15:01:25 <ildikov> o/
15:01:37 <r-mibu> hi
15:02:14 * EmilienM lurks
15:02:29 <nadya> o/
15:02:40 <gordc> let's get started.
15:02:46 <gordc> #topic recurring: roadmap items (new/old/blockers) https://wiki.openstack.org/wiki/Ceilometer/RoadMap
15:03:21 <gordc> under 2 weeks left before we cap liberty off
15:03:27 <gordc> any blockers out there?
15:03:33 <sileht> my integration test is still blocked by the keystonemiddleware/oslo.config issue
15:04:01 <gordc> sileht: :( is it just because of slow reviews or because keystone team has issues with it?
15:04:02 <sileht> I hope keystonemiddleware merged my fixes otherwise we have to merge the cdent workaround
15:04:14 <cdent> I thought we did merge that?
15:05:08 <idegtiarov_> didn't we?
15:05:11 <sileht> gordc, because keystone guys don't really care, 'it works for most projects and a workaround exists'
15:05:29 <sileht> cdent, the global CONF stuffs crap ?
15:05:33 <gordc> sileht: kk. can you send me patches.
15:05:36 <cdent> yeah my fix is merged: aodh devstack puts the config in the paste file
15:05:47 <cdent> oh not _that_ workaround
15:06:00 <cdent> I just made it work the way the keystone guys want it to
15:06:04 <gordc> sileht: maybe it's best to start with workaround and play with proper fix after?
15:06:07 <sileht> oh god configuration in paste file, sniff ....
15:06:33 <cdent> https://github.com/openstack/aodh/blob/master/devstack/plugin.sh#L194
15:06:36 <ildikov> sileht: is that fix a big change in keystonemiddleware?
15:06:52 <sileht> ildikov, not really
15:07:03 <sileht> ildikov, https://review.openstack.org/#/c/208965/
15:08:14 <gordc> cdent: your workaround is in aodh correct?
15:08:15 <sileht> cdent, thx, I guess I can retry to test the integration job with that
15:09:15 <gordc> i'm leaning more to just working with workaround for now, just so we aren't completely blocked.
15:09:21 <ildikov> sileht: hmm, if there isn't anything else there besides the docco stuff, we still should keep some pressure on keystone folks to get this merged
15:09:33 <gordc> sileht: i can follow up with keystone team
15:09:33 <ildikov> sileht: not a big one indeed
15:09:52 <sileht> ildikov, they are a thread on the ML
15:10:15 <ildikov> sileht: cool, I'll check, I'm always behind with the list
15:10:24 <sileht> all middlewares was impacted by the same issues, all have been fixed except the keystonemiddleware one
15:10:35 <gordc> #action gordc will follow up with keystone team regarding middleware.
15:10:35 <ildikov> no comment
15:11:23 <gordc> sileht: can the workaround and keystonemiddleware patch coexist?
15:11:31 <sileht> gordc, yes
15:12:00 <sileht> gordc, the workaround is just a deprecated way to configure the middleware
15:12:15 <gordc> sileht: cool. yeah maybe just try with workaroudn first? we won't get keystonemiddlware release until next week earliest.
15:12:43 <ildikov> gordc: wdo we have an aodh release date target?
15:13:35 <gordc> ildikov: sorry i was googling 'wdo' no i realise it was just 'do'
15:13:56 <gordc> ildikov: i think we can release once we get the integration tests working.
15:14:12 <ildikov> gordc: sorry typing fast is not my skill :)
15:14:43 <gordc> ildikov: i think the previous conditions were we need equivalent functionality and testing before release.
15:15:11 <ildikov> gordc: agreed on that one
15:15:16 <ildikov> gordc: can this middleware fix and the remaining event-alarm patches fit into that timeframe also?
15:15:17 <sileht> gordc, sure I was not aware of the merge workaround
15:15:47 <gordc> sileht: cool cool.
15:16:33 <gordc> ildikov: i'd rather get a release first... but if the middleware fix and event-alarm patches get in before testing is complete, that's cool.
15:17:17 <ildikov> gordc: ok, I will switch into review mode then
15:17:20 <ildikov> gordc: thanks
15:18:01 <gordc> cool, so hopefully we can get first aodh release sometime soon.
15:18:12 <gordc> anyone else with liberty items?
15:18:28 <gordc> nadya: do you think we can start gating on postgres functional tests?
15:19:04 <pradk> gordc,  we have the last few patches for declarative notification.. if we can get it approved soon so we can get it in before gate craps out
15:19:38 <pradk> https://review.openstack.org/#/q/status:open+project:openstack/ceilometer+branch:master+topic:bp/declarative-notifications,n,z
15:19:46 <gordc> pradk: cool. will look.
15:19:51 <nadya> gordc: yep, experimental job is ok
15:20:01 <nadya> gordc: should I make it voting?
15:20:41 <gordc> nadya: i think so, assuming there hasn't been any random errors with the check.
15:21:03 <gordc> nadya: don't want to block our gate but i'd still like to make sure we test everything
15:21:27 <nadya> gordc: ok, I will run it several times and will make it voting today-tomorrow
15:22:01 <gordc> nadya: cool cool.
15:22:05 <ildikov> nadya: cool, just in time before Liberty
15:22:13 <ildikov> nadya: thanks for taking care of this
15:22:29 <gordc> nadya: yep, thanks very much.
15:23:22 <gordc> any other items?
15:23:31 <gordc> r-mibu: everything ok with event-alarms?
15:23:42 <nadya> it's my job (c) :D
15:23:51 <cdent> I'm still trying to get the grenade-related stuff moving, but with linuxcon on this week it's stalled
15:23:54 <r-mibu> gordc, one questionregarding cache
15:25:25 <gordc> cdent: np. i assume the grenade plugin path is still not fully fleshed out yet?
15:25:28 <gordc> r-mibu: sure.
15:26:09 <r-mibu> gordc, I'm trying to create the last patch for event alarm which is for caching event alarm definitions
15:26:15 <cdent> seems so, yeah; it's evolving
15:26:31 <r-mibu> gordc, which is the best libraly for python caching?
15:26:53 <r-mibu> gordc, oslo_cache or dogpile directly?
15:27:33 <gordc> r-mibu: i'm not exactly sure what is in oslo_cache. dogpile.cache appeared useful last i looked?
15:27:57 <gordc> r-mibu: is there a way to do in-memory cache?
15:28:21 <r-mibu> gordc, https://pypi.python.org/pypi/oslo.cache
15:29:29 <r-mibu> gordc, there is a dict backend, i think it can cache data in-memory...
15:29:45 <gordc> r-mibu: oh, it's a wrapper. i guess we should try oslo.cache to see if it helps.
15:30:21 <gordc> r-mibu: i don't have a suggestion right now. not sure if anyone else has opinion? but i'll comment on your patch.
15:31:03 <gordc> r-mibu: also, the monasca team was interested in the event-alarms so they may email you about what your plans.
15:31:40 <ildikov> r-mibu: I talked about Doctor to them on Tuesday
15:32:07 <r-mibu> gordc, ok
15:32:10 <ildikov> r-mibu: I will send some material to them about the project, I will cc you
15:32:39 <r-mibu> gordc, ildikov, nice!
15:33:22 <gordc> cool anything else regarding Liberty features/bugs?
15:34:01 <gordc> #topic recurring: ceilometerclient release?
15:34:14 <gordc> nothing happened here, so next!
15:34:23 <gordc> #topic recurring: Gnocchi status
15:34:44 <gordc> anything of importance?
15:35:21 <cdent> jd__ and I fought with some bugs on friday but he was finally able to find them
15:35:26 <cdent> issues with orphaned metrics
15:35:43 <cdent> this has led to a lot of race condition related fixes
15:35:52 <cdent> influxdb is ready to merge
15:35:52 <gordc> fun
15:36:00 <gordc> cdent: that's great news
15:36:11 <cdent> (still no devstack integration though)
15:36:18 <nadya> *crying*
15:36:46 <gordc> i wasn't really expecting that.
15:37:17 <gordc> is there a reason we haven't +A influx driver?
15:37:44 <cdent> I think it's just a case of minor changes killing prior +2s
15:38:30 <cdent> I was gonna just approve it based on the prior history but then felt guilty
15:38:41 <gordc> cdent: i don't have powers so i'll let someone else do that.
15:38:56 <nadya> what we are waiting for to merge it?
15:39:16 <cdent> nothing now
15:39:28 <idegtiarov_> we are waiting for brave gnocchi core
15:39:52 <cdent> it's done
15:40:06 <idegtiarov_> hurray
15:40:10 <nadya> cdent: Chris, now we have time for taking care about influx driver
15:40:34 <gordc> cool stuff
15:40:51 <gordc> thanks for the effort folks
15:41:06 * cdent says a few hail marys
15:41:35 <gordc> #topic plan for performance testing (nadya/idegtiarov) https://etherpad.openstack.org/p/perfomance_test_plan
15:42:50 <idegtiarov_> folks please take a look at the etherpad now we have some  thoughts  from Chris
15:43:56 <nadya> we have decided to do some benchmarking on a big lab and it would be awesome if you share with us your ideas
15:44:28 * gordc will read and comment.
15:45:27 <nadya> what we want to get is smth like this https://www.mirantis.com/blog/openstack-ceilometer-cloud-performance-hardware-requirements/ but for Liberty
15:45:36 <idegtiarov_> gordc, thanks
15:47:08 <gordc> i take it it's only related to storage?
15:47:16 <gordc> re: performacne testing
15:48:00 <gordc> i'll ask questions in etherpad. :)
15:48:26 <gordc> #topic openstack user survey question
15:49:00 <gordc> we have the opportunity to ask users one multiple choice question.
15:49:19 <idegtiarov_> gordc, sure let move discussion there
15:49:21 <gordc> this is just to get an idea if anyone has a question they've always been wondering about.
15:50:03 <gordc> maybe a question regarding users' impression of gnocchi.
15:50:36 <gordc> or what roadmap features they feel is most important
15:51:27 <gordc> it's a single question, but if anyone has any suggstion feel free to chat about it now (or send me an email)
15:51:45 <gordc> i need to submit a question by next the 25th.
15:52:39 <cdent> how about something radical like: would you prefer to see ceilometer fixed or replaced?
15:52:39 <gordc> that's really all i had.
15:53:00 <gordc> cdent: lol
15:53:13 <gordc> cdent: do you need a survey to know what the answer is?
15:53:13 <nadya> what is your case? for what do you use Ceilo
15:53:35 <cdent> gordc: no but I need supporting data
15:53:48 <gordc> nadya: good question regarding use case
15:54:06 <cdent> with a multiple choice answer, yes? what would the choices be?
15:54:28 <gordc> ... sorry, distracted. there's a guy driving wrong way down street.
15:54:30 <ildikov> gordc: nadya: or what you use/would use Ceilometer for?
15:54:50 <nadya> about use-cases: it's interesting how customers see it, no options :)
15:55:09 <idegtiarov_> nadya good question I would finish it like: what is your case? for what do you use or would like to Ceilo
15:55:27 <idegtiarov_> *to use Ceilo
15:55:29 <gordc> billing data, service healthcheck, resource monitoring,?
15:55:45 <ildikov> there was a concernc from gordc and cdent that people are not willing to write a lot
15:56:01 <cdent> it's not a free form answer, only multiple choice
15:56:07 <gordc> nadya: idegtiarov_: it's better to give them options to choose from (and maybe an 'other' field)
15:56:12 <ildikov> which is something that worth to consider also regarding how to form the question
15:56:15 <nadya> aha, I see...
15:56:50 <gordc> nadya: it can be free form. but no one answers free form. (citation: experience)
15:57:11 <nadya> now I have a task to describe all possible monitoring-related use cases, so I can prepere some options
15:57:19 <idegtiarov_> ildikov,  agreed people do not like to write  :D
15:57:23 <gordc> nadya: that'd be good.
15:57:43 <ildikov> if we want use cases then we can add high level options like 'monitoring', 'resource usage trends', 'billing support', 'other: please describe' and they can check what's inetersting
15:57:47 <nadya> gordc: will do
15:58:08 <ildikov> is the use-case finally that we would like to go with then?
15:58:25 <nadya> ildikov: yep, we need options with descriptions (as detailed as possible)
15:58:31 <gordc> ildikov: i think it's a good question. but i'm open to any.
15:58:59 <idegtiarov_> it is a good question as for me
15:59:11 <gordc> 25th is submission date so please let me know any other ideas.
15:59:13 <ildikov> do we know what we are waiting from the answers?
15:59:16 <idegtiarov_> with options of course
15:59:33 <gordc> we'll get results by summit
15:59:48 <gordc> so it's something we can talk about then.
15:59:58 <ildikov> I mean what would be our take away if people vote on use cases
16:00:18 <gordc> we direct resources as appropriately.
16:00:19 <gordc> times up
16:00:24 <ildikov> would that mean new features, fix issues, help in focusing on Gnocchi, etc.?
16:00:27 <gordc> let's continue at ceilometer channel.
16:00:36 <idegtiarov_> buy
16:00:39 <gordc> #endmeeting