15:00:40 <gordc> #startmeeting ceilometer
15:00:41 <openstack> Meeting started Thu Sep  3 15:00:40 2015 UTC and is due to finish in 60 minutes.  The chair is gordc. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:45 <openstack> The meeting name has been set to 'ceilometer'
15:01:45 <llu-phone> o/ i'm using phone so forgive my slow typing
15:01:49 <liusheng_> o/
15:02:08 <pradk> o/
15:02:10 <cdent> o/
15:02:58 <jd__> o/
15:03:52 <ityaptin> hi!
15:03:52 <gordc> llu-phone: seems like everyone is slow today...
15:04:08 <eglynn> o/
15:04:23 <gordc> ok we'll just start.
15:04:31 <gordc> #liberty code freeze - rc1 and onwards
15:04:37 <gordc> #topic liberty code freeze - rc1 and onwards
15:04:58 <gordc> so we tagged l-3 this morning.
15:05:12 <gordc> basically anything that wasn't in yesterday is not in l-3
15:05:44 <eglynn> any FFEs on the cards?
15:05:55 <eglynn> e.g. the o.vo stuff?
15:06:08 <gordc> sorry. got bothered
15:06:29 <gordc> the two items that have been marked for FFE are declarative SNMP spec
15:06:38 <gordc> and events-rbac spec
15:07:08 <gordc> the ovo stuff will not make it into Ceilometer Liberty... possibly in for Aodh.
15:07:20 <ildikov> o/
15:07:48 <gordc> eglynn: there was a thread we opened and it seems like ovo may not even fit our design based on comments by dansmith
15:08:11 <dansmith> gordc: I don't think I said that
15:08:24 <dansmith> gordc: you store things in the DB just like we do, columns and rows
15:08:34 * cdent experiences deja vu
15:08:53 <pradk> :)
15:09:34 <gordc> dansmith: ok. i think i may have misunderstood your comment hten
15:10:21 <jd__> gordc: removing the agents? :(
15:10:50 <gordc> dansmith: i'm going to add this as the next topic so i can pick your brain more.
15:11:04 <gordc> jd__: so regarding the existing patches that aren't targeted to bugs.
15:11:23 <gordc> there are a few that are deprecation patches.
15:11:30 <gordc> or removal.
15:11:34 <dansmith> gordc: well, today is not really good given the timing.. surely this won't be on the blocks for consideration until M, so maybe we could discuss later?
15:11:51 <gordc> dansmith: sure. i'll reply to ML again
15:12:20 <gordc> i believe some of this stuff should have been removed a long time ago
15:12:36 <gordc> so i'm thinking it's ok for us to just re-target them against bugs and merge them
15:12:57 <jd__> gordc: ok cool!
15:13:29 <gordc> but yeah. anything going forward should not be a new feature (except for the FFE patches)
15:13:40 <gordc> and also everything should be targeted to a bug.
15:14:09 <gordc> with that said, thanks for all the work this past cycle... now time to see how much we broke
15:14:34 <gordc> ^ that second part is a joke... for idle readers.
15:15:08 <gordc> anyone have stuff to add?
15:16:47 <gordc> eglynn: did you want to revisit ovo stuff?
15:17:05 <eglynn> gordc: re-opening on the ML is fine
15:17:36 <eglynn> (since Kamil/Roman prolly not on this meeting anyway)
15:17:37 <gordc> eglynn: ok. yeah, it'd be good to get other eyes on it.
15:17:45 <eglynn> cool, makes sense
15:18:07 <gordc> #topic recurring: ceilometerclient release?
15:18:20 <gordc> we probably need a release of this for liberty.
15:18:42 * cdent nods
15:18:47 <gordc> does anyone have any additional items? i'm only tracking the patch for alarm events.
15:18:59 <idegtiarov> o/
15:19:08 <llu-phone> for cm client i have a question about the aodh spilt on this
15:19:12 <gordc> please let me know if there's something else so i can make sure it gets into liberty version.
15:19:17 <gordc> llu-phone: sure
15:19:43 <llu-phone> should event alarm in cm client?
15:20:02 <gordc> llu-phone: hmmm..
15:20:23 <gordc> you mean should we create a new aodh client and deprecate everything in ceilometerclient?
15:20:45 <llu-phone> basically should future aodh feature have client side in cmclient or its own client?
15:20:56 <liusheng_> llu-phone: seems there is a patch uploaded https://review.openstack.org/#/c/218846/
15:21:09 <liusheng_> llu-phone: about alarm=event
15:21:12 <gordc> i guess it should eventually.
15:21:31 <gordc> looking at roadmap, i don't think we ever discussed when
15:21:38 <llu-phone> i am asking for the long run
15:22:19 <gordc> llu-phone: i see. yeah. i definitely think we should separate in long run if we want to truly maintain Aodh separately
15:22:50 <gordc> but regarding new features... i don't think we have an aodhclient lined up so do we block client stuff until then?
15:23:11 <gordc> sileht: i don't know how easy/difficult client work was... from gnocchi pov
15:23:36 <gordc> i take it aodh maybe a little easier since it's already coded somewhat.
15:24:25 <jd__> it should be
15:24:41 <jd__> if people continue to go for ceilometerclient right now I don't think it's a big deal and we should block
15:24:53 <jd__> we'll start aodhclient as soon as we've time on the table
15:25:26 <gordc> jd__: we should *not* block? correct?
15:25:50 <liusheng_> but maybe users want a seamless access ?
15:26:21 <gordc> liusheng_: seamless access from a separate client or a single client?
15:26:36 <jd__> gordc: yes
15:26:43 <gordc> jd__: kk
15:26:45 <jd__> gordc: forgot a NOT :)
15:27:25 <liusheng_> gordc: so my concern is seamless acess can be  works with a sigle client ? :)
15:27:56 <liusheng_> gordc: a separated client
15:28:22 <gordc> yeah, we don't really have anything lined up for aodhclient so to allow for accessibility, since we already have the redirect in ceilomterclient, it seems to make sense we allow event alarm functionality in
15:28:39 <gordc> but i'll add aodhclient ot roadmap
15:28:45 <pradk> ideally people would want to use this services discretely so separate client would be good imo
15:28:51 <gordc> #action add aodhclient to roadmap
15:29:09 <gordc> but then it'll get wrapped in openstackclient...
15:29:46 <llu-phone> yeah openstack client
15:30:49 <gordc> let's leave aodhclient tabled for now but i think we should probably aim to have it separated as well.
15:30:52 <stevemar_> \o/ openstackclient
15:31:06 <jd__> *cough* *cough*
15:31:06 <idegtiarov> agreed with pradk people would like to have separate clients
15:31:20 <gordc> stevemar_: you got openstackclient hilighted?
15:31:33 <stevemar_> gordc: truth
15:32:19 <gordc> idegtiarov: cool cool. let's aim for that. we can re-raise discussion as a topic before we start work to make sure minds haven't changed since
15:32:45 <gordc> stevemar_: good worker habits.lol
15:33:01 <gordc> anything else? shall we move to gnocchi?
15:33:10 <idegtiarov> gordc, souds good
15:33:22 <gordc> #topic recurring: Gnocchi status
15:33:48 <jd__> it's awesome, as usual
15:33:49 <cdent> I updated things to use infuxdb 0.9.3 and there are still issues with timeouts
15:34:12 <cdent> ityaptin: did you see I updated the bug with a few more details?
15:34:27 <gordc> cdent: i forgot to followup. i can't find pauldix's email to prioritise bug
15:34:37 <gordc> eglynn: do you happen to have his contact?
15:34:48 <pradk> sileht and I working on gnocchiclient in a private repo, some basic stuff in place
15:35:05 <ityaptin> cdent: yes, i see
15:35:25 <jd__> I'm thinking about doing a 1.2.0 release in a few days too, just for fun and because we fixed a few interesting things since 1.1.0
15:36:01 <eglynn> gordc: paul@pauldix.net
15:36:22 <gordc> eglynn: cool cool.
15:36:49 <gordc> cdent: i can reach out and cc you?
15:37:04 <cdent> yeah, and ityaptin too
15:37:14 <ityaptin> yes, thanks
15:37:23 <gordc> kk. i'll just reference your bug. you can follow up to better describe issue.
15:37:46 <jd__> maybe we should propose to give up InfluxDB and focus on Gnocchi?
15:37:51 <jd__> just sayin'…
15:37:53 * jd__ hides
15:38:31 <gordc> good choice (to hide)
15:38:52 <idegtiarov> :D
15:39:19 <gordc> ok. next topic.
15:39:33 <gordc> #topic introducing new cores
15:39:49 <gordc> congrats to ityaptin for becoming gnocchi core
15:40:16 <gordc> welcome to liusheng_ and pradk as ceilometer cores
15:40:26 <gordc> and another congrats to liusheng_ as aodh core.
15:40:40 <gordc> thanks to all of you for your effort so far
15:40:50 <ildikov> welcome and congrats guys! :)
15:40:53 <cdent> yay, more people
15:40:54 * gordc claps
15:40:57 <llu-phone> congratulations !
15:41:00 <ityaptin> Thanks!
15:41:04 <liusheng_> thanks all of you :)
15:41:04 <idegtiarov> congrats!!!
15:41:08 <jd__> \o/
15:41:17 <pradk> Thanks! :)
15:41:46 <gordc> i'll email you the rules later... you'll need to pass a test to finalise everything. the test involves buying us all beer.
15:41:51 <gordc> no take backs. you've accepted.
15:42:06 <pradk> lol
15:42:27 <ildikov> gordc: lol :)
15:42:48 <gordc> jd__ and i will make appropriate permission changes after this meeting (if they aren't done already on gnocchi side)
15:43:13 <gordc> #topic Open discussion
15:43:31 <jd__> gordc: already done on Gnocchi side when I sent the mail :)
15:43:52 <idegtiarov> guys we are in one step of performance testing
15:43:54 <gordc> jd__: ah i see. /me is slow
15:44:04 <gordc> idegtiarov: nice!
15:44:05 <jd__> gordc: except for bugs because it's "Ceilometer driver"
15:44:14 <jd__> gordc: should I change that at this point?
15:44:23 <idegtiarov> thanks gordc and cdent  we use some of your thoughts
15:44:38 <jd__> gordc: or are you comfortable adding ityaptin to ceilometer-drivers?
15:44:38 <gordc> who's in ceilometer driver?
15:44:42 <jd__> gordc: people.
15:44:46 <gordc> oh.
15:44:51 <jd__> https://launchpad.net/~ceilometer-drivers/+members#active
15:45:26 <gordc> jd__: maybe we should create separate groups for each project.
15:45:26 <jd__> I think it's ceilometer-core equivalent on LP
15:45:40 <jd__> gordc: ok I'll do that for Gnocchi and Aodh then
15:45:48 <gordc> jd__: sounds good.
15:45:51 <gordc> thanks!
15:46:01 <gordc> idegtiarov: any pretty graphs?
15:46:11 <gordc> idegtiarov: are you testing against master?
15:46:26 <idegtiarov> suppose we will have some
15:47:28 <idegtiarov> against stable  kilo with some additional patches
15:48:03 <jd__> testing Ceilometer?
15:48:18 <gordc> i see. that'll be interesting... always strange to think of stable builds...
15:48:29 <idegtiarov> we will have 20 node lab on Mon, so some previous result will share next weekly meeting
15:49:00 <idegtiarov> jd__, yep, ceilometer now
15:49:19 <jd__> idegtiarov: with some Gnocchi?
15:49:38 <gordc> idegtiarov: nice. i look forward to seeing results
15:50:03 <idegtiarov> jd__,  not now, gnocchi in our backlog
15:50:14 * jd__ sad face
15:51:32 <gordc> additional items? will close off in a min
15:52:42 <gordc> thanks everyone
15:52:45 <gordc> #endmeeting