15:00:26 <gordc> #startmeeting ceilometer
15:00:26 <openstack> Meeting started Thu Oct  8 15:00:26 2015 UTC and is due to finish in 60 minutes.  The chair is gordc. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:30 <openstack> The meeting name has been set to 'ceilometer'
15:01:29 <sileht> o/
15:01:29 <ildikov> o/
15:01:38 <ildikov> sileht: snap ;)
15:01:40 <eglynn> o/
15:01:47 <pradk> o/
15:01:47 <llu-laptop> o/
15:03:06 <cdent> o/
15:03:16 <gordc> let's go
15:03:21 <gordc> #topic liberty release
15:03:40 <gordc> just a heads up, we tagged rc2 earlier this week
15:04:04 <gordc> it'll be our liberty release unless we find some huge blocker in next week or so
15:04:27 <gordc> now that we have that done, we need to document changes
15:04:33 <gordc> i've started here: https://wiki.openstack.org/wiki/ReleaseNotes/Liberty#OpenStack_Telemetry_.28Ceilometer.29
15:04:37 <gordc> #link https://wiki.openstack.org/wiki/ReleaseNotes/Liberty#OpenStack_Telemetry_.28Ceilometer.29
15:05:06 <gordc> if you have time, take a look and add items you think are important ie. gnocchi/aodh changes
15:05:35 <gordc> i'm pretty much just running through the blueprints we've completed and also the deprecated items
15:05:49 <gordc> cool?
15:05:58 <gordc> cool.
15:06:10 <ildikov> gordc: cool :)
15:06:14 <cdent> cool
15:06:24 <llu-laptop> cool +1
15:06:33 <gordc> awesome
15:06:39 <gordc> now for discussion
15:06:40 <eglynn> maybe drop the "improved" in "improved metadata caching"?
15:06:40 <ityaptin> Hi all!
15:06:58 <eglynn> (since I don't think we did any caching previously)
15:07:34 <gordc> eglynn: sure. (i probably just copied it from bp()
15:08:03 <eglynn> cool yeah, got it
15:08:19 <eglynn> "declarative meters" covers both SNMP and notifications I guess
15:09:02 <gordc> yeah, i'll add snmp explicitly
15:09:30 <eglynn> cool
15:09:32 <llu-laptop> is PowerVM hypervisor support in another repo? Should we put in the ceilometer main feature list?
15:09:43 <eglynn> pollsters-no-transform worth a mention too?
15:10:06 <eglynn> (or more like foundational work for the mitaka agent split out?)
15:10:28 <gordc> eglynn: yeah, i should add i didn't finish running through all the specs
15:10:48 <eglynn> coolness
15:10:56 <gordc> llu-laptop: i think so. we did the same when we added hyper-v/vsphere
15:12:03 <llu-laptop> So maybe we should put it clear that powerVM in another repo, like independant plugin?
15:12:03 <gordc> llu-laptop: i should also mention i added a section in Ceilometer wiki to point out any 'extensions' of ceilometer
15:12:07 <gordc> #link https://wiki.openstack.org/wiki/Ceilometer#Ceilometer_Extensions
15:12:24 <cdent> that was a good idea
15:12:35 <llu-laptop> gordc: nice
15:12:57 <gordc> cdent: we aren't allowed to put it officially in docs.openstack.org if it's not in bigtent so i put it there.
15:13:11 <gordc> i don't know if there's a better place. feel free to move it accordingly
15:13:25 <ildikov> gordc: +1, we can refer to the wiki from OS Manuals I think
15:13:45 <gordc> ildikov: sounds good.
15:13:50 <llu-laptop> forgive my ignorance, what's the relationship between ceilometer and cloudkitty
15:14:38 <gordc> llu-laptop: from what i know, they take ceilometer metrics and attach rating/billing rules to it.
15:14:54 <llu-laptop> gordc: got that, thx
15:14:55 <gordc> it's specifically to create billing reports i think.
15:16:12 <gordc> i guess we can move on to discussing summit
15:16:23 <gordc> #topic design summit planning
15:16:31 <gordc> #link https://docs.google.com/spreadsheets/d/1ea_P2k1kNy_SILEnC-5Zl61IFhqEOrlZ5L8VY4-xNB0/edit?pli=1#gid=0
15:17:02 <gordc> i didn't actually close submissions as originally planned on Monday
15:17:28 <gordc> but that's a list of items we have so far... it pretty much matches the number of slots we have at summit (maybe a few extra)
15:17:49 <gordc> considering there's a pretty clean match, i don't know if we really need to vote on anything
15:18:21 <gordc> we might want to discuss what items we want as fishbowls
15:18:31 <eglynn> a proposer seems to be missing from some of the proposals
15:18:41 <ildikov> gordc: do you think the Aodh one would cover the possible Monasca joint session?
15:18:49 <gordc> eglynn: yeah, i copied them from etherpad. i don't know who proposed them
15:18:54 <eglynn> a-ha, k
15:19:14 <gordc> ildikov: have you heard from them?
15:19:22 <gordc> we can slot it in that session
15:19:42 <gordc> if we do, maybe it makes sense to have that as a fishbowl.
15:19:45 <ildikov> gordc: just a few mails with it would be good
15:19:53 <ildikov> gordc: let's try to use that session
15:19:58 <eglynn> monasca didn't get their own track, right?
15:20:24 <gordc> eglynn: no. they are going to be re-evaluted by tc in a few weeks
15:20:37 <eglynn> a-ha, k
15:21:25 <gordc> ildikov: sure. let's target that as a fishbowl session. if anything we can hash out alarming items as is.
15:21:32 <nadya> eglynn: interesting Monasca session: https://openstacksummitoctober2015tokyo.sched.org/event/1deef6e168ded414c1bb65baaf7c9f89#.VfwnjXthp8A
15:21:45 <ildikov> gordc: cool, sounds good to me, thanks
15:22:53 <gordc> nadya: cool
15:22:56 <eglynn> nadya: indeed interesting ... I think they 3 conference talks in total
15:23:28 <gordc> did anyone have any other topics to add to google docs?
15:23:56 <gordc> i'm thinking since we have roughly same amount of slots and topics...
15:24:05 <nadya> gordc: maybe event-based transformers
15:24:07 <cdent> gordc: just to say that many of those topics originated with me but I don't think I can "own" all of them
15:24:25 <gordc> we just put a theme to each slot and have the topic as the main item of theeme
15:25:08 <gordc> cdent: maybe we don't need an 'owner' for working room
15:25:18 <gordc> just a bunch of discussino items
15:25:22 <nadya> gordc: I will ask Igor to care about it. When document is closed for editing?
15:25:28 <cdent> ✔
15:25:44 <gordc> nadya: i think i already add event transformers
15:26:19 <gordc> nadya: you can add his name as 'owner' if you'd like
15:26:19 <nadya> gordc: transforming events?
15:26:31 <gordc> nadya: yeah, that one
15:26:39 <nadya> gordc: ok, cool
15:26:47 <ildikov> nadya: it's there, I saw it too :)
15:27:06 <nadya> yep, thanks!:)
15:27:35 <gordc> so we have two fishbowls. any ideas on what are the biggest topics?
15:28:04 <gordc> UI could be a fishbowl if we sync in horizon.
15:28:29 <eglynn> yeah, sounds like we'll horizon input into that
15:28:31 <gordc> just a teaser, the survey, a lot of comments were saying ceilometer in horizon is unusable. so ceilometer is unusable.
15:28:39 <pradk> that could be interesting
15:28:43 <eglynn> was that "horizon integration" proposal from the ceilo or horizon team?
15:29:05 <gordc> eglynn: cdent i think... or some by product of os-ceilometer ramblings
15:29:18 <eglynn> a-ha, k
15:29:31 <cdent> It was a recording of ramblings
15:29:31 <gordc> i'll probably need to reach out to horizon to discuss if they can come.
15:29:41 <david-lyle> o/
15:29:56 <gordc> there was also another UI project that jd__ and i were added to... i forget it though
15:29:57 <eglynn> yeah, that would be good ... IIRC lsmola did a lot of that work originally
15:29:58 <cdent> as in: people were talking about this, it seemed like it mattered, better write it down so it comes up again
15:30:25 <gordc> david-lyle: would you be interested in a ceilomter/horizon session?
15:30:28 * jd__ wakes up
15:30:30 <david-lyle> yes
15:30:36 <gordc> david-lyle: cool!
15:30:41 * eglynn doesn't know if Ladislav is coming to summit
15:30:57 <david-lyle> I fully agree that the ceilometer view in Horizon is poor
15:30:58 <jd__> gordc: ah yeah, but I received a mail from LP that the project has been deleted
15:31:05 <jd__> gordc: so I guess the guy rage quit early
15:31:05 <gordc> david-lyle: i'll sync up with you to see if we can find a slot that works for both teams.
15:31:13 <david-lyle> gordc: +1
15:31:15 <gordc> jd__: lol
15:31:27 <gordc> that's pretty quick.
15:31:33 <jd__> let's integrate Gnocchi with Horizon, problem solved?
15:31:43 <jd__> then Aodh, second problem solved
15:31:46 <gordc> david-lyle: awesome. thanks for the quick feedback.
15:31:46 <david-lyle> O_o
15:31:55 <david-lyle> gordc: no problem
15:32:16 <eglynn> yep, lsmola is not travelling to Tokyo AFAICS
15:32:35 <gordc> jd__: yeah we can discuss how to/not to properly integrate ceilometer/gnocchi/aodh
15:32:55 <eglynn> sounds like a good candidate for fishbowl
15:33:16 <gordc> so alarms/monasca and UI/horizon as fishbowl topics? any other candidates?
15:34:01 <cdent> gordc: is there an ops feedback session planned? that would be fish
15:34:20 <eglynn> that was seperate on the ops track in YVR?
15:34:25 <gordc> cdent: good question
15:34:48 <gordc> cdent: i haven't heard back from product wg when they asked if we wanted one originally
15:34:49 <pradk> yea indeed, i think i added it to etherpad
15:34:54 <gordc> let me follow up on that.
15:35:10 <eglynn> (i.e. we didn't need to burn a ceilo session on it in YVR IIRC)
15:35:34 <pradk> ops track might already have something we can participate?
15:35:38 <gordc> do we want to burn a slot for this if there isn't an official one? i'd think it' probably be a fishbowl if we did .
15:35:47 <gordc> pradk: i need to confirm that.
15:36:12 <pradk> cool
15:36:15 <gordc> #action check with product wg to see if there's a ceilometer ops session
15:36:32 <eglynn> gordc: yep, would be a fishbowl if not already on the operator track
15:37:34 * jd__ put his name in the gdoc
15:37:46 <gordc> also need to sync with ops to see if they'll actually come (don't usually get much responses from my messages)
15:39:09 <gordc> alternatively, we can use contributors meetup to discuss replies from survey (if we don't do ops meetup)
15:39:59 <llu-laptop> yeah, we need to discuss the survey replies
15:40:08 <eglynn> gordc: contrib meetup is morning only? (i.e. not full day on the Friday)
15:40:39 <gordc> eglynn: yeah. i asked for half... i feel like everyone was burnt out last time (although it is a shorter summit this time)
15:40:39 <eglynn> if so, yeah that could work for the ops discusion
15:40:54 <gordc> eglynn: cool cool
15:41:30 <eglynn> yeah, exactly my thought ... I wouldn't schedule the ops discussion for the last afternoon when everyone turns zombie :)
15:42:45 <gordc> eglynn: cool. done.
15:42:59 <gordc> so i think we have our two fishbowls and contributors meetup.
15:43:12 <eglynn> coolness, sounds like a plan :)
15:43:14 <gordc> i'll just push themes/topics to the working rooms.
15:43:41 <gordc> feel free to put what topics you're interested in and i'll assign ordering accordingly.
15:44:05 <gordc> once i have that done, you can tell me what needs to be changed or what conflicts.
15:44:10 <gordc> sound good?
15:45:23 <cdent> ✔
15:45:29 <ildikov> gordc: +1
15:46:07 <gordc> #action gordc set working room slots and announce proposals.
15:46:11 <pradk> cool
15:46:27 <gordc> #action gordc sync with david-lyle to see what fishbowl slot works.
15:46:33 <gordc> cool
15:46:50 <gordc> #topic ceilometer mentoring
15:46:59 <gordc> this is just to followup i guess.
15:47:09 <gordc> jd__: i put your name and mine as mentors
15:47:37 <gordc> i was thinking having gnocchi dynamic resource creation as potential work item?
15:47:55 <jd__> would be cool, I guess it depends on the level of the mentee
15:48:00 <gordc> maybe we can have one medium and one hard option? i don't know where ^ falls in... medium?
15:48:35 <jd__> for know since we don't even know how to do it… not sure I can qualify it
15:48:46 <jd__> but I've other things that could be 'medium'
15:48:59 <gordc> jd__: ok.. cool cool.
15:49:24 <gordc> there's actually a lot of names for 'ceilometer' so i don't know how exactly that works
15:49:39 <gordc> maybe we can create a test and pick smartest ;)
15:50:35 <nadya> lol
15:50:38 <jd__> haha
15:50:51 <eglynn> this is OPW amiright?
15:51:05 <eglynn> (or Outreachy now, I guess)
15:51:11 <gordc> eglynn: yep. 'outreachy' i guess they rebranded
15:51:14 <ildikov> eglynn: yeap
15:51:21 <eglynn> cool
15:52:33 <gordc> jd__: kk. i'll send you an email and we can maybe come up with list of 2-3 potentials items
15:52:37 * jd__ nods
15:52:45 <gordc> #topic open dicussion
15:52:56 <cdent> bowling!
15:53:04 * cdent is kidding
15:53:11 <cdent> but there is a bowling alley in my hotel
15:53:18 <gibi> hi
15:53:23 <gibi> I have a spec up in nova to make the nova notification api versioned https://review.openstack.org/#/c/224755/
15:53:25 <gordc> there's bowling in tokyo?
15:53:30 <gibi> As ceilometer is one of the biggest notification consumer I guess you might be interested
15:53:33 <gibi> :)
15:53:54 <gordc> gibi: cool. thanks for headsup.
15:54:04 <gordc> gibi: is this related/unrelated to versionedobjects?
15:54:14 <gibi> it is based on versionedojects
15:54:45 <gordc> can you explain to me versionedobjects.lol half-joking another time.
15:54:51 <ildikov> gibi: +1, versioned notifications make the world a better place
15:55:05 <gibi> gordc: check the spec it has nice examples ;)
15:55:13 <gordc> gibi: there's i believe a cross-project item on this as well
15:55:30 <gordc> something from heat (but user facing events specifically)
15:55:37 <gibi> gordc: do you have a reference?
15:55:55 <gibi> gordc: I only found old etherpad and mailing list discussion from the past
15:55:59 <gordc> gibi: https://review.openstack.org/#/c/231382/
15:56:10 <gibi> gordc: thanks!
15:56:33 <gordc> i think it's specifically for user facing messages but it'd be nice if there was consistency on related attrs regardless
15:56:56 <gibi> gordc: totally agree
15:57:08 <gordc> gibi: is your spec targeting M* or N*? or O*?
15:57:08 <gibi> I will check that spec
15:57:21 <ildikov> gordc: I guess that's a follow up on what was started in YVR
15:57:30 <gibi> gordc: currently targeting M*
15:57:31 <eglynn> https://review.openstack.org/#/c/224755/5/specs/mitaka/approved/versioned-notification-api.rst ... so targeting M*
15:57:44 <ildikov> gordc: we definitely have agreement on this point regardless
15:57:50 <gordc> gibi: eglynn: cool cool
15:58:06 <gordc> we'll keep an eye on it.
15:59:04 <gibi> great, thanks. That was all from me. :)
15:59:08 <eglynn> o.vo for the win! :)
15:59:26 <ildikov> eglynn: lol :)
16:00:00 * gordc won't lie, i still don't understand how it works from db pov.
16:00:06 <gordc> specfically thishttp://lists.openstack.org/pipermail/openstack-dev/2015-September/074503.html
16:00:11 <gordc> darn out of time
16:00:14 <gordc> thanks everyone
16:00:21 <gordc> #endmeeting