15:01:27 <gordc> #startmeeting ceilometer
15:01:28 <openstack> Meeting started Thu Oct 15 15:01:27 2015 UTC and is due to finish in 60 minutes.  The chair is gordc. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:32 <openstack> The meeting name has been set to 'ceilometer'
15:01:34 <cdent> o/
15:01:39 <llu-laptop> o/
15:01:40 <sileht> o/
15:01:46 <liusheng> o/
15:01:47 <nadya> o/
15:02:17 <ildikov> o/
15:02:32 <gordc> #topic design summit
15:02:46 <gordc> ok. so i put up the schedule for design summit.
15:02:51 <gordc> https://mitakadesignsummit.sched.org/overview/type/ceilometer
15:03:03 <KrishR> o/
15:03:04 <gordc> please let me know if you have any conflicts and i'll try to address them.
15:03:41 <gordc> you can also find the list of etherpads for each session here: https://wiki.openstack.org/wiki/Design_Summit/Mitaka/Etherpads
15:03:50 <gordc> #link https://wiki.openstack.org/wiki/Design_Summit/Mitaka/Etherpads
15:04:20 <gordc> i think one item to point out (something llu-laptop reminded me of)
15:04:51 <gordc> as i previously mentioned, we have oppportunity to test ceilometer on 1000 node environment
15:05:19 <gordc> i was thinking it'd be good to have some ideas how/what to deploy on this environment to test.
15:05:34 <gordc> we can use the contributor's meetup to discuss that
15:05:48 <gordc> or do we want a dedicated session?
15:05:56 <ildikov> gordc: Ceilo with the old back ends or Gnocchi?
15:06:32 <gordc> ildikov: nadya(mirantis) are currently testing mongodb i believe
15:06:35 <gordc> but they aren't sharding.
15:06:37 <nadya> gordc: 1000 node without installed OpenStack ?
15:06:48 <KrishR> gordc: we can use the contributors meetup; i assume this is for the OSIC cluster (intel-Rackspace)
15:06:52 <ildikov> gordc: ok
15:06:56 <gordc> KrishR: correct.
15:07:05 <gordc> nadya: not sure what you just asked
15:07:06 <llu-laptop> KrishR: yes
15:07:38 <gordc> ildikov: but yeah, i think the idea is to come up with what we want to test.
15:08:18 <ildikov> gordc: I asked Gnocchi as we plan to move to that API soon I guess, etc. so it would be nice to see what it can handle
15:08:19 <gordc> just bringing it up now so you have a few days/weeks to think about it.
15:08:30 <ildikov> gordc: +1
15:08:54 <nadya> gordc: you have hardware or OpenStack env? you asked 'how deply on this env', what we need to deploy?
15:09:03 <gordc> ildikov: yep. or we can do multiple storage as well. just difference scenarios.
15:09:26 <ildikov> gordc: if that's an option that would be even better
15:09:40 <gordc> nadya: intel-rax have a openstack env they are building
15:09:51 <KrishR> nadya: we can set up the OSIC cluster with whatever versions of ceilometer/gnocchi you want
15:10:03 <gordc> we just need to decide how to implement the ceilometer/aodh/gnocchi parts
15:10:11 <nadya> gordc, KrishR: ok, I see
15:11:22 <gordc> that's all i had on design summit.
15:11:26 <ildikov> gordc: yeap, I was thinking about that too, I mean having all three components in a setup, etc.
15:11:44 <gordc> ildikov: yeah, that's a good idea.
15:12:21 <gordc> just a reminder, the etherpads are live, so if you are leading/participating in one of the sessions. feel free to edit the etherpads
15:12:54 <gordc> i currently just copy/pasted stuff in. i'm going to use "i'm sick" excuse to justify laziness
15:13:15 * cdent gives gordc a cookie
15:13:35 <gordc> cookie cures nothing. but i'll take it.
15:13:50 <gordc> anyone else have items to add?
15:14:54 <gordc> #topic RDO needs/wants this fix (on liberty) to mongodb replica set handling: https://review.openstack.org/#/c/234254
15:15:05 <cdent> yeah that was me
15:15:30 <cdent> apparently there was no test coverage on that chunk and when rdo test day tried to use ?replicaset for ha in a ceilo deploy it didn't work
15:15:43 <cdent> they can workaround by going back to the deprecated method of using a conf setting
15:15:53 <cdent> but that's not got any shelf life
15:15:55 <gordc> cdent: did you want a rc3?
15:16:06 <cdent> so yeah the question is: what are the chances of an rc3
15:16:13 <gordc> because i think ttx just released stable/liberty this morning
15:16:33 <gordc> i'll need to check with ttx/dhellmann post meeting.
15:16:52 <gordc> but i don't think we can spin up another release candidate
15:16:55 <cdent> note that it is not a backport, which sort of weirds it up
15:17:31 <cdent> I guess from rdo's standpoint it doesn't really matter if it gets in a release, just that it will be release eventually, and they can manage the patch until then
15:17:43 <gordc> cdent: is this related to sileht's patch? i vaguely remember it being changed
15:17:46 <cdent> so having it merge asap, even if not released, would be nice
15:17:59 <gordc> cdent: kk.
15:17:59 <cdent> his patch for o.messaging?
15:18:03 <cdent> no
15:18:28 <gordc> no. i think he touched replicaset stuff but i could just be saying sileht because he touches everything
15:18:32 <cdent> the messaging thing is another topic we probably ought to work out: does that cause release crazy?
15:18:37 <cdent> it's true he does
15:18:45 <cdent> I think he is an aggregate
15:19:08 <gordc> :)
15:19:20 <ildikov> cdent: lol :)
15:19:21 <ttx> obviously too late for a rc3
15:19:29 <ttx> since the release is out
15:19:37 <gordc> ttx: thanks for confirmation.
15:20:14 <gordc> cdent: yeah so i guess we'll get it in next stable/liberty
15:20:16 <ttx> yesterday was the last day for respins. Today is final tagging day. FYI it takes 7 hours to go through everything
15:20:48 <ttx> gordc: you can issue a point release early next week if necessary
15:20:56 <cdent> gordc: not a problem, do we happen to know when we'll be able to merge that so it is present on the branch?
15:20:57 <gordc> ttx: i got 200emails from you this morning. that's why i knew it was done
15:21:21 <gordc> ttx: sounds good. i'll sync up with you folks when we want next point release.
15:22:07 <gordc> cdent: i think once ttx tags everything we can merge it in.
15:22:14 <cdent> roger
15:22:23 <gordc> i don't really have a problem with it not being in master (since it's not needed)
15:22:50 <ildikov> I'm sure it's not the first cacse it happens
15:22:51 <cdent> good
15:23:48 <gordc> cdent: you're required to provide an envelope when you add stuff to stable that aren't backports.
15:23:56 <gordc> you decide what is in the envelope.
15:24:16 <cdent> for you, I say tissues
15:24:26 <ildikov> gordc: I guess cookies :)
15:24:43 <gordc> both are good options given current state.
15:25:20 <gordc> #topic meeting next week?
15:25:25 <cdent> no
15:25:29 <gordc> hahaha
15:25:38 <ildikov> cdent: that was fast :)
15:25:56 <gordc> i won't be available either as i'll be travelling
15:26:01 <ildikov> gordc: if we sorted out everything for the design summit, which seems to be the case, I'm fine if we cancel next week
15:26:19 <nadya> have a great rip, folks!
15:26:24 <nadya> *trip
15:26:30 <gordc> do we want to tentatively schedule one but cancel if nothing comes up next few days?
15:26:39 <gordc> nadya: thanks!
15:26:41 <ildikov> nadya: thanks!
15:27:08 <gordc> ildikov: do you want to lead it next week if we do have one?
15:27:32 <gordc> i think if nothing gets raised in mailing list by next tuesday, we can cancel.
15:27:39 <ildikov> gordc: I'm available, so I can do that if needed
15:27:46 <gordc> ildikov: great.
15:27:57 <liusheng> should need a mail thread to inform this cancelation ?
15:28:08 <gordc> i'm pretty sure it'll be cancelled since i know quite a few people will be away
15:28:37 <ildikov> gordc: yeap, I think it's ok if we wait until Tuesday as you said and then send a mail
15:28:38 <gordc> liusheng: i can send an email if/when we officially cancel.
15:29:17 <llu-laptop> about the meeting, forgive me if I missed the email, any conclusion about the alternative meeting time?
15:29:49 <cdent> I think it didn't reach a conclusion
15:29:58 <gordc> llu-laptop: that was just an internal query i had.
15:30:26 <gordc> llu-laptop: is there a specific time that works better for APAC?
15:31:40 <llu-laptop> i'm getting used to this time, but I can't speak on behalf of others
15:31:48 <gordc> llu-laptop: ack
15:31:58 <gordc> llu-laptop: i'll add a thread regarding this
15:32:20 <gordc> i think ultimately we still want to make the ML play a more important role
15:32:30 <llu-laptop> gordc: agreed
15:32:36 <liusheng> +1
15:33:16 <gordc> #action gordc send email regarding modes of communication.
15:33:40 <gordc> #topic open discussion
15:34:09 <cdent> do we need to talk about dealing with o.messaging or is that under control?
15:34:15 <cdent> (especially the liberty parts)
15:34:37 <gordc> cdent: i got the requirements patch to block 2.6.1 approved
15:34:50 <gordc> i take it it needs to be backported to liberty as well
15:34:56 <cdent> presumably
15:35:21 <gordc> cdent: kk. i'll get that looked at as well.
15:35:21 <liusheng> it will need may "recheck" latter :)
15:35:31 <liusheng> s/may/many/
15:35:45 <gordc> liusheng: yeah, definitely
15:36:12 <gordc> is there a backport for liberty already?
15:36:35 <cdent> I don't know.
15:36:50 <cdent> liusheng, you know?
15:37:03 <liusheng> cdent: no
15:37:46 <gordc> ok. i'll be offline for a meeting next hour or so. if there's no backport when i get back, i'll do it and raise it
15:38:07 <gordc> we'll need to wait for all the tags to be finished/merged though.
15:39:41 <gordc> all's good? final countdown.
15:40:43 <gordc> thanks folks.
15:40:51 <gordc> see you in Tokyo.
15:40:52 <ildikov> thanks
15:40:56 * cdent waves
15:40:57 <ildikov> see you in Tokyo!
15:41:03 <gordc> #endmeeting