15:01:22 <gordc> #startmeeting ceilometer
15:01:23 <openstack> Meeting started Thu Nov 12 15:01:22 2015 UTC and is due to finish in 60 minutes.  The chair is gordc. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:27 <openstack> The meeting name has been set to 'ceilometer'
15:01:45 <gordc> i got to figure out what happens when i rename this ^
15:02:53 <zqfan> good evening :)
15:03:10 <gordc> ... hmmm. i probably should've checked who wasn't at the OPNFV conference or holidays
15:03:35 <gordc> i'm going to give this a few mins
15:04:50 <llu-laptop> o/
15:05:21 <ityaptin> Hi!
15:05:22 <llu-laptop> in trainings, might be slow in response
15:05:34 <cdent> o/
15:05:36 <pradk> o/
15:05:40 <cdent> I say o/, but really I completely forgot
15:05:58 <gordc> shakes head
15:06:21 <gordc> we have a 'smaller' group because of conference and pto
15:06:39 <gordc> let's start and have quick meeting
15:06:53 <gordc> #topic summit roundup
15:07:18 <gordc> i summarised most of the items we came out of conference with
15:07:18 <gordc> http://lists.openstack.org/pipermail/openstack-dev/2015-November/078461.html
15:07:24 <gordc> thanks for all the input
15:07:36 <gordc> you can sign up for stuff here: https://etherpad.openstack.org/p/mitaka-telemetry-todos
15:07:58 <gordc> most of the items have owners... everything else i'll just move to roadmap
15:08:09 <gordc> #action gordc clean up roadmap
15:08:25 <gordc> any other items regarding summit?
15:08:53 <gordc> none? cool.
15:09:05 <gordc> #topic marketing 101: rebranding
15:09:29 <gordc> for those interested, this patch landedhttps://review.openstack.org/#/c/240809/
15:09:35 <gordc> #link https://review.openstack.org/#/c/240809/
15:10:07 <gordc> so basically the aodh/ceilometer/gnocchi collective is called telemetry now
15:10:20 <pradk> nice
15:10:29 <cdent> meet the new boss? same as?
15:10:52 <gordc> nothing really changes... just that when people say ceilometer, you'll probably want to ask whether they mean ceiloemter or the collective telemetry project
15:11:12 <gordc> something we probably should've been asking anyways.
15:11:19 <pradk> is the channel name change etc in order?
15:11:19 <llu-laptop> gordc: seems https://wiki.openstack.org/wiki/Telemetry not exsiting?
15:11:25 <gordc> i'll send an email regarding everything
15:11:31 <gordc> i need to do some admin work
15:11:34 <pradk> mailing list name
15:11:41 <gordc> pradk: yes, i need to do that
15:11:49 <pradk> or that remains the same? mailing list?
15:11:56 <gordc> re: irc channel. that will be today if i get help from infra
15:12:02 <pradk> cool
15:12:03 <gordc> llu-laptop: i'll adjust taht as well.
15:12:32 <gordc> llu-laptop: we probably won't be able to redirect ceilometer to telemetry like we did for metering to ceilometer
15:12:52 <gordc> but i'll move stuff accordingly and set up links
15:13:04 <gordc> #action redirect irc channel
15:13:14 <gordc> #action setup telemetry wiki
15:13:27 <gordc> regarding mailing list tag
15:14:02 <pradk> [Telemetry][ceilometer/gnocchi/aodh] ?
15:14:03 <gordc> i've been adding [telemetry] just because... but i think we should start adding it if the scope of topic creeps beyond just a single project.
15:14:20 <pradk> makes sense
15:14:33 <gordc> we should probably just have [ceilometer] or [gnocchi] or [aodh] if it's just the one.
15:15:07 <gordc> any other items we should look at regarding new team name?
15:15:40 <llu-laptop> https://wiki.openstack.org/wiki/Meetings/Ceilometer should change or not?
15:16:08 <gordc> llu-laptop: yeah, that one we can probably redirect to Meetings/Telemetry
15:16:16 <jd__> gordc: so next time that meeting should be telemetry :p
15:16:43 <gordc> jd__: yep... i just didn't put telemetry because i didn't know where the hell the log would go to
15:17:02 <jd__> gordc: in a new blackhole
15:17:35 <llu-laptop> I'm also wondering how this would affect all the documentations, admin manual/config reference, and http://docs.openstack.org/developer/ceilometer/
15:17:38 <gordc> jd__:  seems like if you startmeeting it'll just get dumped in http://eavesdrop.openstack.org/meetings/
15:17:43 <gordc> i'll use telemetry next time.
15:18:27 <gordc> llu-laptop: the dev docs have always been project specific... so i don't really see anything changing there.
15:18:46 <gordc> i don't think we actually reference ceilometer outside dev docs.
15:18:53 <gordc> the admin guide says telemetry already
15:19:47 <gordc> i think a lot of it is already set up because of the failed Project names change from a while back.
15:20:18 <gordc> we just need to adopt the project name as our 'code name' now...
15:20:32 <jd__> what does that mean?
15:21:14 <gordc> i think ceilometer was originally the 'codename' back when they tried to create project names.
15:21:45 <jd__> I think this all disappeared with big tent
15:21:52 <jd__> there's only projects and teams now
15:21:57 <gordc> but project names are dead so yeah... basically the project name stuff hid a lot of the ceiloemeter/aodh branding anyways so we should have less stuff to do from public facing pov
15:22:10 <gordc> jd__: right
15:22:10 <jd__> I don't think we need to do anything more
15:22:17 <jd__> we are the telemetry team, we produce 3 projects
15:22:21 <jd__> and we love each others
15:22:28 <jd__> isn't that enough?
15:22:34 * jd__ hugs everyone
15:22:48 <gordc> jd__: yep. well i just need to create the 'telemetry' version of dev docs
15:22:54 <gordc> s/docs/wiki/
15:23:01 <gordc> we still only have 'ceilometer' wiki
15:23:57 <gordc> jd__: was your comment that we should only have one wiki 'telemetry' and ceilometer/aodh/gnocchi all are subsections of it?
15:24:14 * cdent sends jd__ flowers
15:24:51 <jd__> gordc: sounds like a good idea but I don't remember saying that
15:24:59 <jd__> though since it's a good idea that might be me
15:25:05 <jd__> :->
15:25:48 * gordc has short term memory
15:25:55 <gordc> let's do that then.
15:26:09 <gordc> any other items we think we need to address during changeover?
15:27:10 <jd__> I think we're good
15:27:15 <gordc> #topic client release schedule
15:27:49 <gordc> we keep saying release often but then i forget...
15:28:12 <gordc> so thoughts on me just blindly releasing client/lib every 2 weeks (as long as there was a change)
15:28:58 <cdent> +1
15:29:09 <jd__> wfm
15:29:14 <gordc> aight, well i'm just going to release every 2 weeks then and see if it's actually feasible based on release process
15:29:16 <cdent> (in fact I think it would be awesome if we did that for the servers too but that's a different topic)
15:29:20 <jd__> as long as stick to semver :]
15:29:31 <jd__> cdent: you mean like Gnocchi does?
15:29:37 <gordc> if this blows up, i share blame with all
15:29:40 <cdent> faster than gnocchi!
15:29:47 <jd__> cdent: awesome!
15:29:59 <cdent> and release to pypi!
15:30:02 <gordc> cdent: we can release aodh whenever we want as well
15:30:06 <jd__> cdent: that we do
15:30:14 <gordc> do we want that say every month?
15:30:17 <cdent> I guess ceilometer is really starting to feel very legacy
15:30:27 * jd__ nods
15:30:45 <jd__> cdent: Nova is feeling legacy
15:30:51 * jd__ laughs and drinks to that
15:30:53 <gordc> stop trying to be the cool kids
15:30:59 * jd__ auto-slaps
15:31:11 <jd__> yes boss
15:31:27 <gordc> :)
15:31:51 <gordc> so frequent (monthly) aodh releases as well?
15:32:38 <gordc> err.. ok, i'll just wait for big features for releases
15:32:55 <gordc> we all good?
15:33:01 <cdent> it appears so
15:33:33 <gordc> #topic open discussion
15:34:06 <jd__> I plan to send in a few minutes a mail to tell people to stop opening bugs for (trivial) fixes they send just after
15:34:13 <jd__> like "typo in toto.rst" "here's the patch"
15:34:41 <cdent> Am I correct that people do that to keep the stats pretty?
15:34:42 <gordc> rage away.
15:34:50 <jd__> cdent: I don't know
15:35:01 <gordc> cdent: free tickets!
15:35:03 <jd__> I think some projects have also pushed bureaucracy to that level
15:35:13 <llu-laptop> yes, I believe they have pressure from upper management to have bug/patch #
15:36:00 <gordc> but yeah, i'm cool if you mark those items invalid
15:36:11 <pradk> llu-laptop, mgmt cares about what goes upstream? ;)
15:37:01 <llu-laptop> maybe not CxO, but middle management and their direct manager(1st line) do cares
15:37:36 <llu-laptop> hear several stories about these situations from those poor guys, different companies
15:38:00 <jd__> http://paste.openstack.org/show/0T8t1eTyAeT9GSyTaCXq/ that's my draft if you want to have a look before I send
15:38:37 <jd__> llu-laptop: we'll tell them to send management to us, we'll take care :p
15:38:45 <gordc> llu-laptop: switch companies
15:38:54 <jd__> gordc++
15:39:03 <gordc> jd__: you sending it to [all] or [telemetry]
15:39:16 <jd__> *kff* *koff* we hire *koff* *koff*
15:39:23 <jd__> gordc: [telemetry]
15:39:24 <pradk> if we make that draft more generic, it could be a "popcorn thread"
15:39:25 <llu-laptop> jd__: yeah, if we send out the message clearly and loud, it would help those guys to confront their managers too
15:39:25 * gordc wants to see how much rage jd__  has
15:39:38 <jd__> gordc: [all] does not exist anymore
15:39:49 <gordc> pradk: my thoughts exactly.
15:39:59 <jd__> you trolls
15:40:05 <cdent> Yeah, I think [all] would make for great popcorn
15:40:16 <jd__> well feel free to redirect to [all]
15:40:19 <jd__> I won't
15:40:27 <jd__> maybe I wish you do, but I won't do it
15:40:29 <gordc> jd__: booo
15:40:33 <pradk> hehe
15:41:09 * jd__ . o O (damn this channel is logged)
15:41:11 <gordc> jd__:  it works for me. very political
15:41:19 <jd__> gordc: I progress
15:41:34 <jd__> this is 3rd version
15:41:40 * jd__ laughs
15:41:46 <gordc> lol i do that too.
15:42:22 <gordc> other rage topics?
15:43:27 <jd__> I don't think this meeting is long enough
15:43:30 <jd__> so I'm good
15:43:37 <gordc> harsh bro.
15:43:45 <gordc> thanks everyone.
15:43:52 <gordc> #endmeeting