21:00:23 <alaski> #startmeeting cells
21:00:23 <openstack> Meeting started Wed Apr 15 21:00:23 2015 UTC and is due to finish in 60 minutes.  The chair is alaski. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:27 <openstack> The meeting name has been set to 'cells'
21:00:33 <alaski> anyone around to talk cells?
21:00:34 * bauzas waves
21:00:37 <bauzas> \o
21:00:41 <belmoreira> o/
21:00:50 <alaski> awesome
21:00:52 <dansmith> o/
21:01:01 <alaski> #topic Cells v1 Tempest testing
21:01:14 <alaski> so there's been good progress here
21:01:18 <bauzas> well well well
21:01:26 <alaski> down to 3/4 failures depending on the run
21:01:42 <bauzas> but we're hitting Pareto law
21:02:42 <alaski> I want to make a suggestion, which is let's open a bug for each remaining failing test, and blacklist it
21:02:53 <alaski> and then work towards fixing it
21:02:59 <bauzas> agreed
21:03:25 <bauzas> because I took 6 hours for working on a bug without getting more than just it doesn't work
21:03:52 <alaski> I have been trying to work on that locally, but the ec2 tests are not happy with my env
21:04:46 <alaski> I have to run after this meeting, but I will tackle opening bugs and blacklisting in the morning if no one beats me to it
21:05:20 <alaski> #action someone open bugs for remaining test failures and blacklist them in devstack
21:05:24 <bauzas> alaski: yeah we need to greenify the job because if not, it would be a whack-a-mole
21:05:30 <alaski> agreed
21:05:44 <alaski> anything else on testing?
21:06:00 <dansmith> +1 on the plan :)
21:06:01 <bauzas> I saw you opening a change
21:06:11 <bauzas> about a bug too
21:06:18 <bauzas> alaski: ^
21:06:19 <alaski> dansmith: cool
21:06:25 <alaski> bauzas: https://review.openstack.org/#/c/173513/ ?
21:06:42 <bauzas> indeed
21:06:52 <bauzas> oh no
21:06:55 <bauzas> sec
21:06:56 <alaski> that's more a missing feature than a bug
21:07:07 <bauzas> https://review.openstack.org/#/c/173502/
21:07:24 <alaski> oh, right
21:07:47 <bauzas> sounds like trivial
21:07:51 <alaski> that's not related to a test failure.  though I'm now thinking it should cause a failure so we're missing a test
21:08:13 <bauzas> yeah that's my question
21:08:26 <bauzas> do we need to add a functional test ?
21:08:32 <alaski> we should
21:08:46 <alaski> the failure is trying to snapshot a bfv instance
21:09:12 <bauzas> it wasn't clear if the bug was fixing a blacklisted failure or something which was not already covered
21:09:32 <alaski> yeah, it may already be there and just be skipped for another reason
21:09:49 <alaski> #action look into tempest test for snapshotting a bfv instance
21:10:09 <bauzas> okay, I don't want to block the patch for that reason, but I thought we should be looking at that
21:10:20 <bauzas> cool
21:10:29 <alaski> definitely
21:10:38 <alaski> anything else?
21:10:41 * bauzas is a bit slow tonight
21:11:18 <alaski> #topic Specs
21:11:42 <alaski> so same specs as before
21:11:57 <alaski> I've been a bit behind on getting new ones written up
21:12:26 <alaski> I've gotten some comments that make it clear that people have very different ideas on some of these things
21:13:03 <alaski> I've tried to respond to everything now
21:13:26 <alaski> and I'll iterate the specs soon
21:13:32 <belmoreira> I just add my comments
21:13:53 <alaski> https://review.openstack.org/#/c/141486/ https://review.openstack.org/#/c/136490/ https://review.openstack.org/#/c/169901/
21:13:56 <alaski> for the record
21:14:00 <alaski> belmoreira: thanks
21:14:47 <bauzas> alaski: do you plan to iterate soon, or should we continue discussing meanwhile in the spec ?
21:15:13 <alaski> bauzas: continue in the spec.  I'm not planning anything drastically different yet
21:15:22 <bauzas> okay
21:15:33 <alaski> the scheduling one will likely change a lot, but not in unexpected ways I hope
21:15:52 <bauzas> for the records, I'm working on providing a spec for a scaling-out sched
21:15:54 <alaski> the other big one is how to represent an instance before it's in the instance db in a cell
21:16:24 <belmoreira> bauzas: great
21:17:12 <alaski> bauzas: I would be interested in your comments on the discussion between zz_johnthetubagu and I on https://review.openstack.org/#/c/169901/
21:17:22 <alaski> as I think it relates to scaling out the scheduler
21:17:37 <bauzas> alaski: sure thing
21:18:03 <bauzas> alaski: I just need time, so greenify the cells job would help me :)
21:18:26 <alaski> bauzas: understood
21:18:44 <alaski> it would help me too :)
21:19:11 <bauzas> alaski: by saying "how to represent an instance before it's in the child db", you meant https://review.openstack.org/#/c/136490/ ?
21:19:29 <alaski> dansmith: I know you're a busy person, but would love your input on the specs as well
21:19:40 <alaski> there's no rush though
21:20:00 <dansmith> okay, I fell underqualified to really comment on the scheduling one
21:20:07 <alaski> bauzas: https://review.openstack.org/#/c/169901/
21:20:09 <dansmith> but I'll try to make a point to hit them all in some form soon
21:20:30 <alaski> dansmith: sure.  I'm less concerned on that one as there will be a lot of eyes on it
21:20:40 <bauzas> my biggest concern is how we can iterate over all the specs for Liberty while we're working on the sched too, but I guess all of that will be fixed by Vancouver end
21:21:01 <bauzas> alaski: oh, that one
21:21:15 <dansmith> okay
21:21:24 <bauzas> alaski: well, I would like to see the RequestSpec object BP merged for L-1 or L-2
21:21:41 <bauzas> alaski: https://review.openstack.org/#/c/173316/ as a reference
21:22:07 <bauzas> alaski: because then, it would be nested to persisting it for the cells duty
21:22:39 <bauzas> and we know how we need to persist that spec :)
21:22:52 <alaski> bauzas: okay.  I'll match up what's in there versus what we'll need for the api and comment
21:23:05 <bauzas> alaski: cool, that's an already approved spec
21:23:13 <bauzas> alaski: so I expect a fast approval
21:23:22 <bauzas> alaski: I should bummer zz_johnthetubagu
21:23:37 <alaski> bauzas: okay, I'll look soon :)
21:24:00 <bauzas> alaski: anyway, that's related, not dependent for the cells
21:24:06 <alaski> bauzas: but even if it doesn't have everything we should be able to avoid duplicating that
21:24:08 <bauzas> alaski: so it's a nice to have
21:24:18 <bauzas> agreed
21:24:54 <alaski> any more on specs?
21:25:21 <alaski> #topic Open Discussion
21:26:08 <alaski> I don't have anything more to discuss :)
21:26:15 <bauzas> crickets ?
21:26:39 <alaski> yep, let's call it
21:26:50 <alaski> thanks everyone!
21:26:54 <alaski> #endmeeting