17:01:51 <gnuoy> #startmeeting charms
17:01:52 <openstack> Meeting started Mon Oct  3 17:01:51 2016 UTC and is due to finish in 60 minutes.  The chair is gnuoy. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:53 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:55 <openstack> The meeting name has been set to 'charms'
17:02:01 <gnuoy> #topic Review ACTION points from previous meeting
17:02:13 <icey> o/
17:02:14 * gnuoy gnuoy update charm guide with refactored charms_openstack bits
17:02:31 <gnuoy> inprogess, expect a pull request rsn
17:02:37 * gnuoy jamespage review current newton specs against plan
17:02:38 <cholcombe> o/
17:02:45 <jamespage> yeah still tod
17:02:48 <beisner> o/.
17:02:53 <gnuoy> ack
17:02:56 <jamespage> we have quite alot of charm stuff done, but we're missing mojo specs etc...
17:02:56 * gnuoy gnuoy to make list of chairs and schedule
17:02:59 <gnuoy> Done!
17:03:05 * gnuoy jamespage to identity alternate week slot and get scheduled
17:03:33 <beisner> i still owe the charm-guide a test section update
17:03:34 * jamespage is doing badly this week
17:03:37 <jamespage> apologies
17:03:46 <gnuoy> np
17:04:03 <gnuoy> #topic State of Development for next Charm Release
17:04:15 <gnuoy> we're in the deep freeze
17:04:37 <gnuoy> We have a fix for the mojo newton flavor bug up for review
17:05:12 <beisner> i'll be focusing on the update-amulet-defs batch:  decided to take on the pxc-instead-of-mysql in that so we're actually in control of those entirely.
17:05:19 <gnuoy> I'm stepping back from the mojo/tempest integration for the moment because I can't make tempest run in python2.7 mode and some tests seem to be bust on python 3
17:05:20 <beisner> thx for doing that gnuoy
17:06:02 <beisner> the flavor thing and the spike on the tempest charm.  i'd say, let's proceed with our tempest from a venv approach and continue to improve the tempest charm after 16.10.
17:06:05 <gnuoy> oh, and jamespage has some late newton fixes from ceilometer and aodh I believe
17:06:15 <gnuoy> beisner, +1
17:06:30 <jamespage> I do
17:06:52 <gnuoy> cholcombe, icey how are things from a storage pov?
17:07:10 <icey> testing is slow but ongoing
17:07:22 <gnuoy> ack
17:07:24 <cholcombe> gnuoy, we've got to squash a juju storage bug that popped up on aws
17:07:30 <cholcombe> among other things
17:07:34 <beisner> cholcombe, icey ceph-mon got love on this, but ceph needs love too:  https://bugs.launchpad.net/charms/+source/ceph/+bug/1628322
17:07:36 <openstack> Launchpad bug 1628322 in ceph (Juju Charms Collection) "charm upgrade from 16.07 to master fails" [High,In progress] - Assigned to Chris MacNaughton (chris.macnaughton)
17:07:38 <gnuoy> aws is dead to me :)
17:07:42 <icey> beisner: ack
17:07:53 <beisner> i think that should be high prio
17:08:03 <cholcombe> beisner, ceph charm should get equal love because the upgrade code is moved to a central lib now
17:08:14 <icey> cholcombe: that one is a new hook though
17:08:19 <beisner> cholcombe, does it just need a resync?
17:08:33 <beisner> i confirmed that our charm upgrade mojo spec is still failing over the weekend
17:08:48 <cholcombe> ok
17:08:52 <icey> beisner: just with the ceph charm or with ceph-mon as well?
17:08:53 <beisner> so since it bails on ceph failing early, we don't have a good view of the charm upgradability of the other charms
17:09:00 <beisner> the spec only uses ceph
17:09:35 <gnuoy> Anyone got anymore zOMG 16.10 blockers?
17:09:37 <thedac> should ceph-osd be swapped in for ceph in the spec?
17:09:51 <cholcombe> thedac, ideally yes
17:10:06 <beisner> well, we have to be careful there.  in my mind, until there is an upgrade story of some sort for ceph --> ceph-mon, we get to test both
17:10:14 <icey> I agree with beisner
17:10:21 <icey> ideally, I'd like to see some mojo specs with both
17:11:05 <cholcombe> ok
17:11:11 <gnuoy> Any actions I should minute from the above?
17:11:12 <beisner> actually re: charm upgrades, idea i'm kicking around:  similar to our charm-single deploy test, we could have a new runner that does a single charm upgrade test.  lightweight, cheap, and run it daily against master throughout each cycle so we have earlier notice.
17:11:29 <gnuoy> beisner, sounds good
17:11:33 <beisner> action me on that if it's not a crazy idea :-)
17:11:49 <gnuoy> beisner, maybe with a db in there so we catch schema migrations failures ?
17:12:07 <beisner> yep, some such.  worth discussing a bit before taking it on.
17:12:26 <gnuoy> #action beisner regular upgrade tests
17:12:40 <gnuoy> ok, anymore zOMG bugs?
17:12:52 <beisner> so, to be clear, we now have the charm upgrade tests running weekly
17:12:57 <beisner> as of last week :-)
17:13:07 <gnuoy> tip top
17:13:09 <beisner> but it's the full deploy thingy
17:13:12 <cholcombe> excellent
17:13:31 <gnuoy> #topic https://review.openstack.org/#/c/372548
17:13:36 <beisner> any news on https://bugs.launchpad.net/charms/+source/ceph-osd/+bug/1604501 ?
17:13:37 <openstack> Launchpad bug 1604501 in ceph-osd (Juju Charms Collection) "ceph-osd fails to initialize when encrypt is enabled" [High,Confirmed] - Assigned to Chris Holcombe (xfactor973)
17:13:37 <gnuoy> jamespage, yours ^ ?
17:14:11 <jamespage> gnuoy, really?
17:14:17 <beisner> also re: 16.10 release, barbican-softhsm has a new problem:  https://bugs.launchpad.net/bugs/1629624
17:14:19 <openstack> Launchpad bug 1629624 in OpenStack Barbican SoftHSM Charm "amulet test fails with barbican-softhsm blocking on 'Charm installed and token store configured'" [Undecided,New]
17:14:27 <gnuoy> jamespage, did you not add it to the agenda?
17:14:36 <jamespage> gnuoy, maybe two weeks ago?
17:14:43 <gnuoy> jamespage, argh, copy/pasta aerror from previous
17:14:48 <gnuoy> yep
17:14:51 <gnuoy> moving on...
17:15:05 <gnuoy> #topic High Priority Bugs
17:15:13 <gnuoy> I think we;ve covered that tbh
17:15:35 <gnuoy> #topic Openstack Events
17:15:45 <beisner> can we touch on the 2 i just pasted?  ceph encryption and softhsm charm forever-blocked
17:15:51 <beisner> sorry, laggy over here
17:15:56 <gnuoy> beisner, sure
17:16:38 <beisner> https://bugs.launchpad.net/charms/+source/ceph-osd/+bug/1604501 is milestoned 16.10
17:16:41 <openstack> Launchpad bug 1604501 in ceph-osd (Juju Charms Collection) "ceph-osd fails to initialize when encrypt is enabled" [High,Confirmed] - Assigned to Chris Holcombe (xfactor973)
17:16:45 <gnuoy> beisner, tinwood isn't here but I'll prod him tomorrow on the barbican hsm one
17:16:49 <tinwood> tinwood is here
17:16:56 <tinwood> :)
17:16:57 <gnuoy> tinwood, no he isn't
17:17:07 <tinwood> I'll take the softhsm one
17:17:10 <gnuoy> ta
17:17:12 <beisner> hi tinwood :-) upon a fresh rebuild, barbican-softhsm's amulet test shows it staying blocked
17:17:15 <beisner> thx tinwood
17:17:32 <gnuoy> #action tinwood Bug #1629624
17:17:33 <openstack> bug 1629624 in OpenStack Barbican SoftHSM Charm "amulet test fails with barbican-softhsm blocking on 'Charm installed and token store configured'" [Undecided,New] https://launchpad.net/bugs/1629624
17:18:13 <gnuoy> I think the plan was to fix Bug #1604501 for 16.10 wan't it?
17:18:14 <openstack> bug 1604501 in ceph-osd (Juju Charms Collection) "ceph-osd fails to initialize when encrypt is enabled" [High,Confirmed] https://launchpad.net/bugs/1604501 - Assigned to Chris Holcombe (xfactor973)
17:18:23 <gnuoy> or am I being naive ?
17:18:50 <beisner> that is what i understand re: discussion with cholcombe jamespage in daily last wk
17:19:08 <jamespage> yes
17:19:51 <gnuoy> cholcombe, are you actively working on that one ?
17:20:11 <cholcombe> gnuoy, i believe icey is
17:20:18 <gnuoy> kk
17:20:46 <icey> cholcombe: gnuoy there are 2 upstream bugs blocking on that one -_-
17:20:53 <gnuoy> ah, oh
17:21:01 <cholcombe> yeah it's kind of a mess
17:21:07 <gnuoy> not much we can do then I guess
17:21:30 <cargonza> icey, what are the bug Id please?
17:22:44 <gnuoy> Since we're low on time lets move on while icey goes on a bug id hunt
17:22:57 <cargonza> kk
17:23:20 <gnuoy> On the subject of Openstack Events we have a bunch of charm schools at ods among other things
17:23:26 <icey> https://github.com/ceph/ceph/pull/10382 and http://tracker.ceph.com/issues/17421 cargonza gnuoy
17:23:33 <gnuoy> icey, ta
17:23:42 <gnuoy> Monday day and Wednesday afternoon
17:24:07 <gnuoy> I believe tickets are going fast so if anyone wnats to attend theres probably a url somewhere
17:24:08 <cholcombe> i can dial in remote for them
17:24:32 <gnuoy> cargonza, do you have the url for registration?
17:25:05 <thedac> for general ODS registration https://www.openstack.org/summit/barcelona-2016/
17:25:13 <cargonza> that's it ^^
17:25:34 <gnuoy> ta
17:25:57 <cargonza> please get it done asap to avoid any issues.
17:26:20 <gnuoy> Anymore events before we move onto fish bowls?
17:26:40 <gnuoy> jamespage, happy with https://etherpad.openstack.org/p/ocata-charm-summit-planning ?
17:26:54 <jamespage> I think so
17:26:57 <gnuoy> kk
17:27:10 <jamespage> I have an action to get stuff plugged into the schedule from ttx - I'll get that done this week
17:27:23 <gnuoy> kk
17:27:31 <gnuoy> #topic docstrings and following the coding guidelines
17:27:35 <gnuoy> tinwood, you're up ^
17:27:43 <tinwood> ah, yes.
17:27:45 * gnuoy feels this is aimed my way :-(
17:27:52 * beisner ducks
17:28:09 <tinwood> I just wanted to remind folk and that 'significant' functions in python ought to have docstrings, and comments in general.
17:28:17 <thedac> Everyone but tinwood take a big step forward
17:28:18 <tinwood> I think we are sliding a little in that.
17:28:22 <tinwood> :)
17:28:33 <gnuoy> agreed
17:28:39 <tinwood> It really does help when trying to understand what's going on in a charm.
17:28:51 <thedac> +1
17:29:03 <tinwood> And remember to do a little code gardening if you get the chance.
17:29:08 <gnuoy> tinwood, I'm guilty of "non-of-the-other-functions-have-them-so-meh" and that is bad and I shall punish myself and disist
17:29:17 <tinwood> :)
17:29:23 <tinwood> that's the spirit.
17:29:46 <beisner> 'comments are lies waiting to happen' ;-)   no but really, it's just as important to update docstrings and stuff as new things land.
17:29:49 <gnuoy> thanks for the timely reminder tinwood
17:30:03 <gnuoy> #topic Open Discussion
17:30:35 <gnuoy> tinwood, you're up for chair next week looking at the rota. Obv.s arranage a sway if you can't make it
17:30:42 <gnuoy> s/sway/swap/
17:30:51 <tinwood> no that's good.
17:31:02 <gnuoy> anymore to openly discuss?
17:31:24 <tinwood> not from ne.
17:31:28 <gnuoy> Next meeting 17th October, same time, same place, chair is tinwood
17:31:28 <tinwood> me
17:31:44 <gnuoy> #endmeeting