17:03:43 <gnuoy> #startmeeting charms
17:03:44 <openstack> Meeting started Mon Nov 28 17:03:43 2016 UTC and is due to finish in 60 minutes. The chair is gnuoy. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:03:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:03:49 <openstack> The meeting name has been set to 'charms'
17:04:01 <gnuoy> #topic Review ACTION points from previous meeting
17:04:10 * gnuoy gnuoy determine which openstack release the ceilometer micro services will be introduced
17:04:23 <gnuoy> I did not do that. Carrying forward
17:04:27 * gnuoy jamespage to identity alternate week slot and get scheduled (carried forward)
17:04:42 <jamespage> I have a review raised - needs a fix but lemme check time
17:04:47 <gnuoy> You did that didn't you James ? ^
17:05:06 <jamespage> Mondays 1000 UTC
17:05:09 <jamespage> the other monday
17:05:12 <gnuoy> kk, thanks
17:05:18 * gnuoy all to read through the charm specs: http://specs.openstack.org/openstack/charm-specs/ (carried forward)
17:05:26 <gnuoy> I have no doubt that everyone has done that
17:05:31 <gnuoy> so I'll close that
17:05:36 * gnuoy jamespage allocate days in month for bug squashing. (carried forward)
17:05:57 <jamespage> failing misreably at that
17:06:07 <gnuoy> ok, np. I'll carry it forward
17:06:07 <jamespage> I was going to suggest the first thursday of every month?
17:06:11 <jamespage> how dows that sound?
17:06:13 <gnuoy> sure, +1
17:06:19 <wolsen> +1
17:06:21 <tinwood> +1
17:06:29 <thedac> +1
17:06:54 <gnuoy> kk, thanks everyone
17:07:18 <jamespage> ok I'll sen the note
17:07:20 <gnuoy> #topic State of Development for next Charm Release
17:07:53 <gnuoy> anyone have something they'd like to highlight?
17:08:08 <jamespage> sure we have three new charms inbound
17:08:19 <gnuoy> that is true
17:08:22 <jamespage> mistral, trove and murano (thanks gnuoy for raising the pc changes)
17:08:29 <gnuoy> np
17:08:32 <jamespage> and I think tinwood is almost there with manila landing
17:08:35 <jamespage> \o/
17:08:43 <tinwood> yes, manila is about to land
17:08:54 <beisner> there is the charm-helper update/sync which will be required for ocata support in the non-layer/reactive charms
17:08:56 <jamespage> oh and I need to loop in the cloudkitty charm developer - I want to get their charm into the project as well
17:09:07 <jamespage> I'll reply to his mail via the list!
17:09:31 <gnuoy> I need a pc change to pull in charm templates too fwiw
17:09:55 <jamespage> gnuoy, ++ pls
17:10:10 <jamespage> gnuoy, you're about to start on the memcache support for token caching right?
17:10:26 <gnuoy> Right, I'll be onto that tomorrow I hopw
17:10:29 <gnuoy> * hope
17:10:30 <jamespage> \o/
17:10:48 <gnuoy> ok, I'm about to move on if anyone wants to jump in before that...
17:11:02 <gnuoy> #topic High Priority Bugs
17:11:02 <beisner> we still have an outstanding issue where all src/layer charm repos are gate-blocked on a tox behavior change which now causes missing (undefined) tests to fail.
17:11:20 <beisner> everyone should take a sec and read the last comment here real quick: https://review.openstack.org/#/c/399299/
17:11:23 <gnuoy> beisner, to we have a pc change up to fix that?
17:11:52 <gnuoy> beisner, ah, ok
17:11:58 <beisner> which seems to say, that we will be forced to add a no-op shim for py27 in the charm repos instead of not-testing-py27 on python3-only charms /o\
17:12:14 <gnuoy> It's not ideal but *shrug*
17:12:37 <tinwood> I'm with gnuoy -- just put a comment in the tox.ini
17:12:52 <beisner> so although i did get the project configs sorted in a way where we can start moving charms to the python3 only bucket as they're ready, TC isn't there just yet.
17:13:25 <beisner> duct tape it is /o\ /o\
17:14:22 <jamespage> :(
17:14:28 <gnuoy> We've tripped over some bugs with Juju and secgroups and Juju and volumes.
17:14:28 <beisner> what the actual..
17:14:36 <gnuoy> #link https://bugs.launchpad.net/juju/+bug/1645298
17:14:36 <openstack> Launchpad bug 1645298 in juju "unable to removed units with attached storage with OpenStack Mitaka" [Undecided,New]
17:14:45 <gnuoy> #link https://bugs.launchpad.net/juju/+bug/1625624
17:14:46 <openstack> Launchpad bug 1625624 in juju-core "juju 2 doesn't remove openstack security groups" [Critical,Triaged]
17:14:59 <gnuoy> seem to be mitaka+ specific
17:15:44 <gnuoy> Anyone got any others bugs they'd like to highlight?
17:16:04 <gnuoy> ...
17:16:12 <gnuoy> #topic Openstack Events
17:16:35 <jamespage> PTG!
17:16:36 <gnuoy> jamespage, You've got one on Thursday, right?
17:16:38 <jamespage> Feb 20th
17:16:41 <jamespage> oh yes
17:16:46 <jamespage> OpenStack Meetup in London
17:17:03 <jamespage> not speaking about charms specifically but will be doing a lighting talk on LXD containers in OpenStack
17:17:31 <tinwood> Sounds good.
17:17:37 <beisner> jamespage, can you talk py27 retirement with tc as ptl? with our py3 push, we'll need a clear path forward.
17:17:48 <jamespage> I can
17:17:52 <jamespage> gnuoy, pls action me
17:17:53 <beisner> many thanks
17:18:08 <gnuoy> #action jamespage talk py27 retirement with tc as ptl
17:18:24 <jamespage> ta
17:18:26 <gnuoy> #topic Open Discussion
17:18:40 <beisner> jamespage, "just think of the virtualenvs you won't have to build for no-ops" ;-)
17:20:01 <gnuoy> anything to openly discuss before i end the meeting?
17:20:23 <gnuoy> ...
17:20:31 <gnuoy> #endmeeting