17:01:56 <wolsen> #startmeeting charms
17:01:57 <openstack> Meeting started Mon Jan 23 17:01:56 2017 UTC and is due to finish in 60 minutes.  The chair is wolsen. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:58 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:02:01 <openstack> The meeting name has been set to 'charms'
17:02:09 <wolsen> okay great, lets get this party started
17:02:13 <gnuoy> \o/
17:02:42 <wolsen> #topic Review ACTION points from previous meeting
17:02:43 <tinwood> o/
17:02:48 <icey> o/
17:02:56 <wolsen> let's see, actions carried from last meeting
17:03:01 <wolsen> #subtopic ACTION: jamespage    allocate days in month for bug squashing. (carried forward)
17:03:06 <cargonza> o/
17:03:11 <jamespage> done - first thursday of every month
17:03:16 <wolsen> perfect
17:03:23 <wolsen> #subtopic ACTION: jamespage    talk py27 retirement with tc as ptl
17:03:35 <wolsen> how are we with that?
17:03:42 <cholcombe> o/
17:03:49 <jamespage> need to dig into that more - I think we have a general policy being applied to core projects, which might not be applicable to the charms anyway
17:03:54 <beisner> ooo yah, we cannot use py3-only projects atm, due to a gate hard requirement for py27 unit tests.
17:03:55 <jamespage> so c/f
17:04:02 <jamespage> :(
17:04:05 <wolsen> okay, so we'll carry that action forward
17:04:22 <wolsen> #subtopic ACTION: cholcombe    close out bugs against ceph-fs
17:04:35 <wolsen> I don't know if cholcombe is here, icey ^^?
17:04:37 <cholcombe> wolsen, i got most of them.  i think there's 1 left
17:04:45 <wolsen> ah there you go - missed you cholcombe, sorry about that
17:04:51 <cholcombe> no worries
17:04:53 <wolsen> you know which one is left?
17:05:16 <cholcombe> let me find it
17:05:26 <cholcombe> https://bugs.launchpad.net/charm-ceph-fs/+bug/1640916
17:05:26 <openstack> Launchpad bug 1640916 in OpenStack Ceph-FS Charm "ceph-base layer and ceph-mds interface need to be in git/gerrit with other openstack bits" [High,Triaged] - Assigned to Chris Holcombe (xfactor973)
17:05:47 <wolsen> ah yeah that seems fairly important
17:05:49 <jamespage> yup those need to get into /openstack before we can release
17:05:55 <wolsen> yep
17:06:03 <wolsen> so we'll carry that one forward - cholcombe you have what you need to make progress on it?
17:06:11 <cholcombe> yeah shouldn't be a problem
17:06:19 <cholcombe> i just need to kick off a repo migration
17:06:24 <wolsen> #action cholcombe clouse out bugs against ceph-fs
17:06:34 <wolsen> okay great, good to know
17:06:41 <wolsen> and for good measure...
17:06:49 <wolsen> #action jamespage talk py27 requirement with tc as ptl
17:06:54 <jamespage> ta
17:07:02 <wolsen> ok, so I think that's all from the previous meeting
17:07:20 <wolsen> #topic State of Development for next Charm Release
17:07:32 <wolsen> looks like we have a tentative 17.02 charm feature freeze coming up on Feb 9
17:07:43 <gnuoy> yep, thats the badger
17:07:45 <beisner> i believe that is a now-solidified date
17:07:45 <wolsen> is that still tentative or can we lock it down
17:07:50 <wolsen> great!
17:07:58 <wolsen> and release is Fep 23
17:08:09 <jamespage> thats the ocata release week
17:08:18 <wolsen> okay then its settled
17:08:21 <jamespage> we're committed to line up on that so +2 weeks is the 9th
17:08:30 <wolsen> #agreed Feb 9 feature freeze
17:08:55 <wolsen> okay then, no big suprises there? we think we'll be ready?
17:09:19 <jamespage> yah
17:09:23 <wolsen> great
17:09:30 <wolsen> we'll move on to the next topic if nobody has anything further
17:09:35 <jamespage> we have a clear release policy now - anything that's not meeting that won't make the cut
17:09:48 <wolsen> \o/ I like that policy
17:09:57 <wolsen> #topic High Priority Bugs
17:10:07 <thedac> I'll highlight the need to have any check for an IP go through network-get in the new world of Spaces: https://bugs.launchpad.net/ubuntu/+source/juju-core/+bug/1657305
17:10:07 <openstack> Launchpad bug 1657305 in percona-cluster (Juju Charms Collection) "percona cluster getting wrong private ip" [Critical,Confirmed]
17:10:30 <wolsen> thedac, is it just percona-cluster charm that needs that check?
17:10:33 <beisner> do we foresee re-wiring that across the board, now?
17:10:40 <thedac> We need to audit all of them
17:10:41 <wolsen> I thought I saw some chatter regarding ceph charms as well
17:10:42 <wolsen> ok
17:10:50 <beisner> instead of unit-get, that is?
17:11:16 <icey> wolsen: working on getting https://bugs.launchpad.net/charms/+source/ceph-osd/+bug/1520226 done today
17:11:16 <openstack> Launchpad bug 1520226 in swift-storage (Juju Charms Collection) "Don't run updatedb on storage locations" [High,In progress] - Assigned to Chris MacNaughton (chris.macnaughton)
17:11:31 <beisner> (network-get) seems like a must-do thing, given that recent behavior diff discovery
17:11:37 <wolsen> ah great icey, I can review it when it gets up if you like
17:11:51 <thedac> beisner: yes, We mostly use resolve_ip which uses network-get but we have one offs where unit-get is the first thing tried.
17:12:23 <coreycb> o/
17:12:33 <wolsen> any further bugs that need to be highlighted?
17:12:45 <wolsen> thedac - there's the rabbitmq work too
17:12:57 <wolsen> the cluster count stuff you were investigating
17:13:05 <thedac> Yes, rabbitmq and percona-cluster need to wait for cluster readiness before responding to client relations
17:13:09 <thedac> in progre3ss
17:13:15 <thedac> progress
17:13:26 <wolsen> ok
17:13:30 <wolsen> any other bugs before moving on?
17:13:45 <wolsen> #topic OpenStack Events
17:13:48 <jamespage> ok just a state
17:14:03 <jamespage> we have 7 critical and 73 high bugs open across the charms
17:14:16 <wolsen> ah jamespage, thanks for that - should have grabbed that
17:14:18 <jamespage> we should focus on those and spike next bug squash day
17:15:02 <thedac> Event: PTG in Atlanta Feb 20-24 https://www.openstack.org/ptg/
17:15:07 <wolsen> jamespage: want an action to continue to carry forward on that focus?
17:15:21 <jamespage> no need - it should be BAU
17:15:41 <jamespage> we have a charms room mon/tues
17:15:42 <wolsen> okay so PTG coming up, any other events?
17:15:50 <jamespage> and will be in atlanta the rest of the week
17:15:52 <gnuoy> Event: Juju charmers summit http://summit.juju.solutions/
17:15:58 <cargonza> Event: Openstack Summit in Boston, MA May 8 to 12
17:16:37 <cargonza> Event: Ops Meetup March 15 & 16 Milan Italy
17:16:44 <wolsen> a whole slew of events
17:16:45 <cargonza> https://wiki.openstack.org/wiki/Operations/Meetups
17:17:02 <wolsen> anything on charms slated for the ops meetups?
17:17:34 <wolsen> time for open mic night
17:17:38 <wolsen> #topic Open Discussion
17:17:53 <wolsen> anyone have anything to discuss?
17:18:17 <wolsen> going once...
17:18:40 <jamespage> I might try to get to the one in milan
17:18:59 <tinwood> :)
17:19:01 <wolsen> jamespage: that'd be a nice place to go I'm sure
17:19:06 <jamespage> :)
17:19:15 <thedac> Yes, very self-sacrificial of you
17:19:28 <wolsen> yeah way to take one for the team
17:19:30 <wolsen> :)
17:19:40 <wolsen> okay, looks like there's nothing else coming up
17:19:49 <beisner> thanks wolsen
17:19:50 <wolsen> next meeting starts same time on Feb 6 it looks like
17:20:03 <wolsen> and its either cargonza or jamespage to chair
17:20:11 <cargonza> I'll take it
17:20:15 <jamespage> ta
17:20:21 <jamespage> I think I'll be in Ghent maybe?
17:20:21 <wolsen> alright, cargonza will chair Feb 6
17:20:34 <wolsen> thanks everyone
17:20:36 <wolsen> #endmeeting