17:01:45 <cargonza> #startmeeting charms
17:01:46 <openstack> Meeting started Mon Feb  6 17:01:45 2017 UTC and is due to finish in 60 minutes.  The chair is cargonza. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:47 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:50 <openstack> The meeting name has been set to 'charms'
17:02:15 <icey> o/
17:02:27 <cargonza> #topic: Review ACTIONS points from previous meeting..
17:03:00 <cargonza> #action: jamespage talk py27 retirement with TC as PTL
17:03:40 <cargonza> #subtopic: jamespage talk py27 retirement with TC as PTL
17:03:58 <cargonza> anyone have an update?
17:04:13 <thedac> We have people at FOSDEM/cfgmgmtcamp so we are likely to miss updates on some of these.
17:04:23 <cargonza> ok... lets move on then...
17:04:41 <cargonza> #subtopic: cholcombe close bugs against ceph-fs
17:04:51 <cargonza> cholcombe, any update?
17:06:27 <cholcombe> o/
17:06:53 <cholcombe> cephfs-update you're waiting on?
17:07:00 <cargonza> ack
17:07:22 <cholcombe> well we have amulet tests on it
17:07:29 <cholcombe> they're passing they've landed
17:07:47 <beisner> cholcombe, reminder: need to go through this, confirm each is fix-committed, and update the bugs accordingly: https://bugs.launchpad.net/charm-ceph-fs
17:07:59 <cholcombe> beisner, ack
17:08:11 <cholcombe> yeah there's one last thing where the layer needs to be moved under openstack
17:08:25 <cargonza> #action: cholcombe to review https://bugs.launchpad.net/charm-ceph-fs and provide update for each item.
17:08:31 <cholcombe> will do
17:08:37 <beisner> cholcombe, that'll need to be proposed ASAP in order for ceph-fs to make the freeze/release cut.
17:08:54 <cholcombe> beisner, ok i'll start on it today
17:09:08 <cargonza> cholcombe: who do you need to help you to move the layer under open stack?
17:09:26 <cholcombe> cargonza, nobody. i just need to propose the goverance and project change
17:09:33 <cargonza> ok
17:09:35 <cholcombe> same exact thing the gluster charm is going through
17:09:48 <cargonza> ok
17:09:51 <cargonza> anything else?
17:10:14 <cholcombe> i'll look through those bug reports
17:10:47 <cargonza> k thx
17:10:53 <cargonza> lets move on...
17:10:55 <cargonza> #subtopic: jamespage to send out ether pad link to list for charms planning for mon/tues of PTG week.
17:11:25 <cargonza> I think this is done...
17:11:31 <cargonza> looking for the link
17:12:01 <cargonza> https://etherpad.openstack.org/p/openstack-charms-ptg-pike
17:12:16 <cargonza> lets move on...
17:12:42 <cargonza> #subtopic: all- brainstorm PTG schedule and objectives
17:13:02 <cargonza> any thoughts?
17:13:10 <thedac> I added the openstack-loadbalancer
17:13:20 <thedac> continued discussion ^^
17:13:51 <cargonza> thx thedac
17:14:10 <cargonza> all - please update the ether pad for topics to discuss... thx...
17:14:20 <cargonza> lets move on if nothing else...
17:14:30 <beisner> we will need to overcome the bundle vs. juju deploy vs. juju-deployer issues.  i anticipate further convo needed there.
17:14:52 <cargonza> please add it to the etherpad beisner...
17:14:56 <cargonza> thx!
17:14:58 <beisner> yep will do cargonza
17:15:27 <cargonza> #topic: STATE of Charm Development & Release
17:15:37 <thedac> Feature freeze this Thur, 2017-02-09, @EOB and 17.02 release on 2017-02-23
17:15:57 <cargonza> yup!
17:16:43 <cargonza> if there is nothing else, lets move on...
17:17:03 <beisner> fyi, i'll circulate a 17.02 release checklist later this wk, as in the past.
17:17:19 <cargonza> ok
17:17:44 <cargonza> next topic...
17:17:46 <cargonza> #topic: High Priority Bugs -  https://bugs.launchpad.net/openstack-charms
17:19:11 <cargonza> any insights? bug triage and fix should ramp up more after the 2/9, correct?
17:19:35 <beisner> generally only crit bugs get attention during freeze, correct?
17:19:45 <beisner> we just need to make sure that those are appropriately triaged.
17:20:04 <thedac> Critical bug list  http://j.tinyurl.com/jdn5hbv
17:20:19 <cargonza> ack..
17:21:29 <cargonza> ok lets move on -- we got a plan for critical bugs...
17:21:40 <beisner> hmm, thedac cargonza - that last link misses the new charms that aren't under juju charms collection LP project
17:21:41 <cargonza> #topic: Openstack Events
17:22:12 <cargonza> beisner, ack... lets correct it.
17:22:14 <thedac> beisner: you are right. We need a second link as it is a different LP project
17:22:45 <beisner> yep we do
17:23:02 <thedac> openstack-charms project version: http://j.tinyurl.com/zycpvyv
17:23:25 <cargonza> ok... thx... move on?
17:23:32 <thedac> yes
17:23:38 <beisner> woot thx thedac
17:23:54 <cargonza> #topic: Openstack Events Part 2
17:24:17 <cargonza> Charmer Summit is happening at the moment...
17:24:27 <beisner> thedac, cargonza, cholcombe - i'll elevate any release blockers in that ceph-fs list to crit for the purpose of tracking the release work
17:24:54 <cholcombe> beisner, ok
17:24:57 <cargonza> PTG project planned on 2/20 to 2/24
17:25:00 <cholcombe> beisner, there's a ipv6 bug that i need to solve
17:25:15 <thedac> #link https://www.openstack.org/ptg/
17:25:56 <cargonza> any other events?
17:26:55 <beisner> config mgmt camp underway right now :)
17:27:08 <beisner> but i think we already covered that
17:27:34 <cargonza> ok. lets move on...
17:27:50 <cargonza> #topic Open Discussion
17:28:02 <cargonza> anyone have new or old topics to discuss?
17:28:05 <bdx> hey, hows it going all? just wondering, is there any work being done to enable nova-lxd to use a ceph based backend?
17:28:20 <cargonza> bdx, ack there is...
17:28:38 <cargonza> working it in the 17.04 release
17:29:24 <bdx> cargonza: thats awesome! mind sharing some high level details of how that will happen?
17:30:22 <cargonza> I don't have the info at the moment. rockstar is currently working the design.
17:31:05 <bdx> nice, thx
17:31:48 <cargonza> I'll see if rockstar can reach out to you or I will have some info later in the week... I'll reach out to you directly...
17:32:04 <cargonza> it would be good to see if you have a use case we need to consider also.
17:32:30 <cargonza> any other items to discuss?
17:33:02 <cargonza> ok. then... lets end the meeting
17:33:13 <cargonza> thx all!
17:33:21 <cargonza> next chair is tinwood
17:33:36 <beisner> thx cargonza
17:33:43 <cargonza> on 2/20
17:33:43 <thedac> thanks, cargonza
17:33:46 <cargonza> #endmeeting