10:02:34 <tinwood> #startmeeting charms
10:02:35 <openstack> Meeting started Mon Mar 27 10:02:34 2017 UTC and is due to finish in 60 minutes.  The chair is tinwood. Information about MeetBot at http://wiki.debian.org/MeetBot.
10:02:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
10:02:38 <openstack> The meeting name has been set to 'charms'
10:02:55 <icey> hey folks
10:04:06 <tinwood> hi icey.  I'm just sorting out the agenda which seems to be backward.
10:04:26 * sparkiegeek waves
10:04:45 <icey> looks like https://etherpad.openstack.org/p/openstack-charms-weekly-meeting-20170327 is today?
10:05:01 <tinwood> agenda is at: https://etherpad.openstack.org/p/openstack-charms-weekly-meeting-20170327
10:05:30 <tinwood> yes, but it was a (bad) edit of the even week number.  Anyway, lets get going.
10:05:41 <tinwood> #topic Review ACTION points from previous meeting
10:05:47 <tinwood> o/ sparkiegeek
10:06:05 <tinwood> so, no minutes from the last meeting as we've not really got good at running them at this time.
10:06:29 <tinwood> I don't necessarily want to mix up the two meeting's actions unless someone wants to raise them here.
10:06:41 <icey> +1 tinwood
10:06:52 <tinwood> okay, then, moving on.
10:07:02 <tinwood> #topic State of Development for next Charm Release
10:07:21 <tinwood> any comments/notes for this topic?
10:07:40 <Dmitrii-Sh> 1 comment but it is not directly related
10:07:50 <Dmitrii-Sh> network binding changes for already deployed charms
10:08:05 <Dmitrii-Sh> this is general but for openstack it might make sense
10:08:17 <tinwood> How so?
10:08:39 <Dmitrii-Sh> one example I have is a charm that gets an upgrade that requires a binding for one of the endpoints
10:08:54 <tinwood> ah, so this is on upgrades
10:09:12 <tinwood> Are we missing something from documentation.  (i.e. on upgrades or anything else)?
10:09:29 <tinwood> or does it just not work.
10:09:29 <Dmitrii-Sh> no, this is something that is not implemented in juju as of now
10:09:45 <tinwood> ?
10:09:49 <Dmitrii-Sh> I though it might be worthwhile to point it out here and push for that feature
10:09:58 <icey> thanks Dmitrii-Sh
10:10:21 * tinwood is confused.
10:10:34 <tinwood> Is this a juju 1 vs 2 issue
10:10:35 <tinwood> ?
10:10:50 <icey> it sounds like Juju doesn't support changing network bindings on upgrade Dmitrii-Sh  ?
10:11:04 <Dmitrii-Sh> icey: yes, valid for any juju version
10:11:36 <tinwood> I didn't know this. Does that mean bindings are fixed at deploy/add-unit stage?
10:11:56 <Dmitrii-Sh> tinwood: yes, at deploy stage
10:12:12 <tinwood> ah, okay.  Is there a related bug raised?
10:12:33 <Dmitrii-Sh> tinwood: not yet - I had a discussion about it yesterday
10:13:01 <Dmitrii-Sh> tinwood: I ended up making a workaround for contail but we might hit that in the future so I am going to raise a bug
10:13:14 <tinwood> okay, can you take an action to follow this and either raise a bug or otherwise track the issue?
10:13:33 <Dmitrii-Sh> tinwood: yes, I will ask in the juju-dev first
10:13:53 <tinwood> #action Dmitrii-Sh track the network-binding not being able to be changed after deploy/add-unit.
10:13:56 <tinwood> thanks Dmitrii-Sh
10:13:57 <Dmitrii-Sh> tinwood: and then raise a bug to track this afterwards depending on how conversation goes
10:14:25 <tinwood> okay, anything else for this topic?
10:15:00 <tinwood> #topic High Priority Bugs
10:15:11 <tinwood> Bugs are here: https://bugs.launchpad.net/openstack-charms/+bugs
10:16:06 <tinwood> We have 59 high/critical that are no fix-released
10:16:26 <tinwood> Any that need discussion?
10:16:59 <tinwood> No, okay
10:17:20 <tinwood> Well, Thursday this week is a 'bug-squash' day for everybody who wants to take part.
10:17:47 <tinwood> ... and moving on.
10:17:50 <icey> s/wants to take part/everybody :)
10:17:56 <tinwood> #topic OpenStack events
10:18:15 <tinwood> The next one is the Boston event.
10:18:17 <sparkiegeek> icey: "for everybody who everybody"?
10:18:26 <sparkiegeek> ;)
10:18:35 <icey> sparkiegeek: this is why I don't tend to write code with sed :)
10:18:38 <tinwood> sparkiegeek, yes, exactly! :)
10:19:11 <tinwood> Any thoughts/comments on Boston OSD?
10:19:11 <sparkiegeek> icey: M-x butterfly
10:19:21 * tinwood recoils at emacs ...
10:19:50 <tinwood> okay, on to the open discussion
10:19:57 <tinwood> #topic Open Discussion
10:20:33 <tinwood> So, I'm doing a piece of work in charm-helpers to solve alpha comparisons of OpenStack and Ubuntu releases which are going to wrap 'real-soon'
10:21:09 <tinwood> It's being tracked by bug: https://bugs.launchpad.net/charm-helpers/+bug/1659575
10:21:09 <openstack> Launchpad bug 1659575 in OpenStack keystone charm "distrib_codename alpha comparison will soon yield unintended behavior" [High,In progress] - Assigned to Alex Kavanagh (ajkavanagh)
10:21:38 <tinwood> I'm raising it so that if you have the urge to do something like
10:21:42 <tinwood> release > 'mitaka'
10:21:56 <tinwood> that you instead reach for the new class/functions and instead to
10:22:10 <tinwood> CompareOpenStackReleases(release) > 'mitaka'
10:22:24 <tinwood> The change to charm-helpers should go in today.
10:22:47 <tinwood> and then be rolled out across the charms over the next 2 weeks.
10:23:03 <tinwood> okay, anyone else?
10:23:46 <tinwood> okay, thanks everybody :)
10:23:54 <tinwood> #endmeeting