16:01:28 <cargonza> #startmeeting charms
16:01:29 <openstack> Meeting started Mon Apr  3 16:01:28 2017 UTC and is due to finish in 60 minutes.  The chair is cargonza. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:33 <openstack> The meeting name has been set to 'charms'
16:01:42 <icey> o/
16:01:44 <cholcombe> o/
16:01:53 <tinwood> \o
16:02:03 <cargonza> #topic Review Action points from previous meeting
16:02:24 <tinwood> I don't think there were any
16:02:38 <cargonza> I did not see any items from previous meeting. I think cholcombe and jamespage have resolved their items
16:02:39 <cargonza> ack
16:03:00 <cargonza> #topic New Items up for discussion
16:03:06 <cargonza> any new items?
16:03:44 <tinwood> Not from me.
16:04:22 <cargonza> anything from storage or nova-lxd?
16:04:31 <icey> nope
16:04:37 <cholcombe> not really
16:04:43 <cargonza> lets move on then...
16:04:57 <cargonza> #topic State of Development for next Charm Release
16:05:06 <cargonza> any highlight for 17.04?
16:05:35 <cargonza> we have the memcache and apache wsgi updates in the charm, correct?
16:06:50 <cargonza> Dmitrii-Sh - any update on network-binding?
16:07:08 <Dmitrii-Sh> cargonza: https://lists.ubuntu.com/archives/juju-dev/2017-March/006361.html
16:07:15 <Dmitrii-Sh> cargonza: yes, it's been discussed
16:07:19 <Dmitrii-Sh> cargonza: but not there yet
16:07:28 <Dmitrii-Sh> cargonza: not sure about ETA either
16:07:53 <cargonza> ok, so you are still tracking it then...
16:08:02 <Dmitrii-Sh> cargonza: ok
16:08:11 <cargonza> #action: carry forward, Dmitrii-Sh network-binding work.
16:08:12 <Dmitrii-Sh> cargonza: this may take a while for Juju team to implement
16:08:18 <cargonza> ok
16:08:43 <cargonza> any other items for 17.04?
16:08:51 <cargonza> if not, we can discuss 17.10 planning.
16:09:28 <tinwood> okay, sounds good
16:09:48 <cargonza> telemetry for next release.
16:10:07 <cargonza> gnocchi?
16:10:38 <tinwood> I've not tracked upstream on the preferred approach.  anyone know?
16:12:11 <Dmitrii-Sh> https://docs.openstack.org/developer/ceilometer/install/dbreco.html
16:12:12 <tinwood> I guess not
16:12:21 <cargonza> we're in the process of planning 17.10 and possibly firm that by first week of May. Please reach out to me if there are any other items to include for 17.10 charms. We are also planning a 17.05 charm release but still not firm either.
16:12:26 * tinwood and Dmitrii-Sh just beat me to it!
16:13:41 <tinwood> from Dmitrii-Sh link it does appear that gnocchi is now the preferred backend
16:13:58 <Dmitrii-Sh> tinwood: at the same time "Gnocchi represents a fundamental change in how data is represented and stored."
16:14:03 <tinwood> So I guess it goes on the list
16:14:10 <cargonza> ok
16:14:18 <tinwood> Dmitrii-Sh, yes, upgrades are going to be interesting and thus need also to be planned.
16:14:53 <tinwood> But we would still support the existing implementations
16:15:18 <cargonza> we have to support existing for a period of time.
16:15:44 <tinwood> yup
16:15:46 <cargonza> tinwood, should we include designate-bind HA also?
16:16:05 <cargonza> or get help from our other team to contribute...
16:16:09 <tinwood> I think it can go on a 'let's evaluate that' list.
16:16:16 <cargonza> ok
16:17:21 <cargonza> cholcombe, any news on swift items to consider for 17.10?
16:17:23 <tinwood> Possible more manila backends?>
16:17:33 <cholcombe> hmm good question
16:17:43 * tinwood typed the > by accident
16:17:54 <cargonza> #action tinwood evaluate designate-bind for 17.10
16:18:05 <cholcombe> could get get gluster integration for manila going?
16:18:36 <cargonza> tinwood, manila backends we need to budget or borrow HW correct?
16:18:56 <cholcombe> for swift it still needs a patch for a separate networking backend
16:19:12 <tinwood> cargonza, depends.  If it's a purely software backend (gluster, ceph-fs) then no, but otherwise yes if it involves custom hardware/software.
16:19:27 <cargonza> cholcombe, could you investigate the scope of work and effort for swift and gluster/manila?
16:19:32 <tinwood> also whether opensource vs licenced
16:19:36 <cholcombe> cargonza: sure
16:19:48 * tinwood wonders if it's licensed or licenced ?
16:19:50 <cargonza> tinwood, ack
16:20:24 <cargonza> if just gluster, ceph-fs, then no extra budget needed. lets evaluate it...
16:20:50 <cargonza> #action cholcombe to investigate swift and gluster/manila work.
16:20:52 <cholcombe> yeah i don't think we need any hardware to test gluster or cephfs
16:21:14 <cargonza> next topic?
16:21:36 <cargonza> #topic High Priority Bugs
16:21:43 <cargonza> https://bugs.launchpad.net/openstack-charms/+bugs
16:21:58 <cargonza> 78 high/critical at the moment..
16:22:32 <cargonza> any comments?
16:22:38 <tinwood> that's more than last week; probably due to ocata coming onstream
16:23:17 <cargonza> ack
16:23:31 <cholcombe> quite a few of them are ceph related :-/
16:23:40 <tinwood> some of those are already fix commited
16:23:41 <cargonza> ack cholcombe
16:24:06 <tinwood> 70 still open.
16:24:27 <tinwood> Also 1 'critical' is a year old, so probably not critical!
16:25:01 <cholcombe> the ceph ones center around an upgrade path to ceph-mon and encryption not working right
16:25:30 <cargonza> handful are 100days old
16:25:39 <cargonza> we may need to clean this queue up.
16:26:16 <cholcombe> yeah 1/4 of the bugs almost are ceph related
16:26:40 <cargonza> did you fix it yet ;-)
16:26:50 <cholcombe> hah no
16:27:14 <cargonza> ok we need to discuss internally to get smarter on bug mgmt. I'll take the action
16:27:32 <cargonza> #action cargonza bug management and triage
16:27:38 <cargonza> moving on
16:27:50 <cargonza> #topic Openstack Event
16:28:17 <cargonza> thanks to zul and tinwood on attending Openstack Days and DevOps meetup
16:28:33 <cargonza> any one know of any other Openstack/Devops event?
16:29:07 <icey> ODS is coming up
16:29:20 <cargonza> icey, ack
16:29:45 <cargonza> next topic?
16:29:52 <cargonza> #topic Open Discussion
16:30:00 <cargonza> any items?
16:30:06 <tinwood> Not from me.
16:30:21 <cargonza> if not, we reached our end of meeting slot..
16:30:29 <cargonza> thanks for participating everyone!
16:30:39 <cargonza> #endmeeting