10:00:08 <joedborg> #startmeeting charms
10:00:09 <openstack> Meeting started Mon Apr 24 10:00:08 2017 UTC and is due to finish in 60 minutes.  The chair is joedborg. Information about MeetBot at http://wiki.debian.org/MeetBot.
10:00:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
10:00:12 <openstack> The meeting name has been set to 'charms'
10:00:44 <tinwood> o/
10:00:46 <vds> o/
10:00:52 <joedborg> o/
10:00:58 <joedborg> are you on Dmitrii-Sh
10:01:17 <Dmitrii-Sh> joedborg: ack
10:01:35 <Dmitrii-Sh> joedborg: prepping for the demo - busy
10:01:55 <joedborg> The ethapad has "Dmitrii-Sh track the network-binding not being able to be changed after deploy/add-unit." for review - did you want to discuss that?
10:02:35 <Dmitrii-Sh> joedborg: we decided to stop tracking this here as this is a major feature
10:02:48 <Dmitrii-Sh> joedborg: once it's there I will come back to that
10:02:52 <joedborg> Dmitrii-Sh: ok!
10:03:12 <tinwood> okay, we can remove that action point then. thanks Dmitrii-Sh
10:03:40 <joedborg> #topic Charm Release
10:03:45 <Dmitrii-Sh> tinwood: yw, this is not an easy task for the juju team but I am definitely tracking it )
10:04:11 <tinwood> Dmitrii-Sh: that's great.  Thanks for keeping an eye on it.
10:04:23 <joedborg> there's a point in Charm release "next Ubuntu release will be an 'a' (coming after z) -- still landing the alpha comparison changes to the charms.
10:04:30 <tinwood> yeah, that's mine.
10:04:41 <tinwood> It's just a reminder that I'm still pushing through the changes on ...
10:04:53 <tinwood> charm-helpers in to all of the charms that ...
10:05:09 <tinwood> fix the alpha comparisons on ubuntu releases and openstack releases.
10:05:25 <tinwood> With the next dev version now being an 'a' ...
10:05:27 <tinwood> there's a bit of urgency!
10:05:41 <tinwood> So I'm going to try to push them through today and the rest of the week.
10:06:05 <joedborg> tinwood: thanks
10:06:16 <joedborg> Anything else on charm release?
10:06:21 <tinwood> Remaining ones: https://review.openstack.org/#/q/topic:fix-alpha-comparisons-1659575+is:open
10:06:57 <tinwood> Not from me.
10:07:10 <joedborg> #topic Bugs
10:07:21 <joedborg> Anything on bugs?
10:07:46 <Dmitrii-Sh> https://bugs.launchpad.net/charm-ceph-radosgw/+bug/1685536
10:07:47 <openstack> Launchpad bug 1685536 in OpenStack ceph-radosgw charm "radosgw charm doesn't report an error even though a swift endpoint is not present due to storage provider init failure" [Undecided,New]
10:08:27 <Dmitrii-Sh> restrict-ceph-pools set to true seems to have a dramatic effect on the radosgw daemon
10:09:08 <Dmitrii-Sh> the fun part is that it fails to init but still returns 0 exit code
10:09:19 <Dmitrii-Sh> hence the systemd unit stays active
10:09:38 <Dmitrii-Sh> and there's no indication in juju status of the failure
10:09:39 <tinwood> Dmitrii-Sh: any workarounds?
10:10:01 <Dmitrii-Sh> tinwood: not that I know of yet besides disabling that option
10:10:15 <Dmitrii-Sh> tinwood: James made a comment about it I will take a look after the demo
10:10:48 <Dmitrii-Sh> just a heads-up on that - it takes a quite a bit of time to debug
10:10:50 <tinwood> Dmitrii-Sh: okay.
10:11:05 <joedborg> Any more?
10:11:32 <joedborg> #topic Events
10:11:44 <joedborg> I guess this'll be a quick one
10:12:07 <tinwood> joedborg: I was just going to say that we'll be having another bug thursday soon, but not sure when. I'll ping james on it.
10:12:22 <joedborg> tinwood: ah sorry, i didn't leave enough time
10:12:31 <tinwood> np
10:12:54 <joedborg> Anything for events?  Boston is listed on the agenda but not sure there's much to add
10:13:01 <tinwood> action: tinwood ask jamespage about bug day
10:13:24 <tinwood> #action tinwood ask jamespage about bug day
10:13:53 <tinwood> The Canonical OpenStack team will be at Boston.
10:14:36 <joedborg> Anything more on events?
10:14:46 <tinwood> And we'll be doing training, etc. on charms.
10:15:00 <tinwood> that's it from me.
10:15:20 <joedborg> #topic Open Discussion
10:15:35 <jamespage> o/
10:15:41 <tinwood> \o jamespage
10:15:41 <jamespage> sorry I'm late - got caught otp
10:15:51 * jamespage reads backscroll
10:16:08 <joedborg> no worries jamespage
10:17:03 <jamespage> bug days - yes - we normally do the first thursday of the month which would be next week I think
10:17:11 <jamespage> that would be just before the summit
10:17:27 <jamespage> I'll send out a notice this week and a reminder next week
10:17:36 <tinwood> thanks jamespage
10:17:46 <jamespage> we should target some of the top offenders - I'll generate a list of URL's
10:18:07 <jamespage> all yours joedborg
10:18:38 <joedborg> thanks jamespage!
10:18:57 <joedborg> any other topics from anyone?
10:19:22 <tinwood> No, I'm good.
10:19:54 <joedborg> going once...
10:20:26 <joedborg> okay, thanks all
10:20:33 <joedborg> #endmeeting