17:00:03 <joedborg> #startmeeting charms
17:00:09 <openstack> Meeting started Mon Jul 10 17:00:03 2017 UTC and is due to finish in 60 minutes.  The chair is joedborg. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:13 <openstack> The meeting name has been set to 'charms'
17:00:18 <joedborg> o/
17:00:27 <tinwood> o/
17:00:30 <thedac> o/
17:00:35 <jamespage> o/
17:00:51 <joedborg> #topic Review ACTION points from previous meeting
17:01:02 <wolsen> o/
17:01:13 <joedborg> cholcombe to generate spec for glusterfs charm work
17:01:26 <cholcombe> joedborg: yeah i'm working on that today.  it's almost finished
17:01:38 <joedborg> awesome, thanks cholcombe
17:01:46 <joedborg> jamespage to organise weekly bug triage rota for the team (also on ODD meeting actions)
17:02:09 <jamespage> bah that's a fail again - I keep getting distracted - please carry over
17:02:20 * jamespage makes a note to sort that out this week
17:02:31 <joedborg> no worries, thanks jamespage
17:02:58 <joedborg> #topic State of Development for next Charm Release
17:03:16 <joedborg> Any updates for the Gnocchi charm?
17:03:20 <jamespage> yup
17:03:33 <jamespage> hmm is my collaborator here?
17:03:36 <jamespage> it would appear not
17:03:37 <jamespage> anyway
17:03:52 <jamespage> https://github.com/openstack-charmers/charm-gnocchi
17:04:25 <jamespage> testing at the moment; functionally things appear to work - using ceph for storage, with mysql for indexing the memcached for coordination (required for HA deployments)
17:04:47 <jamespage> some changes into the rest of the charms - specifically ceilometer and keystone reviews up
17:04:59 <jamespage> https://review.openstack.org/#/q/topic:gnocchi-charm
17:05:21 <wolsen> the keystone one should be landed I think
17:05:28 <jamespage> most of the existing notifications configuration in the charms appears to work - I'm validating and will update for deprecations as I go along
17:05:35 <jamespage> wolsen: yeah - thankyou!
17:05:51 <wolsen> jamespage: np, I'll look at the ceilometer one this afternoon
17:05:52 <tinwood> jamespage, does any dictionary data go over the relationship from gnocchi to keystone?
17:05:54 <jamespage> I'm also poking at grafana -> gnocchi for reporting
17:06:12 <jamespage> tinwood: no - but I think I'm seeing that bug in the hacluster sub relation
17:06:21 <tinwood> right.
17:07:02 <jamespage> some considerations for gnocchi - as soon as you configure ceilometer to use gnocchi, it turns its API off...
17:07:15 <tinwood> I'm wondering if it's something we can 'fix' in charms.openstack.  serialisation helper or something.
17:07:20 <jamespage> basically its redundant at that point
17:07:23 <jamespage> tinwood: +1 sounds good
17:07:43 <jamespage> anyway things progress - I'm pretty optimistic about having that ready for the august release
17:07:52 <tinwood> I'll take a poke at it.  joedborg action for me
17:08:01 <coreycb> o/
17:08:06 <jamespage> the charm template helped alot, but its bit-rotted against best practice a bit so we need to refresh
17:09:12 <joedborg> #action tinwood helper for Gnocchi in charms.openstack (serialisation)
17:10:06 <joedborg> anything else on Gnocchi?
17:10:15 <jamespage> joedborg: can you action a refresh of the charm templates as well please
17:10:31 <joedborg> is that to be actioned by you?
17:10:40 <jamespage> yeah why not
17:10:47 <joedborg> :)
17:11:01 <joedborg> #action jamespage refresh of charm templates
17:11:55 <joedborg> Okay, next topic is Snaps integration into Charms
17:12:00 <thedac> coreycb et al have done great work getting the snaps ready in the snap store. \o/
17:12:05 <thedac> Still working on keystone PoC as we have moved from classic back to jail mode but it is close.
17:12:21 <thedac> The helpers are ready for some more eyes on https://code.launchpad.net/~thedac/charm-helpers/os-snaps/+merge/325702
17:12:51 <coreycb> thedac: i'll take a look at that
17:12:59 <thedac> thanks
17:14:06 <joedborg> Anything more to add on Snaps?
17:14:16 <thedac> that is it from me
17:14:38 <coreycb> joedborg: i don't think so, not for this meeting at least
17:15:10 <joedborg> sweet, thanks coreycb and thedac
17:15:13 <joedborg> #topic High Priority Bugs
17:15:23 <joedborg> https://bugs.launchpad.net/openstack-charms/+bugs
17:16:19 <joedborg> Does anyone want to raise anything bug related?
17:16:25 <jamespage> we should try to address the two critical bugs that are not fix committed
17:16:26 <jamespage> https://bugs.launchpad.net/charm-ceph-osd/+bug/1675186
17:16:27 <openstack> Launchpad bug 1675186 in OpenStack ceph-osd charm "ceph-osd storage-attached hook fails" [Critical,Triaged] - Assigned to Chris Holcombe (xfactor973)
17:16:27 <jamespage> and
17:16:34 <jamespage> https://bugs.launchpad.net/charm-hacluster/+bug/1478980
17:16:34 <openstack> Launchpad bug 1478980 in OpenStack hacluster charm "If the principle updates a resource parameter of an already configured resource hacluster ignores it" [Critical,Triaged]
17:16:37 <jamespage> any takers?
17:16:48 <jamespage> that second one is non-trivial
17:17:00 <jamespage> oh cholcombe already has that first one - please can you review!
17:17:18 <cholcombe> jamespage: sure
17:17:20 <thedac> I'll see if I can get to the hacluster one
17:18:01 <wolsen> I can look at the hacluster one as well
17:18:10 <wolsen> I'm getting a ping from someone who needs that at the moment
17:18:29 <thedac> great
17:18:44 <wolsen> I'll assign it to myself right now
17:18:53 <jamespage> ta
17:18:59 <thedac> wolsen: feel free to ping me for reviews then
17:19:14 <wolsen> thedac: will do
17:20:02 <joedborg> Any more bugs?
17:20:34 <jamespage> nope
17:20:43 <jamespage> well there are always bugs but not for today I think!
17:20:56 <joedborg> haha, yeah i thought that when I sent it
17:20:56 <tinwood> indeed.
17:21:01 <joedborg> #topic Openstack Events
17:21:16 <joedborg> According to the notes, there is a PTG in September
17:21:37 <joedborg> Anything to add?
17:21:57 <thedac> Yes, and I believe there a couple of days left for OpenStack Summit proposals
17:22:29 <jamespage> oh yes - good reminder!
17:22:40 <thedac> I am not sure how many of us will make it to Sydney
17:22:53 <jamespage> tis along way!
17:23:00 <wolsen> and short at 3 days
17:23:12 <tinwood> tis a very long way
17:23:17 <jamespage> I'm also speaking at the openstack uk day in london at the end of september
17:23:21 <jamespage> ftr
17:23:28 <jamespage> topic tbc
17:24:08 <tinwood> congrats!
17:24:36 <jamespage> tinwood: ta
17:25:12 <joedborg> Anyone else?
17:25:23 <tinwood> nope, I'm good.
17:25:34 <wolsen> all good on events here
17:25:58 <jamespage> ...
17:26:02 <joedborg> #topic Open Discussion
17:26:06 <jamespage> (that was for gnuoy)
17:26:13 <thedac> :)
17:26:15 <wolsen> heh
17:26:26 <tinwood> :)
17:27:15 <joedborg> Have we anything else to be raised today?
17:27:27 <wolsen> I've been thinking about the openstack charmhelpers stuff
17:27:53 <wolsen> it would be fairly nice to have the contrib.openstack in its own repo at times
17:27:55 * tinwood perks up in interest
17:28:43 <tinwood> wolsen, yes, and some sort of long term merger with charms.openstack would be cool.
17:28:50 <tinwood> Or at least more code sharing.
17:28:51 <wolsen> tinwood: +1000
17:28:53 <wolsen> yeah
17:28:54 <jamespage> I'd support that move
17:29:20 <wolsen> maybe we can start thinking about it for next cycle
17:29:28 <jamespage> however we do need a way to deal with classic style charms in that model
17:29:36 <jamespage> sure that figurable-outable
17:29:38 <wolsen> correct
17:29:43 <tinwood> agreed
17:29:49 <wolsen> s/correct/agreed
17:30:32 <wolsen> so maybe I can chat with tinwood about this idea more as we get near the next cycle
17:30:38 <jamespage> +1 great
17:30:44 <tinwood> sounds good; I'm up for that.
17:30:46 * jamespage has to drop - need to be somewhere else
17:30:54 <tinwood> we should take an action as a reminder.
17:31:01 <tinwood> bye jamespage
17:31:04 <joedborg> ciao jamespage
17:31:16 <wolsen> I think an action would be good
17:31:20 <joedborg> what shall i call it tinwood wolsen ?
17:31:29 <joedborg> and who should i assign it to?
17:31:55 <tinwood> how about: "tinwood wolsen to discus contrib.openstack and charms.openstack roadmap"
17:31:59 <wolsen> perfect
17:32:19 <joedborg> haha that simple
17:32:32 <tinwood> It's a placeholder, but useful.
17:32:39 <joedborg> #action tinwood wolsen discus contrib.openstack and charms.openstack roadmap
17:33:08 <joedborg> Anything else?
17:33:26 <tinwood> Nope, I'm good.
17:33:27 <thedac> Related to that we might want an update on the attempts to move charmhelpers to github. I think there were problems with commit attribution history
17:33:42 <tinwood> thedac, I'm sure james is all over that
17:33:47 <tinwood> (at least he was)
17:33:48 <wolsen> yeah, I recently had a short discussion with jamespage on that
17:33:51 <thedac> ok
17:34:06 <tinwood> But, we should keep it on a card or something
17:34:20 <wolsen> he was working on it and I think it was a matter of rewriting emails or something - there's a lot of commits so it takes more time
17:35:29 <joedborg> shall i add an action wolsen / thedac ?
17:35:42 <thedac> joedborg: jamespage ;)
17:36:07 <joedborg> #action jamespage moving charmhelpers to github
17:36:18 <wolsen> boy james has a lot of actions
17:36:23 <tinwood> actions in absence - the ideal of a meeting
17:36:26 <tinwood> :)
17:36:42 <wolsen> "he didn't say no"
17:36:42 <thedac> Agreed, we can figure out redistribution offline
17:37:52 <joedborg> Anything else?
17:38:04 <wolsen> I'm good
17:38:08 <thedac> All done
17:38:22 <tinwood> all done too
17:38:56 <joedborg> #topic Next Chair
17:39:12 <joedborg> I'm not sure if this goes back the beisner?
17:39:27 <tinwood> nah, just rotate to the next one (which is probably me)
17:39:40 <joedborg> It's Dmitrii-Sh
17:39:45 <tinwood> we have a winner!
17:39:50 <wolsen> haha
17:40:00 <thedac> Do we need to remove Dmitrii-Sh? Is he likely to be available?
17:40:31 <joedborg> It's a bit uncertain with all of us FEs (we can talk about it after)
17:40:47 <thedac> ok
17:40:58 <joedborg> So it'll either be Dmitrii-Sh or tinwood :)
17:41:03 <tinwood> yay
17:41:19 <joedborg> #endmeeting