10:01:26 <jamespage> #startmeeting charms
10:01:27 <openstack> Meeting started Mon Jul 31 10:01:26 2017 UTC and is due to finish in 60 minutes.  The chair is jamespage. Information about MeetBot at http://wiki.debian.org/MeetBot.
10:01:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
10:01:30 <openstack> The meeting name has been set to 'charms'
10:01:38 <jamespage> #topic Review ACTION points from previous meeting
10:01:51 <icey> o/ jamespage
10:01:55 <jamespage> ok so I had an action to setup rotas for a few things
10:01:59 <tinwood> o/ all
10:02:08 <jamespage> Review is up - https://review.openstack.org/#/c/486697/
10:02:19 <jamespage> needs some +2's to land and then folk can add themselves to the rotas
10:02:48 <jamespage> second one was wolsen to finish amulet tests for internal-dns
10:02:57 <jamespage> as wolsen does not make this meeting - deferring
10:03:00 <jamespage> #action wolsen to finish amulet tests for internal-dns
10:03:23 <jamespage> tinwood, icey: please could you review the rota change and then raise changes for yourselves - I'll pester others in channel
10:03:33 <jamespage> #topic State of Development for next Charm Release
10:03:34 <tinwood> will do
10:03:34 <jamespage> #
10:03:52 <jamespage> ok so we're 2.5 weeks off feature freeze
10:04:07 <jamespage> some things we do know - GlusterFS won't be completed this cycle
10:04:09 <jamespage> sorry folks
10:04:24 <jamespage> I'm focussed on the telemetry review stuff this week
10:04:40 <jamespage> gnocchi and suchlike - hope to have all existing charm impacts up for review today/tommorw
10:05:40 <jamespage> anything else ?
10:06:00 <tinwood> yep, about charms.openstack and reactive changes
10:06:11 <tinwood> if this is the appropriate topic
10:06:37 <tinwood> (shall I continue?)
10:06:45 <icey> +1
10:06:49 <Dmitrii-Sh> +
10:07:22 <jamespage> go for it
10:07:27 <tinwood> Okay, charms.reactive changed such that handlers (@when, etc) are only allowed in reactive/* and hooks/* directories, and NOT in lib/*
10:07:43 <tinwood> This broke charms.openstack default handlers. (which live in lib/...../etc)
10:08:07 <tinwood> So, I'm doing a fix which will go through this week, but it needs EVERY charms.openstack charm to be rebuilt afterwards.
10:08:26 <tinwood> No changes are needed to the charms' code though.
10:08:34 <Dmitrii-Sh> Is there a commit id for that in reactive?
10:08:52 <tinwood> Dmitrii-Sh, probably.  it was in may, and it'll be referenced in my commits.
10:09:08 <Dmitrii-Sh> It could have been communicated in a better way to us
10:09:23 <Dmitrii-Sh> Anyway, thank you for debugging
10:09:37 <tinwood> Dmitrii-Sh, it's probably(*) always supposed to have been like that.
10:09:46 <Dmitrii-Sh> Ok
10:10:15 <tinwood> Okay, that's that one.
10:10:25 <tinwood> The other is worker-multiplier ...
10:10:34 <tinwood> is coming to reactive charms also this week.
10:10:42 <jamespage> \o/
10:10:44 <jamespage> w00t
10:10:57 <jamespage> ready to move on folks?
10:11:01 <tinwood> yup
10:11:09 <icey> yea
10:11:50 <jamespage> #topic High Priority Bugs
10:11:57 <jamespage> #url https://bugs.launchpad.net/openstack-charms/+bugs
10:12:07 <jamespage> #url http://tinyurl.com/charm-stable-backports
10:12:14 <jamespage> #url  https://tinyurl.com/osc-critical-bugs
10:12:20 <jamespage> #url https://tinyurl.com/osc-high-priority
10:12:49 <jamespage> Dmitrii-Sh: where you taking a punt at the remaining open critical bug?
10:13:44 <jamespage> https://bugs.launchpad.net/charm-hacluster/+bug/1478980
10:13:44 <openstack> Launchpad bug 1478980 in OpenStack hacluster charm "If the principle updates a resource parameter of an already configured resource hacluster ignores it" [Critical,Triaged] - Assigned to Billy Olsen (billy-olsen)
10:13:58 <jamespage> that knarly one with regards to reconfiguring hacluster resources on the fly
10:14:09 <jamespage> oh wait - it was wolsen not you - apologies
10:14:31 <Dmitrii-Sh> I can try to fix it
10:14:35 <Dmitrii-Sh> Ok
10:14:36 <jamespage> the high priority bug list should be focus for the next few weeks
10:14:50 <jamespage> so if you need filler that's a good list to pick from
10:15:14 <jamespage> #topic Openstack Events
10:15:23 <Dmitrii-Sh> ack
10:15:33 <jamespage> PTG is in just over a month; I think we'll have around 6-7 of the charms team there
10:15:52 <jamespage> I know wolsen and dosaboy are both attending
10:15:59 <jamespage> anything else?
10:16:13 <tinwood> not that I know of.
10:16:30 <jamespage> #topic Open Discussion
10:16:37 <jamespage> floor is open
10:17:03 <tinwood> Nothing more from me.
10:17:36 <jamespage> icey, Dmitrii-Sh?
10:17:50 <icey> nothing to add
10:18:15 <jamespage> okies
10:18:24 <jamespage> #topic Next Chair
10:18:30 <jamespage> joedborg gets the pleasure
10:18:31 <Dmitrii-Sh> Same here
10:18:33 <jamespage> #endmeeting