10:00:47 <joedborg> #startmeeting charms
10:00:48 <openstack> Meeting started Mon Aug 14 10:00:47 2017 UTC and is due to finish in 60 minutes.  The chair is joedborg. Information about MeetBot at http://wiki.debian.org/MeetBot.
10:00:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
10:00:51 <openstack> The meeting name has been set to 'charms'
10:00:55 <joedborg> Hello all!
10:00:58 <fnordahl> o/
10:01:02 <Dmitrii-Sh> o/
10:01:02 <joedborg> excuse my butter fingers
10:01:10 <icey> o/
10:01:10 <fnordahl> could happen to anyone
10:01:39 <joedborg> #topic Review ACTION points from previous meeting
10:02:04 <joedborg> I have, on the agenda, wolsen; an update on amulet tests for internal DNS
10:02:55 <tinwood> o/
10:02:58 <fnordahl> it is night in his timezone so that one is best left for the next weeks meeting which will suit his tz better
10:03:27 <joedborg> thanks fnordahl, I'll move it onto the next meeting
10:03:37 <tinwood> thanks joedborg
10:03:56 <joedborg> #topic State of Development for next Charm Release
10:04:22 <tinwood> We are coming up on charm release:
10:04:24 <tinwood> Release dates update:
10:04:24 <tinwood> Aug 24 - OpenStack Charms Feature Freeze
10:04:24 <tinwood> Sept 1 - Upstream OpenStack Pike Release
10:04:24 <tinwood> Sept 7 - OpenStack Charms Release
10:04:26 <tinwood> https://wiki.ubuntu.com/ArtfulAardvark/ReleaseSchedule
10:04:28 <tinwood> https://releases.openstack.org/pike/schedule.html
10:04:41 <tinwood> 10 days until feature freeze.
10:04:54 <Dmitrii-Sh> https://bugs.launchpad.net/charm-ceph-osd/+bug/1710474 https://bugs.launchpad.net/charm-ceph-osd/+bug/1710477
10:04:56 <openstack> Launchpad bug 1710474 in OpenStack ceph-osd charm "bluestore-specific configuration support" [Undecided,New]
10:04:57 <openstack> Launchpad bug 1710477 in OpenStack ceph-osd charm "Jewel -> Luminous upgrade actions: filestore -> bluestore and msgr1 -> msgr2 upgrade path" [Undecided,New]
10:05:03 <Dmitrii-Sh> it's probably not possible within 10 days
10:05:29 <Dmitrii-Sh> but bluestore-specific journal options are important to have
10:05:42 <tinwood> Dmitrii-Sh, yes, that's a bit too late in the cycle for inclusion now.  better to bring it in for the next cycle.
10:06:13 <tinwood> Basically, we're finalising features now, and cleaning up for the release
10:06:21 <dosaboy> tinwood: on the topic of ceph, do you kow if the ceph -> ceph-mon/osd migration plan is due to land for 17.08
10:06:44 <tinwood> dosaboy, that I couldn't tell you.  icey?
10:06:51 <icey> dosaboy: as far as I know, there is no plan nto have that migration
10:06:59 <icey> dosaboy: me and Dmitrii-Sh were speaking a bit about that this morning
10:07:22 <dosaboy> icey: you mean there's no plan to ever have it or no plan to have it for 17.08?
10:07:36 <Dmitrii-Sh> dosaboy: I think not for 17.08
10:07:36 <icey> dosaboy: every time I get to discuss it, it gets pushed back
10:07:45 <icey> dosaboy: I have no confidennnce that it will get actively put onn a roadmap
10:07:54 <icey> friggin sticky 'n' key
10:08:07 <dosaboy> icey: fwiu that's not really a matter of choice
10:08:20 <tinwood> Is it because it is difficult, or just that ther is a manual mechanism as an alternative?
10:08:21 <Dmitrii-Sh> dosaboy: with BlueStore becoming a default this is a problem of course
10:08:24 <dosaboy> the ceph charm has been deprecated for a while now and it is lagging in terms of support
10:08:44 <icey> tinwood: it would likely have to be done externally to juju, as there's no way to remove an in-use relation with Juju
10:09:00 <dosaboy> Dmitrii-Sh: yes
10:09:09 <icey> tinwood: there is no documented mechanism to migrate from ceph+ceph-osd to ceph-mon+ceph-osd
10:09:19 <tinwood> dosaboy, icey: yes that would make it tricky.
10:09:33 <dosaboy> icey: there is (ish) jamespage came up with a design a little while back
10:10:02 <icey> dosaboy: I've even done that upgrade (by hand), I haven't seen anything "official" out of the idea
10:10:11 <dosaboy> we need to make a decsion, either bring the ceph charm up to parity or implement a migration strategy
10:10:31 <icey> dosaboy: I've brought that up every time we've had a release since ceph-mon first appeared ;-)
10:11:05 <dosaboy> icey: lets take this offline and i'll get you up to speed as i know that jamespage is not around atm
10:11:13 <icey> dosaboy: +1
10:11:39 <joedborg> anything else?
10:12:03 <tinwood> No, I'm good.
10:12:43 <joedborg> okay, onto bugs
10:12:44 <joedborg> #topic High Priority Bugs
10:13:04 <joedborg> First, on the agenda, is Use stable-backport tag for bugs  http://tinyurl.com/charm-stable-backports
10:13:52 <tinwood> joedborg, it's more of a "here's a list of searches about bugs"
10:14:10 <tinwood> The interesting ones are critical and high-priority in terms of the upcoming release.
10:14:19 <joedborg> tinwood: ah you're right, I didn't read it properly :)
10:14:28 <tinwood> There are NO critical bugs!
10:14:33 <tinwood> \o/
10:14:53 <Dmitrii-Sh> tinwood: well, I'd consider the lack of bluestore options a critical one :^)
10:15:10 <tinwood> Dmitrii-Sh, that's a feature, not a bug.
10:15:11 <tinwood> :)
10:15:43 <Dmitrii-Sh> tinwood: that's the way to solve a problem - rename it ;^)
10:15:53 <tinwood> There are 67 high-priority bugs, so those should continue to be the focus for the next couple of weeks.
10:16:31 <tinwood> Does anyone have any bugs (apart from bluestore) that they particularly want to highlight?
10:17:01 <Dmitrii-Sh> yes
10:17:13 <Dmitrii-Sh> https://bugs.launchpad.net/charms/+source/memcached/+bug/1684217
10:17:14 <openstack> Launchpad bug 1684217 in memcached (Juju Charms Collection) "memcached and nova-cc relation sets up incorrect ufw rules in multi-network env" [Undecided,New]
10:17:20 <Dmitrii-Sh> this is not really a charm bug now
10:17:35 <Dmitrii-Sh> rather a Juju bug https://bugs.launchpad.net/juju/+bug/1708492
10:17:37 <openstack> Launchpad bug 1708492 in juju "[2.2.2] private-address relation setting is not based on a default space binding" [High,In progress] - Assigned to Witold Krecicki (wpk)
10:17:53 <tinwood> Witold is a good chap.
10:18:06 <Dmitrii-Sh> he's on vacation now :^)
10:18:13 <tinwood> oh
10:18:24 <tinwood> I'm sure he'll come back.
10:18:27 <Dmitrii-Sh> I will talk to JAM and see what can be done
10:19:02 <joedborg> Any more?
10:19:05 <tinwood> On the topic of bugs ...
10:19:15 <tinwood> I'd like to remind people to sign up to the bug rota.
10:19:25 <Dmitrii-Sh> but until then be careful with assuming that private-address will be taken as a --primary-address of a default binding space
10:19:26 * tinwood is trying to find the url
10:20:07 <tinwood> Here's one I did: https://review.openstack.org/#/c/493009/
10:20:15 <tinwood> sorry Dmitrii-Sh; please continue.
10:20:24 <Dmitrii-Sh> np, I'm good
10:21:04 <joedborg> Anything else?
10:21:29 <tinwood> These are the rotas so far: https://docs.openstack.org/charm-guide/latest/rotas.html
10:21:58 <tinwood> I've got nothing further on this. :)
10:22:52 <joedborg> #topic Openstack Events
10:23:04 <joedborg> PTG in September
10:24:08 <joedborg> anything to add to that? :D
10:24:29 <tinwood> Nothing from me on this; the Europe contingent isn't really going to this one.
10:24:33 <tinwood> AFAIK
10:24:47 <Dmitrii-Sh> I'm not going to be there
10:25:08 <Dmitrii-Sh> nothing to add as there are no NA folks here
10:25:50 <joedborg> cool, onto the closer
10:25:51 <joedborg> #topic Open Discussion
10:26:27 <tinwood> I'm trying to get the documentation sorted for the end of cycle; so if there's anything you want to add/want added, please do let me know.
10:27:16 <Dmitrii-Sh> tinwood: I am not sure if it's there but reactive charm rebuild instructions would be nice to have
10:27:29 <Dmitrii-Sh> tinwood: i.e. our hackery with uuid
10:27:44 <tinwood> Dmitrii-Sh, indeed.  That might need to go in the dev section.
10:27:58 <tinwood> #action tinwood add 'reactive charm' rebuild instructions to docs.
10:28:09 <Dmitrii-Sh> tinwood: thanks
10:29:14 <joedborg> anything else?
10:29:27 <tinwood> not from me
10:30:09 <joedborg> next chair is you tinwood
10:30:20 <tinwood> thank joedborg
10:30:30 <joedborg> thanks everyone
10:30:41 <joedborg> have a good rest of your day
10:30:46 <tinwood> you thanks
10:30:51 <fnordahl> thank you joedborg
10:30:52 <fnordahl> o/
10:30:55 <tinwood> don't forget to endmeeting
10:30:57 <joedborg> #endmeeting