17:01:51 <coreycb> #startmeeting charms
17:01:52 <openstack> Meeting started Mon Oct  2 17:01:51 2017 UTC and is due to finish in 60 minutes.  The chair is coreycb. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:53 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:55 <openstack> The meeting name has been set to 'charms'
17:02:17 <coreycb> hello and welcome everyone
17:02:20 <beisner> o/
17:04:52 <coreycb> Agenda:
17:05:07 <coreycb> #link https://etherpad.openstack.org/p/openstack-charms-weekly-meeting-20171002
17:05:17 <coreycb> #topic Review ACTION points from previous meeting
17:05:45 <coreycb> I'm not seeing any carry-over actions. does anyone have anything to add?
17:07:24 <coreycb> ok still early in the release cycle. we had a bit of focus on sprint activity last week that we may have updates on today.
17:07:28 <coreycb> #topic State of Development for next Charm Release
17:08:04 <coreycb> any updates here?
17:08:12 <coreycb> may be quiet today as people are recovering from travel
17:08:49 <coreycb> i'm working through the gnocchi snap support today and received some initial input from jamespage. plan to get that done asap.
17:09:01 <coreycb> for the gnocchi charm, that is
17:09:36 <coreycb> a lot of preliminary design was done on the openstack load balancer last week
17:11:18 <coreycb> ok moving on
17:11:19 <coreycb> #topic High Priority Bugs
17:11:32 <coreycb> #link https://tinyurl.com/osc-critical-bugs
17:11:39 <coreycb> #link https://tinyurl.com/osc-high-priority
17:12:11 <jamespage> o/
17:12:14 <jamespage> sorry I'm late
17:12:24 <coreycb> o/ jamespage
17:12:26 <beisner> shall we talk about the next charm release/freeze dates here?
17:12:32 <coreycb> looks like liam is working on https://bugs.launchpad.net/charm-nova-cloud-controller/+bug/1544959
17:12:33 <openstack> Launchpad bug 1544959 in OpenStack nova-cloud-controller charm "Adding a unit to an existing nova-cloud-controller overwrites the vip in the catalogue" [Critical,In progress] - Assigned to Liam Young (gnuoy)
17:12:33 <jamespage> sounds good
17:12:34 <beisner> and the new naming/numbering scheme?
17:12:55 <coreycb> want to wrap up high prio bugs first?
17:13:12 <beisner> yep
17:13:32 <jamespage> gnuoy is also assessing that bug against others that might have the same behaviour as a priority
17:13:44 <jamespage> that's our only critical atm
17:14:06 <jamespage> we have 67 high priority bugs across the charms other than that one
17:14:23 <coreycb> ok yeah just was scanning the high prio ones
17:14:40 <coreycb> we could use a bug squash party
17:14:57 <jamespage> also our undecided queue is at a recent all time low of 41 which includes 15 which I can't effectively mark as 'low' as its a bug with multiple tasks to fix unit test deprecations
17:15:30 <beisner> yeah many thx for the bug spike!
17:15:38 <jamespage> coreycb: fwiw we've close out about 10% of our bugs in the last two weeks - from 600 open -> 540 ish
17:15:53 <coreycb> jamespage: awesome, nice job
17:15:58 <jamespage> I'd really like to get that down to 250 or so so a bug party would be good
17:16:05 <jamespage> we have 130 wish list bugs...
17:16:47 <jamespage> 602->531
17:17:00 <coreycb> great, so progress is being made
17:17:24 <coreycb> anything else need highlighting for bugs?
17:17:42 <jamespage> I don't think so other that to highlight that link as a source for priority work
17:17:52 <coreycb> ok
17:17:54 <jamespage> getting the 65 or so high priority bugs closed would be awesome
17:19:09 <coreycb> #action all - fix high priority bugs (currently at 65) https://tinyurl.com/osc-high-priority
17:19:30 <coreycb> #topic OpenStack Events
17:19:41 <coreycb> any updates on events?
17:20:14 <coreycb> probably not much as PTG was a few weeks ago
17:20:15 <coreycb> #topic Open Discussion
17:20:37 <coreycb> beisner: want to chat about charm release/freeze dates?
17:20:48 <beisner> actually, first, naming please
17:21:03 <coreycb> beisner: sounds good
17:21:04 <beisner> AIUI:  Starting in 2018, we will move to YYYY.n release naming, where n is the nth release of that year (no longer correlated with the month).  So, 2018.1, 2018.2, 2018.3 and so on, regardless of the month released.
17:21:18 <beisner> ^ is that the general understanding still?
17:21:35 <gnuoy> that is my understanding and makes sense to me
17:21:40 <jamespage> +1 based on the fact we don't need semantic versioning for upgrade paths as the charm store revision is agnositci of the release version
17:21:41 <beisner> For any remaining 2017 releases, we should still use the existing .MONTH schema probably.
17:21:56 <jamespage> so .11 will be our last old style release right?
17:22:03 <beisner> yeah
17:22:29 <beisner> awesome
17:22:33 <beisner> ok, dates...
17:22:38 <beisner> we were looking at ~thanksgiving week.
17:22:48 <beisner> let's all look at November
17:23:07 <beisner> Freeze on Mon Nov 13, release on _____ ?  idr
17:23:56 <beisner> Tue Nov 21st?
17:24:13 <jamespage> +1
17:24:29 <beisner> So, smaller freeze, given we have mojo specs churning regularly, and follow the dont-release-on-Mon-or-Fri-or-Major-Hols :-)
17:24:41 <gnuoy> +1 (if the auto-mojo testing gives us a head start)
17:24:58 <coreycb> +1
17:24:59 <gnuoy> Does osci use the snapped mojo ooi?
17:25:00 <beisner> They're running now, weekly.  We just need to make sure we have people triaging any failures.
17:25:11 <beisner> gnuoy: no it uses everything in a python venv.
17:25:32 <gnuoy> which is why it works for you. ok.
17:25:40 <beisner> https://github.com/openstack-charmers/charm-test-infra/blob/master/clients-requirements.txt
17:25:48 <beisner> ^  :-)  yes.
17:25:57 <gnuoy> I think the snap is bust fwiw
17:26:54 <coreycb> ok anything else to cover here?
17:27:04 <beisner> ok, so Freeze Nov 13, Release Nov 21, but we'll make an assessment @ start of Freeze wrt test confidence.
17:27:06 <beisner> thanks
17:27:19 <jamespage> +1
17:27:25 <coreycb> sounds good
17:27:30 <jamespage> sorry but I have to drop again.
17:27:32 <jamespage> ttfn
17:27:41 <beisner> o/ ditto, cheers & thanks coreycb & all
17:27:42 <coreycb> #topic Next Chair
17:27:45 <coreycb> jamespage
17:27:50 <coreycb> you're next up
17:27:55 <beisner> i see what you did there jamespage ;-)
17:28:14 <coreycb> #endmeeting