17:00:43 <jamespage> #startmeeting charms
17:00:44 <openstack> Meeting started Mon Oct 16 17:00:43 2017 UTC and is due to finish in 60 minutes.  The chair is jamespage. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:45 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:47 <openstack> The meeting name has been set to 'charms'
17:00:53 <jamespage> #topic Review ACTION points from previous meeting
17:00:57 <jamespage> ok so first up is
17:01:02 * jamespage all - fix high priority bugs (currently at 65)
17:01:05 * jamespage looks today
17:01:33 <coreycb> o/
17:01:37 <jamespage> current stats are 1 critical and 59 high; so some progress!
17:01:46 <jamespage> lets carry that action
17:02:02 <jamespage> #action all - fix critical and high priority bugs (currently at 1/59)
17:02:14 <gnuoy> o/
17:02:19 <jamespage> #topic State of Development for next Charm Release
17:02:29 <jamespage> OK so I think we have most specs in
17:02:44 <jamespage> I see a review up for panko which Dimitri-sh had in flight
17:02:51 <jamespage> that may need a polish - I'll case him on that
17:03:06 <jamespage> #action jamespage to track down author of panko spec for polish
17:03:20 <jamespage> anything else on specs today?
17:03:32 <jamespage> #link http://specs.openstack.org/openstack/charm-specs/
17:03:36 <gnuoy> I have some mp's against the load balancer spec fwiw
17:03:45 <jamespage> gnuoy: yeah on my list to review
17:03:49 <gnuoy> kk, ta
17:03:58 <jamespage> #action jamespage to review changes to openstack endpoint loadbalancer spec
17:04:20 <jamespage> looks like with have ceph migration (reviews up for that one)
17:04:32 <jamespage> service restart control which dosaboy is driving
17:04:38 <jamespage> endpoint loadbalancer
17:04:56 <jamespage> service-discovery, which I think we should land after the charm hygene work this cycle
17:05:02 <jamespage> and extended swift cluster ops
17:05:08 <jamespage> (again dosaboy)
17:05:24 <jamespage> I think we may have some other bits and pieces pop up in the next week or so
17:05:32 <jamespage> but we're not feature spec frozen just yet.
17:05:47 <jamespage> #topic High Priority Bugs
17:05:56 <jamespage> #link https://bugs.launchpad.net/openstack-charms/+bugs
17:06:05 <jamespage> #link https://tinyurl.com/osc-critical-bugs
17:06:12 <jamespage> #link http://tinyurl.com/charm-stable-backports
17:06:20 <jamespage> #link https://tinyurl.com/osc-high-priority
17:07:08 <jamespage> the critical bug is the dns backend network space binding problem that tytus is working on - we may need to extend him some help on that one as its quite a heavy lift in terms of changes
17:07:58 <gnuoy> What tz is tytus in? I can certainly lend a hand
17:08:01 <jamespage> we have a few potential stable backports in the list
17:08:06 <jamespage> gnuoy: germany I think
17:08:22 <gnuoy> only hour different from me then I expect
17:08:36 <jamespage> gnuoy: the current changes add a new key to the relation data based on the network space binding
17:08:59 <gnuoy> ok
17:09:16 <jamespage> it might be possible to encapsulate all of that in the relation itself, using get_relation_ip inside appropriate code to automatically set private-address correctly; which would avoid any direct changes into desginate itself
17:09:24 <jamespage> we did something similar for rabbitmq and memcache
17:09:41 <jamespage> thanks for the offer of help
17:09:47 <gnuoy> np
17:10:00 <jamespage> #action gnuoy to reach out to tytus on dns-backend relation network binding work
17:10:02 <thedac> gnuoy: https://github.com/juju/charm-helpers/blob/master/charmhelpers/contrib/network/ip.py#L559
17:10:18 <gnuoy> ta
17:10:58 <jamespage> gnuoy: https://github.com/openstack/charm-interface-rabbitmq/blob/master/requires.py#L87
17:11:05 <jamespage> usage thereof
17:11:07 <jamespage> anyway
17:11:12 <jamespage> ping me if needed :)
17:11:36 <gnuoy> ty
17:11:45 <jamespage> anything else on bugs? those lists are good to work from
17:12:35 <jamespage> I had a few people raise lack of knowledge on the ceph charms - I'll run a g+ hangout to give a 101 tomorrow at 1630 BST to cover that - if anyone not already invited wants to attend PM me.
17:12:58 <jamespage> #topic OpenStack Events
17:13:03 <jamespage> summit next month
17:13:25 <jamespage> we have onboarding and project update sessions booked up on the monday and tuesday of the summit - I'll be doing a bit of PR around those.
17:13:58 <jamespage> #action jamespage to tweet/book/blog about summit project sessions
17:14:04 <jamespage> anyone else?
17:14:53 <jamespage> moving on then
17:15:01 <jamespage> #topic open discussion
17:15:07 <jamespage> I have one
17:15:14 <jamespage> unless beisner wants to raise it first
17:16:03 <beisner> oh - we need to backpedal a bit on the rmq restart changes, and get the spec landed.
17:16:12 <beisner> that one?
17:16:17 <jamespage> beisner: no
17:16:20 <jamespage> releases!
17:16:32 <beisner> ah that too.
17:16:37 <jamespage> we had mucho discussion about naming and I think we're just about come back to where we started
17:16:44 <beisner> go ahead jamespage
17:17:10 <jamespage> so we'll go 17.11, 18.02, 18.05, 18.08, 18.11
17:17:41 <beisner> ack, agree.
17:17:47 <jamespage> and aim to freeze in sufficient time to hit those dates; if we stick with three months, if a feature is to tight for the main openstack aligned release, we can always bump it to +3 months
17:17:54 <jamespage> constraints are
17:17:57 <jamespage> working UOSCI cloud
17:18:07 <jamespage> good coverage on functional test runs all of the time
17:18:28 <jamespage> so we're always in good shape to pop a release, reducing the burden on the last haul marathon we have done in the past.
17:18:32 <jamespage> how does that sound?
17:19:04 <jamespage> which means that
17:19:08 <jamespage> #link https://docs.openstack.org/charm-guide/latest/charm-release.html
17:19:12 <jamespage> is still good and valid!
17:19:14 <jamespage> woot
17:19:19 <thedac> \o/
17:19:38 <jamespage> ish
17:19:43 <jamespage> looks like it needs a minor fix
17:19:51 <jamespage> #action jamespage - update the release policy again
17:19:53 <jamespage> \o/
17:19:56 <jamespage> love it
17:19:58 <beisner> thanks jamespage
17:20:01 <jamespage> anything else from anybody else?
17:20:28 <beisner> svc restart spec?  or discuss out of band?
17:21:17 <jamespage> up to you
17:21:35 <beisner> ah yes, this spec has landed:  https://review.openstack.org/#/c/504310/
17:21:44 <beisner> "Add spec for charm controlled service restarts"
17:22:33 <thedac> Yeah, I was hoping for some generalization on that one. But it landed. We can discuss if needed
17:23:18 <beisner> ok, so we'll either need to adjust the spec, or circle back to rabbitmq @ master and make it reflect the spec.
17:23:24 <beisner> we can discuss in channel/dailies, etc imho.
17:23:32 <thedac> ack
17:23:39 <beisner> cool, thx, that's all from me.
17:23:57 <jamespage> ok
17:23:58 <jamespage> ...
17:24:00 <jamespage> ..
17:24:02 <jamespage> .
17:24:04 <jamespage> #topic Next Chair
17:24:08 * jamespage looks
17:24:18 <jamespage> beisner is in the hotseat!
17:24:22 <jamespage> +2 weeks from now
17:24:27 <jamespage> #endmeeting