17:01:31 <tinwood> #startmeeting charms
17:01:32 <openstack> Meeting started Mon Nov 13 17:01:31 2017 UTC and is due to finish in 60 minutes.  The chair is tinwood. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:33 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:35 <openstack> The meeting name has been set to 'charms'
17:01:39 <tinwood> The agenda is: https://etherpad.openstack.org/p/openstack-charms-weekly-meeting-20171113
17:01:44 <tinwood> Hello all
17:01:59 <tinwood> kicking off, just a quick review
17:02:08 <tinwood> #topic Review ACTION points from previous meeting
17:02:12 <tinwood> the actions were:
17:02:19 <tinwood> all - fix critical and high priority bugs (currently at 1/59) - carried over
17:02:19 <tinwood> jamespage to review changes to openstack endpoint loadbalancer spec
17:02:19 <tinwood> jamespage - update the release policy again - ongoing.
17:02:40 <tinwood> The first one we can probably drop?  (i.e. we're always going to want to do that).
17:02:58 <tinwood> Is jamespage with us?
17:03:31 <tinwood> okay, we'll carry those two over.
17:03:36 <jamespage> o/
17:03:43 <jamespage> sorry was typing something needed to finish
17:03:45 <tinwood> Hi jamespage
17:03:56 <jamespage> yes just carry the release clarification one pls
17:04:14 <tinwood> okay, will do.
17:04:21 <tinwood> right, moving on ...
17:04:31 <tinwood> #topic State of Development for next Charm Release
17:04:50 <tinwood> Anything significant that needs to be noted?
17:05:19 <thedac> Work on the Python3 migration in progress
17:05:33 <thedac> Swift storage ACLs landed
17:05:35 <tinwood> ah, yes, some are easier than others.
17:05:57 <tinwood> And lots of bugs fixed.
17:06:26 <tinwood> Anyone else for this topic?
17:06:56 <tinwood> Okay, moving on ...
17:07:15 <tinwood> #topic High Priority Bugs
17:07:21 <tinwood> Useful urls:
17:07:28 <tinwood> https://bugs.launchpad.net/openstack-charms/+bugs
17:07:28 <tinwood> Use stable-backport tag for bugs  http://tinyurl.com/charm-stable-backports
17:07:28 <tinwood> Critical bugs: https://tinyurl.com/osc-critical-bugs
17:07:28 <tinwood> High priority bugs: https://tinyurl.com/osc-high-priority
17:08:14 <tinwood> We have just 2 open critical bugs: https://bugs.launchpad.net/charm-test-infra/+bug/1728843 and https://bugs.launchpad.net/charm-neutron-api/+bug/1723981
17:08:14 <openstack> Launchpad bug 1728843 in OpenStack Charm Test Infra "OSCI test_charm_single failing due to missing keystone package" [Critical,Confirmed] - Assigned to Ryan Beisner (1chb1n)
17:08:15 <openstack> Launchpad bug 1723981 in OpenStack neutron-api charm "Neutron-api fails ocata to pike upgrade" [Critical,Confirmed]
17:08:48 <thedac> I am looking at the neutron-api bug
17:08:56 <thedac> I'll take ownership of that
17:09:04 <tinwood> Thanks very much thedac
17:10:06 <tinwood> There are 51 outstanding high priority bugs currently.
17:10:20 <tinwood> Which is fewer than a couple of weeks ago.
17:10:24 <tinwood> Which is good news.
17:10:38 <tinwood> Anything more on bugs?
17:10:50 <coreycb> nice downward trend
17:11:23 <tinwood> Okay, on to the next topic ...
17:11:31 <tinwood> #topic Openstack Events
17:11:42 <tinwood> So we just had sydney.
17:12:19 <tinwood> Any comments from attendees?
17:13:08 <tinwood> (I think they mostly have jetlag!)
17:13:34 <thedac> :)
17:13:39 <tinwood> Right next!
17:13:46 <tinwood> #topic Open Discussion
17:13:51 <tinwood> The floor is open :)
17:14:37 <thedac> nothing from me
17:14:57 <Dmitrii-Sh> question
17:15:03 <tinwood> Hi Dmitrii-Sh:)
17:15:08 <tinwood> go on.
17:15:09 <Dmitrii-Sh> what's the latest on service discovery?
17:15:14 <Dmitrii-Sh> sorry, got in late
17:15:22 <tinwood> no problem
17:15:32 <Dmitrii-Sh> I have an intention to write some code in ceilometer
17:15:35 <tinwood> I'm going to have to defer that question to someone else.
17:15:44 <Dmitrii-Sh> where it checks relations via charm-helpers
17:15:48 <tinwood> We can take it as an action?
17:16:01 <Dmitrii-Sh> yes
17:16:21 <Dmitrii-Sh> this is needed for panko basically
17:16:30 <tinwood> okay, Dmitrii-Sh, I'll take an action to find out where we are with it.
17:16:46 <tinwood> #action tinwood find out status of service discovery
17:17:10 <Dmitrii-Sh> if there is no panko, there shouldn't be a configuration that configures a publisher for it in ceilometer
17:17:45 <thedac> Dmitrii-Sh: https://specs.openstack.org/openstack/charm-specs/specs/queens/approved/service-discovery.html
17:17:48 <Dmitrii-Sh> otherwise messages will not be delivered to anyone
17:18:07 <thedac> that spec is designed to solve this issue
17:18:19 <Dmitrii-Sh> thedac: yes, just wanted to know if anybody had a peek at that yet before I start doing any changes
17:18:39 <thedac> jamespage: ? ^^
17:18:55 <thedac> I am not aware of anyone diving in quite yet
17:18:59 <jamespage> not yet
17:19:53 <Dmitrii-Sh> ok
17:20:17 <tinwood> Okay, thanks Dmitrii-Sh for raising that.
17:20:29 <tinwood> Is there anything else (from anybody including Dmitrii-Sh)?
17:20:40 <Dmitrii-Sh> I will get back to my ceilometer patch then and see how I can take that spec into account
17:21:31 <tinwood> okay.
17:21:45 <tinwood> well, next up in the chair is beisner
17:21:54 <tinwood> and with that, thanks everybody.
17:22:01 <thedac> thanks, tinwood
17:22:02 <tinwood> #endmeeting