10:02:56 <icey> #startmeeting charms
10:02:57 <openstack> Meeting started Mon Dec  4 10:02:56 2017 UTC and is due to finish in 60 minutes.  The chair is icey. Information about MeetBot at http://wiki.debian.org/MeetBot.
10:02:58 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
10:03:00 <openstack> The meeting name has been set to 'charms'
10:03:02 <gnuoy> morning icey
10:03:15 <icey> #topic Review ACTION points from previous meeting
10:03:23 <tinwood> morning
10:03:38 <icey> looks like the only action in the last meeting was for beisner : add release schedule info to charm-guide
10:03:43 <icey> should we include the last odd meeting as well?
10:04:00 <jamespage> yes
10:04:03 <tinwood> yes, icey, I think everything is supposed to be merged.
10:04:07 <gnuoy> I think it makes sense for actions to pass between the even and odds
10:04:09 <icey> tinwood find out status of service discovery
10:04:16 <icey> would be the other action
10:04:16 <tinwood> ah
10:04:25 <tinwood> not done that
10:04:31 <tinwood> can we carry over
10:04:52 <icey> sure
10:04:53 <icey> #action beisner add release schedule info to charm-guide
10:05:00 <icey> #action tinwood find out status of service discovery
10:05:13 <icey> Ok
10:05:14 <icey> #topic State of Development for next Charm Release
10:05:25 <tinwood> We released! yay!
10:05:33 <icey> Indeed we did
10:05:33 <gnuoy> Go team us!
10:05:41 * icey lights fireworks
10:05:56 <icey> Anything we want to highlight for this recent release or looking to the next one?
10:06:19 <tinwood> we're about 3rd of our way through python 3 migration on the charms.
10:06:26 <tinwood> That'll be complete for the next release.
10:06:50 <gnuoy> https://docs.openstack.org/charm-guide/latest/1711.html  <- more info  on the release that just happened
10:07:40 <gnuoy> I don't have anything else
10:07:52 <icey> Ok then, onto ...
10:07:56 <icey> #topic High Priority Bugs
10:07:56 <icey> #link https://bugs.launchpad.net/openstack-charms/+bugs
10:07:56 <icey> #link http://tinyurl.com/charm-stable-backports
10:07:56 <icey> #link https://tinyurl.com/osc-critical-bugs
10:07:56 <icey> #link https://tinyurl.com/osc-high-priority
10:07:57 <icey> #link https://bugs.launchpad.net/openstack-charms/+bugs?search=Search&field.status=New&orderby=-importance
10:08:41 <icey> Looks like all critical bugs are released
10:08:49 <icey> fix-released that is
10:08:54 <gnuoy> ceph-{mon,osd} fixes were backported to stable this morning
10:09:14 <gnuoy> Bug ##1735720
10:09:15 <jamespage> hmm I think I saw something critical-ish come in over the weekend
10:09:17 <jamespage> lemme check
10:09:45 <jamespage> hmm yes - https://bugs.launchpad.net/charm-neutron-api/+bug/1735797
10:09:45 <openstack> Launchpad bug 1735797 in OpenStack neutron-api charm "neutron.conf templates for pythone 3 use iteritems(), should use items()" [Undecided,New]
10:10:09 <icey> Ah, not tagged yet then
10:10:14 <jamespage> gnuoy: did nova-compute go py3?
10:10:20 <gnuoy> it did
10:10:39 <gnuoy> jamespage, that seems unrelated to that bug though?
10:11:11 <jamespage> gnuoy: any py3 based charm that provided config-flags probably has this issue
10:11:28 <gnuoy> ah, the template with the issue is in ch?
10:11:50 <jamespage> no
10:12:41 <jamespage> gnuoy: nova-compute is ok actually - n-gateway and n-api have issues
10:12:46 <jamespage> I'll pick those up now
10:12:55 <gnuoy> I updated all the templates in the charms I did
10:13:26 <jamespage> gnuoy: you did better than me then :-)
10:13:33 * jamespage tidies his oversight
10:14:41 <icey> do you want to action that or just get it done jamespage?
10:14:52 <jamespage> no action - theres a bug
10:14:59 <icey> ack
10:15:10 <gnuoy> Mojo testing missed this because the charm doesn't use config-flags in the test I guess
10:15:18 <gnuoy> {% if user_config_flags -%}
10:16:21 <icey> any other bugs to mention or discuss here?
10:16:23 <gnuoy> nothing else from me
10:16:23 <tinwood> if reasonable/feasible, ought there be a test for that?
10:16:45 <icey> could do tinwood, but it could get messy in mojo
10:16:46 <gnuoy> tinwood, we could add one to amulet easily enough
10:16:54 <icey> seems to me that it'd be nice to have an almost no-op one in amulet\
10:17:02 <icey> something that adds a comment or something to the config maybe?
10:17:28 <jamespage> tbh the key=value can be anything - we just want to exercise the codebase right?
10:17:35 <gnuoy> right
10:18:04 <gnuoy> beer=awesome
10:18:07 <gnuoy> or some such
10:18:12 * tinwood lol
10:18:14 <jamespage> yeah
10:18:17 <icey> or: "# = test" ...
10:18:28 <icey> wouldn't want to break services that don't ignore unknown options?
10:18:48 <jamespage> icey: I think we're pretty safe on that front
10:18:54 <icey> This seems ot be a better discussion fo rin channel while building it though :)
10:19:19 <gnuoy> agreed
10:19:22 <icey> Ok then
10:19:25 <icey> #topic OpenStack Events
10:19:35 <icey> https://www.openstack.org/ptg/
10:19:39 <icey> "The third Project Teams Gathering (PTG) will be in Dublin, Ireland, the week of Feb 26, 2018"
10:19:57 <icey> Per last week's discussion, scheduling conflicts should be discussed soon :)
10:20:51 <icey> any other Openstack Events ?
10:21:03 <tinwood> Dublin's nice.
10:21:32 <icey> indeed!
10:22:28 <icey> #topic open discussion
10:23:00 <icey> Anything else we should discuss?
10:23:07 <tinwood> Not from me.
10:23:11 <gnuoy> yep
10:23:30 <gnuoy> Opinions on keystone federation spec https://review.openstack.org/#/c/524209/ are very weolcome
10:23:34 <gnuoy> * welcome
10:24:04 <gnuoy> thats it from me
10:24:30 <icey> Alright
10:24:39 <icey> #topic Next Chair
10:24:48 * gnuoy ducks
10:25:06 <icey> I see jamespage as the next chair?
10:25:18 <jamespage> yeah! I'm the winner!
10:25:25 <jamespage> works for me - I'm here in two weeks time
10:25:57 <icey> great, same time, same place in two weeks!
10:26:06 <icey> thanks all
10:26:09 <icey> #endmeeting