16:59:57 <gnuoy> #startmeeting charms
16:59:58 <openstack> Meeting started Mon Jan 7 16:59:57 2019 UTC and is due to finish in 60 minutes. The chair is gnuoy. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:59:59 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:01 <coreycb> o/
17:00:02 <openstack> The meeting name has been set to 'charms'
17:00:08 <gnuoy> #topic Review ACTION points from previous meeting
17:00:33 <tinwood> I'd give it a minute. We're just on the hour
17:00:41 <gnuoy> I see no Ships
17:00:47 <gnuoy> s/Ships/actions/
17:00:52 <thedac> o/
17:01:10 <gnuoy> #topic State of Development for next Charm Release
17:01:34 <gnuoy> Anyone now the data of the next charm release?
17:01:46 <gnuoy> I think its way off in the distant future
17:01:50 <fnordahl> o/
17:02:23 <thedac> gnuoy: 19-04 I think
17:02:39 <gnuoy> ah, thanks
17:03:02 <coreycb> makes sense. stein is april 8-12
17:03:35 <jamespage> o/
17:03:37 <gnuoy> I'm going to be looking at creating a template for cinder backends using a subordinate charm and the reactive framework
17:03:50 <gnuoy> Anyone got anything they'd like to highlight ?
17:03:56 <jamespage> yup
17:04:19 <jamespage> I'm doing some refatoring of the ceph-radosgw charm to support gateway federation
17:04:35 <fnordahl> I'm taking on a new Ceph RBD mirror charm and some associated interface work
17:04:37 <jamespage> there are some upgrade considerations so I'll look to address those in my reviews
17:05:58 <gnuoy> kk, onwards
17:06:02 <coreycb> i've switched the sqlalchemy package back to using mysqldb as the default dialect (was patched to use pymysql). I don't think this affects the charms since they just use mysql (not mysql+pymysql) via SharedDBContext.
17:06:32 <coreycb> but if anything breaks in that area then call me
17:06:38 <gnuoy> thanks coreycb
17:06:52 <jamespage> something will break
17:06:54 <jamespage> :)
17:06:57 <coreycb> haha
17:07:07 <gnuoy> jamespage the eternal optimist
17:07:21 <jamespage> new years resolution is to be more pessimistic
17:07:21 <gnuoy> #topic High Priority Bugs
17:07:37 <gnuoy> https://bugs.launchpad.net/openstack-charms/+bugs
17:08:34 <gnuoy> Lots of bugs that need triaging by the looks of it
17:09:20 <gnuoy> http://tinyurl.com/charm-stable-backports
17:09:46 <fnordahl> apropos, I have taken a beat at the review queue today and forced abandonment on many reviews not touched in the past 6 months
17:10:05 <gnuoy> ah, yes, I saw that
17:10:07 <gnuoy> Thanks
17:10:20 <gnuoy> I need to prod some of mine
17:10:30 <gnuoy> Critical bugs: https://tinyurl.com/osc-critical-bugs
17:10:30 <gnuoy> High priority bugs: https://tinyurl.com/osc-high-priority
17:11:06 <gnuoy> One critical which is being actively worked on/monitored
17:11:49 <gnuoy> Anyone got anything to add to bugs ? Otherwise I shall move on...
17:12:23 <jamespage> nothing from me
17:12:23 <gnuoy> #topic Openstack Events
17:12:40 <gnuoy> Ok, well I don't think there is anything coming up in the next month or so?
17:12:51 <jamespage> no next event is really denver
17:13:02 <gnuoy> Right then
17:13:05 <gnuoy> #topic Open Discussion
17:13:06 <jamespage> however I think we have to say whether we're doing the PTG soon
17:13:09 <jamespage> fnordahl?
17:13:32 <fnordahl> right, I have some e-mail to catch up on there
17:14:34 <fnordahl> We need to project attendance by January 20th
17:15:36 <gnuoy> shall all action fnordahl with thinking about it ?
17:16:25 <gnuoy> #action fnordahl Look into charms attendance at PTG
17:16:56 <beisner> it is coupled with the summit next time, right?
17:17:03 <beisner> @ denver iirc
17:17:03 <fnordahl> Yes
17:17:51 <fnordahl> Summit and PTG share the same space physically but the Summit will be at the beginning of the week and PTG at the end afair
17:19:39 <gnuoy> ok, anyone got anything to add to ^ or anything else to bring up ?
17:19:46 <coreycb> jamespage: actually i think you're right on. i think we need to force mysql+pymysql dialect now.
17:20:00 <coreycb> gnuoy: carry on that's just a comment
17:20:06 <gnuoy> ack, ta
17:20:45 <jamespage> call for papers is 23 of Jan deadline btw
17:20:55 <gnuoy> ah, good point ^
17:21:12 <fnordahl> Indeed, that is getting near fast
17:21:44 <jamespage> just under two weeks
17:21:57 <gnuoy> ok, then. Get thinking about talks
17:22:23 <gnuoy> I'm about push the next-chair-button
17:22:37 <gnuoy> #topic Next Chair
17:22:57 <gnuoy> Someone called coreycb apparently
17:23:07 <coreycb> gnuoy: that's me
17:23:14 <coreycb> see you then!
17:23:24 <jamespage> thanks gnuoy
17:23:28 <tinwood> thanks gnuoy
17:23:32 <gnuoy> Ok, two weeks from now, same time same place
17:23:41 <thedac> thanks, gnuoy
17:23:45 <gnuoy> #endmeeting