10:07:19 <icey> #startmeeting charms
10:07:20 <openstack> Meeting started Mon Jul  1 10:07:19 2019 UTC and is due to finish in 60 minutes.  The chair is icey. Information about MeetBot at http://wiki.debian.org/MeetBot.
10:07:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
10:07:23 <openstack> The meeting name has been set to 'charms'
10:07:49 <icey> #topic Review ACTION points from previous meeting
10:08:21 <icey> the only action that I see is: "gnuoy run with https://bugs.launchpad.net/charm-neutron-api/+bug/1830536"
10:08:23 <openstack> Launchpad bug 1830536 in OpenStack neutron-api charm "All users with the admin role are cloud admins" [Critical,Triaged] - Assigned to Liam Young (gnuoy)
10:08:49 <gnuoy> ack, please carry it forward
10:09:11 <icey> #action gnuoy run with https://bugs.launchpad.net/charm-neutron-api/+bug/1830536
10:09:15 <gnuoy> ta
10:09:30 <icey> ok, let's jump into...
10:09:34 <icey> #topic State of Development for next Charm Release
10:09:52 <icey> The next release is later this month, ~3 weeks I believe
10:10:21 <icey> 23 July is the scheduled date
10:10:23 <jamespage> wow that's crept up quickly
10:10:27 <jamespage> when is freeze?
10:10:33 <tinwood> golly, eys
10:10:34 <tinwood> yes
10:10:40 <icey> I suspect one week before, so, two weeks tomorrow?
10:11:20 <jamespage> that sounds right
10:11:39 <jamespage> Tue, Jul 16, 2019
10:11:51 <jamespage> according to https://docs.openstack.org/charm-guide/latest/release-schedule.html
10:12:07 <icey> I'm still hoping to get the DVR validation bundles in for the release, but that may get deferred in favor of interim validation that we've been stepping up in the last few days
10:12:33 <jamespage> ok
10:12:53 <icey> fortunately, most of thew groundwork on that has been done in migrating neutron-api to Zaza, and adding additional networking validation tests
10:13:23 <icey> anybody have anything else to call out regarding the next release?
10:13:36 <tinwood> not especially
10:13:48 <jamespage> fwaas logging is nearly landed
10:13:59 <jamespage> zuul missed a check so just trigger that manially
10:15:03 <icey> alright!
10:15:06 <icey> Let's move on then
10:15:08 <icey> #topic High Priority Bugs
10:15:19 <gnuoy> Does manially mean that you're doing it in a crazy rush ?
10:15:20 <icey> https://bugs.launchpad.net/openstack-charms/+bugs
10:15:20 <icey> Use stable-backport tag for bugs  http://tinyurl.com/charm-stable-backports
10:15:20 <icey> Critical bugs: https://tinyurl.com/osc-critical-bugs
10:15:20 <icey> High priority bugs: https://tinyurl.com/osc-high-priority
10:16:15 <icey> I see 10 criticals, with about half of those open
10:16:34 <gnuoy> We need to get eyes on that designate one I would think
10:17:07 <icey> and the other three that aren't fix-committed - it would be nice to have those at least somewhat mitigated at release
10:17:53 <jamespage> agreed
10:18:04 <jamespage> I'll take a look at the barbican one
10:18:43 <jamespage> thedac and gnuoy have one assigned each  just need an assignee for the designate one I think
10:19:01 <jamespage> https://bugs.launchpad.net/charm-designate/+bug/1828534
10:19:02 <openstack> Launchpad bug 1828534 in OpenStack Designate Charm "[19.04][Queens -> Rocky] Upgrading to Rocky resulted in "Services not running that should be: designate-producer"" [Critical,Triaged]
10:19:05 <jamespage> any volunteers?
10:19:09 <gnuoy> me
10:19:13 <gnuoy> I can grab it
10:19:20 <jamespage> done
10:19:24 <jamespage> as in assigned
10:19:35 <gnuoy> kk, ty
10:19:54 <icey> anything else bug-related that we want to discuss / call-out?
10:20:38 <gnuoy> not from me
10:20:48 <jamespage> just a reminder to keep on triaging new bugs - we're at 57 right now
10:21:20 <icey> indeed
10:22:09 <icey> #topic Openstack Events
10:22:20 <icey> I'm actually going to be at Ceph Days NL tomorrow
10:22:28 <icey> the CFP for the Shanghai summit closes soon!
10:23:15 <jamespage> have fun
10:24:10 <icey> jamespage: I think that you and fnordahl are planning on attending another OpenStack event soon?
10:24:36 <jamespage> its in the autumn - open infra nordics
10:25:03 <icey> well, it's about the summer holidays where nothing's going to happen, so I figure autumnal events are relevant ;-)
10:25:12 <jamespage> indeed
10:25:26 <jamespage> https://openinfranordics.com/ - 2/3 October
10:25:37 <jamespage> 2nd is workshops, 3rd is conference
10:25:59 <jamespage> I've submitted a talk about ceph + openstack + k8s
10:26:07 <jamespage> which fnordahl and I will co-present
10:26:12 <jamespage> if its accepted ;)
10:26:26 <icey> cool :)
10:26:36 <icey> if there's no other events to call out...?
10:27:45 <icey> #topic Open Discussion
10:27:51 <icey> The floor is open!
10:28:06 <tinwood> nothing from me
10:28:13 <gnuoy> nor me
10:29:04 <sahid> nada
10:29:12 <icey> well then, we'll move onto
10:29:13 <icey> #topic Next Chair
10:29:32 <icey> it looks like fnordahl is our lucky winner!
10:29:53 <tinwood> and he's not here
10:30:14 <icey> indeed, so maybe we should defer and let jamespage be up next!
10:30:32 <tinwood> no no, I'm sure he'll be fine about it :)
10:30:32 <icey> does that work for you jamespage?
10:30:48 <icey> can we volunteer him for other work then as well? ;-)
10:30:56 <jamespage> yes
10:31:05 <jamespage> that's what happens when you take time off right?
10:31:07 <jamespage> ;)
10:31:18 <tinwood> indeed ;)
10:31:18 <jamespage> no that's fine - if he can't do it I'll pick it up
10:31:35 <icey> indeed :-D I'll put him on the roster but you're up after him anyways jamespage
10:31:52 <icey> all right, thank you all!
10:32:02 <icey> #endmeeting